]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- use new faster rpm's GConf automation
[packages/liferea.git] / liferea.spec
1 # Conditional build:
2 %bcond_without  mozilla # without mozilla
3 #
4 Summary:        A RSS feed reader
5 Summary(pl):    Program do pobierania informacji w formacie RSS
6 Name:           liferea
7 Version:        0.9.1
8 Release:        2
9 License:        GPL
10 Group:          X11/Applications/Networking
11 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
12 # Source0-md5:  f0d5f184034697522e68e92909897043
13 Patch0:         %{name}-desktop.patch
14 URL:            http://liferea.sourceforge.net/
15 BuildRequires:  GConf2-devel >= 2.10.0
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  gtk+2-devel >= 2:2.6.3
19 BuildRequires:  libxml2-devel >= 1:2.6.19
20 BuildRequires:  libgtkhtml-devel >= 2.6.3
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool
23 %{?with_mozilla:BuildRequires:  mozilla-devel}
24 BuildRequires:  pkgconfig
25 BuildRequires:  rpmbuild(macros) >= 1.196
26 Requires(post,preun):   GConf2
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
30
31 %description
32 Liferea is a GTK+ clone of FeedReader.
33
34 %description -l pl
35 Liferea jest klonem, napisanym za pomoc± biblioteki GTK+, programu
36 FeedReader.
37
38 %package mozilla
39 Summary:        Mozilla HTML browser module for Liferea
40 Summary(pl):    Modu³ przegl±darki HTML dla Liferea oparty na Mozilli
41 Group:          X11/Applications/Networking
42 Requires:       %{name} = %{version}-%{release}
43
44 %description mozilla
45 Mozilla HTML browser module for Liferea.
46
47 %description mozilla -l pl
48 Modu³ przegl±darki HTML dla Liferea oparty na Mozilli.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53
54 %build
55 glib-gettextize -f
56 %{__aclocal}
57 %{__libtoolize}
58 %{__autoheader}
59 %{__automake}
60 %{__autoconf}
61 %configure \
62         --disable-schemas-install \
63     %{!?with_mozilla:--without-mozilla}
64 %{__make}
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT \
71         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
72
73 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
74
75 %find_lang %{name}
76
77 %post
78 %gconf_schema_install /etc/gconf/schemas/liferea.schemas
79
80 %preun
81 if [ $1 = 0 ]; then
82         %gconf_schema_uninstall /etc/gconf/schemas/liferea.schemas
83 fi
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files -f %{name}.lang
89 %defattr(644,root,root,755)
90 %doc AUTHORS ChangeLog NEWS README
91 %attr(755,root,root) %{_bindir}/*
92 %dir %{_libdir}/%{name}
93 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
94 %{_sysconfdir}/gconf/schemas/*.schemas
95 %{_datadir}/%{name}
96 %{_desktopdir}/*
97 %{_pixmapsdir}/*
98 %{_mandir}/man1/liferea.1*
99
100 %if %{with mozilla}
101 %files mozilla
102 %defattr(644,root,root,755)
103 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlm.so*
104 %endif
This page took 0.326353 seconds and 3 git commands to generate.