]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
93d86f6375c12d4101a56cc61b537bf4072c5ad1
[packages/liferea.git] / liferea.spec
1 # TODO:
2 # - create subpackage -lua (?)
3 # - webkit support
4 #
5 # Conditional build:
6 %bcond_without  dbus            # without DBUS support
7 %bcond_without  gtkhtml         # without GtkHTML
8 %bcond_without  xulrunner       # without XULRunner backend
9 %bcond_without  lua             # without LUA scripting support
10 %bcond_with     nm              # with NetworkManager support
11 #
12 %ifarch %{x8664}
13 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
14 %endif
15 Summary:        A RSS feed reader
16 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
17 Name:           liferea
18 Version:        1.4.10
19 Release:        1
20 License:        GPL v2
21 Group:          X11/Applications/Networking
22 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
23 # Source0-md5:  7a60b58fc0044f72fb0d67f77eaffad5
24 Patch0:         %{name}-desktop.patch
25 Patch1:         %{name}-xulrunner.patch
26 Patch2:         %{name}-lua51.patch
27 URL:            http://liferea.sourceforge.net/
28 BuildRequires:  GConf2-devel >= 2.10.0
29 %{?with_nm:BuildRequires:       NetworkManager-devel}
30 BuildRequires:  autoconf >= 2.59
31 BuildRequires:  automake
32 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
33 BuildRequires:  gnutls-devel
34 BuildRequires:  gtk+2-devel >= 2:2.8.0
35 BuildRequires:  intltool >= 0.35.5
36 BuildRequires:  libglade2-devel >= 2.0.0
37 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
38 BuildRequires:  libnotify-devel >= 0.3.2
39 BuildRequires:  libstdc++-devel
40 BuildRequires:  libtool
41 BuildRequires:  libxml2-devel >= 1:2.6.27
42 BuildRequires:  libxslt-devel >= 1.1.19
43 %{?with_lua:BuildRequires:      lua51-devel}
44 BuildRequires:  pkgconfig
45 BuildRequires:  rpmbuild(macros) >= 1.311
46 BuildRequires:  sqlite3-devel
47 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
48 Requires(post,postun):  gtk+2
49 Requires(post,postun):  hicolor-icon-theme
50 Requires(post,preun):   GConf2
51 Requires:       %{name}-backend = %{version}-%{release}
52 %ifarch %{x8664}
53 Obsoletes:      liferea-gtkhtml
54 %endif
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
58 # we have strict deps for it
59 %define         _noautoreq      libxpcom.so
60
61 %description
62 Liferea is a GTK+ clone of FeedReader.
63
64 %description -l pl.UTF-8
65 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
66 FeedReader.
67
68 %package gtkhtml
69 Summary:        GtkHTML module for Liferea
70 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
71 Group:          X11/Applications/Networking
72 Requires:       %{name} = %{version}-%{release}
73 Provides:       %{name}-backend = %{version}-%{release}
74
75 %description gtkhtml
76 GtkHTML module for Liferea.
77
78 %description gtkhtml -l pl.UTF-8
79 Moduł GtkHTML dla Liferea.
80
81 %package mozilla
82 Summary:        Mozilla HTML browser module for Liferea
83 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
84 Group:          X11/Applications/Networking
85 Requires:       %{name} = %{version}-%{release}
86 %requires_eq_to xulrunner xulrunner-devel
87 Provides:       %{name}-backend = %{version}-%{release}
88
89 %description mozilla
90 Mozilla HTML browser module for Liferea.
91
92 %description mozilla -l pl.UTF-8
93 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
94
95 %prep
96 %setup -q
97 %patch0 -p1
98 %patch1 -p1
99 %patch2 -p1
100
101 %build
102 %{__glib_gettextize}
103 %{__intltoolize}
104 %{__aclocal}
105 %{__libtoolize}
106 %{__autoheader}
107 %{__automake}
108 %{__autoconf}
109 %configure \
110         --disable-schemas-install \
111         %{!?with_dbus: --disable-dbus} \
112         %{!?with_gtkhtml: --disable-gtkhtml2} \
113         %{!?with_lua: --disable-lua} \
114         %{!?with_nm: --disable-nm} \
115         %{!?with_xulrunner: --disable-xulrunner}
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT \
123         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
124
125 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
126
127 %find_lang %{name}
128
129 %post
130 %gconf_schema_install liferea.schemas
131 %update_icon_cache hicolor
132
133 %preun
134 %gconf_schema_uninstall liferea.schemas
135
136 %postun
137 %update_icon_cache hicolor
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %files -f %{name}.lang
143 %defattr(644,root,root,755)
144 %doc AUTHORS ChangeLog NEWS README
145 %attr(755,root,root) %{_bindir}/*
146 %dir %{_libdir}/%{name}
147 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
148 %{_iconsdir}/hicolor/48x48/apps/liferea.png
149 %{_mandir}/pl/man1/liferea.1*
150 %{_sysconfdir}/gconf/schemas/liferea.schemas
151 %{_datadir}/%{name}
152 %{_desktopdir}/*.desktop
153 %{_mandir}/man1/liferea.1*
154 %if %{with lua}
155 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
156 %endif
157
158 %if %{with gtkhtml}
159 %files gtkhtml
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
162 %endif
163
164 %if %{with xulrunner}
165 %files mozilla
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
168 %endif
This page took 0.146517 seconds and 3 git commands to generate.