]> git.pld-linux.org Git - packages/liferea.git/blob - liferea.spec
- release 3 (xulrunner 1.8.1.11)
[packages/liferea.git] / liferea.spec
1 # TODO: create subpackage -lua (?)
2 #
3 # Conditional build:
4 %bcond_without  dbus            # without DBUS support
5 %bcond_without  gtkhtml         # without GtkHTML
6 %bcond_without  xulrunner       # without XULRunner backend
7 %bcond_without  lua             # without LUA scripting support
8 %bcond_with     nm              # with NetworkManager support
9 #
10 %ifarch %{x8664}
11 %undefine       with_gtkhtml    # GtkHTML backend disabled on x86_64
12 %endif
13 Summary:        A RSS feed reader
14 Summary(pl.UTF-8):      Program do pobierania informacji w formacie RSS
15 Name:           liferea
16 Version:        1.4.8
17 Release:        3
18 License:        GPL v2
19 Group:          X11/Applications/Networking
20 Source0:        http://dl.sourceforge.net/liferea/%{name}-%{version}.tar.gz
21 # Source0-md5:  92806e9432481e65f21e8f86ff4a4fe2
22 Patch0:         %{name}-desktop.patch
23 Patch1:         %{name}-xulrunner.patch
24 Patch2:         %{name}-lua51.patch
25 URL:            http://liferea.sourceforge.net/
26 BuildRequires:  GConf2-devel >= 2.10.0
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake
29 %{?with_dbus:BuildRequires:     dbus-glib-devel >= 0.33}
30 BuildRequires:  gtk+2-devel >= 2:2.8.0
31 BuildRequires:  intltool >= 0.35.5
32 %{?with_gtkhtml:BuildRequires:  libgtkhtml-devel >= 2.6.3}
33 BuildRequires:  libnotify-devel >= 0.3.2
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  libtool
36 BuildRequires:  libxml2-devel >= 1:2.6.19
37 BuildRequires:  libxslt-devel >= 1.1.19
38 %{?with_lua:BuildRequires:      lua51-devel}
39 %{?with_nm:BuildRequires:       NetworkManager-devel}
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpmbuild(macros) >= 1.311
42 BuildRequires:  sqlite3-devel
43 %{?with_xulrunner:BuildRequires:        xulrunner-devel}
44 Requires(post,postun):  gtk+2
45 Requires(post,postun):  hicolor-icon-theme
46 Requires(post,preun):   GConf2
47 Requires:       %{name}-backend = %{version}-%{release}
48 %ifarch %{x8664}
49 Obsoletes:      liferea-gtkhtml
50 %endif
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         _noautoreqdep   libgtkembedmoz.so libxpcom.so
54 # we have strict deps for it
55 %define         _noautoreq      libxpcom.so
56
57 %description
58 Liferea is a GTK+ clone of FeedReader.
59
60 %description -l pl.UTF-8
61 Liferea jest klonem, napisanym za pomocą biblioteki GTK+, programu
62 FeedReader.
63
64 %package gtkhtml
65 Summary:        GtkHTML module for Liferea
66 Summary(pl.UTF-8):      Moduł GtkHTML dla Liferea
67 Group:          X11/Applications/Networking
68 Requires:       %{name} = %{version}-%{release}
69 Provides:       %{name}-backend = %{version}-%{release}
70
71 %description gtkhtml
72 GtkHTML module for Liferea.
73
74 %description gtkhtml -l pl.UTF-8
75 Moduł GtkHTML dla Liferea.
76
77 %package mozilla
78 Summary:        Mozilla HTML browser module for Liferea
79 Summary(pl.UTF-8):      Moduł przeglądarki HTML dla Liferea oparty na Mozilli
80 Group:          X11/Applications/Networking
81 Requires:       %{name} = %{version}-%{release}
82 %requires_eq_to xulrunner xulrunner-devel
83 Provides:       %{name}-backend = %{version}-%{release}
84
85 %description mozilla
86 Mozilla HTML browser module for Liferea.
87
88 %description mozilla -l pl.UTF-8
89 Moduł przeglądarki HTML dla Liferea oparty na Mozilli.
90
91 %prep
92 %setup -q
93 %patch0 -p1
94 %patch1 -p1
95 %patch2 -p1
96
97 %build
98 %{__glib_gettextize}
99 %{__intltoolize}
100 %{__aclocal}
101 %{__libtoolize}
102 %{__autoheader}
103 %{__automake}
104 %{__autoconf}
105 %configure \
106         --disable-schemas-install \
107         %{!?with_dbus: --disable-dbus} \
108         %{!?with_gtkhtml: --disable-gtkhtml2} \
109         %{!?with_lua: --disable-lua} \
110         %{!?with_nm: --disable-nm} \
111         %{!?with_xulrunner: --disable-xulrunner}
112 %{__make}
113
114 %install
115 rm -rf $RPM_BUILD_ROOT
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT \
119         GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
120
121 rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib*.la
122
123 %find_lang %{name}
124
125 %post
126 %gconf_schema_install liferea.schemas
127 %update_icon_cache hicolor
128
129 %preun
130 %gconf_schema_uninstall liferea.schemas
131
132 %postun
133 %update_icon_cache hicolor
134
135 %clean
136 rm -rf $RPM_BUILD_ROOT
137
138 %files -f %{name}.lang
139 %defattr(644,root,root,755)
140 %doc AUTHORS ChangeLog NEWS README
141 %attr(755,root,root) %{_bindir}/*
142 %dir %{_libdir}/%{name}
143 %attr(755,root,root) %{_libdir}/%{name}/*.so.*.*.*
144 %{_iconsdir}/hicolor/48x48/apps/liferea.png
145 %{_mandir}/pl/man1/liferea.1*
146 %{_sysconfdir}/gconf/schemas/liferea.schemas
147 %{_datadir}/%{name}
148 %{_desktopdir}/*.desktop
149 %{_mandir}/man1/liferea.1*
150 %if %{with lua}
151 %attr(755,root,root) %{_libdir}/%{name}/libliscrlua.so
152 %endif
153
154 %if %{with gtkhtml}
155 %files gtkhtml
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlg.so*
158 %endif
159
160 %if %{with xulrunner}
161 %files mozilla
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/%{name}/liblihtmlx.so*
164 %endif
This page took 0.174154 seconds and 3 git commands to generate.