]> git.pld-linux.org Git - packages/libxcrypt.git/blob - libxcrypt.spec
- initial 3.0.2
[packages/libxcrypt.git] / libxcrypt.spec
1 Summary:        Crypt Library for DES, MD5, and Blowfish
2 Name:           libxcrypt
3 Version:        3.0.2
4 Release:        1
5 License:        LGPL v2+, Public Domain, Freeware
6 Group:          Libraries
7 Source0:        ftp://ftp.suse.com/pub/people/kukuk/libxcrypt/%{name}-%{version}.tar.bz2
8 # Source0-md5:  56cf4285086f26649b8792b53fe8b00f
9 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
10
11 %description
12 Libxcrypt is a replacement for libcrypt, which comes with the GNU C
13 Library. It supports DES crypt, MD5, and passwords with blowfish
14 encryption.
15
16 %package devel
17 Summary:        Header files and develpment documentation for libxcrypt
18 Group:          Development/Libraries
19 Requires:       %{name} = %{epoch}:%{version}-%{release}
20
21 %description devel
22 This package contains the header files to develop software using
23 libxcrypt.
24
25 %package static
26 Summary:        Static libxcrypt library
27 Group:          Development/Libraries
28 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
29
30 %description static
31 This package contains the static library used for development.
32
33 %prep
34 %setup -q
35
36 %build
37 %configure \
38         --libdir=/%{_lib}
39 %{__make}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_libdir}
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 mv $RPM_BUILD_ROOT/%{_lib}/lib*.{l,}a $RPM_BUILD_ROOT%{_libdir}
49 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
50         lib=$(echo $lib | sed -e "s#$RPM_BUILD_ROOT##g")
51         slib=$(basename $lib | sed -e 's#\.so\..*#.so#g')
52         ln -sf $lib $RPM_BUILD_ROOT%{_libdir}/$slib
53 done
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %post   -p /sbin/ldconfig
59 %postun -p /sbin/ldconfig
60
61 %files
62 %defattr(644,root,root,755)
63 %doc ChangeLog NEWS README*
64 %attr(755,root,root) /%{_lib}/libxcrypt.so.*
65 %dir  /%{_lib}/xcrypt
66 %attr(755,root,root) /%{_lib}/xcrypt/libxcrypt*.so*
67
68 %files devel
69 %defattr(644,root,root,755)
70 %attr(755,root,root) %{_libdir}/libxcrypt.so
71 %{_includedir}/xcrypt.h
72 %{_libdir}/*.la
73
74 %files static
75 %defattr(644,root,root,755)
76 %{_libdir}/libxcrypt.a
This page took 0.061251 seconds and 4 git commands to generate.