]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
- s/2.14.0/2.14/
[packages/libx264.git] / libx264.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap
4 #
5 %define         snap    20110327
6 %define         snaph   2245
7 %define         rel             1
8 Summary:        H264 encoder library
9 Summary(pl.UTF-8):      Biblioteka kodująca H264
10 Name:           libx264
11 Version:        0.1.3
12 Release:        1.%{snap}_%{snaph}.%{rel}
13 License:        GPL v2+
14 Group:          Libraries
15 # still no releases, use snapshots
16 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
17 # Source0-md5:  7579aff8166a974a1b293cd18b9ead92
18 Patch0:         %{name}-alpha.patch
19 Patch1:         altivec-no-vand.patch
20 URL:            http://www.videolan.org/developers/x264.html
21 BuildRequires:  pkgconfig
22 %ifarch %{ix86} %{x8664}
23 BuildRequires:  yasm >= 0.6.0
24 %endif
25 %if %{without bootstrap}
26 # which version exactly???
27 # for full x264 CLI utility functionality it wants:
28 # libswscale >= 0.9.0 (in pkgconfig file)
29 # libav{format,codec,util} from ffmpeg >= r21854
30 BuildRequires:  ffmpeg-devel >= 0.6.0
31 BuildRequires:  ffmpegsource-devel >= 2.14
32 # gpac >= 2007-06-21
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 # encoder/macroblock.c breaks strict-aliasing rules
37 %define         specflags       -fno-strict-aliasing
38
39 %description
40 libx264 library for encoding H264 video format.
41
42 %description -l pl.UTF-8
43 Biblioteka libx264 do kodowania w formacie obrazu H264.
44
45 %package devel
46 Summary:        Header files for x264 library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x264
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50
51 %description devel
52 Header files for x264 library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe biblioteki x264.
56
57 %package static
58 Summary:        Static x264 library
59 Summary(pl.UTF-8):      Statyczna biblioteka x264
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static x264 library.
65
66 %description static -l pl.UTF-8
67 Statyczna biblioteka x264.
68
69 %package -n x264
70 Summary:        x264 CLI decoder
71 Summary(pl.UTF-8):      Dekoder x264 działający z linii poleceń
72 Group:          Applications/Multimedia
73 Requires:       %{name} = %{version}-%{release}
74
75 %description -n x264
76 x264 CLI decoder.
77
78 %description -n x264 -l pl.UTF-8
79 Dekoder x264 działający z linii poleceń.
80
81 %prep
82 %setup -q -n x264-snapshot-%{snap}-%{snaph}
83 %patch0 -p1
84 %if "%{pld_release}" == "ac"
85 %patch1 -p1
86 %endif
87
88 %build
89 CC="%{__cc}" \
90 ./configure \
91         --prefix=%{_prefix} \
92         --exec-prefix=%{_prefix} \
93         --bindir=%{_bindir} \
94         --includedir=%{_includedir} \
95         --libdir=%{_libdir} \
96         --extra-cflags="%{rpmcflags}" \
97         --enable-pic \
98         --enable-shared
99
100 %{__make}
101
102 %install
103 rm -rf $RPM_BUILD_ROOT
104
105 %{__make} install \
106         DESTDIR=$RPM_BUILD_ROOT
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS
117 %attr(755,root,root) %{_libdir}/libx264.so.114
118
119 %files devel
120 %defattr(644,root,root,755)
121 %attr(755,root,root) %{_libdir}/libx264.so
122 %{_includedir}/x264.h
123 %{_includedir}/x264_config.h
124 %{_pkgconfigdir}/x264.pc
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libx264.a
129
130 %files -n x264
131 %defattr(644,root,root,755)
132 %attr(755,root,root) %{_bindir}/x264
This page took 0.045719 seconds and 4 git commands to generate.