]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
correct yasm BR
[packages/libx264.git] / libx264.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap       # no ffmpeg/gpac support in x264 utility
4
5 %define         rel     3
6 %define         snap    20140824
7 %define         snaph   2245
8 Summary:        H264 encoder library
9 Summary(pl.UTF-8):      Biblioteka kodująca H264
10 Name:           libx264
11 Version:        0.1.3
12 Release:        1.%{snap}_%{snaph}.%{rel}
13 License:        GPL v2+
14 Group:          Libraries
15 # still no releases, use snapshots
16 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
17 # Source0-md5:  d2a779a864254ca426dfb1f3115987a0
18 Patch0:         %{name}-alpha.patch
19 Patch1:         altivec-no-vand.patch
20 Patch2:         %{name}-gpac.patch
21 URL:            http://www.videolan.org/developers/x264.html
22 BuildRequires:  pkgconfig
23 %ifarch %{ix86} %{x8664} x32
24 BuildRequires:  yasm >= 1.2.0
25 %endif
26 %if %{without bootstrap}
27 # which version exactly???
28 # for full x264 CLI utility functionality it wants:
29 # libswscale >= 0.9.0 (in pkgconfig file)
30 # libav{format,codec,util} from ffmpeg >= r21854
31 BuildRequires:  ffmpeg-devel >= 0.7.1
32 BuildRequires:  ffmpegsource-devel >= 2.16
33 # gpac >= 2007-06-21
34 BuildRequires:  gpac-devel >= 0.5.0-3
35 %endif
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 # encoder/macroblock.c breaks strict-aliasing rules
39 %define         specflags       -fno-strict-aliasing
40
41 %description
42 libx264 library for encoding H264 video format.
43
44 %description -l pl.UTF-8
45 Biblioteka libx264 do kodowania w formacie obrazu H264.
46
47 %package devel
48 Summary:        Header files for x264 library
49 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x264
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52
53 %description devel
54 Header files for x264 library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki x264.
58
59 %package static
60 Summary:        Static x264 library
61 Summary(pl.UTF-8):      Statyczna biblioteka x264
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static x264 library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka x264.
70
71 %package -n x264
72 Summary:        x264 CLI decoder
73 Summary(pl.UTF-8):      Dekoder x264 działający z linii poleceń
74 Group:          Applications/Multimedia
75 Requires:       %{name} = %{version}-%{release}
76 %if %{without bootstrap}
77 Requires:       gpac >= 0.5.0-3
78 %endif
79
80 %description -n x264
81 x264 CLI decoder.
82
83 %description -n x264 -l pl.UTF-8
84 Dekoder x264 działający z linii poleceń.
85
86 %prep
87 %setup -q -n x264-snapshot-%{snap}-%{snaph}
88 %patch0 -p1
89 %if "%{pld_release}" == "ac"
90 %patch1 -p1
91 %endif
92 %patch2 -p1
93
94 %build
95 CC="%{__cc}" \
96 ./configure \
97         --prefix=%{_prefix} \
98         --exec-prefix=%{_prefix} \
99         --bindir=%{_bindir} \
100         --includedir=%{_includedir} \
101         --libdir=%{_libdir} \
102         --extra-cflags="%{rpmcflags}" \
103         --enable-pic \
104         --enable-shared \
105         --enable-static
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS
124 %attr(755,root,root) %{_libdir}/libx264.so.142
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/libx264.so
129 %{_includedir}/x264.h
130 %{_includedir}/x264_config.h
131 %{_pkgconfigdir}/x264.pc
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libx264.a
136
137 %files -n x264
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/x264
This page took 0.037233 seconds and 4 git commands to generate.