]> git.pld-linux.org Git - packages/libx264.git/blob - libx264.spec
- rel 4
[packages/libx264.git] / libx264.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap
4 #
5 %define         snap    20110625
6 %define         snaph   2245
7 %define         rel             4
8 Summary:        H264 encoder library
9 Summary(pl.UTF-8):      Biblioteka kodująca H264
10 Name:           libx264
11 Version:        0.1.3
12 Release:        1.%{snap}_%{snaph}.%{rel}
13 License:        GPL v2+
14 Group:          Libraries
15 # still no releases, use snapshots
16 Source0:        ftp://ftp.videolan.org/pub/videolan/x264/snapshots/x264-snapshot-%{snap}-%{snaph}.tar.bz2
17 # Source0-md5:  6463c144cd10c26d721fac212a747910
18 Patch0:         %{name}-alpha.patch
19 Patch1:         altivec-no-vand.patch
20 Patch2:         %{name}-gpac.patch
21 Patch3:         %{name}-ffmpeg.patch
22 URL:            http://www.videolan.org/developers/x264.html
23 BuildRequires:  pkgconfig
24 %ifarch %{ix86} %{x8664}
25 BuildRequires:  yasm >= 0.6.0
26 %endif
27 %if %{without bootstrap}
28 # which version exactly???
29 # for full x264 CLI utility functionality it wants:
30 # libswscale >= 0.9.0 (in pkgconfig file)
31 # libav{format,codec,util} from ffmpeg >= r21854
32 BuildRequires:  ffmpeg-devel >= 0.7.1
33 BuildRequires:  ffmpegsource-devel >= 2.15
34 # gpac >= 2007-06-21
35 BuildRequires:  gpac-devel >= 0.4.5-2
36 Requires:       gpac >= 0.4.5-2
37 %endif
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 # encoder/macroblock.c breaks strict-aliasing rules
41 %define         specflags       -fno-strict-aliasing
42
43 %description
44 libx264 library for encoding H264 video format.
45
46 %description -l pl.UTF-8
47 Biblioteka libx264 do kodowania w formacie obrazu H264.
48
49 %package devel
50 Summary:        Header files for x264 library
51 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki x264
52 Group:          Development/Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description devel
56 Header files for x264 library.
57
58 %description devel -l pl.UTF-8
59 Pliki nagłówkowe biblioteki x264.
60
61 %package static
62 Summary:        Static x264 library
63 Summary(pl.UTF-8):      Statyczna biblioteka x264
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static x264 library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka x264.
72
73 %package -n x264
74 Summary:        x264 CLI decoder
75 Summary(pl.UTF-8):      Dekoder x264 działający z linii poleceń
76 Group:          Applications/Multimedia
77 Requires:       %{name} = %{version}-%{release}
78
79 %description -n x264
80 x264 CLI decoder.
81
82 %description -n x264 -l pl.UTF-8
83 Dekoder x264 działający z linii poleceń.
84
85 %prep
86 %setup -q -n x264-snapshot-%{snap}-%{snaph}
87 %patch0 -p1
88 %if "%{pld_release}" == "ac"
89 %patch1 -p1
90 %endif
91 %patch2 -p1
92 %patch3 -p1
93
94 %build
95 CC="%{__cc}" \
96 ./configure \
97         --prefix=%{_prefix} \
98         --exec-prefix=%{_prefix} \
99         --bindir=%{_bindir} \
100         --includedir=%{_includedir} \
101         --libdir=%{_libdir} \
102         --extra-cflags="%{rpmcflags}" \
103         --enable-pic \
104         --enable-shared \
105         --enable-static
106
107 %{__make}
108
109 %install
110 rm -rf $RPM_BUILD_ROOT
111
112 %{__make} install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %post   -p /sbin/ldconfig
119 %postun -p /sbin/ldconfig
120
121 %files
122 %defattr(644,root,root,755)
123 %doc AUTHORS
124 %attr(755,root,root) %{_libdir}/libx264.so.115
125
126 %files devel
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_libdir}/libx264.so
129 %{_includedir}/x264.h
130 %{_includedir}/x264_config.h
131 %{_pkgconfigdir}/x264.pc
132
133 %files static
134 %defattr(644,root,root,755)
135 %{_libdir}/libx264.a
136
137 %files -n x264
138 %defattr(644,root,root,755)
139 %attr(755,root,root) %{_bindir}/x264
This page took 0.041419 seconds and 4 git commands to generate.