]> git.pld-linux.org Git - packages/libvirt.git/blob - libvirt.spec
- desc fixes, added remaining pl
[packages/libvirt.git] / libvirt.spec
1 #
2 # Conditional build:
3 %bcond_without  esx             # VMware ESX support
4 %bcond_without  hyperv          # Hyper-V support
5 %bcond_without  libxl           # libxenlight
6 %bcond_without  lxc             # LXC support
7 %bcond_without  netcf           # host interfaces support
8 %bcond_without  openvz          # OpenVZ support
9 %bcond_without  phyp            # PHYP support
10 %bcond_without  polkit          # PolicyKit
11 %bcond_without  qemu            # Qemu
12 %bcond_without  sanlock         # sanlock storage lock manager
13 %bcond_without  uml             # UML support
14 %bcond_without  vbox            # VirtualBox support
15 %bcond_without  vmware          # VMware Workstation/Player support
16 %bcond_with     xenapi          # XenAPI support
17 %bcond_without  xen_proxy       # Xen proxy
18 %bcond_without  xen             # xen
19
20 # qemu available only on x86 and ppc
21 %ifnarch %{ix86} %{x8664} ppc
22 %undefine       with_qemu
23 %endif
24 # Xen is available only on x86 and ia64
25 %ifnarch %{ix86} %{x8664} ia64
26 %undefine       with_xen
27 %endif
28 %if %{without xen}
29 %undefine       with_xen_proxy
30 %endif
31
32 Summary:        Toolkit to interact with virtualization capabilities
33 Summary(pl.UTF-8):      Narzędzia współpracujące z funkcjami wirtualizacji
34 Name:           libvirt
35 Version:        0.9.11
36 Release:        1
37 License:        LGPL v2.1+
38 Group:          Libraries
39 Source0:        ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
40 # Source0-md5:  6e9fab115075a8fd21d9bd0d7e558a52
41 Source1:        %{name}.init
42 Source2:        %{name}.tmpfiles
43 Patch0:         %{name}-sasl.patch
44 Patch1:         %{name}-lxc.patch
45 Patch2:         %{name}-qemu-acl.patch
46 Patch3:         %{name}-xend.patch
47 Patch4:         lxc-without-selinux.patch
48 Patch5:         %{name}-driver-modules.patch
49 URL:            http://www.libvirt.org/
50 BuildRequires:  audit-libs-devel
51 BuildRequires:  augeas-devel
52 BuildRequires:  autoconf >= 2.50
53 BuildRequires:  automake
54 BuildRequires:  avahi-devel >= 0.6.0
55 BuildRequires:  curl-devel >= 7.18.0
56 BuildRequires:  cyrus-sasl-devel
57 BuildRequires:  device-mapper-devel >= 1.0.0
58 BuildRequires:  gawk
59 BuildRequires:  gettext-devel >= 0.17
60 BuildRequires:  gnutls-devel >= 1.0.25
61 BuildRequires:  libapparmor-devel
62 BuildRequires:  libblkid-devel >= 2.17
63 BuildRequires:  libcap-ng-devel >= 0.4.0
64 BuildRequires:  libgcrypt-devel
65 BuildRequires:  libnl1-devel >= 1.1
66 BuildRequires:  libpcap-devel >= 1.0.0
67 BuildRequires:  libselinux-devel >= 2.0.82
68 BuildRequires:  libssh2-devel >= 1.0
69 BuildRequires:  libstdc++-devel
70 BuildRequires:  libtool
71 BuildRequires:  libxml2-devel >= 1:2.6.0
72 BuildRequires:  libxslt-devel
73 BuildRequires:  ncurses-devel
74 %{?with_netcf:BuildRequires:    netcf-devel >= 0.1.4}
75 BuildRequires:  numactl-devel
76 BuildRequires:  openldap-devel
77 BuildRequires:  openwsman-devel >= 2.2.3
78 BuildRequires:  parted-devel >= 1.8.0
79 BuildRequires:  perl-tools-pod
80 %{?with_polkit:BuildRequires:   polkit >= 0.90}
81 BuildRequires:  pkgconfig
82 BuildRequires:  python
83 BuildRequires:  python-devel
84 BuildRequires:  readline-devel
85 BuildRequires:  rpm-pythonprov
86 BuildRequires:  rpmbuild(macros) >= 1.627
87 %{?with_sanlock:BuildRequires:  sanlock-devel >= 0.8}
88 BuildRequires:  udev-devel >= 145
89 %{?with_xen:BuildRequires:      xen-devel >= 4.1.2}
90 # For disk driver
91 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10.0
92 BuildRequires:  yajl-devel
93 Requires:       curl-libs >= 7.18.0
94 Requires:       device-mapper >= 1.0.0
95 Requires:       libcap-ng >= 0.4.0
96 Requires:       libnl1 >= 1.1
97 Requires:       libpcap >= 1.0.0
98 Requires:       libselinux >= 2.0.82
99 Requires:       libssh2 >= 1.0
100 Requires:       libxml2 >= 1:2.6.0
101 Requires:       openwsman-libs >= 2.2.3
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %description
105 Libvirt is a C toolkit to interact with the virtualization
106 capabilities of recent versions of Linux.
107
108 Virtualization of the Linux Operating System means the ability to run
109 multiple instances of Operating Systems concurently on a single
110 hardware system where the basic resources are driven by a Linux
111 instance. The library aim at providing long term stable C API
112 initially for the Xen paravirtualization but should be able to
113 integrate other virtualization mechanisms if needed.
114
115 This package contains the base libraries and configuration file.
116
117 %description -l pl.UTF-8
118 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
119 obecnych wersji Linuksa.
120
121 Wirtualizacja w systemie operacyjnym Linux oznacza możliwość
122 jednoczesnego uruchamiania wielu instancji systemu operacyjnego na
123 pojedynczym systemie sprzętowym, którego podstawowe zasoby są
124 zarządzane przez instancję Linuksa. Celem biblioteki jest zapewnienie
125 długotrwale stabilnego API C, początkowo do parawirtualizacji Xen, ale
126 dającej się zintegrować w razie potrzeby z innymi mechanizmami
127 wirtualizacji.
128
129 Ten pakiet zawiera podstawowe biblioteki oraz plik konfiguracyjny.
130
131 %package devel
132 Summary:        Development files for programs using libvirt
133 Summary(pl.UTF-8):      Pliki programistyczne do programów wykorzystujących libvirt
134 Group:          Development/Libraries
135 Requires:       %{name} = %{version}-%{release}
136 Requires:       audit-libs-devel
137 Requires:       curl-devel >= 7.18.0
138 Requires:       device-mapper-devel >= 1.0.0
139 Requires:       gnutls-devel >= 1.0.25
140 Requires:       libapparmor-devel
141 Requires:       libcap-ng-devel >= 0.4.0
142 Requires:       libgcrypt-devel
143 Requires:       libnl1-devel >= 1.1
144 Requires:       libpcap-devel >= 1.0.0
145 Requires:       libselinux-devel >= 2.0.82
146 Requires:       libxml2-devel >= 1:2.6.0
147 Requires:       numactl-devel
148 Requires:       openwsman-devel >= 2.2.3
149 %{?with_xen:Requires: xen-devel}
150 Requires:       yajl-devel
151
152 %description devel
153 Libvirt is a C toolkit to interact with the virtualization
154 capabilities of recent versions of Linux.
155
156 This package contains the header files needed for developing programs
157 using the libvirt library.
158
159 %description devel -l pl.UTF-8
160 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
161 obecnych wersji Linuksa.
162
163 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
164 wykorzystujących bibliotekę libvirt.
165
166 %package static
167 Summary:        Development static libraries for programs using libvirt
168 Summary(pl.UTF-8):      Statyczne biblioteki programistyczne do programów wykorzystujących libvirt
169 Group:          Development/Libraries
170 Requires:       %{name}-devel = %{version}-%{release}
171
172 %description static
173 Libvirt is a C toolkit to interact with the virtualization
174 capabilities of recent versions of Linux.
175
176 This package contains the static libraries for developing programs
177 using the libvirt library.
178
179 %description static -l pl.UTF-8
180 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
181 obecnych wersji Linuksa.
182
183 Ten pakiet zawiera biblioteki statyczne do tworzenia programów
184 wykorzystujących bibliotekę libvirt.
185
186 %package -n python-%{name}
187 Summary:        Python bindings to interact with virtualization capabilities
188 Summary(pl.UTF-8):      Wiązania Pythona do współpracy z funkcjami wirtualizacji
189 Group:          Development/Languages/Python
190 Requires:       %{name} = %{version}-%{release}
191
192 %description -n python-%{name}
193 Libvirt is a C toolkit to interact with the virtualization
194 capabilities of recent versions of Linux.
195
196 This package contains the Python bindings for the libvirt library.
197
198 %description -n python-%{name} -l pl.UTF-8
199 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
200 obecnych wersji Linuksa.
201
202 Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
203
204 %package lock-sanlock
205 Summary:        Sanlock lock manager plugin for libvirt
206 Summary(pl.UTF-8):      Zarządca blokad sanlock dla biblioteki libvirt
207 Group:          Libraries
208 Requires:       %{name} = %{version}-%{release}
209
210 %description lock-sanlock
211 Sanlock lock manager plugin for libvirt.
212
213 %description lock-sanlock -l pl.UTF-8
214 Zarządca blokad sanlock dla biblioteki libvirt.
215
216 %package daemon
217 Summary:        Server side daemon and supporting files for libvirt library
218 Summary(pl.UTF-8):      Demon działający po stronie serwera oraz pliki wspierające dla biblioteki libvirt
219 Group:          Applications/System
220 Requires:       %{name} = %{version}-%{release}
221 Requires:       avahi-libs >= 0.6.0
222 Requires:       iproute2
223 Requires:       libblkid >= 2.17
224 Provides:       libvirt(hypervisor)
225 Requires:       parted-libs >= 1.8.0
226 # Needed for probing the power management features of the host.
227 Requires:       pm-utils
228 Requires:       systemd-units >= 37-0.10
229 Requires:       udev-libs >= 145
230 Requires:       util-linux
231 Requires:       virtual(module-tools)
232 Requires:       xorg-lib-libpciaccess >= 0.10.0
233 Requires(post): systemd-units
234 Requires(preun):        systemd-units
235 Requires(postun):       systemd-units
236 Suggests:       bridge-utils
237 Suggests:       cyrus-sasl
238 Suggests:       cyrus-sasl-digest-md5
239 Suggests:       dmidecode
240 Suggests:       dnsmasq >= 2.41
241 Suggests:       ebtables
242 Suggests:       gawk
243 Suggests:       glusterfs-client >= 2.0.1
244 Suggests:       iptables
245 Suggests:       iptables
246 Suggests:       libcgroup
247 Suggests:       lvm2
248 Suggests:       numad
249 Suggests:       open-iscsi
250 Suggests:       parted
251 Suggests:       polkit >= 0.93
252 Suggests:       radvd
253 Suggests:       scrub
254
255 %description daemon
256 Server side daemon required to manage the virtualization capabilities
257 of recent versions of Linux. Requires a hypervisor specific sub-RPM
258 for specific drivers.
259
260 %description daemon -l pl.UTF-8
261 Demon działający po stronie serwera wymagany do zarządzania funkcjami
262 wirtualizacji nowych wersji Linuksa. Wymaga podpakietu specyficznego
263 dla hipernadzorcy.
264
265 %package daemon-esx
266 Summary:        Server side driver required to run VMware ESX guests
267 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości VMware ESX
268 Group:          Libraries
269 Requires:       %{name}-daemon = %{version}-%{release}
270 Provides:       libvirt(hypervisor)
271
272 %description daemon-esx
273 Server side driver required to manage the virtualization capabilities
274 of the VMware ESX emulators.
275
276 %description daemon-esx -l pl.UTF-8
277 Sterownik wymagany po stronie serwera do zarządzania funkcjami
278 wirtualizacji emulatora VMware ESX.
279
280 %package daemon-hyperv
281 Summary:        Server side driver required to run Microsoft Hyper-V guests
282 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Microsoft Hyper-V
283 Group:          Libraries
284 Requires:       %{name}-daemon = %{version}-%{release}
285 Provides:       libvirt(hypervisor)
286
287 %description daemon-hyperv
288 Server side driver required to manage the virtualization capabilities
289 of the Microsoft Hyper-V emulators.
290
291 %description daemon-hyperv -l pl.UTF-8
292 Sterownik wymagany po stronie serwera do zarządzania funkcjami
293 wirtualizacji emulatora Microsoft Hyper-V.
294
295 %package daemon-libxl
296 Summary:        Server side driver required to run XEN guests (xenlight)
297 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości XEN (xenlight)
298 Group:          Libraries
299 Requires:       %{name}-daemon = %{version}-%{release}
300 Requires:       /usr/sbin/qcow-create
301 Requires:       xen
302 Provides:       libvirt(hypervisor)
303
304 %description daemon-libxl
305 Server side driver required to manage the virtualization capabilities
306 of XEN via xenlight interface.
307
308 %description daemon-libxl -l pl.UTF-8
309 Sterownik wymagany po stronie serwera do zarządzania funkcjami
310 wirtualizacji XEN poprzez interfejs xenlight.
311
312 %package daemon-lxc
313 Summary:        Server side driver required to run LXC guests
314 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości LXC
315 Group:          Libraries
316 Requires:       %{name}-daemon = %{version}-%{release}
317 Provides:       libvirt(hypervisor)
318
319 %description daemon-lxc
320 Server side driver required to manage the virtualization capabilities
321 of LXC.
322
323 %description daemon-lxc -l pl.UTF-8
324 Sterownik wymagany po stronie serwera do zarządzania funkcjami
325 wirtualizacji LXC.
326
327 %package daemon-openvz
328 Summary:        Server side driver required to run OpenVZ guests
329 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości OpenVZ
330 Group:          Libraries
331 Requires:       %{name}-daemon = %{version}-%{release}
332 Provides:       libvirt(hypervisor)
333
334 %description daemon-openvz
335 Server side driver required to manage the virtualization capabilities
336 of OpenVZ.
337
338 %description daemon-openvz -l pl.UTF-8
339 Sterownik wymagany po stronie serwera do zarządzania funkcjami
340 wirtualizacji OpenVZ.
341
342 %package daemon-phyp
343 Summary:        Server side driver required to run Power Hypervisors guests
344 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Power Hypervisors
345 Group:          Libraries
346 Requires:       %{name}-daemon = %{version}-%{release}
347 Provides:       libvirt(hypervisor)
348
349 %description daemon-phyp
350 Server side driver required to manage the virtualization capabilities
351 of Power Hypervisors.
352
353 %description daemon-phyp -l pl.UTF-8
354 Sterownik wymagany po stronie serwera do zarządzania funkcjami
355 wirtualizacji Power Hypervisors.
356
357 %package daemon-qemu
358 Summary:        Server side driver required to run QEMU guests
359 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości QEMU
360 Group:          Libraries
361 Requires:       %{name}-daemon = %{version}-%{release}
362 Requires:       /usr/bin/qemu-img
363 Requires:       qemu
364 Requires:       bzip2
365 Requires:       gzip
366 Requires:       lzop
367 Requires:       xz
368 Provides:       libvirt(hypervisor)
369
370 %description daemon-qemu
371 Server side driver required to manage the virtualization capabilities
372 of the QEMU emulators.
373
374 %description daemon-qemu -l pl.UTF-8
375 Sterownik wymagany po stronie serwera do zarządzania funkcjami
376 wirtualizacji emulatora QEMU.
377
378 %package daemon-uml
379 Summary:        Server side driver required to run UML guests
380 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości UML
381 Group:          Libraries
382 Requires:       %{name}-daemon = %{version}-%{release}
383 Provides:       libvirt(hypervisor)
384
385 %description daemon-uml
386 Server side driver required to manage the virtualization capabilities
387 of UML.
388
389 %description daemon-uml -l pl.UTF-8
390 Sterownik wymagany po stronie serwera do zarządzania funkcjami
391 wirtualizacji UML.
392
393 %package daemon-vbox
394 Summary:        Server side driver required to run Oracle VirtualBox guests
395 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Oracle VirtualBox
396 Group:          Libraries
397 Requires:       %{name}-daemon = %{version}-%{release}
398 Provides:       libvirt(hypervisor)
399
400 %description daemon-vbox
401 Server side driver required to manage the virtualization capabilities
402 of Oracle VirtualBox.
403
404 %description daemon-vbox -l pl.UTF-8
405 Sterownik wymagany po stronie serwera do zarządzania funkcjami
406 wirtualizacji Oracle VirtualBox.
407
408 %package daemon-vmware
409 Summary:        Server side driver required to run VMware Workstation guests
410 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości VMware Workstation
411 Group:          Libraries
412 Requires:       %{name}-daemon = %{version}-%{release}
413 Provides:       libvirt(hypervisor)
414
415 %description daemon-vmware
416 Server side driver required to manage the virtualization capabilities
417 of VMware Workstation.
418
419 %description daemon-vmware -l pl.UTF-8
420 Sterownik wymagany po stronie serwera do zarządzania funkcjami
421 wirtualizacji VMware Workstation.
422
423 %package daemon-xen
424 Summary:        Server side driver required to run XEN guests
425 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości XEN
426 Group:          Libraries
427 Requires:       %{name}-daemon = %{version}-%{release}
428 Requires:       /usr/sbin/qcow-create
429 Requires:       xen
430 Requires:       xen-xend
431 Provides:       libvirt(hypervisor)
432
433 %description daemon-xen
434 Server side driver required to manage the virtualization capabilities
435 of XEN.
436
437 %description daemon-xen -l pl.UTF-8
438 Sterownik wymagany po stronie serwera do zarządzania funkcjami
439 wirtualizacji XEN.
440
441 %package client
442 Summary:        Client side utilities of the libvirt library
443 Summary(pl.UTF-8):      Narzędzia klienckie do biblioteki libvirt
444 Group:          Applications/System
445 Requires:       gettext >= 0.18.1.1-6
446 Requires:       gnutls >= 1.0.25
447 Requires:       netcat-openbsd
448 Requires(post): systemd-units
449 Requires(preun):        systemd-units
450 Requires(postun):       systemd-units
451
452 %description client
453 Client binaries needed to access to the virtualization capabilities of
454 recent versions of Linux (and other OSes).
455
456 %description client -l pl.UTF-8
457 Programy klienckie potrzebne do funkcji wirtualizacji nowych wersji
458 Linuksa (oraz innych systemów operacyjnych).
459
460 %package utils
461 Summary:        Tools to interact with virtualization capabilities (metapackage)
462 Summary(pl.UTF-8):      Narzędzia do współpracy z funkcjami wirtualizacyjnymi (metapakiet)
463 Group:          Applications/System
464 Requires:       %{name}-client = %{version}-%{release}
465 Requires:       %{name}-daemon = %{version}-%{release}
466 Requires:       %{name}-daemon-esx = %{version}-%{release}
467 Requires:       %{name}-daemon-hyperv = %{version}-%{release}
468 Requires:       %{name}-daemon-libxl = %{version}-%{release}
469 Requires:       %{name}-daemon-lxc = %{version}-%{release}
470 Requires:       %{name}-daemon-openvz = %{version}-%{release}
471 Requires:       %{name}-daemon-phyp = %{version}-%{release}
472 Requires:       %{name}-daemon-qemu = %{version}-%{release}
473 Requires:       %{name}-daemon-uml = %{version}-%{release}
474 Requires:       %{name}-daemon-vbox = %{version}-%{release}
475 Requires:       %{name}-daemon-vmware = %{version}-%{release}
476 Requires:       %{name}-daemon-xen = %{version}-%{release}
477
478 %description utils
479 Libvirt is a C toolkit to interact with the virtualization
480 capabilities of recent versions of Linux.
481
482 This is metapackage gathering all tools for the libvirt library.
483
484 %description utils -l pl.UTF-8
485 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
486 obecnych wersji Linuksa.
487
488 To jest metapakiet zbierający wszystkie narzędzia przeznaczone dla
489 biblioteki libvirt.
490
491 %prep
492 %setup -q
493 %patch0 -p1
494 %patch1 -p1
495 %patch2 -p1
496 %patch3 -p1
497 %patch4 -p1
498 %patch5 -p1
499
500 # weird translations
501 %{__rm} po/{my,eu_ES}.{po,gmo}
502
503 mv po/vi_VN.po po/vi.po
504 mv po/vi_VN.gmo po/vi.gmo
505
506 %build
507 %{__libtoolize}
508 %{__aclocal} -I gnulib/m4 -I m4
509 %{__autoconf}
510 %{__autoheader}
511 %{__automake}
512
513 %configure \
514         PVCREATE=/sbin/pvcreate \
515         VGCREATE=/sbin/vgcreate \
516         LVCREATE=/sbin/lvcreate \
517         PVREMOVE=/sbin/pvremove \
518         VGREMOVE=/sbin/vgremove \
519         LVREMOVE=/sbin/lvremove \
520         VGCHANGE=/sbin/vgchange \
521         LVCHANGE=/sbin/lvchange \
522           VGSCAN=/sbin/vgscan   \
523              PVS=/sbin/pvs      \
524              VGS=/sbin/vgs      \
525              LVS=/sbin/lvs      \
526               TC=/sbin/tc \
527            BRCTL=/sbin/brctl    \
528         ISCSIADM=/sbin/iscsiadm \
529         SHOWMOUNT=/usr/sbin/showmount \
530         MOUNT=/bin/mount \
531         UMOUNT=/bin/umount \
532         MKFS=/sbin/mkfs \
533         SHOWMOUNT=/usr/sbin/showmount \
534         IPTABLES_PATH=/usr/sbin/iptables \
535         IP6TABLES_PATH=/usr/sbin/ip6tables \
536         EBTABLES_PATH=/usr/sbin/ebtables \
537         ISCSIADM=/sbin/iscsiadm \
538         DNSMASQ=/usr/sbin/dnsmasq \
539         RADVD=/usr/sbin/radvd \
540         UDEVADM=/sbin/udevadm \
541         MODPROBE=/sbin/modprobe \
542         SCRUB=/usr/bin/scrub \
543         OVSVSCTL=/usr/bin/ovs-vsctl \
544         NUMAD=/usr/bin/numad \
545         --disable-silent-rules \
546         --with-html-dir=%{_gtkdocdir} \
547         --with-html-subdir=%{name} \
548         --with-init-script=redhat \
549         --with-storage-lvm \
550         --with-storage-fs \
551         --with-storage-iscsi \
552         --with-storage-scsi \
553         --with-storage-mpath \
554         --with-storage-disk \
555         --with-macvtap \
556         --with-virtualport \
557         --with-udev \
558         --with-libssh2 \
559         --with-avahi \
560         --with-audit \
561         --with-libblkid \
562         --with-macvtap \
563         --with-virtualport \
564         --with-numad \
565         --with-numactl \
566         --with-sasl \
567         --with-yajl \
568         --with-selinux \
569         --with-apparmor \
570         --with-qemu-user=qemu \
571         --with-qemu-group=qemu \
572         --without-hal \
573         --with-driver-modules \
574         %{__with_without polkit} \
575         %{__with_without esx} \
576         %{__with_without hyperv} \
577         %{__with_without libxl} \
578         %{__with_without lxc} \
579         %{__with_without netcf} \
580         %{__with_without openvz} \
581         %{__with_without phyp} \
582         %{__with_without qemu} \
583         %{__with_without sanlock} \
584         %{__with_without uml} \
585         %{__with_without vbox vbox %{_libdir}/VirtualBox} \
586         %{__with_without vmware} \
587         %{__with_without xen} \
588         %{__with_without xenapi} \
589         --x-libraries=%{_libdir} \
590         --with-init-script=systemd
591
592 %{__make} \
593         AWK=gawk
594
595 %install
596 rm -rf $RPM_BUILD_ROOT
597 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
598         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
599
600 %{__make} install \
601         DEVHELP_DIR=%{_gtkdocdir}/%{name}/devhelp \
602         DESTDIR=$RPM_BUILD_ROOT
603
604 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
605 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
606
607 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
608 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
609 %py_postclean
610 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
611
612 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
613 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.{a,la}
614
615 %if %{with sanlock}
616 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.{a,la}
617 %endif
618
619 %find_lang %{name}
620
621 %clean
622 rm -rf $RPM_BUILD_ROOT
623
624 %post   -p /sbin/ldconfig
625 %postun -p /sbin/ldconfig
626
627 %post daemon
628 %systemd_post libvirtd.service
629
630 %preun daemon
631 %systemd_preun libvirtd.service
632
633 %postun daemon
634 %systemd_reload
635
636 %post client
637 NORESTART=1
638 %systemd_post libvirt-guests.service
639
640 %preun client
641 %systemd_preun libvirt-guests.service
642
643 %postun client
644 %systemd_reload
645
646 %files -f %{name}.lang
647 %defattr(644,root,root,755)
648 %doc ChangeLog README TODO NEWS
649 %dir %{_sysconfdir}/libvirt
650 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirt.conf
651 %attr(755,root,root) %{_libdir}/libvirt.so.*.*.*
652 %attr(755,root,root) %ghost %{_libdir}/libvirt.so.0
653 %if %{with qemu}
654 %attr(755,root,root) %{_libdir}/libvirt-qemu.so.*.*.*
655 %attr(755,root,root) %ghost %{_libdir}/libvirt-qemu.so.0
656 %endif
657 %dir %{_libdir}/libvirt
658
659 %files devel
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_libdir}/libvirt.so
662 %attr(755,root,root) %{_libdir}/libvirt-qemu.so
663 %{_datadir}/%{name}/api
664 %{_gtkdocdir}/%{name}
665 %{_includedir}/%{name}
666 %{_pkgconfigdir}/%{name}.pc
667
668 %files static
669 %defattr(644,root,root,755)
670 %{_libdir}/libvirt.a
671 %{_libdir}/libvirt-qemu.a
672
673 %files -n python-%{name}
674 %defattr(644,root,root,755)
675 %doc %{_docdir}/%{name}-python-%{version}
676 %attr(755,root,root) %{py_sitedir}/libvirtmod.so
677 %attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
678 %{py_sitedir}/libvirt.py[co]
679 %{py_sitedir}/libvirt_qemu.py[co]
680
681 %if %{with sanlock}
682 %files lock-sanlock
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_sbindir}/virt-sanlock-cleanup
685 %dir %{_libdir}/libvirt/lock-driver
686 %attr(755,root,root) %{_libdir}/libvirt/lock-driver/sanlock.so
687 %{_datadir}/augeas/lenses/libvirt_sanlock.aug
688 %{_datadir}/augeas/lenses/tests/test_libvirt_sanlock.aug
689 %dir /var/lib/libvirt/sanlock
690 %{_mandir}/man8/virt-sanlock-cleanup.8*
691 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-sanlock.conf
692 %endif
693
694 %files daemon
695 %defattr(644,root,root,755)
696 %doc docs/*.xml
697 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/nwfilter
698 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu
699 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks
700 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks/autostart
701 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirtd.conf
702 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/default.xml
703 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/autostart/default.xml
704 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/nwfilter/*.xml
705 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/libvirt.conf
706 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
707 %attr(754,root,root) /etc/rc.d/init.d/libvirtd
708 %{systemdunitdir}/libvirtd.service
709 %config(noreplace) %verify(not md5 mtime size) /etc/sysctl.d/libvirtd
710 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
711 %attr(755,root,root) %{_libdir}/libvirt_iohelper
712 %attr(755,root,root) %{_libdir}/libvirt_parthelper
713 %attr(755,root,root) %{_libdir}/virt-aa-helper
714 %attr(755,root,root) %{_sbindir}/libvirtd
715 %{_datadir}/augeas/lenses/libvirtd.aug
716 %{_datadir}/augeas/lenses/tests/test_libvirtd.aug
717 %{?with_polkit:%{_datadir}/polkit-1/actions/org.libvirt.unix.policy}
718 %{_mandir}/man8/libvirtd.8*
719 %dir /var/lib/libvirt
720 %dir /var/lib/libvirt/dnsmasq
721 %attr(711,root,root) %dir /var/lib/libvirt/boot
722 %attr(700,root,root) %dir /var/lib/libvirt/network
723 %attr(711,root,root) %dir /var/lib/libvirt/images
724 %attr(711,root,root) %dir /var/lib/libvirt/filesystems
725 %attr(700,root,root) %dir /var/log/libvirt
726 %attr(711,root,root) %dir /var/cache/libvirt
727 %dir /var/run/libvirt
728 %dir /var/run/libvirt/network
729 %{systemdtmpfilesdir}/%{name}.conf
730 %dir %{_libdir}/libvirt/connection-driver
731 %{?with_netcf:%attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_interface.so}
732 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_network.so
733 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nodedev.so
734 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nwfilter.so
735 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_secret.so
736 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_storage.so
737 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_test.so
738
739 %if %{with esx}
740 %files daemon-esx
741 %defattr(644,root,root,755)
742 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_esx.so
743 %endif
744
745 %if %{with hyperv}
746 %files daemon-hyperv
747 %defattr(644,root,root,755)
748 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_hyperv.so
749 %endif
750
751 %if %{with libxl}
752 %files daemon-libxl
753 %defattr(644,root,root,755)
754 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_libxl.so
755 %attr(700,root,root) %dir /var/lib/libvirt/libxl
756 %attr(700,root,root) %dir /var/run/libvirt/libxl
757 %attr(700,root,root) %dir /var/log/libvirt/libxl
758 %endif
759
760 %if %{with lxc}
761 %files daemon-lxc
762 %defattr(644,root,root,755)
763 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/lxc.conf
764 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.lxc
765 %attr(700,root,root) %dir /var/lib/libvirt/lxc
766 %attr(700,root,root) %dir /var/run/libvirt/lxc
767 %attr(700,root,root) %dir /var/log/libvirt/lxc
768 %{_datadir}/augeas/lenses/libvirtd_lxc.aug
769 %{_datadir}/augeas/lenses/tests/test_libvirtd_lxc.aug
770 %attr(755,root,root) %{_libdir}/libvirt_lxc
771 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_lxc.so
772 %endif
773
774 %if %{with openvz}
775 %files daemon-openvz
776 %defattr(644,root,root,755)
777 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_openvz.so
778 %endif
779
780 %if %{with phyp}
781 %files daemon-phyp
782 %defattr(644,root,root,755)
783 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_phyp.so
784 %endif
785
786 %if %{with qemu}
787 %files daemon-qemu
788 %defattr(644,root,root,755)
789 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu.conf
790 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.qemu
791 %attr(750,qemu,qemu) %dir /var/cache/libvirt/qemu
792 %attr(750,qemu,qemu) %dir /var/lib/libvirt/qemu
793 %attr(700,root,root) %dir /var/log/libvirt/qemu
794 %attr(700,root,root) %dir /var/run/libvirt/qemu
795 %{_datadir}/augeas/lenses/libvirtd_qemu.aug
796 %{_datadir}/augeas/lenses/tests/test_libvirtd_qemu.aug
797 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_qemu.so
798 %endif
799
800 %if %{with uml}
801 %files daemon-uml
802 %defattr(644,root,root,755)
803 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_uml.so
804 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.uml
805 %attr(700,root,root) %dir /var/lib/libvirt/uml
806 %attr(700,root,root) %dir /var/run/libvirt/uml
807 %attr(700,root,root) %dir /var/log/libvirt/uml
808 %endif
809
810 %if %{with vbox}
811 %files daemon-vbox
812 %defattr(644,root,root,755)
813 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vbox.so
814 %endif
815
816 %if %{with vmware}
817 %files daemon-vmware
818 %defattr(644,root,root,755)
819 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vmware.so
820 %endif
821
822 %if %{with xen}
823 %files daemon-xen
824 %defattr(644,root,root,755)
825 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_xen.so
826 %endif
827
828 %files client
829 %defattr(644,root,root,755)
830 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
831 %attr(754,root,root) /etc/rc.d/init.d/libvirt-guests
832 %{systemdunitdir}/libvirt-guests.service
833 %attr(755,root,root) %{_bindir}/virsh
834 %attr(755,root,root) %{_bindir}/virt-host-validate
835 %attr(755,root,root) %{_bindir}/virt-xml-validate
836 %attr(755,root,root) %{_bindir}/virt-pki-validate
837 %{_mandir}/man1/virsh.1*
838 %{_mandir}/man1/virt-host-validate.1*
839 %{_mandir}/man1/virt-xml-validate.1*
840 %{_mandir}/man1/virt-pki-validate.1*
841 %dir %{_datadir}/libvirt
842 %{_datadir}/libvirt/cpu_map.xml
843 %dir %{_datadir}/libvirt/schemas
844 %{_datadir}/libvirt/schemas/basictypes.rng
845 %{_datadir}/libvirt/schemas/capability.rng
846 %{_datadir}/libvirt/schemas/domain.rng
847 %{_datadir}/libvirt/schemas/domaincommon.rng
848 %{_datadir}/libvirt/schemas/domainsnapshot.rng
849 %{_datadir}/libvirt/schemas/interface.rng
850 %{_datadir}/libvirt/schemas/network.rng
851 %{_datadir}/libvirt/schemas/networkcommon.rng
852 %{_datadir}/libvirt/schemas/nodedev.rng
853 %{_datadir}/libvirt/schemas/nwfilter.rng
854 %{_datadir}/libvirt/schemas/secret.rng
855 %{_datadir}/libvirt/schemas/storageencryption.rng
856 %{_datadir}/libvirt/schemas/storagepool.rng
857 %{_datadir}/libvirt/schemas/storagevol.rng
858
859 %files utils
860 %defattr(644,root,root,755)
This page took 0.113578 seconds and 4 git commands to generate.