]> git.pld-linux.org Git - packages/libvirt.git/blob - libvirt.spec
- rel 2
[packages/libvirt.git] / libvirt.spec
1 #
2 # Conditional build:
3 %bcond_without  esx             # VMware ESX support
4 %bcond_without  hyperv          # Hyper-V support
5 %bcond_without  libxl           # libxenlight support
6 %bcond_without  lxc             # LXC support
7 %bcond_without  netcf           # host interfaces support
8 %bcond_without  openvz          # OpenVZ support
9 %bcond_without  phyp            # PHYP support
10 %bcond_without  polkit          # PolicyKit support
11 %bcond_without  qemu            # Qemu support
12 %bcond_without  sanlock         # sanlock storage lock manager
13 %bcond_without  uml             # UML support
14 %bcond_without  vbox            # VirtualBox support
15 %bcond_without  vmware          # VMware Workstation/Player support
16 %bcond_with     xenapi          # Xen API (Citrix XenServer) support
17 %bcond_without  xen             # Xen support
18
19 # qemu available only on x86 and ppc
20 %ifnarch %{ix86} %{x8664} ppc
21 %undefine       with_qemu
22 %endif
23 # Xen is available only on x86 and ia64
24 %ifnarch %{ix86} %{x8664} ia64
25 %undefine       with_xen
26 %endif
27 Summary:        Toolkit to interact with virtualization capabilities
28 Summary(pl.UTF-8):      Narzędzia współpracujące z funkcjami wirtualizacji
29 Name:           libvirt
30 Version:        0.9.11
31 Release:        2
32 License:        LGPL v2.1+
33 Group:          Libraries
34 Source0:        ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
35 # Source0-md5:  6e9fab115075a8fd21d9bd0d7e558a52
36 Source1:        %{name}.init
37 Source2:        %{name}.tmpfiles
38 Patch0:         %{name}-sasl.patch
39 Patch1:         %{name}-lxc.patch
40 Patch2:         %{name}-qemu-acl.patch
41 Patch3:         %{name}-xend.patch
42 Patch4:         lxc-without-selinux.patch
43 Patch5:         %{name}-driver-modules.patch
44 Patch6:         %{name}-uri-user.patch
45 URL:            http://www.libvirt.org/
46 BuildRequires:  audit-libs-devel
47 BuildRequires:  augeas-devel
48 BuildRequires:  autoconf >= 2.50
49 BuildRequires:  automake
50 BuildRequires:  avahi-devel >= 0.6.0
51 BuildRequires:  curl-devel >= 7.18.0
52 BuildRequires:  cyrus-sasl-devel
53 BuildRequires:  device-mapper-devel >= 1.0.0
54 BuildRequires:  gawk
55 BuildRequires:  gettext-devel >= 0.17
56 BuildRequires:  gnutls-devel >= 1.0.25
57 BuildRequires:  libapparmor-devel
58 BuildRequires:  libblkid-devel >= 2.17
59 BuildRequires:  libcap-ng-devel >= 0.4.0
60 BuildRequires:  libgcrypt-devel
61 BuildRequires:  libnl1-devel >= 1.1
62 BuildRequires:  libpcap-devel >= 1.0.0
63 BuildRequires:  libselinux-devel >= 2.0.82
64 BuildRequires:  libssh2-devel >= 1.0
65 BuildRequires:  libstdc++-devel
66 BuildRequires:  libtool
67 BuildRequires:  libxml2-devel >= 1:2.6.0
68 BuildRequires:  libxslt-devel
69 BuildRequires:  ncurses-devel
70 %{?with_netcf:BuildRequires:    netcf-devel >= 0.1.4}
71 BuildRequires:  numactl-devel
72 BuildRequires:  openldap-devel
73 BuildRequires:  openwsman-devel >= 2.2.3
74 BuildRequires:  parted-devel >= 1.8.0
75 BuildRequires:  perl-tools-pod
76 %{?with_polkit:BuildRequires:   polkit >= 0.90}
77 BuildRequires:  pkgconfig
78 BuildRequires:  python
79 BuildRequires:  python-devel
80 BuildRequires:  readline-devel
81 BuildRequires:  rpm-pythonprov
82 BuildRequires:  rpmbuild(macros) >= 1.627
83 %{?with_sanlock:BuildRequires:  sanlock-devel >= 0.8}
84 BuildRequires:  udev-devel >= 1:145
85 %{?with_xen:BuildRequires:      xen-devel >= 4.1.2}
86 # For disk driver
87 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10.0
88 BuildRequires:  yajl-devel
89 Requires:       curl-libs >= 7.18.0
90 Requires:       device-mapper >= 1.0.0
91 Requires:       libcap-ng >= 0.4.0
92 Requires:       libnl1 >= 1.1
93 Requires:       libpcap >= 1.0.0
94 Requires:       libselinux >= 2.0.82
95 Requires:       libssh2 >= 1.0
96 Requires:       libxml2 >= 1:2.6.0
97 Requires:       openwsman-libs >= 2.2.3
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %description
101 Libvirt is a C toolkit to interact with the virtualization
102 capabilities of recent versions of Linux.
103
104 Virtualization of the Linux Operating System means the ability to run
105 multiple instances of Operating Systems concurently on a single
106 hardware system where the basic resources are driven by a Linux
107 instance. The library aim at providing long term stable C API
108 initially for the Xen paravirtualization but should be able to
109 integrate other virtualization mechanisms if needed.
110
111 This package contains the base libraries and configuration file.
112
113 %description -l pl.UTF-8
114 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
115 obecnych wersji Linuksa.
116
117 Wirtualizacja w systemie operacyjnym Linux oznacza możliwość
118 jednoczesnego uruchamiania wielu instancji systemu operacyjnego na
119 pojedynczym systemie sprzętowym, którego podstawowe zasoby są
120 zarządzane przez instancję Linuksa. Celem biblioteki jest zapewnienie
121 długotrwale stabilnego API C, początkowo do parawirtualizacji Xen, ale
122 dającej się zintegrować w razie potrzeby z innymi mechanizmami
123 wirtualizacji.
124
125 Ten pakiet zawiera podstawowe biblioteki oraz plik konfiguracyjny.
126
127 %package devel
128 Summary:        Development files for programs using libvirt
129 Summary(pl.UTF-8):      Pliki programistyczne do programów wykorzystujących libvirt
130 Group:          Development/Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       audit-libs-devel
133 Requires:       curl-devel >= 7.18.0
134 Requires:       device-mapper-devel >= 1.0.0
135 Requires:       gnutls-devel >= 1.0.25
136 Requires:       libapparmor-devel
137 Requires:       libcap-ng-devel >= 0.4.0
138 Requires:       libgcrypt-devel
139 Requires:       libnl1-devel >= 1.1
140 Requires:       libpcap-devel >= 1.0.0
141 Requires:       libselinux-devel >= 2.0.82
142 Requires:       libxml2-devel >= 1:2.6.0
143 Requires:       numactl-devel
144 Requires:       openwsman-devel >= 2.2.3
145 %{?with_xen:Requires: xen-devel}
146 Requires:       yajl-devel
147
148 %description devel
149 Libvirt is a C toolkit to interact with the virtualization
150 capabilities of recent versions of Linux.
151
152 This package contains the header files needed for developing programs
153 using the libvirt library.
154
155 %description devel -l pl.UTF-8
156 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
157 obecnych wersji Linuksa.
158
159 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
160 wykorzystujących bibliotekę libvirt.
161
162 %package static
163 Summary:        Development static libraries for programs using libvirt
164 Summary(pl.UTF-8):      Statyczne biblioteki programistyczne do programów wykorzystujących libvirt
165 Group:          Development/Libraries
166 Requires:       %{name}-devel = %{version}-%{release}
167
168 %description static
169 Libvirt is a C toolkit to interact with the virtualization
170 capabilities of recent versions of Linux.
171
172 This package contains the static libraries for developing programs
173 using the libvirt library.
174
175 %description static -l pl.UTF-8
176 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
177 obecnych wersji Linuksa.
178
179 Ten pakiet zawiera biblioteki statyczne do tworzenia programów
180 wykorzystujących bibliotekę libvirt.
181
182 %package -n python-%{name}
183 Summary:        Python bindings to interact with virtualization capabilities
184 Summary(pl.UTF-8):      Wiązania Pythona do współpracy z funkcjami wirtualizacji
185 Group:          Development/Languages/Python
186 Requires:       %{name} = %{version}-%{release}
187
188 %description -n python-%{name}
189 Libvirt is a C toolkit to interact with the virtualization
190 capabilities of recent versions of Linux.
191
192 This package contains the Python bindings for the libvirt library.
193
194 %description -n python-%{name} -l pl.UTF-8
195 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
196 obecnych wersji Linuksa.
197
198 Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
199
200 %package lock-sanlock
201 Summary:        Sanlock lock manager plugin for libvirt
202 Summary(pl.UTF-8):      Zarządca blokad sanlock dla biblioteki libvirt
203 Group:          Libraries
204 Requires:       %{name} = %{version}-%{release}
205
206 %description lock-sanlock
207 Sanlock lock manager plugin for libvirt.
208
209 %description lock-sanlock -l pl.UTF-8
210 Zarządca blokad sanlock dla biblioteki libvirt.
211
212 %package daemon
213 Summary:        Server side daemon and supporting files for libvirt library
214 Summary(pl.UTF-8):      Demon działający po stronie serwera oraz pliki wspierające dla biblioteki libvirt
215 Group:          Applications/System
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       avahi-libs >= 0.6.0
218 Requires:       iproute2
219 Requires:       libblkid >= 2.17
220 Provides:       libvirt(hypervisor)
221 %{?with_netcf:Requires: netcf >= 0.1.4}
222 Requires:       parted-libs >= 1.8.0
223 # Needed for probing the power management features of the host.
224 Requires:       pm-utils
225 Requires:       systemd-units >= 37-0.10
226 Requires:       udev-libs >= 1:145
227 Requires:       util-linux
228 Requires:       virtual(module-tools)
229 Requires:       xorg-lib-libpciaccess >= 0.10.0
230 Requires(post): systemd-units
231 Requires(preun):        systemd-units
232 Requires(postun):       systemd-units
233 Suggests:       bridge-utils
234 Suggests:       cyrus-sasl
235 Suggests:       cyrus-sasl-digest-md5
236 Suggests:       dmidecode
237 Suggests:       dnsmasq >= 2.41
238 Suggests:       ebtables
239 Suggests:       gawk
240 Suggests:       glusterfs-client >= 2.0.1
241 Suggests:       iptables
242 Suggests:       iptables
243 Suggests:       libcgroup
244 Suggests:       lvm2
245 Suggests:       numad
246 Suggests:       open-iscsi
247 Suggests:       parted
248 Suggests:       polkit >= 0.93
249 Suggests:       radvd
250 Suggests:       scrub
251
252 %description daemon
253 Server side daemon required to manage the virtualization capabilities
254 of recent versions of Linux. Requires a hypervisor specific sub-RPM
255 for specific drivers.
256
257 %description daemon -l pl.UTF-8
258 Demon działający po stronie serwera wymagany do zarządzania funkcjami
259 wirtualizacji nowych wersji Linuksa. Wymaga podpakietu specyficznego
260 dla hipernadzorcy.
261
262 %package daemon-esx
263 Summary:        Server side driver required to run VMware ESX guests
264 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości VMware ESX
265 Group:          Libraries
266 Requires:       %{name}-daemon = %{version}-%{release}
267 Provides:       libvirt(hypervisor)
268
269 %description daemon-esx
270 Server side driver required to manage the virtualization capabilities
271 of the VMware ESX emulators.
272
273 %description daemon-esx -l pl.UTF-8
274 Sterownik wymagany po stronie serwera do zarządzania funkcjami
275 wirtualizacji emulatora VMware ESX.
276
277 %package daemon-hyperv
278 Summary:        Server side driver required to run Microsoft Hyper-V guests
279 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Microsoft Hyper-V
280 Group:          Libraries
281 Requires:       %{name}-daemon = %{version}-%{release}
282 Provides:       libvirt(hypervisor)
283
284 %description daemon-hyperv
285 Server side driver required to manage the virtualization capabilities
286 of the Microsoft Hyper-V emulators.
287
288 %description daemon-hyperv -l pl.UTF-8
289 Sterownik wymagany po stronie serwera do zarządzania funkcjami
290 wirtualizacji emulatora Microsoft Hyper-V.
291
292 %package daemon-libxl
293 Summary:        Server side driver required to run XEN guests (xenlight)
294 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości XEN (xenlight)
295 Group:          Libraries
296 Requires:       %{name}-daemon = %{version}-%{release}
297 Requires:       /usr/sbin/qcow-create
298 Requires:       xen
299 Provides:       libvirt(hypervisor)
300
301 %description daemon-libxl
302 Server side driver required to manage the virtualization capabilities
303 of XEN via xenlight interface.
304
305 %description daemon-libxl -l pl.UTF-8
306 Sterownik wymagany po stronie serwera do zarządzania funkcjami
307 wirtualizacji XEN poprzez interfejs xenlight.
308
309 %package daemon-lxc
310 Summary:        Server side driver required to run LXC guests
311 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości LXC
312 Group:          Libraries
313 Requires:       %{name}-daemon = %{version}-%{release}
314 Provides:       libvirt(hypervisor)
315
316 %description daemon-lxc
317 Server side driver required to manage the virtualization capabilities
318 of LXC.
319
320 %description daemon-lxc -l pl.UTF-8
321 Sterownik wymagany po stronie serwera do zarządzania funkcjami
322 wirtualizacji LXC.
323
324 %package daemon-openvz
325 Summary:        Server side driver required to run OpenVZ guests
326 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości OpenVZ
327 Group:          Libraries
328 Requires:       %{name}-daemon = %{version}-%{release}
329 Provides:       libvirt(hypervisor)
330
331 %description daemon-openvz
332 Server side driver required to manage the virtualization capabilities
333 of OpenVZ.
334
335 %description daemon-openvz -l pl.UTF-8
336 Sterownik wymagany po stronie serwera do zarządzania funkcjami
337 wirtualizacji OpenVZ.
338
339 %package daemon-phyp
340 Summary:        Server side driver required to run Power Hypervisors guests
341 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Power Hypervisors
342 Group:          Libraries
343 Requires:       %{name}-daemon = %{version}-%{release}
344 Provides:       libvirt(hypervisor)
345
346 %description daemon-phyp
347 Server side driver required to manage the virtualization capabilities
348 of Power Hypervisors.
349
350 %description daemon-phyp -l pl.UTF-8
351 Sterownik wymagany po stronie serwera do zarządzania funkcjami
352 wirtualizacji Power Hypervisors.
353
354 %package daemon-qemu
355 Summary:        Server side driver required to run QEMU guests
356 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości QEMU
357 Group:          Libraries
358 Requires:       %{name}-daemon = %{version}-%{release}
359 Requires:       /usr/bin/qemu-img
360 Requires:       qemu
361 Requires:       bzip2
362 Requires:       gzip
363 Requires:       lzop
364 Requires:       xz
365 Provides:       libvirt(hypervisor)
366
367 %description daemon-qemu
368 Server side driver required to manage the virtualization capabilities
369 of the QEMU emulators.
370
371 %description daemon-qemu -l pl.UTF-8
372 Sterownik wymagany po stronie serwera do zarządzania funkcjami
373 wirtualizacji emulatora QEMU.
374
375 %package daemon-uml
376 Summary:        Server side driver required to run UML guests
377 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości UML
378 Group:          Libraries
379 Requires:       %{name}-daemon = %{version}-%{release}
380 Provides:       libvirt(hypervisor)
381
382 %description daemon-uml
383 Server side driver required to manage the virtualization capabilities
384 of UML.
385
386 %description daemon-uml -l pl.UTF-8
387 Sterownik wymagany po stronie serwera do zarządzania funkcjami
388 wirtualizacji UML.
389
390 %package daemon-vbox
391 Summary:        Server side driver required to run Oracle VirtualBox guests
392 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Oracle VirtualBox
393 Group:          Libraries
394 Requires:       %{name}-daemon = %{version}-%{release}
395 Provides:       libvirt(hypervisor)
396
397 %description daemon-vbox
398 Server side driver required to manage the virtualization capabilities
399 of Oracle VirtualBox.
400
401 %description daemon-vbox -l pl.UTF-8
402 Sterownik wymagany po stronie serwera do zarządzania funkcjami
403 wirtualizacji Oracle VirtualBox.
404
405 %package daemon-vmware
406 Summary:        Server side driver required to run VMware Workstation guests
407 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości VMware Workstation
408 Group:          Libraries
409 Requires:       %{name}-daemon = %{version}-%{release}
410 Provides:       libvirt(hypervisor)
411
412 %description daemon-vmware
413 Server side driver required to manage the virtualization capabilities
414 of VMware Workstation.
415
416 %description daemon-vmware -l pl.UTF-8
417 Sterownik wymagany po stronie serwera do zarządzania funkcjami
418 wirtualizacji VMware Workstation.
419
420 %package daemon-xen
421 Summary:        Server side driver required to run XEN guests
422 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości XEN
423 Group:          Libraries
424 Requires:       %{name}-daemon = %{version}-%{release}
425 Requires:       /usr/sbin/qcow-create
426 Requires:       xen
427 Requires:       xen-xend
428 Provides:       libvirt(hypervisor)
429
430 %description daemon-xen
431 Server side driver required to manage the virtualization capabilities
432 of XEN.
433
434 %description daemon-xen -l pl.UTF-8
435 Sterownik wymagany po stronie serwera do zarządzania funkcjami
436 wirtualizacji XEN.
437
438 %package client
439 Summary:        Client side utilities of the libvirt library
440 Summary(pl.UTF-8):      Narzędzia klienckie do biblioteki libvirt
441 Group:          Applications/System
442 Requires:       gettext >= 0.18.1.1-6
443 Requires:       gnutls >= 1.0.25
444 Requires:       netcat-openbsd
445 Requires(post): systemd-units
446 Requires(preun):        systemd-units
447 Requires(postun):       systemd-units
448
449 %description client
450 Client binaries needed to access to the virtualization capabilities of
451 recent versions of Linux (and other OSes).
452
453 %description client -l pl.UTF-8
454 Programy klienckie potrzebne do funkcji wirtualizacji nowych wersji
455 Linuksa (oraz innych systemów operacyjnych).
456
457 %package utils
458 Summary:        Tools to interact with virtualization capabilities (metapackage)
459 Summary(pl.UTF-8):      Narzędzia do współpracy z funkcjami wirtualizacyjnymi (metapakiet)
460 Group:          Applications/System
461 Requires:       %{name}-client = %{version}-%{release}
462 Requires:       %{name}-daemon = %{version}-%{release}
463 Requires:       %{name}-daemon-esx = %{version}-%{release}
464 Requires:       %{name}-daemon-hyperv = %{version}-%{release}
465 Requires:       %{name}-daemon-libxl = %{version}-%{release}
466 Requires:       %{name}-daemon-lxc = %{version}-%{release}
467 Requires:       %{name}-daemon-openvz = %{version}-%{release}
468 Requires:       %{name}-daemon-phyp = %{version}-%{release}
469 Requires:       %{name}-daemon-qemu = %{version}-%{release}
470 Requires:       %{name}-daemon-uml = %{version}-%{release}
471 Requires:       %{name}-daemon-vbox = %{version}-%{release}
472 Requires:       %{name}-daemon-vmware = %{version}-%{release}
473 Requires:       %{name}-daemon-xen = %{version}-%{release}
474
475 %description utils
476 Libvirt is a C toolkit to interact with the virtualization
477 capabilities of recent versions of Linux.
478
479 This is metapackage gathering all tools for the libvirt library.
480
481 %description utils -l pl.UTF-8
482 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
483 obecnych wersji Linuksa.
484
485 To jest metapakiet zbierający wszystkie narzędzia przeznaczone dla
486 biblioteki libvirt.
487
488 %prep
489 %setup -q
490 %patch0 -p1
491 %patch1 -p1
492 %patch2 -p1
493 %patch3 -p1
494 %patch4 -p1
495 %patch5 -p1
496 %patch6 -p1
497
498 # weird translations
499 %{__rm} po/{my,eu_ES}.{po,gmo}
500
501 mv po/vi_VN.po po/vi.po
502 mv po/vi_VN.gmo po/vi.gmo
503
504 %build
505 %{__libtoolize}
506 %{__aclocal} -I gnulib/m4 -I m4
507 %{__autoconf}
508 %{__autoheader}
509 %{__automake}
510
511 %configure \
512         PVCREATE=/sbin/pvcreate \
513         VGCREATE=/sbin/vgcreate \
514         LVCREATE=/sbin/lvcreate \
515         PVREMOVE=/sbin/pvremove \
516         VGREMOVE=/sbin/vgremove \
517         LVREMOVE=/sbin/lvremove \
518         VGCHANGE=/sbin/vgchange \
519         LVCHANGE=/sbin/lvchange \
520           VGSCAN=/sbin/vgscan   \
521              PVS=/sbin/pvs      \
522              VGS=/sbin/vgs      \
523              LVS=/sbin/lvs      \
524               TC=/sbin/tc \
525            BRCTL=/sbin/brctl    \
526         ISCSIADM=/sbin/iscsiadm \
527         SHOWMOUNT=/usr/sbin/showmount \
528         MOUNT=/bin/mount \
529         UMOUNT=/bin/umount \
530         MKFS=/sbin/mkfs \
531         SHOWMOUNT=/usr/sbin/showmount \
532         IPTABLES_PATH=/usr/sbin/iptables \
533         IP6TABLES_PATH=/usr/sbin/ip6tables \
534         EBTABLES_PATH=/usr/sbin/ebtables \
535         ISCSIADM=/sbin/iscsiadm \
536         DNSMASQ=/usr/sbin/dnsmasq \
537         RADVD=/usr/sbin/radvd \
538         UDEVADM=/sbin/udevadm \
539         MODPROBE=/sbin/modprobe \
540         SCRUB=/usr/bin/scrub \
541         OVSVSCTL=/usr/bin/ovs-vsctl \
542         NUMAD=/usr/bin/numad \
543         --disable-silent-rules \
544         --with-html-dir=%{_gtkdocdir} \
545         --with-html-subdir=%{name} \
546         --with-init-script=redhat \
547         --with-storage-lvm \
548         --with-storage-fs \
549         --with-storage-iscsi \
550         --with-storage-scsi \
551         --with-storage-mpath \
552         --with-storage-disk \
553         --with-macvtap \
554         --with-virtualport \
555         --with-udev \
556         --with-libssh2 \
557         --with-avahi \
558         --with-audit \
559         --with-libblkid \
560         --with-macvtap \
561         --with-virtualport \
562         --with-numad \
563         --with-numactl \
564         --with-sasl \
565         --with-yajl \
566         --with-selinux \
567         --with-apparmor \
568         --with-qemu-user=qemu \
569         --with-qemu-group=qemu \
570         --without-hal \
571         --with-driver-modules \
572         %{__with_without polkit} \
573         %{__with_without esx} \
574         %{__with_without hyperv} \
575         %{__with_without libxl} \
576         %{__with_without lxc} \
577         %{__with_without netcf} \
578         %{__with_without openvz} \
579         %{__with_without phyp} \
580         %{__with_without qemu} \
581         %{__with_without sanlock} \
582         %{__with_without uml} \
583         %{__with_without vbox vbox %{_libdir}/VirtualBox} \
584         %{__with_without vmware} \
585         %{__with_without xen} \
586         %{__with_without xenapi} \
587         --x-libraries=%{_libdir} \
588         --with-init-script=systemd
589
590 %{__make} \
591         AWK=gawk
592
593 %install
594 rm -rf $RPM_BUILD_ROOT
595 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
596         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
597
598 %{__make} install \
599         DEVHELP_DIR=%{_gtkdocdir}/%{name}/devhelp \
600         DESTDIR=$RPM_BUILD_ROOT
601
602 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
603 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
604
605 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
606 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
607 %py_postclean
608 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
609
610 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
611 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.{a,la}
612
613 %if %{with sanlock}
614 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.{a,la}
615 %endif
616
617 %find_lang %{name}
618
619 %clean
620 rm -rf $RPM_BUILD_ROOT
621
622 %post   -p /sbin/ldconfig
623 %postun -p /sbin/ldconfig
624
625 %post daemon
626 %systemd_post libvirtd.service
627
628 %preun daemon
629 %systemd_preun libvirtd.service
630
631 %postun daemon
632 %systemd_reload
633
634 %post client
635 NORESTART=1
636 %systemd_post libvirt-guests.service
637
638 %preun client
639 %systemd_preun libvirt-guests.service
640
641 %postun client
642 %systemd_reload
643
644 %files -f %{name}.lang
645 %defattr(644,root,root,755)
646 %doc ChangeLog README TODO NEWS
647 %dir %{_sysconfdir}/libvirt
648 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirt.conf
649 %attr(755,root,root) %{_libdir}/libvirt.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libvirt.so.0
651 %if %{with qemu}
652 %attr(755,root,root) %{_libdir}/libvirt-qemu.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libvirt-qemu.so.0
654 %endif
655 %dir %{_libdir}/libvirt
656
657 %files devel
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/libvirt.so
660 %attr(755,root,root) %{_libdir}/libvirt-qemu.so
661 %{_datadir}/%{name}/api
662 %{_gtkdocdir}/%{name}
663 %{_includedir}/%{name}
664 %{_pkgconfigdir}/%{name}.pc
665
666 %files static
667 %defattr(644,root,root,755)
668 %{_libdir}/libvirt.a
669 %{_libdir}/libvirt-qemu.a
670
671 %files -n python-%{name}
672 %defattr(644,root,root,755)
673 %doc %{_docdir}/%{name}-python-%{version}
674 %attr(755,root,root) %{py_sitedir}/libvirtmod.so
675 %attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
676 %{py_sitedir}/libvirt.py[co]
677 %{py_sitedir}/libvirt_qemu.py[co]
678
679 %if %{with sanlock}
680 %files lock-sanlock
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_sbindir}/virt-sanlock-cleanup
683 %dir %{_libdir}/libvirt/lock-driver
684 %attr(755,root,root) %{_libdir}/libvirt/lock-driver/sanlock.so
685 %{_datadir}/augeas/lenses/libvirt_sanlock.aug
686 %{_datadir}/augeas/lenses/tests/test_libvirt_sanlock.aug
687 %dir /var/lib/libvirt/sanlock
688 %{_mandir}/man8/virt-sanlock-cleanup.8*
689 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-sanlock.conf
690 %endif
691
692 %files daemon
693 %defattr(644,root,root,755)
694 %doc docs/*.xml
695 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/nwfilter
696 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu
697 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks
698 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks/autostart
699 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirtd.conf
700 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/default.xml
701 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/autostart/default.xml
702 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/nwfilter/*.xml
703 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/libvirt.conf
704 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
705 %attr(754,root,root) /etc/rc.d/init.d/libvirtd
706 %{systemdunitdir}/libvirtd.service
707 %config(noreplace) %verify(not md5 mtime size) /etc/sysctl.d/libvirtd
708 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
709 %attr(755,root,root) %{_libdir}/libvirt_iohelper
710 %attr(755,root,root) %{_libdir}/libvirt_parthelper
711 %attr(755,root,root) %{_libdir}/virt-aa-helper
712 %attr(755,root,root) %{_sbindir}/libvirtd
713 %{_datadir}/augeas/lenses/libvirtd.aug
714 %{_datadir}/augeas/lenses/tests/test_libvirtd.aug
715 %{?with_polkit:%{_datadir}/polkit-1/actions/org.libvirt.unix.policy}
716 %{_mandir}/man8/libvirtd.8*
717 %dir /var/lib/libvirt
718 %dir /var/lib/libvirt/dnsmasq
719 %attr(711,root,root) %dir /var/lib/libvirt/boot
720 %attr(700,root,root) %dir /var/lib/libvirt/network
721 %attr(711,root,root) %dir /var/lib/libvirt/images
722 %attr(711,root,root) %dir /var/lib/libvirt/filesystems
723 %attr(700,root,root) %dir /var/log/libvirt
724 %attr(711,root,root) %dir /var/cache/libvirt
725 %dir /var/run/libvirt
726 %dir /var/run/libvirt/network
727 %{systemdtmpfilesdir}/%{name}.conf
728 %dir %{_libdir}/libvirt/connection-driver
729 %{?with_netcf:%attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_interface.so}
730 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_network.so
731 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nodedev.so
732 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nwfilter.so
733 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_secret.so
734 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_storage.so
735 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_test.so
736
737 %if %{with esx}
738 %files daemon-esx
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_esx.so
741 %endif
742
743 %if %{with hyperv}
744 %files daemon-hyperv
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_hyperv.so
747 %endif
748
749 %if %{with libxl}
750 %files daemon-libxl
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_libxl.so
753 %attr(700,root,root) %dir /var/lib/libvirt/libxl
754 %attr(700,root,root) %dir /var/run/libvirt/libxl
755 %attr(700,root,root) %dir /var/log/libvirt/libxl
756 %endif
757
758 %if %{with lxc}
759 %files daemon-lxc
760 %defattr(644,root,root,755)
761 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/lxc.conf
762 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.lxc
763 %attr(700,root,root) %dir /var/lib/libvirt/lxc
764 %attr(700,root,root) %dir /var/run/libvirt/lxc
765 %attr(700,root,root) %dir /var/log/libvirt/lxc
766 %{_datadir}/augeas/lenses/libvirtd_lxc.aug
767 %{_datadir}/augeas/lenses/tests/test_libvirtd_lxc.aug
768 %attr(755,root,root) %{_libdir}/libvirt_lxc
769 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_lxc.so
770 %endif
771
772 %if %{with openvz}
773 %files daemon-openvz
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_openvz.so
776 %endif
777
778 %if %{with phyp}
779 %files daemon-phyp
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_phyp.so
782 %endif
783
784 %if %{with qemu}
785 %files daemon-qemu
786 %defattr(644,root,root,755)
787 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu.conf
788 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.qemu
789 %attr(750,qemu,qemu) %dir /var/cache/libvirt/qemu
790 %attr(750,qemu,qemu) %dir /var/lib/libvirt/qemu
791 %attr(700,root,root) %dir /var/log/libvirt/qemu
792 %attr(700,root,root) %dir /var/run/libvirt/qemu
793 %{_datadir}/augeas/lenses/libvirtd_qemu.aug
794 %{_datadir}/augeas/lenses/tests/test_libvirtd_qemu.aug
795 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_qemu.so
796 %endif
797
798 %if %{with uml}
799 %files daemon-uml
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_uml.so
802 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.uml
803 %attr(700,root,root) %dir /var/lib/libvirt/uml
804 %attr(700,root,root) %dir /var/run/libvirt/uml
805 %attr(700,root,root) %dir /var/log/libvirt/uml
806 %endif
807
808 %if %{with vbox}
809 %files daemon-vbox
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vbox.so
812 %endif
813
814 %if %{with vmware}
815 %files daemon-vmware
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vmware.so
818 %endif
819
820 %if %{with xen}
821 %files daemon-xen
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_xen.so
824 %endif
825
826 %files client
827 %defattr(644,root,root,755)
828 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
829 %attr(754,root,root) /etc/rc.d/init.d/libvirt-guests
830 %{systemdunitdir}/libvirt-guests.service
831 %attr(755,root,root) %{_bindir}/virsh
832 %attr(755,root,root) %{_bindir}/virt-host-validate
833 %attr(755,root,root) %{_bindir}/virt-xml-validate
834 %attr(755,root,root) %{_bindir}/virt-pki-validate
835 %{_mandir}/man1/virsh.1*
836 %{_mandir}/man1/virt-host-validate.1*
837 %{_mandir}/man1/virt-xml-validate.1*
838 %{_mandir}/man1/virt-pki-validate.1*
839 %dir %{_datadir}/libvirt
840 %{_datadir}/libvirt/cpu_map.xml
841 %dir %{_datadir}/libvirt/schemas
842 %{_datadir}/libvirt/schemas/basictypes.rng
843 %{_datadir}/libvirt/schemas/capability.rng
844 %{_datadir}/libvirt/schemas/domain.rng
845 %{_datadir}/libvirt/schemas/domaincommon.rng
846 %{_datadir}/libvirt/schemas/domainsnapshot.rng
847 %{_datadir}/libvirt/schemas/interface.rng
848 %{_datadir}/libvirt/schemas/network.rng
849 %{_datadir}/libvirt/schemas/networkcommon.rng
850 %{_datadir}/libvirt/schemas/nodedev.rng
851 %{_datadir}/libvirt/schemas/nwfilter.rng
852 %{_datadir}/libvirt/schemas/secret.rng
853 %{_datadir}/libvirt/schemas/storageencryption.rng
854 %{_datadir}/libvirt/schemas/storagepool.rng
855 %{_datadir}/libvirt/schemas/storagevol.rng
856
857 %files utils
858 %defattr(644,root,root,755)
This page took 0.093038 seconds and 4 git commands to generate.