]> git.pld-linux.org Git - packages/libvirt.git/blob - libvirt.spec
- BR: dbus-devel
[packages/libvirt.git] / libvirt.spec
1 #
2 # Conditional build:
3 %bcond_without  esx             # VMware ESX support
4 %bcond_without  hyperv          # Hyper-V support
5 %bcond_without  libxl           # libxenlight support
6 %bcond_without  lxc             # LXC support
7 %bcond_without  netcf           # host interfaces support
8 %bcond_without  openvz          # OpenVZ support
9 %bcond_without  phyp            # PHYP support
10 %bcond_without  polkit          # PolicyKit support
11 %bcond_without  qemu            # Qemu support
12 %bcond_without  sanlock         # sanlock storage lock manager
13 %bcond_without  uml             # UML support
14 %bcond_without  vbox            # VirtualBox support
15 %bcond_without  vmware          # VMware Workstation/Player support
16 %bcond_with     xenapi          # Xen API (Citrix XenServer) support
17 %bcond_without  xen             # Xen support
18
19 # qemu available only on x86 and ppc
20 %ifnarch %{ix86} %{x8664} ppc
21 %undefine       with_qemu
22 %endif
23 # Xen is available only on x86 and ia64
24 %ifnarch %{ix86} %{x8664} ia64
25 %undefine       with_xen
26 %endif
27 Summary:        Toolkit to interact with virtualization capabilities
28 Summary(pl.UTF-8):      Narzędzia współpracujące z funkcjami wirtualizacji
29 Name:           libvirt
30 Version:        0.9.12
31 Release:        2
32 License:        LGPL v2.1+
33 Group:          Libraries
34 Source0:        ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
35 # Source0-md5:  5e842bc55733ceba60c64767580ff3e4
36 Source1:        %{name}.init
37 Source2:        %{name}.tmpfiles
38 Patch0:         %{name}-sasl.patch
39 Patch1:         %{name}-lxc.patch
40 Patch2:         %{name}-qemu-acl.patch
41 Patch3:         %{name}-xend.patch
42 Patch4:         lxc-without-selinux.patch
43 Patch5:         %{name}-driver-modules.patch
44 URL:            http://www.libvirt.org/
45 BuildRequires:  audit-libs-devel
46 BuildRequires:  augeas-devel
47 BuildRequires:  autoconf >= 2.50
48 BuildRequires:  automake
49 BuildRequires:  avahi-devel >= 0.6.0
50 BuildRequires:  curl-devel >= 7.18.0
51 BuildRequires:  cyrus-sasl-devel
52 BuildRequires:  dbus-devel >= 1.0.0
53 BuildRequires:  device-mapper-devel >= 1.0.0
54 BuildRequires:  gawk
55 BuildRequires:  gettext-devel >= 0.17
56 BuildRequires:  gnutls-devel >= 1.0.25
57 BuildRequires:  libapparmor-devel
58 BuildRequires:  libblkid-devel >= 2.17
59 BuildRequires:  libcap-ng-devel >= 0.4.0
60 BuildRequires:  libgcrypt-devel
61 BuildRequires:  libnl-devel >= 3.2
62 BuildRequires:  libpcap-devel >= 1.0.0
63 BuildRequires:  libselinux-devel >= 2.0.82
64 BuildRequires:  libssh2-devel >= 1.0
65 BuildRequires:  libstdc++-devel
66 BuildRequires:  libtool
67 BuildRequires:  libxml2-devel >= 1:2.6.0
68 BuildRequires:  libxslt-devel
69 BuildRequires:  ncurses-devel
70 %{?with_netcf:BuildRequires:    netcf-devel >= 0.1.4}
71 BuildRequires:  numactl-devel
72 BuildRequires:  openldap-devel
73 BuildRequires:  openwsman-devel >= 2.2.3
74 BuildRequires:  parted-devel >= 1.8.0
75 BuildRequires:  perl-tools-pod
76 %{?with_polkit:BuildRequires:   polkit >= 0.90}
77 BuildRequires:  pkgconfig
78 BuildRequires:  python
79 BuildRequires:  python-devel
80 BuildRequires:  readline-devel
81 BuildRequires:  rpm-pythonprov
82 BuildRequires:  rpmbuild(macros) >= 1.627
83 %{?with_sanlock:BuildRequires:  sanlock-devel >= 0.8}
84 BuildRequires:  udev-devel >= 1:145
85 %{?with_xen:BuildRequires:      xen-devel >= 4.1.2}
86 # For disk driver
87 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10.0
88 BuildRequires:  yajl-devel
89 Requires:       curl-libs >= 7.18.0
90 Requires:       device-mapper >= 1.0.0
91 Requires:       libcap-ng >= 0.4.0
92 Requires:       libnl >= 3.2
93 Requires:       libpcap >= 1.0.0
94 Requires:       libselinux >= 2.0.82
95 Requires:       libssh2 >= 1.0
96 Requires:       libxml2 >= 1:2.6.0
97 Requires:       openwsman-libs >= 2.2.3
98 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
99
100 %description
101 Libvirt is a C toolkit to interact with the virtualization
102 capabilities of recent versions of Linux.
103
104 Virtualization of the Linux Operating System means the ability to run
105 multiple instances of Operating Systems concurently on a single
106 hardware system where the basic resources are driven by a Linux
107 instance. The library aim at providing long term stable C API
108 initially for the Xen paravirtualization but should be able to
109 integrate other virtualization mechanisms if needed.
110
111 This package contains the base libraries and configuration file.
112
113 %description -l pl.UTF-8
114 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
115 obecnych wersji Linuksa.
116
117 Wirtualizacja w systemie operacyjnym Linux oznacza możliwość
118 jednoczesnego uruchamiania wielu instancji systemu operacyjnego na
119 pojedynczym systemie sprzętowym, którego podstawowe zasoby są
120 zarządzane przez instancję Linuksa. Celem biblioteki jest zapewnienie
121 długotrwale stabilnego API C, początkowo do parawirtualizacji Xen, ale
122 dającej się zintegrować w razie potrzeby z innymi mechanizmami
123 wirtualizacji.
124
125 Ten pakiet zawiera podstawowe biblioteki oraz plik konfiguracyjny.
126
127 %package devel
128 Summary:        Development files for programs using libvirt
129 Summary(pl.UTF-8):      Pliki programistyczne do programów wykorzystujących libvirt
130 Group:          Development/Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       audit-libs-devel
133 Requires:       curl-devel >= 7.18.0
134 Requires:       dbus-devel >= 1.0.0
135 Requires:       device-mapper-devel >= 1.0.0
136 Requires:       gnutls-devel >= 1.0.25
137 Requires:       libapparmor-devel
138 Requires:       libcap-ng-devel >= 0.4.0
139 Requires:       libgcrypt-devel
140 Requires:       libnl-devel >= 3.2
141 Requires:       libpcap-devel >= 1.0.0
142 Requires:       libselinux-devel >= 2.0.82
143 Requires:       libxml2-devel >= 1:2.6.0
144 Requires:       numactl-devel
145 Requires:       openwsman-devel >= 2.2.3
146 %{?with_xen:Requires: xen-devel}
147 Requires:       yajl-devel
148
149 %description devel
150 Libvirt is a C toolkit to interact with the virtualization
151 capabilities of recent versions of Linux.
152
153 This package contains the header files needed for developing programs
154 using the libvirt library.
155
156 %description devel -l pl.UTF-8
157 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
158 obecnych wersji Linuksa.
159
160 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
161 wykorzystujących bibliotekę libvirt.
162
163 %package static
164 Summary:        Development static libraries for programs using libvirt
165 Summary(pl.UTF-8):      Statyczne biblioteki programistyczne do programów wykorzystujących libvirt
166 Group:          Development/Libraries
167 Requires:       %{name}-devel = %{version}-%{release}
168
169 %description static
170 Libvirt is a C toolkit to interact with the virtualization
171 capabilities of recent versions of Linux.
172
173 This package contains the static libraries for developing programs
174 using the libvirt library.
175
176 %description static -l pl.UTF-8
177 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
178 obecnych wersji Linuksa.
179
180 Ten pakiet zawiera biblioteki statyczne do tworzenia programów
181 wykorzystujących bibliotekę libvirt.
182
183 %package -n python-%{name}
184 Summary:        Python bindings to interact with virtualization capabilities
185 Summary(pl.UTF-8):      Wiązania Pythona do współpracy z funkcjami wirtualizacji
186 Group:          Development/Languages/Python
187 Requires:       %{name} = %{version}-%{release}
188
189 %description -n python-%{name}
190 Libvirt is a C toolkit to interact with the virtualization
191 capabilities of recent versions of Linux.
192
193 This package contains the Python bindings for the libvirt library.
194
195 %description -n python-%{name} -l pl.UTF-8
196 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
197 obecnych wersji Linuksa.
198
199 Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
200
201 %package lock-sanlock
202 Summary:        Sanlock lock manager plugin for libvirt
203 Summary(pl.UTF-8):      Zarządca blokad sanlock dla biblioteki libvirt
204 Group:          Libraries
205 Requires:       %{name} = %{version}-%{release}
206
207 %description lock-sanlock
208 Sanlock lock manager plugin for libvirt.
209
210 %description lock-sanlock -l pl.UTF-8
211 Zarządca blokad sanlock dla biblioteki libvirt.
212
213 %package daemon
214 Summary:        Server side daemon and supporting files for libvirt library
215 Summary(pl.UTF-8):      Demon działający po stronie serwera oraz pliki wspierające dla biblioteki libvirt
216 Group:          Applications/System
217 Requires:       %{name} = %{version}-%{release}
218 Requires:       avahi-libs >= 0.6.0
219 Requires:       iproute2
220 Requires:       libblkid >= 2.17
221 Provides:       libvirt(hypervisor)
222 %{?with_netcf:Requires: netcf >= 0.1.4}
223 Requires:       parted-libs >= 1.8.0
224 # Needed for probing the power management features of the host.
225 Requires:       pm-utils
226 Requires:       systemd-units >= 37-0.10
227 Requires:       udev-libs >= 1:145
228 Requires:       util-linux
229 Requires:       virtual(module-tools)
230 Requires:       xorg-lib-libpciaccess >= 0.10.0
231 Requires(post): systemd-units
232 Requires(preun):        systemd-units
233 Requires(postun):       systemd-units
234 Suggests:       bridge-utils
235 Suggests:       cyrus-sasl
236 Suggests:       cyrus-sasl-digest-md5
237 Suggests:       dmidecode
238 Suggests:       dnsmasq >= 2.41
239 Suggests:       ebtables
240 Suggests:       gawk
241 Suggests:       glusterfs-client >= 2.0.1
242 Suggests:       iptables
243 Suggests:       iptables
244 Suggests:       libcgroup
245 Suggests:       lvm2
246 Suggests:       numad
247 Suggests:       open-iscsi
248 Suggests:       parted >= 1.8.0
249 Suggests:       polkit >= 0.93
250 Suggests:       radvd
251 Suggests:       scrub
252
253 %description daemon
254 Server side daemon required to manage the virtualization capabilities
255 of recent versions of Linux. Requires a hypervisor specific sub-RPM
256 for specific drivers.
257
258 %description daemon -l pl.UTF-8
259 Demon działający po stronie serwera wymagany do zarządzania funkcjami
260 wirtualizacji nowych wersji Linuksa. Wymaga podpakietu specyficznego
261 dla hipernadzorcy.
262
263 %package daemon-esx
264 Summary:        Server side driver required to run VMware ESX guests
265 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości VMware ESX
266 Group:          Libraries
267 Requires:       %{name}-daemon = %{version}-%{release}
268 Provides:       libvirt(hypervisor)
269
270 %description daemon-esx
271 Server side driver required to manage the virtualization capabilities
272 of the VMware ESX emulators.
273
274 %description daemon-esx -l pl.UTF-8
275 Sterownik wymagany po stronie serwera do zarządzania funkcjami
276 wirtualizacji emulatora VMware ESX.
277
278 %package daemon-hyperv
279 Summary:        Server side driver required to run Microsoft Hyper-V guests
280 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Microsoft Hyper-V
281 Group:          Libraries
282 Requires:       %{name}-daemon = %{version}-%{release}
283 Provides:       libvirt(hypervisor)
284
285 %description daemon-hyperv
286 Server side driver required to manage the virtualization capabilities
287 of the Microsoft Hyper-V emulators.
288
289 %description daemon-hyperv -l pl.UTF-8
290 Sterownik wymagany po stronie serwera do zarządzania funkcjami
291 wirtualizacji emulatora Microsoft Hyper-V.
292
293 %package daemon-libxl
294 Summary:        Server side driver required to run XEN guests (xenlight)
295 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości XEN (xenlight)
296 Group:          Libraries
297 Requires:       %{name}-daemon = %{version}-%{release}
298 Requires:       /usr/sbin/qcow-create
299 Requires:       xen
300 Provides:       libvirt(hypervisor)
301
302 %description daemon-libxl
303 Server side driver required to manage the virtualization capabilities
304 of XEN via xenlight interface.
305
306 %description daemon-libxl -l pl.UTF-8
307 Sterownik wymagany po stronie serwera do zarządzania funkcjami
308 wirtualizacji XEN poprzez interfejs xenlight.
309
310 %package daemon-lxc
311 Summary:        Server side driver required to run LXC guests
312 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości LXC
313 Group:          Libraries
314 Requires:       %{name}-daemon = %{version}-%{release}
315 Provides:       libvirt(hypervisor)
316
317 %description daemon-lxc
318 Server side driver required to manage the virtualization capabilities
319 of LXC.
320
321 %description daemon-lxc -l pl.UTF-8
322 Sterownik wymagany po stronie serwera do zarządzania funkcjami
323 wirtualizacji LXC.
324
325 %package daemon-openvz
326 Summary:        Server side driver required to run OpenVZ guests
327 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości OpenVZ
328 Group:          Libraries
329 Requires:       %{name}-daemon = %{version}-%{release}
330 Provides:       libvirt(hypervisor)
331
332 %description daemon-openvz
333 Server side driver required to manage the virtualization capabilities
334 of OpenVZ.
335
336 %description daemon-openvz -l pl.UTF-8
337 Sterownik wymagany po stronie serwera do zarządzania funkcjami
338 wirtualizacji OpenVZ.
339
340 %package daemon-phyp
341 Summary:        Server side driver required to run Power Hypervisors guests
342 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Power Hypervisors
343 Group:          Libraries
344 Requires:       %{name}-daemon = %{version}-%{release}
345 Provides:       libvirt(hypervisor)
346
347 %description daemon-phyp
348 Server side driver required to manage the virtualization capabilities
349 of Power Hypervisors.
350
351 %description daemon-phyp -l pl.UTF-8
352 Sterownik wymagany po stronie serwera do zarządzania funkcjami
353 wirtualizacji Power Hypervisors.
354
355 %package daemon-qemu
356 Summary:        Server side driver required to run QEMU guests
357 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości QEMU
358 Group:          Libraries
359 Requires:       %{name}-daemon = %{version}-%{release}
360 Requires:       /usr/bin/qemu-img
361 Requires:       qemu
362 Requires:       bzip2
363 Requires:       gzip
364 Requires:       lzop
365 Requires:       xz
366 Provides:       libvirt(hypervisor)
367
368 %description daemon-qemu
369 Server side driver required to manage the virtualization capabilities
370 of the QEMU emulators.
371
372 %description daemon-qemu -l pl.UTF-8
373 Sterownik wymagany po stronie serwera do zarządzania funkcjami
374 wirtualizacji emulatora QEMU.
375
376 %package daemon-uml
377 Summary:        Server side driver required to run UML guests
378 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości UML
379 Group:          Libraries
380 Requires:       %{name}-daemon = %{version}-%{release}
381 Provides:       libvirt(hypervisor)
382
383 %description daemon-uml
384 Server side driver required to manage the virtualization capabilities
385 of UML.
386
387 %description daemon-uml -l pl.UTF-8
388 Sterownik wymagany po stronie serwera do zarządzania funkcjami
389 wirtualizacji UML.
390
391 %package daemon-vbox
392 Summary:        Server side driver required to run Oracle VirtualBox guests
393 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości Oracle VirtualBox
394 Group:          Libraries
395 Requires:       %{name}-daemon = %{version}-%{release}
396 Provides:       libvirt(hypervisor)
397
398 %description daemon-vbox
399 Server side driver required to manage the virtualization capabilities
400 of Oracle VirtualBox.
401
402 %description daemon-vbox -l pl.UTF-8
403 Sterownik wymagany po stronie serwera do zarządzania funkcjami
404 wirtualizacji Oracle VirtualBox.
405
406 %package daemon-vmware
407 Summary:        Server side driver required to run VMware Workstation guests
408 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości VMware Workstation
409 Group:          Libraries
410 Requires:       %{name}-daemon = %{version}-%{release}
411 Provides:       libvirt(hypervisor)
412
413 %description daemon-vmware
414 Server side driver required to manage the virtualization capabilities
415 of VMware Workstation.
416
417 %description daemon-vmware -l pl.UTF-8
418 Sterownik wymagany po stronie serwera do zarządzania funkcjami
419 wirtualizacji VMware Workstation.
420
421 %package daemon-xen
422 Summary:        Server side driver required to run XEN guests
423 Summary(pl.UTF-8):      Sterownik wymagany po stronie serwera do uruchamiania gości XEN
424 Group:          Libraries
425 Requires:       %{name}-daemon = %{version}-%{release}
426 Requires:       /usr/sbin/qcow-create
427 Requires:       xen
428 Requires:       xen-xend
429 Provides:       libvirt(hypervisor)
430
431 %description daemon-xen
432 Server side driver required to manage the virtualization capabilities
433 of XEN.
434
435 %description daemon-xen -l pl.UTF-8
436 Sterownik wymagany po stronie serwera do zarządzania funkcjami
437 wirtualizacji XEN.
438
439 %package client
440 Summary:        Client side utilities of the libvirt library
441 Summary(pl.UTF-8):      Narzędzia klienckie do biblioteki libvirt
442 Group:          Applications/System
443 Requires:       gettext >= 0.18.1.1-6
444 Requires:       gnutls >= 1.0.25
445 Requires:       netcat-openbsd
446 Requires(post): systemd-units
447 Requires(preun):        systemd-units
448 Requires(postun):       systemd-units
449
450 %description client
451 Client binaries needed to access to the virtualization capabilities of
452 recent versions of Linux (and other OSes).
453
454 %description client -l pl.UTF-8
455 Programy klienckie potrzebne do funkcji wirtualizacji nowych wersji
456 Linuksa (oraz innych systemów operacyjnych).
457
458 %package utils
459 Summary:        Tools to interact with virtualization capabilities (metapackage)
460 Summary(pl.UTF-8):      Narzędzia do współpracy z funkcjami wirtualizacyjnymi (metapakiet)
461 Group:          Applications/System
462 Requires:       %{name}-client = %{version}-%{release}
463 Requires:       %{name}-daemon = %{version}-%{release}
464 Requires:       %{name}-daemon-esx = %{version}-%{release}
465 Requires:       %{name}-daemon-hyperv = %{version}-%{release}
466 Requires:       %{name}-daemon-libxl = %{version}-%{release}
467 Requires:       %{name}-daemon-lxc = %{version}-%{release}
468 Requires:       %{name}-daemon-openvz = %{version}-%{release}
469 Requires:       %{name}-daemon-phyp = %{version}-%{release}
470 Requires:       %{name}-daemon-qemu = %{version}-%{release}
471 Requires:       %{name}-daemon-uml = %{version}-%{release}
472 Requires:       %{name}-daemon-vbox = %{version}-%{release}
473 Requires:       %{name}-daemon-vmware = %{version}-%{release}
474 Requires:       %{name}-daemon-xen = %{version}-%{release}
475
476 %description utils
477 Libvirt is a C toolkit to interact with the virtualization
478 capabilities of recent versions of Linux.
479
480 This is metapackage gathering all tools for the libvirt library.
481
482 %description utils -l pl.UTF-8
483 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
484 obecnych wersji Linuksa.
485
486 To jest metapakiet zbierający wszystkie narzędzia przeznaczone dla
487 biblioteki libvirt.
488
489 %prep
490 %setup -q
491 %patch0 -p1
492 %patch1 -p1
493 %patch2 -p1
494 %patch3 -p1
495 %patch4 -p1
496 %patch5 -p1
497
498 # weird translations
499 %{__rm} po/{my,eu_ES}.{po,gmo}
500
501 mv po/vi_VN.po po/vi.po
502 mv po/vi_VN.gmo po/vi.gmo
503
504 %build
505 %{__libtoolize}
506 %{__aclocal} -I gnulib/m4 -I m4
507 %{__autoconf}
508 %{__autoheader}
509 %{__automake}
510
511 %configure \
512         PVCREATE=/sbin/pvcreate \
513         VGCREATE=/sbin/vgcreate \
514         LVCREATE=/sbin/lvcreate \
515         PVREMOVE=/sbin/pvremove \
516         VGREMOVE=/sbin/vgremove \
517         LVREMOVE=/sbin/lvremove \
518         VGCHANGE=/sbin/vgchange \
519         LVCHANGE=/sbin/lvchange \
520           VGSCAN=/sbin/vgscan   \
521              PVS=/sbin/pvs      \
522              VGS=/sbin/vgs      \
523              LVS=/sbin/lvs      \
524               TC=/sbin/tc \
525            BRCTL=/sbin/brctl    \
526         ISCSIADM=/sbin/iscsiadm \
527         SHOWMOUNT=/usr/sbin/showmount \
528         MOUNT=/bin/mount \
529         UMOUNT=/bin/umount \
530         MKFS=/sbin/mkfs \
531         SHOWMOUNT=/usr/sbin/showmount \
532         IPTABLES_PATH=/usr/sbin/iptables \
533         IP6TABLES_PATH=/usr/sbin/ip6tables \
534         EBTABLES_PATH=/usr/sbin/ebtables \
535         ISCSIADM=/sbin/iscsiadm \
536         DNSMASQ=/usr/sbin/dnsmasq \
537         RADVD=/usr/sbin/radvd \
538         UDEVADM=/sbin/udevadm \
539         MODPROBE=/sbin/modprobe \
540         SCRUB=/usr/bin/scrub \
541         OVSVSCTL=/usr/bin/ovs-vsctl \
542         NUMAD=/usr/bin/numad \
543         --disable-silent-rules \
544         --with-html-dir=%{_gtkdocdir} \
545         --with-html-subdir=%{name} \
546         --with-init-script=redhat \
547         --with-storage-lvm \
548         --with-storage-fs \
549         --with-storage-iscsi \
550         --with-storage-scsi \
551         --with-storage-mpath \
552         --with-storage-disk \
553         --with-macvtap \
554         --with-virtualport \
555         --with-udev \
556         --with-libssh2 \
557         --with-avahi \
558         --with-audit \
559         --with-libblkid \
560         --with-macvtap \
561         --with-virtualport \
562         --with-numad \
563         --with-numactl \
564         --with-sasl \
565         --with-yajl \
566         --with-selinux \
567         --with-apparmor \
568         --with-qemu-user=qemu \
569         --with-qemu-group=qemu \
570         --without-hal \
571         --with-driver-modules \
572         %{__with_without polkit} \
573         %{__with_without esx} \
574         %{__with_without hyperv} \
575         %{__with_without libxl} \
576         %{__with_without lxc} \
577         %{__with_without netcf} \
578         %{__with_without openvz} \
579         %{__with_without phyp} \
580         %{__with_without qemu} \
581         %{__with_without sanlock} \
582         %{__with_without uml} \
583         %{__with_without vbox vbox %{_libdir}/VirtualBox} \
584         %{__with_without vmware} \
585         %{__with_without xen} \
586         %{__with_without xenapi} \
587         --x-libraries=%{_libdir} \
588         --with-init-script=systemd
589
590 %{__make} \
591         AWK=gawk
592
593 %install
594 rm -rf $RPM_BUILD_ROOT
595 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
596         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
597
598 %{__make} install \
599         DEVHELP_DIR=%{_gtkdocdir}/%{name}/devhelp \
600         DESTDIR=$RPM_BUILD_ROOT
601
602 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
603 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
604
605 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
606 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
607 %py_postclean
608 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
609
610 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
611 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.{a,la}
612
613 %if %{with sanlock}
614 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.{a,la}
615 %endif
616
617 %find_lang %{name}
618
619 %clean
620 rm -rf $RPM_BUILD_ROOT
621
622 %post   -p /sbin/ldconfig
623 %postun -p /sbin/ldconfig
624
625 %post daemon
626 %systemd_post libvirtd.service
627
628 %preun daemon
629 %systemd_preun libvirtd.service
630
631 %postun daemon
632 %systemd_reload
633
634 %post client
635 NORESTART=1
636 %systemd_post libvirt-guests.service
637
638 %preun client
639 %systemd_preun libvirt-guests.service
640
641 %postun client
642 %systemd_reload
643
644 %files -f %{name}.lang
645 %defattr(644,root,root,755)
646 %doc ChangeLog README TODO NEWS
647 %dir %{_sysconfdir}/libvirt
648 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirt.conf
649 %attr(755,root,root) %{_libdir}/libvirt.so.*.*.*
650 %attr(755,root,root) %ghost %{_libdir}/libvirt.so.0
651 %if %{with qemu}
652 %attr(755,root,root) %{_libdir}/libvirt-qemu.so.*.*.*
653 %attr(755,root,root) %ghost %{_libdir}/libvirt-qemu.so.0
654 %endif
655 %dir %{_libdir}/libvirt
656
657 %files devel
658 %defattr(644,root,root,755)
659 %attr(755,root,root) %{_libdir}/libvirt.so
660 %attr(755,root,root) %{_libdir}/libvirt-qemu.so
661 %{_datadir}/%{name}/api
662 %{_gtkdocdir}/%{name}
663 %{_includedir}/%{name}
664 %{_pkgconfigdir}/%{name}.pc
665
666 %files static
667 %defattr(644,root,root,755)
668 %{_libdir}/libvirt.a
669 %{_libdir}/libvirt-qemu.a
670
671 %files -n python-%{name}
672 %defattr(644,root,root,755)
673 %doc %{_docdir}/%{name}-python-%{version}
674 %attr(755,root,root) %{py_sitedir}/libvirtmod.so
675 %attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
676 %{py_sitedir}/libvirt.py[co]
677 %{py_sitedir}/libvirt_qemu.py[co]
678
679 %if %{with sanlock}
680 %files lock-sanlock
681 %defattr(644,root,root,755)
682 %attr(755,root,root) %{_sbindir}/virt-sanlock-cleanup
683 %dir %{_libdir}/libvirt/lock-driver
684 %attr(755,root,root) %{_libdir}/libvirt/lock-driver/sanlock.so
685 %{_datadir}/augeas/lenses/libvirt_sanlock.aug
686 %{_datadir}/augeas/lenses/tests/test_libvirt_sanlock.aug
687 %dir /var/lib/libvirt/sanlock
688 %{_mandir}/man8/virt-sanlock-cleanup.8*
689 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-sanlock.conf
690 %endif
691
692 %files daemon
693 %defattr(644,root,root,755)
694 %doc docs/*.xml
695 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/nwfilter
696 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu
697 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks
698 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks/autostart
699 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirtd.conf
700 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/default.xml
701 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/autostart/default.xml
702 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/nwfilter/*.xml
703 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/libvirt.conf
704 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
705 %attr(754,root,root) /etc/rc.d/init.d/libvirtd
706 %{systemdunitdir}/libvirtd.service
707 %config(noreplace) %verify(not md5 mtime size) /etc/sysctl.d/libvirtd
708 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
709 %attr(755,root,root) %{_libdir}/libvirt_iohelper
710 %attr(755,root,root) %{_libdir}/libvirt_parthelper
711 %attr(755,root,root) %{_libdir}/virt-aa-helper
712 %attr(755,root,root) %{_sbindir}/libvirtd
713 %{_datadir}/augeas/lenses/libvirtd.aug
714 %{_datadir}/augeas/lenses/tests/test_libvirtd.aug
715 %{?with_polkit:%{_datadir}/polkit-1/actions/org.libvirt.unix.policy}
716 %{_mandir}/man8/libvirtd.8*
717 %dir /var/lib/libvirt
718 %dir /var/lib/libvirt/dnsmasq
719 %attr(711,root,root) %dir /var/lib/libvirt/boot
720 %attr(700,root,root) %dir /var/lib/libvirt/network
721 %attr(711,root,root) %dir /var/lib/libvirt/images
722 %attr(711,root,root) %dir /var/lib/libvirt/filesystems
723 %attr(700,root,root) %dir /var/log/libvirt
724 %attr(711,root,root) %dir /var/cache/libvirt
725 %dir /var/run/libvirt
726 %dir /var/run/libvirt/network
727 %{systemdtmpfilesdir}/%{name}.conf
728 %dir %{_libdir}/libvirt/connection-driver
729 %{?with_netcf:%attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_interface.so}
730 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_network.so
731 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nodedev.so
732 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nwfilter.so
733 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_secret.so
734 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_storage.so
735 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_test.so
736
737 %if %{with esx}
738 %files daemon-esx
739 %defattr(644,root,root,755)
740 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_esx.so
741 %endif
742
743 %if %{with hyperv}
744 %files daemon-hyperv
745 %defattr(644,root,root,755)
746 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_hyperv.so
747 %endif
748
749 %if %{with libxl}
750 %files daemon-libxl
751 %defattr(644,root,root,755)
752 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_libxl.so
753 %attr(700,root,root) %dir /var/lib/libvirt/libxl
754 %attr(700,root,root) %dir /var/run/libvirt/libxl
755 %attr(700,root,root) %dir /var/log/libvirt/libxl
756 %endif
757
758 %if %{with lxc}
759 %files daemon-lxc
760 %defattr(644,root,root,755)
761 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/lxc.conf
762 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.lxc
763 %attr(700,root,root) %dir /var/lib/libvirt/lxc
764 %attr(700,root,root) %dir /var/run/libvirt/lxc
765 %attr(700,root,root) %dir /var/log/libvirt/lxc
766 %{_datadir}/augeas/lenses/libvirtd_lxc.aug
767 %{_datadir}/augeas/lenses/tests/test_libvirtd_lxc.aug
768 %attr(755,root,root) %{_libdir}/libvirt_lxc
769 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_lxc.so
770 %endif
771
772 %if %{with openvz}
773 %files daemon-openvz
774 %defattr(644,root,root,755)
775 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_openvz.so
776 %endif
777
778 %if %{with phyp}
779 %files daemon-phyp
780 %defattr(644,root,root,755)
781 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_phyp.so
782 %endif
783
784 %if %{with qemu}
785 %files daemon-qemu
786 %defattr(644,root,root,755)
787 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu.conf
788 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.qemu
789 %attr(750,qemu,qemu) %dir /var/cache/libvirt/qemu
790 %attr(750,qemu,qemu) %dir /var/lib/libvirt/qemu
791 %attr(700,root,root) %dir /var/log/libvirt/qemu
792 %attr(700,root,root) %dir /var/run/libvirt/qemu
793 %{_datadir}/augeas/lenses/libvirtd_qemu.aug
794 %{_datadir}/augeas/lenses/tests/test_libvirtd_qemu.aug
795 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_qemu.so
796 %endif
797
798 %if %{with uml}
799 %files daemon-uml
800 %defattr(644,root,root,755)
801 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_uml.so
802 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.uml
803 %attr(700,root,root) %dir /var/lib/libvirt/uml
804 %attr(700,root,root) %dir /var/run/libvirt/uml
805 %attr(700,root,root) %dir /var/log/libvirt/uml
806 %endif
807
808 %if %{with vbox}
809 %files daemon-vbox
810 %defattr(644,root,root,755)
811 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vbox.so
812 %endif
813
814 %if %{with vmware}
815 %files daemon-vmware
816 %defattr(644,root,root,755)
817 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vmware.so
818 %endif
819
820 %if %{with xen}
821 %files daemon-xen
822 %defattr(644,root,root,755)
823 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_xen.so
824 %endif
825
826 %files client
827 %defattr(644,root,root,755)
828 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
829 %attr(754,root,root) /etc/rc.d/init.d/libvirt-guests
830 %{systemdunitdir}/libvirt-guests.service
831 %attr(755,root,root) %{_bindir}/virsh
832 %attr(755,root,root) %{_bindir}/virt-host-validate
833 %attr(755,root,root) %{_bindir}/virt-xml-validate
834 %attr(755,root,root) %{_bindir}/virt-pki-validate
835 %{_mandir}/man1/virsh.1*
836 %{_mandir}/man1/virt-host-validate.1*
837 %{_mandir}/man1/virt-xml-validate.1*
838 %{_mandir}/man1/virt-pki-validate.1*
839 %dir %{_datadir}/libvirt
840 %{_datadir}/libvirt/cpu_map.xml
841 %dir %{_datadir}/libvirt/schemas
842 %{_datadir}/libvirt/schemas/basictypes.rng
843 %{_datadir}/libvirt/schemas/capability.rng
844 %{_datadir}/libvirt/schemas/domain.rng
845 %{_datadir}/libvirt/schemas/domaincommon.rng
846 %{_datadir}/libvirt/schemas/domainsnapshot.rng
847 %{_datadir}/libvirt/schemas/interface.rng
848 %{_datadir}/libvirt/schemas/network.rng
849 %{_datadir}/libvirt/schemas/networkcommon.rng
850 %{_datadir}/libvirt/schemas/nodedev.rng
851 %{_datadir}/libvirt/schemas/nwfilter.rng
852 %{_datadir}/libvirt/schemas/secret.rng
853 %{_datadir}/libvirt/schemas/storageencryption.rng
854 %{_datadir}/libvirt/schemas/storagepool.rng
855 %{_datadir}/libvirt/schemas/storagevol.rng
856
857 %files utils
858 %defattr(644,root,root,755)
This page took 0.085775 seconds and 4 git commands to generate.