]> git.pld-linux.org Git - packages/libvirt.git/blob - libvirt.spec
- rel 1
[packages/libvirt.git] / libvirt.spec
1 #
2 # Conditional build:
3 %bcond_without  esx             # VMware ESX support
4 %bcond_without  hyperv          # Hyper-V support
5 %bcond_without  libxl           # libxenlight
6 %bcond_without  lxc             # LXC support
7 %bcond_without  netcf           # host interfaces support
8 %bcond_without  openvz          # OpenVZ support
9 %bcond_without  phyp            # PHYP support
10 %bcond_without  polkit          # PolicyKit
11 %bcond_without  qemu            # Qemu
12 %bcond_without  sanlock         # sanlock storage lock manager
13 %bcond_without  uml             # UML support
14 %bcond_without  vbox            # VirtualBox support
15 %bcond_without  vmware          # VMware Workstation/Player support
16 %bcond_with     xenapi          # XenAPI support
17 %bcond_without  xen_proxy       # Xen proxy
18 %bcond_without  xen             # xen
19
20 # qemu available only on x86 and ppc
21 %ifnarch %{ix86} %{x8664} ppc
22 %undefine       with_qemu
23 %endif
24 # Xen is available only on x86 and ia64
25 %ifnarch %{ix86} %{x8664} ia64
26 %undefine       with_xen
27 %endif
28 %if %{without xen}
29 %undefine       with_xen_proxy
30 %endif
31
32 Summary:        Toolkit to interact with virtualization capabilities
33 Summary(pl.UTF-8):      Narzędzia współpracujące z funkcjami wirtualizacji
34 Name:           libvirt
35 Version:        0.9.11
36 Release:        1
37 License:        LGPL v2.1+
38 Group:          Libraries
39 Source0:        ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
40 # Source0-md5:  6e9fab115075a8fd21d9bd0d7e558a52
41 Source1:        %{name}.init
42 Source2:        %{name}.tmpfiles
43 Patch0:         %{name}-sasl.patch
44 Patch1:         %{name}-lxc.patch
45 Patch2:         %{name}-qemu-acl.patch
46 Patch3:         %{name}-xend.patch
47 Patch4:         lxc-without-selinux.patch
48 Patch5:         %{name}-driver-modules.patch
49 URL:            http://www.libvirt.org/
50 BuildRequires:  audit-libs-devel
51 BuildRequires:  augeas-devel
52 BuildRequires:  autoconf >= 2.50
53 BuildRequires:  automake
54 BuildRequires:  avahi-devel >= 0.6.0
55 BuildRequires:  curl-devel >= 7.18.0
56 BuildRequires:  cyrus-sasl-devel
57 BuildRequires:  device-mapper-devel >= 1.0.0
58 BuildRequires:  gawk
59 BuildRequires:  gettext-devel >= 0.17
60 BuildRequires:  gnutls-devel >= 1.0.25
61 BuildRequires:  libapparmor-devel
62 BuildRequires:  libblkid-devel >= 2.17
63 BuildRequires:  libcap-ng-devel >= 0.4.0
64 BuildRequires:  libgcrypt-devel
65 BuildRequires:  libnl1-devel >= 1.1
66 BuildRequires:  libpcap-devel >= 1.0.0
67 BuildRequires:  libselinux-devel >= 2.0.82
68 BuildRequires:  libssh2-devel >= 1.0
69 BuildRequires:  libstdc++-devel
70 BuildRequires:  libtool
71 BuildRequires:  libxml2-devel >= 1:2.6.0
72 BuildRequires:  libxslt-devel
73 BuildRequires:  ncurses-devel
74 %{?with_netcf:BuildRequires:    netcf-devel >= 0.1.4}
75 BuildRequires:  numactl-devel
76 BuildRequires:  openldap-devel
77 BuildRequires:  openwsman-devel >= 2.2.3
78 BuildRequires:  parted-devel >= 1.8.0
79 BuildRequires:  perl-tools-pod
80 %{?with_polkit:BuildRequires:   polkit >= 0.90}
81 BuildRequires:  pkgconfig
82 BuildRequires:  python
83 BuildRequires:  python-devel
84 BuildRequires:  readline-devel
85 BuildRequires:  rpm-pythonprov
86 BuildRequires:  rpmbuild(macros) >= 1.627
87 %{?with_sanlock:BuildRequires:  sanlock-devel >= 0.8}
88 BuildRequires:  udev-devel >= 145
89 %{?with_xen:BuildRequires:      xen-devel >= 4.1.2}
90 # For disk driver
91 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10.0
92 BuildRequires:  yajl-devel
93 Requires:       curl-libs >= 7.18.0
94 Requires:       device-mapper >= 1.0.0
95 Requires:       libcap-ng >= 0.4.0
96 Requires:       libnl1 >= 1.1
97 Requires:       libpcap >= 1.0.0
98 Requires:       libselinux >= 2.0.82
99 Requires:       libssh2 >= 1.0
100 Requires:       libxml2 >= 1:2.6.0
101 Requires:       openwsman-libs >= 2.2.3
102 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
103
104 %description
105 Libvirt is a C toolkit to interact with the virtualization
106 capabilities of recent versions of Linux.
107
108 Virtualization of the Linux Operating System means the ability to run
109 multiple instances of Operating Systems concurently on a single
110 hardware system where the basic resources are driven by a Linux
111 instance. The library aim at providing long term stable C API
112 initially for the Xen paravirtualization but should be able to
113 integrate other virtualization mechanisms if needed.
114
115 %description -l pl.UTF-8
116 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
117 obecnych wersji Linuksa.
118
119 Wirtualizacja w systemie operacyjnym Linux oznacza możliwość
120 jednoczesnego uruchamiania wielu instancji systemu operacyjnego na
121 pojedynczym systemie sprzętowym, którego podstawowe zasoby są
122 zarządzane przez instancję Linuksa. Celem biblioteki jest zapewnienie
123 długotrwale stabilnego API C, początkowo do parawirtualizacji Xen, ale
124 dającej się zintegrować w razie potrzeby z innymi mechanizmami
125 wirtualizacji.
126
127 %package devel
128 Summary:        Development files for programs using libvirt
129 Summary(pl.UTF-8):      Pliki programistyczne do programów wykorzystujących libvirt
130 Group:          Development/Libraries
131 Requires:       %{name} = %{version}-%{release}
132 Requires:       audit-libs-devel
133 Requires:       curl-devel >= 7.18.0
134 Requires:       device-mapper-devel >= 1.0.0
135 Requires:       gnutls-devel >= 1.0.25
136 Requires:       libapparmor-devel
137 Requires:       libcap-ng-devel >= 0.4.0
138 Requires:       libgcrypt-devel
139 Requires:       libnl1-devel >= 1.1
140 Requires:       libpcap-devel >= 1.0.0
141 Requires:       libselinux-devel >= 2.0.82
142 Requires:       libxml2-devel >= 1:2.6.0
143 Requires:       numactl-devel
144 Requires:       openwsman-devel >= 2.2.3
145 %{?with_xen:Requires: xen-devel}
146 Requires:       yajl-devel
147
148 %description devel
149 Libvirt is a C toolkit to interact with the virtualization
150 capabilities of recent versions of Linux.
151
152 This package contains the header files needed for developing programs
153 using the libvirt library.
154
155 %description devel -l pl.UTF-8
156 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
157 obecnych wersji Linuksa.
158
159 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
160 wykorzystujących bibliotekę libvirt.
161
162 %package static
163 Summary:        Development static libraries for programs using libvirt
164 Summary(pl.UTF-8):      Statyczne biblioteki programistyczne do programów wykorzystujących libvirt
165 Group:          Development/Libraries
166 Requires:       %{name}-devel = %{version}-%{release}
167
168 %description static
169 Libvirt is a C toolkit to interact with the virtualization
170 capabilities of recent versions of Linux.
171
172 This package contains the static libraries for developing programs
173 using the libvirt library.
174
175 %description static -l pl.UTF-8
176 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
177 obecnych wersji Linuksa.
178
179 Ten pakiet zawiera biblioteki statyczne do tworzenia programów
180 wykorzystujących bibliotekę libvirt.
181
182 %package -n python-%{name}
183 Summary:        Python bindings to interact with virtualization capabilities
184 Summary(pl.UTF-8):      Wiązania Pythona do współpracy z funkcjami wirtualizacji
185 Group:          Development/Languages/Python
186 Requires:       %{name} = %{version}-%{release}
187
188 %description -n python-%{name}
189 Libvirt is a C toolkit to interact with the virtualization
190 capabilities of recent versions of Linux.
191
192 This package contains the Python bindings for the libvirt library.
193
194 %description -n python-%{name} -l pl.UTF-8
195 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
196 obecnych wersji Linuksa.
197
198 Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
199
200 %package lock-sanlock
201 Summary:        Sanlock lock manager plugin for libvirt
202 Summary(pl.UTF-8):      Zarządca blokad sanlock dla biblioteki libvirt
203 Group:          Libraries
204 Requires:       %{name} = %{version}-%{release}
205
206 %description lock-sanlock
207 Sanlock lock manager plugin for libvirt.
208
209 %description lock-sanlock -l pl.UTF-8
210 Zarządca blokad sanlock dla biblioteki libvirt.
211
212 %package daemon
213 Summary:        Server side daemon and supporting files for libvirt library
214 Group:          Applications/System
215 Requires:       %{name} = %{version}-%{release}
216 Requires:       avahi-libs >= 0.6.0
217 Requires:       iproute2
218 Requires:       libblkid >= 2.17
219 Provides:       libvirt(hypervisor)
220 Requires:       parted-libs >= 1.8.0
221 # Needed for probing the power management features of the host.
222 Requires:       pm-utils
223 Requires:       systemd-units >= 37-0.10
224 Requires:       udev-libs >= 145
225 Requires:       util-linux
226 Requires:       virtual(module-tools)
227 Requires:       xorg-lib-libpciaccess >= 0.10.0
228 Requires(post): systemd-units
229 Requires(preun):        systemd-units
230 Requires(postun):       systemd-units
231 Suggests:       bridge-utils
232 Suggests:       cyrus-sasl
233 Suggests:       cyrus-sasl-digest-md5
234 Suggests:       dmidecode
235 Suggests:       dnsmasq >= 2.41
236 Suggests:       ebtables
237 Suggests:       gawk
238 Suggests:       glusterfs-client >= 2.0.1
239 Suggests:       iptables
240 Suggests:       iptables
241 Suggests:       libcgroup
242 Suggests:       lvm2
243 Suggests:       numad
244 Suggests:       open-iscsi
245 Suggests:       parted
246 Suggests:       polkit >= 0.93
247 Suggests:       radvd
248 Suggests:       scrub
249
250 %description daemon
251 Server side daemon required to manage the virtualization capabilities
252 of recent versions of Linux. Requires a hypervisor specific sub-RPM
253 for specific drivers.
254
255 %package daemon-esx
256 Summary:        Server side daemon & driver required to run VMware ESX guests
257 Group:          Development/Libraries
258 Requires:       %{name}-daemon = %{version}-%{release}
259 Provides:       libvirt(hypervisor)
260
261 %description daemon-esx
262 Server side daemon and driver required to manage the virtualization
263 capabilities of the VMware ESX emulators
264
265 %package daemon-hyperv
266 Summary:        Server side daemon & driver required to run Microsoft Hyper-V guests
267 Group:          Development/Libraries
268 Requires:       %{name}-daemon = %{version}-%{release}
269 Provides:       libvirt(hypervisor)
270
271 %description daemon-hyperv
272 Server side daemon and driver required to manage the virtualization
273 capabilities of the Microsoft Hyper-V emulators
274
275 %package daemon-libxl
276 Summary:        Server side daemon & driver required to run XEN guests (xenlight)
277 Group:          Development/Libraries
278 Requires:       %{name}-daemon = %{version}-%{release}
279 Requires:       /usr/sbin/qcow-create
280 Requires:       xen
281 Provides:       libvirt(hypervisor)
282
283 %description daemon-libxl
284 Server side daemon and driver required to manage the virtualization
285 capabilities of XEN via xenlight interface
286
287 %package daemon-lxc
288 Summary:        Server side daemon & driver required to run LXC guests
289 Group:          Development/Libraries
290 Requires:       %{name}-daemon = %{version}-%{release}
291 Provides:       libvirt(hypervisor)
292
293 %description daemon-lxc
294 Server side daemon and driver required to manage the virtualization
295 capabilities of LXC
296
297 %package daemon-openvz
298 Summary:        Server side daemon & driver required to run OpenVZ guests
299 Group:          Development/Libraries
300 Requires:       %{name}-daemon = %{version}-%{release}
301 Provides:       libvirt(hypervisor)
302
303 %description daemon-openvz
304 Server side daemon and driver required to manage the virtualization
305 capabilities of OpenVZ
306
307 %package daemon-phyp
308 Summary:        Server side daemon & driver required to run Power Hypervisors guests
309 Group:          Development/Libraries
310 Requires:       %{name}-daemon = %{version}-%{release}
311 Provides:       libvirt(hypervisor)
312
313 %description daemon-phyp
314 Server side daemon and driver required to manage the virtualization
315 capabilities of Power Hypervisors
316
317 %package daemon-qemu
318 Summary:        Server side daemon & driver required to run QEMU guests
319 Group:          Development/Libraries
320 Requires:       %{name}-daemon = %{version}-%{release}
321 Requires:       /usr/bin/qemu-img
322 Requires:       qemu
323 Requires:       bzip2
324 Requires:       gzip
325 Requires:       lzop
326 Requires:       xz
327 Provides:       libvirt(hypervisor)
328
329 %description daemon-qemu
330 Server side daemon and driver required to manage the virtualization
331 capabilities of the QEMU emulators
332
333 %package daemon-uml
334 Summary:        Server side daemon & driver required to run UML guests
335 Group:          Development/Libraries
336 Requires:       %{name}-daemon = %{version}-%{release}
337 Provides:       libvirt(hypervisor)
338
339 %description daemon-uml
340 Server side daemon and driver required to manage the virtualization
341 capabilities of UML
342
343 %package daemon-vbox
344 Summary:        Server side daemon & driver required to run Oracle VirtualBox guests
345 Group:          Development/Libraries
346 Requires:       %{name}-daemon = %{version}-%{release}
347 Provides:       libvirt(hypervisor)
348
349 %description daemon-vbox
350 Server side daemon and driver required to manage the virtualization
351 capabilities of Oracle VirtualBox
352
353 %package daemon-vmware
354 Summary:        Server side daemon & driver required to run VMware Workstation guests
355 Group:          Development/Libraries
356 Requires:       %{name}-daemon = %{version}-%{release}
357 Provides:       libvirt(hypervisor)
358
359 %description daemon-vmware
360 Server side daemon and driver required to manage the virtualization
361 capabilities of VMware Workstation
362
363 %package daemon-xen
364 Summary:        Server side daemon & driver required to run XEN guests
365 Group:          Development/Libraries
366 Requires:       %{name}-daemon = %{version}-%{release}
367 Requires:       /usr/sbin/qcow-create
368 Requires:       xen
369 Requires:       xen-xend
370 Provides:       libvirt(hypervisor)
371
372 %description daemon-xen
373 Server side daemon and driver required to manage the virtualization
374 capabilities of XEN
375
376 %package client
377 Summary:        Client side library and utilities of the libvirt library
378 Group:          Applications/System
379 Requires:       gettext >= 0.18.1.1-6
380 Requires:       gnutls >= 1.0.25
381 Requires:       netcat-openbsd
382 Requires(post): systemd-units
383 Requires(preun):        systemd-units
384 Requires(postun):       systemd-units
385
386 %description client
387 Shared libraries and client binaries needed to access to the
388 virtualization capabilities of recent versions of Linux (and other
389 OSes).
390
391 %package utils
392 Summary:        Tools to interact with virtualization capabilities
393 Summary(pl.UTF-8):      Narzędzia do współpracy z funkcjami wirtualizacyjnymi
394 Group:          Applications/System
395 Requires:       %{name}-client = %{version}-%{release}
396 Requires:       %{name}-daemon = %{version}-%{release}
397 Requires:       %{name}-daemon-esx = %{version}-%{release}
398 Requires:       %{name}-daemon-hyperv = %{version}-%{release}
399 Requires:       %{name}-daemon-libxl = %{version}-%{release}
400 Requires:       %{name}-daemon-lxc = %{version}-%{release}
401 Requires:       %{name}-daemon-openvz = %{version}-%{release}
402 Requires:       %{name}-daemon-phyp = %{version}-%{release}
403 Requires:       %{name}-daemon-qemu = %{version}-%{release}
404 Requires:       %{name}-daemon-uml = %{version}-%{release}
405 Requires:       %{name}-daemon-vbox = %{version}-%{release}
406 Requires:       %{name}-daemon-vmware = %{version}-%{release}
407 Requires:       %{name}-daemon-xen = %{version}-%{release}
408
409 %description utils
410 Libvirt is a C toolkit to interact with the virtualization
411 capabilities of recent versions of Linux.
412
413 This package contains tools for the libvirt library.
414
415 %description utils -l pl.UTF-8
416 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
417 obecnych wersji Linuksa.
418
419 Ten pakiet zawiera narzędzia do biblioteki libvirt.
420
421 %prep
422 %setup -q
423 %patch0 -p1
424 %patch1 -p1
425 %patch2 -p1
426 %patch3 -p1
427 %patch4 -p1
428 %patch5 -p1
429
430 # weird translations
431 %{__rm} po/{my,eu_ES}.{po,gmo}
432
433 mv po/vi_VN.po po/vi.po
434 mv po/vi_VN.gmo po/vi.gmo
435
436 %build
437 %{__libtoolize}
438 %{__aclocal} -I gnulib/m4 -I m4
439 %{__autoconf}
440 %{__autoheader}
441 %{__automake}
442
443 %configure \
444         PVCREATE=/sbin/pvcreate \
445         VGCREATE=/sbin/vgcreate \
446         LVCREATE=/sbin/lvcreate \
447         PVREMOVE=/sbin/pvremove \
448         VGREMOVE=/sbin/vgremove \
449         LVREMOVE=/sbin/lvremove \
450         VGCHANGE=/sbin/vgchange \
451         LVCHANGE=/sbin/lvchange \
452           VGSCAN=/sbin/vgscan   \
453              PVS=/sbin/pvs      \
454              VGS=/sbin/vgs      \
455              LVS=/sbin/lvs      \
456               TC=/sbin/tc \
457            BRCTL=/sbin/brctl    \
458         ISCSIADM=/sbin/iscsiadm \
459         SHOWMOUNT=/usr/sbin/showmount \
460         MOUNT=/bin/mount \
461         UMOUNT=/bin/umount \
462         MKFS=/sbin/mkfs \
463         SHOWMOUNT=/usr/sbin/showmount \
464         IPTABLES_PATH=/usr/sbin/iptables \
465         IP6TABLES_PATH=/usr/sbin/ip6tables \
466         EBTABLES_PATH=/usr/sbin/ebtables \
467         ISCSIADM=/sbin/iscsiadm \
468         DNSMASQ=/usr/sbin/dnsmasq \
469         RADVD=/usr/sbin/radvd \
470         UDEVADM=/sbin/udevadm \
471         MODPROBE=/sbin/modprobe \
472         SCRUB=/usr/bin/scrub \
473         OVSVSCTL=/usr/bin/ovs-vsctl \
474         NUMAD=/usr/bin/numad \
475         --disable-silent-rules \
476         --with-html-dir=%{_gtkdocdir} \
477         --with-html-subdir=%{name} \
478         --with-init-script=redhat \
479         --with-storage-lvm \
480         --with-storage-fs \
481         --with-storage-iscsi \
482         --with-storage-scsi \
483         --with-storage-mpath \
484         --with-storage-disk \
485         --with-macvtap \
486         --with-virtualport \
487         --with-udev \
488         --with-libssh2 \
489         --with-avahi \
490         --with-audit \
491         --with-libblkid \
492         --with-macvtap \
493         --with-virtualport \
494         --with-numad \
495         --with-numactl \
496         --with-sasl \
497         --with-yajl \
498         --with-selinux \
499         --with-apparmor \
500         --with-qemu-user=qemu \
501         --with-qemu-group=qemu \
502         --without-hal \
503         --with-driver-modules \
504         %{__with_without polkit} \
505         %{__with_without esx} \
506         %{__with_without hyperv} \
507         %{__with_without libxl} \
508         %{__with_without lxc} \
509         %{__with_without netcf} \
510         %{__with_without openvz} \
511         %{__with_without phyp} \
512         %{__with_without qemu} \
513         %{__with_without sanlock} \
514         %{__with_without uml} \
515         %{__with_without vbox vbox %{_libdir}/VirtualBox} \
516         %{__with_without vmware} \
517         %{__with_without xen} \
518         %{__with_without xenapi} \
519         --x-libraries=%{_libdir} \
520         --with-init-script=systemd
521
522 %{__make} \
523         AWK=gawk
524
525 %install
526 rm -rf $RPM_BUILD_ROOT
527 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
528         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
529
530 %{__make} install \
531         DEVHELP_DIR=%{_gtkdocdir}/%{name}/devhelp \
532         DESTDIR=$RPM_BUILD_ROOT
533
534 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
535 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
536
537 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
538 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
539 %py_postclean
540 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
541
542 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
543 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.{a,la}
544
545 %if %{with sanlock}
546 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.{a,la}
547 %endif
548
549 %find_lang %{name}
550
551 %clean
552 rm -rf $RPM_BUILD_ROOT
553
554 %post   -p /sbin/ldconfig
555 %postun -p /sbin/ldconfig
556
557 %post daemon
558 %systemd_post libvirtd.service
559
560 %preun daemon
561 %systemd_preun libvirtd.service
562
563 %postun daemon
564 %systemd_reload
565
566 %post client
567 NORESTART=1
568 %systemd_post libvirt-guests.service
569
570 %preun client
571 %systemd_preun libvirt-guests.service
572
573 %postun client
574 %systemd_reload
575
576 %files -f %{name}.lang
577 %defattr(644,root,root,755)
578 %doc ChangeLog README TODO NEWS
579 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirt.conf
580 %attr(755,root,root) %{_libdir}/libvirt.so.*.*.*
581 %attr(755,root,root) %ghost %{_libdir}/libvirt.so.0
582 %if %{with qemu}
583 %attr(755,root,root) %{_libdir}/libvirt-qemu.so.*.*.*
584 %attr(755,root,root) %ghost %{_libdir}/libvirt-qemu.so.0
585 %endif
586 %dir %{_libdir}/libvirt
587
588 %if %{with sanlock}
589 %files lock-sanlock
590 %defattr(644,root,root,755)
591 %attr(755,root,root) %{_sbindir}/virt-sanlock-cleanup
592 %dir %{_libdir}/libvirt/lock-driver
593 %attr(755,root,root) %{_libdir}/libvirt/lock-driver/sanlock.so
594 %{_datadir}/augeas/lenses/libvirt_sanlock.aug
595 %{_datadir}/augeas/lenses/tests/test_libvirt_sanlock.aug
596 %dir /var/lib/libvirt/sanlock
597 %{_mandir}/man8/virt-sanlock-cleanup.8*
598 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-sanlock.conf
599 %endif
600
601 %files devel
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_libdir}/libvirt.so
604 %attr(755,root,root) %{_libdir}/libvirt-qemu.so
605 %{_datadir}/%{name}/api
606 %{_gtkdocdir}/%{name}
607 %{_includedir}/%{name}
608 %{_pkgconfigdir}/%{name}.pc
609
610 %files static
611 %defattr(644,root,root,755)
612 %{_libdir}/libvirt.a
613 %{_libdir}/libvirt-qemu.a
614
615 %files -n python-%{name}
616 %defattr(644,root,root,755)
617 %doc %{_docdir}/%{name}-python-%{version}
618 %attr(755,root,root) %{py_sitedir}/libvirtmod.so
619 %attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
620 %{py_sitedir}/libvirt.py[co]
621 %{py_sitedir}/libvirt_qemu.py[co]
622
623 %files daemon
624 %defattr(644,root,root,755)
625 %doc docs/*.xml
626 %dir %{_sysconfdir}/libvirt
627 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/nwfilter
628 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu
629 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks
630 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks/autostart
631 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirtd.conf
632 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/default.xml
633 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/autostart/default.xml
634 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/nwfilter/*.xml
635 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/libvirt.conf
636 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
637 %attr(754,root,root) /etc/rc.d/init.d/libvirtd
638 %{systemdunitdir}/libvirtd.service
639 %config(noreplace) %verify(not md5 mtime size) /etc/sysctl.d/libvirtd
640 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
641 %attr(755,root,root) %{_libdir}/libvirt_iohelper
642 %attr(755,root,root) %{_libdir}/libvirt_parthelper
643 %attr(755,root,root) %{_libdir}/virt-aa-helper
644 %attr(755,root,root) %{_sbindir}/libvirtd
645 %{_datadir}/augeas/lenses/libvirtd.aug
646 %{_datadir}/augeas/lenses/tests/test_libvirtd.aug
647 %{?with_polkit:%{_datadir}/polkit-1/actions/org.libvirt.unix.policy}
648 %{_mandir}/man8/libvirtd.8*
649 %dir /var/lib/libvirt
650 %dir /var/lib/libvirt/dnsmasq
651 %attr(711,root,root) %dir /var/lib/libvirt/boot
652 %attr(700,root,root) %dir /var/lib/libvirt/network
653 %attr(711,root,root) %dir /var/lib/libvirt/images
654 %attr(711,root,root) %dir /var/lib/libvirt/filesystems
655 %attr(700,root,root) %dir /var/log/libvirt
656 %attr(711,root,root) %dir /var/cache/libvirt
657 %dir /var/run/libvirt
658 %dir /var/run/libvirt/network
659 %{systemdtmpfilesdir}/%{name}.conf
660 %dir %{_libdir}/libvirt/connection-driver
661 %{?with_netcf:%attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_interface.so}
662 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_network.so
663 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nodedev.so
664 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nwfilter.so
665 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_secret.so
666 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_storage.so
667 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_test.so
668
669 %if %{with_esx}
670 %files daemon-esx
671 %defattr(644,root,root,755)
672 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_esx.so
673 %endif
674
675 %if %{with_hyperv}
676 %files daemon-hyperv
677 %defattr(644,root,root,755)
678 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_hyperv.so
679 %endif
680
681 %if %{with_libxl}
682 %files daemon-libxl
683 %defattr(644,root,root,755)
684 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_libxl.so
685 %attr(700,root,root) %dir /var/lib/libvirt/libxl
686 %attr(700,root,root) %dir /var/run/libvirt/libxl
687 %attr(700,root,root) %dir /var/log/libvirt/libxl
688 %endif
689
690 %if %{with_lxc}
691 %files daemon-lxc
692 %defattr(644,root,root,755)
693 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/lxc.conf
694 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.lxc
695 %attr(700,root,root) %dir /var/lib/libvirt/lxc
696 %attr(700,root,root) %dir /var/run/libvirt/lxc
697 %attr(700,root,root) %dir /var/log/libvirt/lxc
698 %{_datadir}/augeas/lenses/libvirtd_lxc.aug
699 %{_datadir}/augeas/lenses/tests/test_libvirtd_lxc.aug
700 %attr(755,root,root) %{_libdir}/libvirt_lxc
701 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_lxc.so
702 %endif
703
704 %if %{with_openvz}
705 %files daemon-openvz
706 %defattr(644,root,root,755)
707 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_openvz.so
708 %endif
709
710 %if %{with_phyp}
711 %files daemon-phyp
712 %defattr(644,root,root,755)
713 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_phyp.so
714 %endif
715
716 %if %{with qemu}
717 %files daemon-qemu
718 %defattr(644,root,root,755)
719 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu.conf
720 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.qemu
721 %attr(750,qemu,qemu) %dir /var/cache/libvirt/qemu
722 %attr(750,qemu,qemu) %dir /var/lib/libvirt/qemu
723 %attr(700,root,root) %dir /var/log/libvirt/qemu
724 %attr(700,root,root) %dir /var/run/libvirt/qemu
725 %{_datadir}/augeas/lenses/libvirtd_qemu.aug
726 %{_datadir}/augeas/lenses/tests/test_libvirtd_qemu.aug
727 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_qemu.so
728 %endif
729
730 %if %{with_uml}
731 %files daemon-uml
732 %defattr(644,root,root,755)
733 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_uml.so
734 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.uml
735 %attr(700,root,root) %dir /var/lib/libvirt/uml
736 %attr(700,root,root) %dir /var/run/libvirt/uml
737 %attr(700,root,root) %dir /var/log/libvirt/uml
738 %endif
739
740 %if %{with_vbox}
741 %files daemon-vbox
742 %defattr(644,root,root,755)
743 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vbox.so
744 %endif
745
746 %if %{with_vmware}
747 %files daemon-vmware
748 %defattr(644,root,root,755)
749 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vmware.so
750 %endif
751
752 %if %{with_xen}
753 %files daemon-xen
754 %defattr(644,root,root,755)
755 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_xen.so
756 %endif
757
758 %files client
759 %defattr(644,root,root,755)
760 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
761 %attr(754,root,root) /etc/rc.d/init.d/libvirt-guests
762 %{systemdunitdir}/libvirt-guests.service
763 %attr(755,root,root) %{_bindir}/virsh
764 %attr(755,root,root) %{_bindir}/virt-host-validate
765 %attr(755,root,root) %{_bindir}/virt-xml-validate
766 %attr(755,root,root) %{_bindir}/virt-pki-validate
767 %{_mandir}/man1/virsh.1*
768 %{_mandir}/man1/virt-host-validate.1*
769 %{_mandir}/man1/virt-xml-validate.1*
770 %{_mandir}/man1/virt-pki-validate.1*
771 %dir %{_datadir}/libvirt
772 %{_datadir}/libvirt/cpu_map.xml
773 %dir %{_datadir}/libvirt/schemas
774 %{_datadir}/libvirt/schemas/basictypes.rng
775 %{_datadir}/libvirt/schemas/capability.rng
776 %{_datadir}/libvirt/schemas/domain.rng
777 %{_datadir}/libvirt/schemas/domaincommon.rng
778 %{_datadir}/libvirt/schemas/domainsnapshot.rng
779 %{_datadir}/libvirt/schemas/interface.rng
780 %{_datadir}/libvirt/schemas/network.rng
781 %{_datadir}/libvirt/schemas/networkcommon.rng
782 %{_datadir}/libvirt/schemas/nodedev.rng
783 %{_datadir}/libvirt/schemas/nwfilter.rng
784 %{_datadir}/libvirt/schemas/secret.rng
785 %{_datadir}/libvirt/schemas/storageencryption.rng
786 %{_datadir}/libvirt/schemas/storagepool.rng
787 %{_datadir}/libvirt/schemas/storagevol.rng
788
789 %files utils
790 %defattr(644,root,root,755)
This page took 0.094836 seconds and 4 git commands to generate.