]> git.pld-linux.org Git - packages/libvirt.git/blob - libvirt.spec
- 0.9.11 final
[packages/libvirt.git] / libvirt.spec
1 #
2 # Conditional build:
3 %bcond_without  esx             # VMware ESX support
4 %bcond_without  hyperv          # Hyper-V support
5 %bcond_without  libxl           # libxenlight
6 %bcond_without  lxc             # LXC support
7 %bcond_without  netcf           # host interfaces support
8 %bcond_without  openvz          # OpenVZ support
9 %bcond_without  phyp            # PHYP support
10 %bcond_without  polkit          # PolicyKit
11 %bcond_without  qemu            # Qemu
12 %bcond_without  sanlock         # sanlock storage lock manager
13 %bcond_without  uml             # UML support
14 %bcond_without  vbox            # VirtualBox support
15 %bcond_without  vmware          # VMware Workstation/Player support
16 %bcond_with     xenapi          # XenAPI support
17 %bcond_without  xen_proxy       # Xen proxy
18 %bcond_without  xen             # xen
19
20 # qemu available only on x86 and ppc
21 %ifnarch %{ix86} %{x8664} ppc
22 %undefine       with_qemu
23 %endif
24 # Xen is available only on x86 and ia64
25 %ifnarch %{ix86} %{x8664} ia64
26 %undefine       with_xen
27 %endif
28 %if %{without xen}
29 %undefine       with_xen_proxy
30 %endif
31
32 #define         pre     rc2
33 Summary:        Toolkit to interact with virtualization capabilities
34 Summary(pl.UTF-8):      Narzędzia współpracujące z funkcjami wirtualizacji
35 Name:           libvirt
36 Version:        0.9.11
37 Release:        0.1
38 License:        LGPL v2.1+
39 Group:          Libraries
40 Source0:        ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
41 # Source0-md5:  6e9fab115075a8fd21d9bd0d7e558a52
42 Source1:        %{name}.init
43 Source2:        %{name}.tmpfiles
44 Patch0:         %{name}-sasl.patch
45 Patch1:         %{name}-lxc.patch
46 Patch2:         %{name}-qemu-acl.patch
47 Patch3:         %{name}-xend.patch
48 Patch4:         lxc-without-selinux.patch
49 Patch5:         %{name}-driver-modules.patch
50 URL:            http://www.libvirt.org/
51 BuildRequires:  audit-libs-devel
52 BuildRequires:  augeas-devel
53 BuildRequires:  autoconf >= 2.50
54 BuildRequires:  automake
55 BuildRequires:  avahi-devel >= 0.6.0
56 BuildRequires:  curl-devel >= 7.18.0
57 BuildRequires:  cyrus-sasl-devel
58 BuildRequires:  device-mapper-devel >= 1.0.0
59 BuildRequires:  gawk
60 BuildRequires:  gettext-devel >= 0.17
61 BuildRequires:  gnutls-devel >= 1.0.25
62 BuildRequires:  libapparmor-devel
63 BuildRequires:  libblkid-devel >= 2.17
64 BuildRequires:  libcap-ng-devel >= 0.4.0
65 BuildRequires:  libgcrypt-devel
66 BuildRequires:  libnl1-devel >= 1.1
67 BuildRequires:  libpcap-devel >= 1.0.0
68 BuildRequires:  libselinux-devel >= 2.0.82
69 BuildRequires:  libssh2-devel >= 1.0
70 BuildRequires:  libstdc++-devel
71 BuildRequires:  libtool
72 BuildRequires:  libxml2-devel >= 1:2.6.0
73 BuildRequires:  libxslt-devel
74 BuildRequires:  ncurses-devel
75 %{?with_netcf:BuildRequires:    netcf-devel >= 0.1.4}
76 BuildRequires:  numactl-devel
77 BuildRequires:  openldap-devel
78 BuildRequires:  openwsman-devel >= 2.2.3
79 BuildRequires:  parted-devel >= 1.8.0
80 BuildRequires:  perl-tools-pod
81 %{?with_polkit:BuildRequires:   polkit >= 0.90}
82 BuildRequires:  pkgconfig
83 BuildRequires:  python
84 BuildRequires:  python-devel
85 BuildRequires:  readline-devel
86 BuildRequires:  rpm-pythonprov
87 BuildRequires:  rpmbuild(macros) >= 1.627
88 %{?with_sanlock:BuildRequires:  sanlock-devel >= 0.8}
89 BuildRequires:  udev-devel >= 145
90 %{?with_xen:BuildRequires:      xen-devel >= 4.1.2}
91 # For disk driver
92 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.10.0
93 BuildRequires:  yajl-devel
94 Requires:       curl-libs >= 7.18.0
95 Requires:       device-mapper >= 1.0.0
96 Requires:       libcap-ng >= 0.4.0
97 Requires:       libnl1 >= 1.1
98 Requires:       libpcap >= 1.0.0
99 Requires:       libselinux >= 2.0.82
100 Requires:       libssh2 >= 1.0
101 Requires:       libxml2 >= 1:2.6.0
102 Requires:       openwsman-libs >= 2.2.3
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %description
106 Libvirt is a C toolkit to interact with the virtualization
107 capabilities of recent versions of Linux.
108
109 Virtualization of the Linux Operating System means the ability to run
110 multiple instances of Operating Systems concurently on a single
111 hardware system where the basic resources are driven by a Linux
112 instance. The library aim at providing long term stable C API
113 initially for the Xen paravirtualization but should be able to
114 integrate other virtualization mechanisms if needed.
115
116 %description -l pl.UTF-8
117 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
118 obecnych wersji Linuksa.
119
120 Wirtualizacja w systemie operacyjnym Linux oznacza możliwość
121 jednoczesnego uruchamiania wielu instancji systemu operacyjnego na
122 pojedynczym systemie sprzętowym, którego podstawowe zasoby są
123 zarządzane przez instancję Linuksa. Celem biblioteki jest zapewnienie
124 długotrwale stabilnego API C, początkowo do parawirtualizacji Xen, ale
125 dającej się zintegrować w razie potrzeby z innymi mechanizmami
126 wirtualizacji.
127
128 %package devel
129 Summary:        Development files for programs using libvirt
130 Summary(pl.UTF-8):      Pliki programistyczne do programów wykorzystujących libvirt
131 Group:          Development/Libraries
132 Requires:       %{name} = %{version}-%{release}
133 Requires:       audit-libs-devel
134 Requires:       curl-devel >= 7.18.0
135 Requires:       device-mapper-devel >= 1.0.0
136 Requires:       gnutls-devel >= 1.0.25
137 Requires:       libapparmor-devel
138 Requires:       libcap-ng-devel >= 0.4.0
139 Requires:       libgcrypt-devel
140 Requires:       libnl1-devel >= 1.1
141 Requires:       libpcap-devel >= 1.0.0
142 Requires:       libselinux-devel >= 2.0.82
143 Requires:       libxml2-devel >= 1:2.6.0
144 Requires:       numactl-devel
145 Requires:       openwsman-devel >= 2.2.3
146 %{?with_xen:Requires: xen-devel}
147 Requires:       yajl-devel
148
149 %description devel
150 Libvirt is a C toolkit to interact with the virtualization
151 capabilities of recent versions of Linux.
152
153 This package contains the header files needed for developing programs
154 using the libvirt library.
155
156 %description devel -l pl.UTF-8
157 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
158 obecnych wersji Linuksa.
159
160 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
161 wykorzystujących bibliotekę libvirt.
162
163 %package static
164 Summary:        Development static libraries for programs using libvirt
165 Summary(pl.UTF-8):      Statyczne biblioteki programistyczne do programów wykorzystujących libvirt
166 Group:          Development/Libraries
167 Requires:       %{name}-devel = %{version}-%{release}
168
169 %description static
170 Libvirt is a C toolkit to interact with the virtualization
171 capabilities of recent versions of Linux.
172
173 This package contains the static libraries for developing programs
174 using the libvirt library.
175
176 %description static -l pl.UTF-8
177 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
178 obecnych wersji Linuksa.
179
180 Ten pakiet zawiera biblioteki statyczne do tworzenia programów
181 wykorzystujących bibliotekę libvirt.
182
183 %package -n python-%{name}
184 Summary:        Python bindings to interact with virtualization capabilities
185 Summary(pl.UTF-8):      Wiązania Pythona do współpracy z funkcjami wirtualizacji
186 Group:          Development/Languages/Python
187 Requires:       %{name} = %{version}-%{release}
188
189 %description -n python-%{name}
190 Libvirt is a C toolkit to interact with the virtualization
191 capabilities of recent versions of Linux.
192
193 This package contains the Python bindings for the libvirt library.
194
195 %description -n python-%{name} -l pl.UTF-8
196 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
197 obecnych wersji Linuksa.
198
199 Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
200
201 %package lock-sanlock
202 Summary:        Sanlock lock manager plugin for libvirt
203 Summary(pl.UTF-8):      Zarządca blokad sanlock dla biblioteki libvirt
204 Group:          Libraries
205 Requires:       %{name} = %{version}-%{release}
206
207 %description lock-sanlock
208 Sanlock lock manager plugin for libvirt.
209
210 %description lock-sanlock -l pl.UTF-8
211 Zarządca blokad sanlock dla biblioteki libvirt.
212
213 %package daemon
214 Summary:        Server side daemon and supporting files for libvirt library
215 Group:          Applications/System
216 Requires:       %{name} = %{version}-%{release}
217 Requires:       avahi-libs >= 0.6.0
218 Requires:       iproute2
219 Requires:       libblkid >= 2.17
220 Provides:       libvirt(hypervisor)
221 Requires:       parted-libs >= 1.8.0
222 # Needed for probing the power management features of the host.
223 Requires:       pm-utils
224 Requires:       systemd-units >= 37-0.10
225 Requires:       udev-libs >= 145
226 Requires:       util-linux
227 Requires:       virtual(module-tools)
228 Requires:       xorg-lib-libpciaccess >= 0.10.0
229 Requires(post): systemd-units
230 Requires(preun):        systemd-units
231 Requires(postun):       systemd-units
232 Suggests:       bridge-utils
233 Suggests:       cyrus-sasl
234 Suggests:       cyrus-sasl-digest-md5
235 Suggests:       dmidecode
236 Suggests:       dnsmasq >= 2.41
237 Suggests:       ebtables
238 Suggests:       gawk
239 Suggests:       glusterfs-client >= 2.0.1
240 Suggests:       iptables
241 Suggests:       iptables
242 Suggests:       libcgroup
243 Suggests:       lvm2
244 Suggests:       numad
245 Suggests:       open-iscsi
246 Suggests:       parted
247 Suggests:       polkit >= 0.93
248 Suggests:       radvd
249 Suggests:       scrub
250
251 %description daemon
252 Server side daemon required to manage the virtualization capabilities
253 of recent versions of Linux. Requires a hypervisor specific sub-RPM
254 for specific drivers.
255
256 %package daemon-esx
257 Summary:        Server side daemon & driver required to run VMware ESX guests
258 Group:          Development/Libraries
259 Requires:       %{name}-daemon = %{version}-%{release}
260 Provides:       libvirt(hypervisor)
261
262 %description daemon-esx
263 Server side daemon and driver required to manage the virtualization
264 capabilities of the VMware ESX emulators
265
266 %package daemon-hyperv
267 Summary:        Server side daemon & driver required to run Microsoft Hyper-V guests
268 Group:          Development/Libraries
269 Requires:       %{name}-daemon = %{version}-%{release}
270 Provides:       libvirt(hypervisor)
271
272 %description daemon-hyperv
273 Server side daemon and driver required to manage the virtualization
274 capabilities of the Microsoft Hyper-V emulators
275
276 %package daemon-libxl
277 Summary:        Server side daemon & driver required to run XEN guests (xenlight)
278 Group:          Development/Libraries
279 Requires:       %{name}-daemon = %{version}-%{release}
280 Requires:       /usr/sbin/qcow-create
281 Requires:       xen
282 Provides:       libvirt(hypervisor)
283
284 %description daemon-libxl
285 Server side daemon and driver required to manage the virtualization
286 capabilities of XEN via xenlight interface
287
288 %package daemon-lxc
289 Summary:        Server side daemon & driver required to run LXC guests
290 Group:          Development/Libraries
291 Requires:       %{name}-daemon = %{version}-%{release}
292 Provides:       libvirt(hypervisor)
293
294 %description daemon-lxc
295 Server side daemon and driver required to manage the virtualization
296 capabilities of LXC
297
298 %package daemon-openvz
299 Summary:        Server side daemon & driver required to run OpenVZ guests
300 Group:          Development/Libraries
301 Requires:       %{name}-daemon = %{version}-%{release}
302 Provides:       libvirt(hypervisor)
303
304 %description daemon-openvz
305 Server side daemon and driver required to manage the virtualization
306 capabilities of OpenVZ
307
308 %package daemon-phyp
309 Summary:        Server side daemon & driver required to run Power Hypervisors guests
310 Group:          Development/Libraries
311 Requires:       %{name}-daemon = %{version}-%{release}
312 Provides:       libvirt(hypervisor)
313
314 %description daemon-phyp
315 Server side daemon and driver required to manage the virtualization
316 capabilities of Power Hypervisors
317
318 %package daemon-qemu
319 Summary:        Server side daemon & driver required to run QEMU guests
320 Group:          Development/Libraries
321 Requires:       %{name}-daemon = %{version}-%{release}
322 Requires:       /usr/bin/qemu-img
323 Requires:       qemu
324 Requires:       bzip2
325 Requires:       gzip
326 Requires:       lzop
327 Requires:       xz
328 Provides:       libvirt(hypervisor)
329
330 %description daemon-qemu
331 Server side daemon and driver required to manage the virtualization
332 capabilities of the QEMU emulators
333
334 %package daemon-uml
335 Summary:        Server side daemon & driver required to run UML guests
336 Group:          Development/Libraries
337 Requires:       %{name}-daemon = %{version}-%{release}
338 Provides:       libvirt(hypervisor)
339
340 %description daemon-uml
341 Server side daemon and driver required to manage the virtualization
342 capabilities of UML
343
344 %package daemon-vbox
345 Summary:        Server side daemon & driver required to run Oracle VirtualBox guests
346 Group:          Development/Libraries
347 Requires:       %{name}-daemon = %{version}-%{release}
348 Provides:       libvirt(hypervisor)
349
350 %description daemon-vbox
351 Server side daemon and driver required to manage the virtualization
352 capabilities of Oracle VirtualBox
353
354 %package daemon-vmware
355 Summary:        Server side daemon & driver required to run VMware Workstation guests
356 Group:          Development/Libraries
357 Requires:       %{name}-daemon = %{version}-%{release}
358 Provides:       libvirt(hypervisor)
359
360 %description daemon-vmware
361 Server side daemon and driver required to manage the virtualization
362 capabilities of VMware Workstation
363
364 %package daemon-xen
365 Summary:        Server side daemon & driver required to run XEN guests
366 Group:          Development/Libraries
367 Requires:       %{name}-daemon = %{version}-%{release}
368 Requires:       /usr/sbin/qcow-create
369 Requires:       xen
370 Requires:       xen-xend
371 Provides:       libvirt(hypervisor)
372
373 %description daemon-xen
374 Server side daemon and driver required to manage the virtualization
375 capabilities of XEN
376
377 %package client
378 Summary:        Client side library and utilities of the libvirt library
379 Group:          Applications/System
380 Requires:       gettext >= 0.18.1.1-6
381 Requires:       gnutls >= 1.0.25
382 Requires:       netcat-openbsd
383 Requires(post): systemd-units
384 Requires(preun):        systemd-units
385 Requires(postun):       systemd-units
386
387 %description client
388 Shared libraries and client binaries needed to access to the
389 virtualization capabilities of recent versions of Linux (and other
390 OSes).
391
392 %package utils
393 Summary:        Tools to interact with virtualization capabilities
394 Summary(pl.UTF-8):      Narzędzia do współpracy z funkcjami wirtualizacyjnymi
395 Group:          Applications/System
396 Requires:       %{name}-client = %{version}-%{release}
397 Requires:       %{name}-daemon = %{version}-%{release}
398 Requires:       %{name}-daemon-esx = %{version}-%{release}
399 Requires:       %{name}-daemon-hyperv = %{version}-%{release}
400 Requires:       %{name}-daemon-libxl = %{version}-%{release}
401 Requires:       %{name}-daemon-lxc = %{version}-%{release}
402 Requires:       %{name}-daemon-openvz = %{version}-%{release}
403 Requires:       %{name}-daemon-phyp = %{version}-%{release}
404 Requires:       %{name}-daemon-qemu = %{version}-%{release}
405 Requires:       %{name}-daemon-uml = %{version}-%{release}
406 Requires:       %{name}-daemon-vbox = %{version}-%{release}
407 Requires:       %{name}-daemon-vmware = %{version}-%{release}
408 Requires:       %{name}-daemon-xen = %{version}-%{release}
409
410 %description utils
411 Libvirt is a C toolkit to interact with the virtualization
412 capabilities of recent versions of Linux.
413
414 This package contains tools for the libvirt library.
415
416 %description utils -l pl.UTF-8
417 Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
418 obecnych wersji Linuksa.
419
420 Ten pakiet zawiera narzędzia do biblioteki libvirt.
421
422 %prep
423 %setup -q
424 %patch0 -p1
425 %patch1 -p1
426 %patch2 -p1
427 %patch3 -p1
428 %patch4 -p1
429 %patch5 -p1
430
431 # weird translations
432 %{__rm} po/{my,eu_ES}.{po,gmo}
433
434 mv po/vi_VN.po po/vi.po
435 mv po/vi_VN.gmo po/vi.gmo
436
437 %build
438 %{__libtoolize}
439 %{__aclocal} -I gnulib/m4 -I m4
440 %{__autoconf}
441 %{__autoheader}
442 %{__automake}
443
444 %configure \
445         PVCREATE=/sbin/pvcreate \
446         VGCREATE=/sbin/vgcreate \
447         LVCREATE=/sbin/lvcreate \
448         PVREMOVE=/sbin/pvremove \
449         VGREMOVE=/sbin/vgremove \
450         LVREMOVE=/sbin/lvremove \
451         VGCHANGE=/sbin/vgchange \
452         LVCHANGE=/sbin/lvchange \
453           VGSCAN=/sbin/vgscan   \
454              PVS=/sbin/pvs      \
455              VGS=/sbin/vgs      \
456              LVS=/sbin/lvs      \
457               TC=/sbin/tc \
458            BRCTL=/sbin/brctl    \
459         ISCSIADM=/sbin/iscsiadm \
460         SHOWMOUNT=/usr/sbin/showmount \
461         MOUNT=/bin/mount \
462         UMOUNT=/bin/umount \
463         MKFS=/sbin/mkfs \
464         SHOWMOUNT=/usr/sbin/showmount \
465         IPTABLES_PATH=/usr/sbin/iptables \
466         IP6TABLES_PATH=/usr/sbin/ip6tables \
467         EBTABLES_PATH=/usr/sbin/ebtables \
468         ISCSIADM=/sbin/iscsiadm \
469         DNSMASQ=/usr/sbin/dnsmasq \
470         RADVD=/usr/sbin/radvd \
471         UDEVADM=/sbin/udevadm \
472         MODPROBE=/sbin/modprobe \
473         SCRUB=/usr/bin/scrub \
474         OVSVSCTL=/usr/bin/ovs-vsctl \
475         NUMAD=/usr/bin/numad \
476         --disable-silent-rules \
477         --with-html-dir=%{_gtkdocdir} \
478         --with-html-subdir=%{name} \
479         --with-init-script=redhat \
480         --with-storage-lvm \
481         --with-storage-fs \
482         --with-storage-iscsi \
483         --with-storage-scsi \
484         --with-storage-mpath \
485         --with-storage-disk \
486         --with-macvtap \
487         --with-virtualport \
488         --with-udev \
489         --with-libssh2 \
490         --with-avahi \
491         --with-audit \
492         --with-libblkid \
493         --with-macvtap \
494         --with-virtualport \
495         --with-numad \
496         --with-numactl \
497         --with-sasl \
498         --with-yajl \
499         --with-selinux \
500         --with-apparmor \
501         --with-qemu-user=qemu \
502         --with-qemu-group=qemu \
503         --without-hal \
504         --with-driver-modules \
505         %{__with_without polkit} \
506         %{__with_without esx} \
507         %{__with_without hyperv} \
508         %{__with_without libxl} \
509         %{__with_without lxc} \
510         %{__with_without netcf} \
511         %{__with_without openvz} \
512         %{__with_without phyp} \
513         %{__with_without qemu} \
514         %{__with_without sanlock} \
515         %{__with_without uml} \
516         %{__with_without vbox vbox %{_libdir}/VirtualBox} \
517         %{__with_without vmware} \
518         %{__with_without xen} \
519         %{__with_without xenapi} \
520         --x-libraries=%{_libdir} \
521         --with-init-script=systemd
522
523 %{__make} \
524         AWK=gawk
525
526 %install
527 rm -rf $RPM_BUILD_ROOT
528 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
529         $RPM_BUILD_ROOT%{systemdtmpfilesdir}
530
531 %{__make} install \
532         DEVHELP_DIR=%{_gtkdocdir}/%{name}/devhelp \
533         DESTDIR=$RPM_BUILD_ROOT
534
535 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
536 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
537
538 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
539 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
540 %py_postclean
541 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
542
543 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
544 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.{a,la}
545
546 %if %{with sanlock}
547 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.{a,la}
548 %endif
549
550 %find_lang %{name}
551
552 %clean
553 rm -rf $RPM_BUILD_ROOT
554
555 %post   -p /sbin/ldconfig
556 %postun -p /sbin/ldconfig
557
558 %post daemon
559 %systemd_post libvirtd.service
560
561 %preun daemon
562 %systemd_preun libvirtd.service
563
564 %postun daemon
565 %systemd_reload
566
567 %post client
568 NORESTART=1
569 %systemd_post libvirt-guests.service
570
571 %preun client
572 %systemd_preun libvirt-guests.service
573
574 %postun client
575 %systemd_reload
576
577 %files -f %{name}.lang
578 %defattr(644,root,root,755)
579 %doc ChangeLog README TODO NEWS
580 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirt.conf
581 %attr(755,root,root) %{_libdir}/libvirt.so.*.*.*
582 %attr(755,root,root) %ghost %{_libdir}/libvirt.so.0
583 %if %{with qemu}
584 %attr(755,root,root) %{_libdir}/libvirt-qemu.so.*.*.*
585 %attr(755,root,root) %ghost %{_libdir}/libvirt-qemu.so.0
586 %endif
587 %dir %{_libdir}/libvirt
588
589 %if %{with sanlock}
590 %files lock-sanlock
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_sbindir}/virt-sanlock-cleanup
593 %dir %{_libdir}/libvirt/lock-driver
594 %attr(755,root,root) %{_libdir}/libvirt/lock-driver/sanlock.so
595 %{_datadir}/augeas/lenses/libvirt_sanlock.aug
596 %{_datadir}/augeas/lenses/tests/test_libvirt_sanlock.aug
597 %dir /var/lib/libvirt/sanlock
598 %{_mandir}/man8/virt-sanlock-cleanup.8*
599 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-sanlock.conf
600 %endif
601
602 %files devel
603 %defattr(644,root,root,755)
604 %attr(755,root,root) %{_libdir}/libvirt.so
605 %attr(755,root,root) %{_libdir}/libvirt-qemu.so
606 %{_datadir}/%{name}/api
607 %{_gtkdocdir}/%{name}
608 %{_includedir}/%{name}
609 %{_pkgconfigdir}/%{name}.pc
610
611 %files static
612 %defattr(644,root,root,755)
613 %{_libdir}/libvirt.a
614 %{_libdir}/libvirt-qemu.a
615
616 %files -n python-%{name}
617 %defattr(644,root,root,755)
618 %doc %{_docdir}/%{name}-python-%{version}
619 %attr(755,root,root) %{py_sitedir}/libvirtmod.so
620 %attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
621 %{py_sitedir}/libvirt.py[co]
622 %{py_sitedir}/libvirt_qemu.py[co]
623
624 %files daemon
625 %defattr(644,root,root,755)
626 %doc docs/*.xml
627 %dir %{_sysconfdir}/libvirt
628 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/nwfilter
629 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu
630 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks
631 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks/autostart
632 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirtd.conf
633 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/default.xml
634 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/autostart/default.xml
635 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/nwfilter/*.xml
636 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/libvirt.conf
637 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
638 %attr(754,root,root) /etc/rc.d/init.d/libvirtd
639 %{systemdunitdir}/libvirtd.service
640 %config(noreplace) %verify(not md5 mtime size) /etc/sysctl.d/libvirtd
641 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
642 %attr(755,root,root) %{_libdir}/libvirt_iohelper
643 %attr(755,root,root) %{_libdir}/libvirt_parthelper
644 %attr(755,root,root) %{_libdir}/virt-aa-helper
645 %attr(755,root,root) %{_sbindir}/libvirtd
646 %{_datadir}/augeas/lenses/libvirtd.aug
647 %{_datadir}/augeas/lenses/tests/test_libvirtd.aug
648 %{?with_polkit:%{_datadir}/polkit-1/actions/org.libvirt.unix.policy}
649 %{_mandir}/man8/libvirtd.8*
650 %dir /var/lib/libvirt
651 %dir /var/lib/libvirt/dnsmasq
652 %attr(711,root,root) %dir /var/lib/libvirt/boot
653 %attr(700,root,root) %dir /var/lib/libvirt/network
654 %attr(711,root,root) %dir /var/lib/libvirt/images
655 %attr(711,root,root) %dir /var/lib/libvirt/filesystems
656 %attr(700,root,root) %dir /var/log/libvirt
657 %attr(711,root,root) %dir /var/cache/libvirt
658 %dir /var/run/libvirt
659 %dir /var/run/libvirt/network
660 %{systemdtmpfilesdir}/%{name}.conf
661 %dir %{_libdir}/libvirt/connection-driver
662 %{?with_netcf:%{_libdir}/libvirt/connection-driver/libvirt_driver_interface.so}
663 %{_libdir}/libvirt/connection-driver/libvirt_driver_network.so
664 %{_libdir}/libvirt/connection-driver/libvirt_driver_nodedev.so
665 %{_libdir}/libvirt/connection-driver/libvirt_driver_nwfilter.so
666 %{_libdir}/libvirt/connection-driver/libvirt_driver_remote.so
667 %{_libdir}/libvirt/connection-driver/libvirt_driver_secret.so
668 %{_libdir}/libvirt/connection-driver/libvirt_driver_storage.so
669 %{_libdir}/libvirt/connection-driver/libvirt_driver_test.so
670
671 %if %{with_esx}
672 %files daemon-esx
673 %defattr(644,root,root,755)
674 %{_libdir}/libvirt/connection-driver/libvirt_driver_esx.so
675 %endif
676
677 %if %{with_hyperv}
678 %files daemon-hyperv
679 %defattr(644,root,root,755)
680 %{_libdir}/libvirt/connection-driver/libvirt_driver_hyperv.so
681 %endif
682
683 %if %{with_libxl}
684 %files daemon-libxl
685 %defattr(644,root,root,755)
686 %{_libdir}/libvirt/connection-driver/libvirt_driver_libxl.so
687 %attr(700,root,root) %dir /var/lib/libvirt/libxl
688 %attr(700,root,root) %dir /var/run/libvirt/libxl
689 %attr(700,root,root) %dir /var/log/libvirt/libxl
690 %endif
691
692 %if %{with_lxc}
693 %files daemon-lxc
694 %defattr(644,root,root,755)
695 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/lxc.conf
696 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.lxc
697 %attr(700,root,root) %dir /var/lib/libvirt/lxc
698 %attr(700,root,root) %dir /var/run/libvirt/lxc
699 %attr(700,root,root) %dir /var/log/libvirt/lxc
700 %{_datadir}/augeas/lenses/libvirtd_lxc.aug
701 %{_datadir}/augeas/lenses/tests/test_libvirtd_lxc.aug
702 %attr(755,root,root) %{_libdir}/libvirt_lxc
703 %{_libdir}/libvirt/connection-driver/libvirt_driver_lxc.so
704 %endif
705
706 %if %{with_openvz}
707 %files daemon-openvz
708 %defattr(644,root,root,755)
709 %{_libdir}/libvirt/connection-driver/libvirt_driver_openvz.so
710 %endif
711
712 %if %{with_phyp}
713 %files daemon-phyp
714 %defattr(644,root,root,755)
715 %{_libdir}/libvirt/connection-driver/libvirt_driver_phyp.so
716 %endif
717
718 %if %{with qemu}
719 %files daemon-qemu
720 %defattr(644,root,root,755)
721 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu.conf
722 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.qemu
723 %attr(750,qemu,qemu) %dir /var/cache/libvirt/qemu
724 %attr(750,qemu,qemu) %dir /var/lib/libvirt/qemu
725 %attr(700,root,root) %dir /var/log/libvirt/qemu
726 %attr(700,root,root) %dir /var/run/libvirt/qemu
727 %{_datadir}/augeas/lenses/libvirtd_qemu.aug
728 %{_datadir}/augeas/lenses/tests/test_libvirtd_qemu.aug
729 %{_libdir}/libvirt/connection-driver/libvirt_driver_qemu.so
730 %endif
731
732 %if %{with_uml}
733 %files daemon-uml
734 %defattr(644,root,root,755)
735 %{_libdir}/libvirt/connection-driver/libvirt_driver_uml.so
736 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.uml
737 %attr(700,root,root) %dir /var/lib/libvirt/uml
738 %attr(700,root,root) %dir /var/run/libvirt/uml
739 %attr(700,root,root) %dir /var/log/libvirt/uml
740 %endif
741
742 %if %{with_vbox}
743 %files daemon-vbox
744 %defattr(644,root,root,755)
745 %{_libdir}/libvirt/connection-driver/libvirt_driver_vbox.so
746 %endif
747
748 %if %{with_vmware}
749 %files daemon-vmware
750 %defattr(644,root,root,755)
751 %{_libdir}/libvirt/connection-driver/libvirt_driver_vmware.so
752 %endif
753
754 %if %{with_xen}
755 %files daemon-xen
756 %defattr(644,root,root,755)
757 %{_libdir}/libvirt/connection-driver/libvirt_driver_xen.so
758 %endif
759
760 %files client
761 %defattr(644,root,root,755)
762 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
763 %attr(754,root,root) /etc/rc.d/init.d/libvirt-guests
764 %{systemdunitdir}/libvirt-guests.service
765 %attr(755,root,root) %{_bindir}/virsh
766 %attr(755,root,root) %{_bindir}/virt-host-validate
767 %attr(755,root,root) %{_bindir}/virt-xml-validate
768 %attr(755,root,root) %{_bindir}/virt-pki-validate
769 %{_mandir}/man1/virsh.1*
770 %{_mandir}/man1/virt-host-validate.1*
771 %{_mandir}/man1/virt-xml-validate.1*
772 %{_mandir}/man1/virt-pki-validate.1*
773 %dir %{_datadir}/libvirt
774 %{_datadir}/libvirt/cpu_map.xml
775 %dir %{_datadir}/libvirt/schemas
776 %{_datadir}/libvirt/schemas/basictypes.rng
777 %{_datadir}/libvirt/schemas/capability.rng
778 %{_datadir}/libvirt/schemas/domain.rng
779 %{_datadir}/libvirt/schemas/domaincommon.rng
780 %{_datadir}/libvirt/schemas/domainsnapshot.rng
781 %{_datadir}/libvirt/schemas/interface.rng
782 %{_datadir}/libvirt/schemas/network.rng
783 %{_datadir}/libvirt/schemas/networkcommon.rng
784 %{_datadir}/libvirt/schemas/nodedev.rng
785 %{_datadir}/libvirt/schemas/nwfilter.rng
786 %{_datadir}/libvirt/schemas/secret.rng
787 %{_datadir}/libvirt/schemas/storageencryption.rng
788 %{_datadir}/libvirt/schemas/storagepool.rng
789 %{_datadir}/libvirt/schemas/storagevol.rng
790
791 %files utils
792 %defattr(644,root,root,755)
This page took 0.119886 seconds and 4 git commands to generate.