]> git.pld-linux.org Git - packages/libunwind.git/blob - libunwind.spec
- rel 2; rebuild with fPIC
[packages/libunwind.git] / libunwind.spec
1 %bcond_with     tests
2 Summary:        libunwind - a (mostly) platform-independent unwind API
3 Summary(pl.UTF-8):      libunwind - (prawie) niezależne od platformy API do rozwijania
4 Name:           libunwind
5 Version:        0.99
6 Release:        2
7 License:        MIT
8 Group:          Libraries
9 Source0:        http://download.savannah.gnu.org/releases/libunwind/%{name}-%{version}.tar.gz
10 # Source0-md5:  3e9ca08118e22165a7f07d01d61a2d0d
11 Patch0:         %{name}-disable-setjmp.patch
12 Patch1:         %{name}-rpath.patch
13 URL:            http://www.nongnu.org/libunwind/
14 BuildRequires:  autoconf
15 BuildRequires:  automake >= 1.6
16 %ifarch %{x8664}
17 BuildRequires:  binutils >= 2:2.15.94.0.2.2
18 %endif
19 BuildRequires:  libtool
20 BuildRequires:  rpmbuild(macros) >= 1.213
21 ExclusiveArch:  %{ix86} %{x8664} hppa ia64
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 # x86/x86_64/hppa/ia64
25 %ifarch %{ix86}
26 %define asuf    x86
27 %else
28 %ifarch %{x8664}
29 %define asuf    x86_64
30 %else
31 %define asuf    %{_target_cpu}
32 %endif
33 %endif
34
35 %description
36 The goal of the libunwind project is to define a portable and
37 efficient C programming interface (API) to determine the call-chain
38 of a program.
39  
40 %description -l pl.UTF-8
41 Celem projektu libunwind jest zdefiniowanie przenośnego i wydajnego
42 API w języku C do określania łańcucha wywołań w programie.
43
44 %package devel
45 Summary:        Header files for libunwind library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libunwind
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description devel
51 Header files for libunwind library.
52
53 %description devel -l pl.UTF-8
54 Pliki nagłówkowe biblioteki libunwind.
55
56 %package static
57 Summary:        Static libunwind library
58 Summary(pl.UTF-8):      Statyczna biblioteka libunwind
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}-%{release}
61
62 %description static
63 Static libunwind library.
64
65 %description static -l pl.UTF-8
66 Statyczna biblioteka libunwind.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71 %patch1 -p1
72
73 %build
74 %{__libtoolize}
75 %{__aclocal}
76 %{__autoconf}
77 %{__autoheader}
78 %{__automake}
79 %configure \
80         CPPFLAGS="%{rpmcppflags} -fPIC"
81 %{__make}
82
83 %{?with_tests:%{__make} check}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS COPYING ChangeLog NEWS README TODO
100 %attr(755,root,root) %{_libdir}/libunwind.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libunwind.so.7
102 %attr(755,root,root) %{_libdir}/libunwind-%{asuf}.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libunwind-%{asuf}.so.7
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libunwind.so
108 %attr(755,root,root) %{_libdir}/libunwind-generic.so
109 %attr(755,root,root) %{_libdir}/libunwind-%{asuf}.so
110 %{_libdir}/libunwind.la
111 %{_libdir}/libunwind-%{asuf}.la
112 # static-only
113 %{_libdir}/libunwind-ptrace.a
114 %{_includedir}/libunwind*.h
115 %{_includedir}/unwind.h
116 %{_mandir}/man3/_U_dyn_*.3*
117 %{_mandir}/man3/libunwind*.3*
118 %{_mandir}/man3/unw_*.3*
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libunwind.a
123 %{_libdir}/libunwind-generic.a
124 %{_libdir}/libunwind-%{asuf}.a
This page took 0.04339 seconds and 4 git commands to generate.