]> git.pld-linux.org Git - packages/libu2f-server.git/blob - libu2f-server.spec
- new
[packages/libu2f-server.git] / libu2f-server.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        Yubico Universal 2nd Factor (U2F) Server C Library
6 Summary(pl.UTF-8):      Biblioteka C serwera Universal 2nd Factor (U2F) Yubico
7 Name:           libu2f-server
8 Version:        1.1.0
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 Source0:        https://developers.yubico.com/libu2f-server/Releases/%{name}-%{version}.tar.xz
13 # Source0-md5:  7350f22ff60f21133a2f78d050448dae
14 URL:            https://developers.yubico.com/libu2f-server/
15 BuildRequires:  gengetopt
16 BuildRequires:  help2man
17 BuildRequires:  json-c-devel
18 BuildRequires:  openssl-devel
19 BuildRequires:  pkgconfig
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 libu2f-server is a C library that implements the server-side of the
26 U2F protocol. More precisely, it provides an API for generating the
27 JSON blobs required by U2F devices to perform the U2F Registration and
28 U2F Authentication operations, and functionality for verifying the
29 cryptographic operations.
30
31 %description -l pl.UTF-8
32 libu2f-server to biblioteka C implementująca stronę serwera protokołu
33 U2F. Ściślej mówiąc, udostępnia API do generowania blobów JSON
34 wymaganych przez urządzenia U2F do wykonywania operacji U2F
35 Registration i U2F Authentication oraz funkcjonalność weryfikowania
36 operacji kryptograficznych.
37
38 %package devel
39 Summary:        Header files for libu2f-server library
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libu2f-server
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for libu2f-server library.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki libu2f-server.
49
50 %package static
51 Summary:        Static libu2f-server library
52 Summary(pl.UTF-8):      Statyczna biblioteka libu2f-server
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static libu2f-server library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka libu2f-server.
61
62 %prep
63 %setup -q
64
65 %build
66 %configure \
67         --disable-silent-rules \
68         %{!?with_static_libs:--disable-static}
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 # obsoleted by pkg-config
78 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libu2f-server.la
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %post   -p /sbin/ldconfig
84 %postun -p /sbin/ldconfig
85
86 %files
87 %defattr(644,root,root,755)
88 %doc AUTHORS COPYING ChangeLog NEWS README THANKS
89 %attr(755,root,root) %{_bindir}/u2f-server
90 %attr(755,root,root) %{_libdir}/libu2f-server.so.*.*.*
91 %attr(755,root,root) %ghost %{_libdir}/libu2f-server.so.0
92 %{_mandir}/man1/u2f-server.1*
93
94 %files devel
95 %defattr(644,root,root,755)
96 %attr(755,root,root) %{_libdir}/libu2f-server.so
97 %{_includedir}/u2f-server
98 %{_pkgconfigdir}/u2f-server.pc
99
100 %if %{with static_libs}
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libu2f-server.a
104 %endif
This page took 0.06967 seconds and 3 git commands to generate.