]> git.pld-linux.org Git - packages/libtorrent.git/blob - libtorrent.spec
- updated to 0.7.2
[packages/libtorrent.git] / libtorrent.spec
1 Summary:        LibTorrent - a BitTorrent library written in C++ for Unix
2 Summary(pl):    LibTorrent - biblioteka BitTorrenta napisana w C++ dla Uniksa
3 Name:           libtorrent
4 Version:        0.7.2
5 Release:        1
6 License:        GPL v2
7 Group:          Libraries
8 Source0:        http://libtorrent.rakshasa.no/downloads/%{name}-%{version}.tar.gz
9 # Source0-md5:  85494bf78eb1a70bacf94044bfd29a6b
10 URL:            http://libtorrent.rakshasa.no/
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  libsigc++-devel >= 2.0
14 BuildRequires:  libtool
15 BuildRequires:  openssl-devel >= 0.9.7d
16 BuildRequires:  pkgconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 LibTorrent is a BitTorrent library written in C++ for Unix. It is
21 designed to avoid the redundant buffers and data copying that most
22 (all?) other BitTorrent implementations suffer from. The library is
23 single-threaded and the client handles the select loop.
24
25 %description -l pl
26 LibTorrent to biblioteka BitTorrenta napisana w C++ dla Uniksa. Jest
27 zaprojektowana aby unikn±æ nadmiarowego kopiowania buforów i danych,
28 bêd±cego wad± wiêkszo¶ci (wszystkich?) innych implementacji
29 BitTorrenta. Biblioteka jest jednow±tkowa, klient obs³uguje pêtlê
30 select.
31
32 %package devel
33 Summary:        Development files for libtorrent
34 Summary(pl):    Pliki programistyczne libtorrent
35 Group:          Development/Libraries
36 Requires:       %{name} = %{version}-%{release}
37 Requires:       libsigc++-devel >= 2.0
38 Requires:       openssl-devel >= 0.9.7d
39
40 %description devel
41 Development files for libtorrent.
42
43 %description devel -l pl
44 Pliki programistyczne libtorrent.
45
46 %package static
47 Summary:        Static libtorrent library
48 Summary(pl):    Statyczna biblioteka libtorrent
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static libtorrent library.
54
55 %description static -l pl
56 Statyczna biblioteka libtorrent.
57
58 %prep
59 %setup -q
60
61 %build
62 %{__libtoolize}
63 %{__aclocal}
64 %{__autoconf}
65 %{__automake}
66 %configure \
67         --%{?debug:en}%{!?debug:dis}able-debug \
68         --enable-static
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %post   -p /sbin/ldconfig
81 %postun -p /sbin/ldconfig
82
83 %files
84 %defattr(644,root,root,755)
85 %doc AUTHORS ChangeLog README TODO
86 %attr(755,root,root) %{_libdir}/libtorrent.so.*.*.*
87
88 %files devel
89 %defattr(644,root,root,755)
90 %attr(755,root,root) %{_libdir}/libtorrent.so
91 %{_libdir}/libtorrent.la
92 %{_includedir}/torrent
93 %{_pkgconfigdir}/libtorrent.pc
94
95 %files static
96 %defattr(644,root,root,755)
97 %{_libdir}/libtorrent.a
This page took 0.079604 seconds and 3 git commands to generate.