]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blob - libtorrent-rasterbar.spec
caeea0f750474214f5d98db680bb70b7dae7d315
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
1 Summary:        A C++ BitTorrent library
2 Summary(hu.UTF-8):      C++ BitTorrent könyvtár
3 Summary(pl.UTF-8):      Biblioteka BitTorrenta napisana w C++
4 Name:           libtorrent-rasterbar
5 Version:        0.15.6
6 Release:        3
7 Epoch:          1
8 License:        BSD
9 Group:          Libraries
10 Source0:        http://libtorrent.googlecode.com/files/%{name}-%{version}.tar.gz
11 # Source0-md5:  53c64fe121c7fd0383f90dc653930f4a
12 URL:            http://www.rasterbar.com/products/libtorrent/
13 Patch0:         bashizm.patch
14 BuildRequires:  GeoIP-devel
15 BuildRequires:  autoconf >= 2.63
16 BuildRequires:  automake >= 1:1.11
17 BuildRequires:  boost-devel >= 1.35.0
18 BuildRequires:  boost-python-devel
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool >= 2:2.2.6
21 BuildRequires:  openssl-devel
22 BuildRequires:  pkgconfig >= 1:0.20
23 BuildRequires:  python-devel
24 BuildRequires:  python-modules
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  sed >= 4.0
27 BuildRequires:  util-linux
28 BuildRequires:  which
29 BuildRequires:  zlib-devel
30 Obsoletes:      rb_libtorrent
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 libtorrent-rasterbar is a C++ library that aims to be a good
35 alternative to all the other BitTorrent implementations around. It is
36 a library and not a full featured client, although it comes with a
37 working example client.
38
39 Its main goals are to be very efficient (in terms of CPU and memory
40 usage) as well as being very easy to use both as a user and developer.
41
42 %description -l hu.UTF-8
43 libtorrent-rasterbar egy C++ könyvtár, amely egy jó alternatívája
44 kíván lenni az összes többi BitTorrent implementációjának. Ez "csak"
45 egy könyvtár, és nem egy szolgáltatásgazdag kliens, habár ad egy
46 működő példa-klienst.
47
48 A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
49 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
50
51 %description -l pl.UTF-8
52 libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
53 bycia dobrą alternatywą dla wszystkich innych implementacji
54 BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
55 pakiet zawiera działającego przykładowego klienta.
56
57 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
58 wykorzystania procesora i pamięci) jak również łatwą w użyciu zarówno
59 dla użytkownika, jak i programisty.
60
61 %package devel
62 Summary:        Header files for %{name} library
63 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki %{name}
64 License:        BSD, zlib/libpng License, Boost Software License
65 Group:          Development/Libraries
66 Requires:       %{name} = %{epoch}:%{version}-%{release}
67 Requires:       boost-devel
68 Requires:       openssl-devel
69 Obsoletes:      rb_libtorrent-devel
70
71 %description    devel
72 The libtorrent-rasterbar-devel package contains libraries and header
73 files for developing applications that use libtorrent-rasterbar.
74
75 The various source and header files included in this package are
76 licensed under the revised BSD, zlib/libpng, and Boost Public
77 licenses.
78
79 %description devel -l hu.UTF-8
80 A libtorrent-rasterbar-devel csomag tartalmazza a könyvtári és
81 fejlesztői fájlokat, amellyel libtorrent-rasterbar-t használó
82 alkalmazásokat fejleszthetsz.
83
84 %description devel -l pl.UTF-8
85 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
86 rozwijania aplikacji używających libtorrent-rasterbar.
87
88 Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
89 licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
90 License.
91
92 %package static
93 Summary:        Static %{name} library
94 Summary(pl.UTF-8):      Statyczna biblioteka %{name}
95 Group:          Development/Libraries
96 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
97 Obsoletes:      rb_libtorrent-static
98
99 %description static
100 Static libtorrent-rasterbar library.
101
102 %description static -l hu.UTF-8
103 Statikus libtorrent-rasterbar könyvtár.
104
105 %description static -l pl.UTF-8
106 Statyczna biblioteka libtorrent-rasterbar.
107
108 %package -n python-libtorrent-rasterbar
109 Summary:        Python bindings for libtorrent-rasterbar
110 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki libtorrent-rasterbar
111 Group:          Libraries/Python
112 Requires:       %{name} = %{epoch}:%{version}-%{release}
113
114 %description -n python-libtorrent-rasterbar
115 Python bindings for libtorrent-rasterbar.
116
117 %description -n python-libtorrent-rasterbar -l pl.UTF-8
118 Wiązania Pythona do biblioteki libtorrent-rasterbar.
119
120 %prep
121 %setup -q
122 %patch0 -p1
123
124 ## Some of the sources and docs are executable, which makes rpmlint against
125 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
126 find src docs -type f | xargs chmod a-x
127 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
128 ## The RST files are the sources used to create the final HTML files; and are
129 ## not needed.
130 %{__rm} docs/*.rst
131
132 %build
133 %{__libtoolize}
134 %{__aclocal} -I m4
135 %{__autoconf}
136 %{__automake}
137 %configure \
138         LIBS="-lpthread -lrt" \
139         --disable-silent-rules \
140         --enable-python-binding \
141         --with-boost-libdir=%{_libdir} \
142         --with-boost-system=boost_system \
143         --with-boost-filesystem=boost_filesystem \
144         --with-boost-thread=boost_thread \
145         --with-boost-regex=boost_regex \
146         --with-boost-program-options=boost_program_options \
147         --with-asio=system \
148         --with-zlib=system \
149         --with-libgeoip=system \
150         --with-ssl
151
152 %{__make}
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156
157 %{__make} install \
158         DESTDIR=$RPM_BUILD_ROOT
159
160 %clean
161 rm -rf $RPM_BUILD_ROOT
162
163 %post   -p /sbin/ldconfig
164 %postun -p /sbin/ldconfig
165
166 %files
167 %defattr(644,root,root,755)
168 %doc AUTHORS ChangeLog COPYING README
169 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so.*.*.*
170 %attr(755,root,root) %ghost %{_libdir}/libtorrent-rasterbar.so.6
171
172 %files devel
173 %defattr(644,root,root,755)
174 %doc docs/
175 %attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so
176 %{_libdir}/libtorrent-rasterbar.la
177 %{_pkgconfigdir}/libtorrent-rasterbar.pc
178 %{_includedir}/libtorrent
179
180 %files static
181 %defattr(644,root,root,755)
182 %{_libdir}/libtorrent-rasterbar.a
183
184 %files -n python-libtorrent-rasterbar
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{py_sitedir}/libtorrent.so
187 %{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.076805 seconds and 3 git commands to generate.