]> git.pld-linux.org Git - packages/libtool.git/blob - libtool.spec
851e9c595322ddfe3f8ea188c3300029913c9545
[packages/libtool.git] / libtool.spec
1 Summary:        GNU libtool, a shared library generation tool.
2 Summary(pl):    GNU libtool - narzêdzie do generowania bibliotek wspó³dzielonych
3 Name:           libtool
4 Version:        1.3
5 Release:        3
6 Copyright:      GPL
7 Group:          Development/Tools
8 Group(pl):      Programowanie/Narzêdzia
9 Source:         ftp://ftp.gnu.org/gnu/libtool/%{name}-%{version}.tar.gz
10 Patch0:         libtool-info.patch
11 Patch1:         libtool-cache.patch
12 URL:            http://www.gnu.org/software/libtool/
13 PreReq:         /sbin/install-info
14 BuildRoot:      /tmp/%{name}-%{version}-root
15
16 %description
17 GNU libtool is a set of shell scripts to automatically configure
18 UNIX architectures to build shared libraries in generic fashion.
19
20 %description -l pl
21 GNU libtool jest zbiorem skryptów shellowych do automatycznego gemnerowania
22 bibliotek wspó³dzielonych niezale¿nie od typu platformy systemowej.
23
24 %package -n     libltdl
25 Summary:        System independent dlopen wrapper for GNU libtool
26 Summary(pl):    Biblioteka ogólnych wywo³añ dlopen
27 Group:          Libraries
28 Group(pl):      Biblioteki
29
30 %description -n libltdl
31 System independent dlopen wrapper for GNU libtool
32
33 %description -n libltdl -l pl
34 Biblioteka ogólnych wywo³añ dlopen
35
36 %package -n     libltdl-devel
37 Summary:        System independent dlopen wrapper for GNU libtool
38 Summary(pl):    Biblioteka ogólnych wywo³añ dlopen
39 Group:          Development/Libraries
40 Group(pl):      Programowanie/Biblioteki
41 Requires:       libltdl = %{version}
42
43 %description -n libltdl-devel
44 System independent dlopen wrapper for GNU libtool
45
46 %description -n libltdl-devel -l pl
47 Biblioteka ogólnych wywo³añ dlopen
48
49 %package -n     libltdl-static
50 Summary:        Static system independent dlopen wrapper for GNU libtool
51 Summary(pl):    Statyczna biblioteka ogólnych wywo³añ dlopen
52 Group:          Development/Libraries
53 Group(pl):      Programowanie/Biblioteki
54 Requires:       libltdl-devel = %{version}
55
56 %description -n libltdl-static
57 Static system independent dlopen wrapper for GNU libtool
58
59 %description -n libltdl-static -l pl
60 Statyczna biblioteka ogólnych wywo³añ dlopen
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66
67 %build
68 aclocal
69 CFLAGS="$RPM_OPT_FLAGS" \
70     ./configure \
71         --prefix=%{_prefix} \
72         %{_target_platform}
73
74 (cd doc && make -k)
75 make
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 make \
81     prefix=$RPM_BUILD_ROOT%{_prefix} \
82     install
83
84 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*so.*.*
85
86 gzip -9nf $RPM_BUILD_ROOT%{_infodir}/*.info* \
87         AUTHORS NEWS README THANKS TODO ChangeLog
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post
93 /sbin/install-info %{_infodir}/libtool.info.gz /etc/info-dir
94
95 %preun
96 if [ "$1" = "0" ]; then
97     /sbin/install-info --delete %{_infodir}/libtool.info.gz /etc/info-dir
98 fi
99 %post -n libltdl
100 /sbin/ldconfig
101
102 %post -n libltdl-devel
103 /sbin/ldconfig
104
105 %postun -n libltdl
106 /sbin/ldconfig
107
108 %postun -n libltdl-devel
109 /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc {AUTHORS,NEWS,README,THANKS,TODO,ChangeLog}.gz demo
114
115 %attr(755,root,root) %{_bindir}/*
116
117 %{_infodir}/libtool.info*
118
119 %dir %{_datadir}/libtool
120 %attr(755,root,root) %{_datadir}/libtool/config.guess
121 %attr(755,root,root) %{_datadir}/libtool/config.sub
122 %attr(755,root,root) %{_datadir}/libtool/ltconfig
123
124 %{_datadir}/libtool/ltmain.sh
125 %{_datadir}/aclocal/libtool.m4
126
127 %files -n libltdl
128 %defattr(755,root,root,755)
129 %{_libdir}/lib*.so.*.*
130
131 %files -n libltdl-devel
132 %defattr(644,root,root,755)
133
134 %attr(755,root,root) %{_libdir}/lib*.so
135 %attr(755,root,root) %{_libdir}/lib*.la
136
137 %{_includedir}/*
138 %attr(-,root,root) %{_datadir}/libtool/libltdl
139
140 %files -n libltdl-static
141 %defattr(644,root,root,755)
142
143 %{_libdir}/lib*.a
144
145 %changelog
146 * Sun May 23 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
147   [1.3-3]
148 - added some macros,
149 - fixed %post & %postun,
150 - cosmetic.
151
152 * Wed May  5 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
153   [1.3-2]
154 - added CFLAGS="$RPM_OPT_FLAGS" to ./configure enviroment,
155 - added stripping shared libraries.
156
157 * Fri Apr 30 1999 Artur Frysiak <wiget@pld.org.pl>
158 - added libltdl, libltdl-devel and libltdl-static subpackage
159 - removed BuildArch: noarch (added subpackage are system independent)
160 - added patch for work correct with grep 2.3
161
162 * Sun Mar 14 1999 Micha³ Kuratczyk <kura@pld.org.pl>
163   [1.2d-3]
164 - added gzipping documentation
165
166 * Thu Mar 11 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
167   [1.2d-2]
168 - Group changed to Development/Tools,
169 - added Group(pl).
170
171 * Tue Dec 29 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
172   [1.2d-1]
173 - added pl translation,
174 - added libtool-info.patch.
175 - standarized {un}registering info pages.
176
177 * Wed Nov 25 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
178   [1.2b-2]
179 - added URL field,
180 - fixed --entry text on {un}registering info page for libtool in %post
181   %preun in devel.
182
183 * Thu Sep  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
184   [1.2-1]
185 - added -q %setup parameter,
186 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
187 - added using %%{name} and %%{version} in Source,
188 - removed COPYING and INSTALL drom %doc,
189 - added %attr and %defattr macros in %files (allows build package from
190   non-root account),
191 - start at RH spec.
This page took 0.065955 seconds and 2 git commands to generate.