]> git.pld-linux.org Git - packages/libtirpc.git/blob - libtirpc.spec
- updated to 1.3.4
[packages/libtirpc.git] / libtirpc.spec
1 #
2 # Conditional build
3 %bcond_without  gssapi          # GSSAPI support
4 %bcond_without  musl            # minimal tirpc for musl usage
5
6 %if %{with musl}
7 %undefine       gssapi
8 %endif
9
10 Summary:        Transport Independent RPC Library
11 Summary(pl.UTF-8):      Biblioteka RPC niezależnego od transportu
12 Name:           libtirpc
13 Version:        1.3.4
14 Release:        1
15 Epoch:          1
16 License:        BSD
17 Group:          Libraries
18 Source0:        https://downloads.sourceforge.net/libtirpc/%{name}-%{version}.tar.bz2
19 # Source0-md5:  375dbe7ceb2d0300d173fb40321b49b6
20 Patch0:         %{name}-link.patch
21 URL:            http://sourceforge.net/projects/libtirpc/
22 BuildRequires:  autoconf >= 2.50
23 BuildRequires:  automake >= 1:1.11
24 BuildRequires:  glibc >= 6:2.14-9.1
25 %{?with_gssapi:BuildRequires:   heimdal-devel}
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 %{?with_gssapi:Requires:        heimdal-libs}
29 %if %{with musl}
30 BuildRequires:  musl-devel
31 BuildRequires:  linux-musl-headers
32 %endif
33 Requires:       glibc >= 6:2.14-9.1
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 This package contains SunLib's implementation of transport-independent
38 RPC (TI-RPC) documentation. This library forms a piece of the base of
39 Open Network Computing (ONC), and is derived directly from the Solaris
40 2.3 source.
41
42 TI-RPC is an enhanced version of TS-RPC that requires the UNIX System
43 V Transport Layer Interface (TLI) or an equivalent X/Open Transport
44 Interface (XTI). TI-RPC is on-the-wire compatible with the TS-RPC,
45 which is supported by almost 70 vendors on all major operating
46 systems. TS-RPC source code (RPCSRC 4.0) remains available from
47 several Internet sites.
48
49 %description -l pl.UTF-8
50 Ten pakiet zawiera implementację SunLib RPC niezależnego od transportu
51 (TI-RPC). Ta biblioteka tworzy element podstawy dla ONC (Open Network
52 Computing) i wywodzi się bezpośrednio ze źródeł Solarisa 2.3.
53
54 TI-RPC to rozszerzona wersja TS-RPC wymagająca TLI (UNIX System V
55 Transport Layer Interface). Jest kompatybilna w locie z TS-RPC,
56 obsługiwanym przez prawie 70 producentów dla wszystkich znaczących
57 systemów operacyjnych. Kod źródłowy TS-RPC (RPCSRC 4.0) pozostaje
58 dostępny z różnych stron internetowych.
59
60 %package devel
61 Summary:        Development files for the TI-RPC library
62 Summary(pl.UTF-8):      Pliki programistyczne biblioteki TI-RPC
63 Group:          Development/Libraries
64 Requires:       %{name} = %{epoch}:%{version}-%{release}
65 Requires:       glibc-devel >= 6:2.14-9.1
66 %{?with_gssapi:Requires:        heimdal-devel}
67
68 %description devel
69 This package includes header files necessary for developing programs
70 which use the TI-RPC library.
71
72 %description devel -l pl.UTF-8
73 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
74 wykorzystujących bibliotekę TI-RPC.
75
76 %package static
77 Summary:        Static TI-RPC library
78 Summary(pl.UTF-8):      Statyczna biblioteka TI-RPC
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
81 %{?with_gssapi:Requires:        heimdal-static}
82
83 %description static
84 This package includes static TI-RPC library.
85
86 %description static -l pl.UTF-8
87 Ten pakiet zawiera statyczną bibliotekę TI-RPC.
88
89 %package musl-devel
90 Summary:        Static TI-RPC library for musl usage
91 Summary(pl.UTF-8):      Statyczna biblioteka TI-RPC do użycia z musl
92 Group:          Development/Libraries
93
94 %description musl-devel
95 This package includes static TI-RPC library for musl usage.
96
97 %description musl-devel -l pl.UTF-8
98 Ten pakiet zawiera statyczną bibliotekę TI-RPC do użycia z musl.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103
104 %build
105 %{__libtoolize}
106 %{__aclocal} -I m4
107 %{__autoconf}
108 %{__autoheader}
109 %{__automake}
110 install -d build
111 cd build
112 ../%configure \
113         --disable-silent-rules \
114         --enable-authdes \
115         %{!?with_gssapi:--disable-gssapi}
116
117 %{__make}
118 cd ..
119
120 %if %{with musl}
121 install -d musl
122 cd musl
123 ../%configure \
124         CC="musl-gcc" \
125         CFLAGS="%{rpmcflags} -I%{_includedir}/musl -fno-stack-protector" \
126         LDFLAGS="%{rpmldflags} -L%{_libdir}/musl" \
127         --disable-silent-rules \
128         --enable-authdes \
129         --disable-gssapi
130 %{__make}
131 cd ..
132 %endif
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{_sysconfdir},/%{_lib},%{_mandir}/man{3,5}}
137
138 %{__make} -C build install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %if %{with musl}
142 %{__make} -C musl install \
143         DESTDIR=$(pwd)/musl/destdir
144
145 install -d $RPM_BUILD_ROOT{%{_includedir}/musl,%{_libdir}/musl}
146 %{__mv} musl/destdir%{_includedir}/tirpc $RPM_BUILD_ROOT%{_includedir}/musl
147 %{__mv} musl/destdir%{_libdir}/libtirpc.a $RPM_BUILD_ROOT%{_libdir}/musl
148 %endif
149
150 %{__make} -C build/doc install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 %{__mv} $RPM_BUILD_ROOT%{_libdir}/libtirpc.so.* $RPM_BUILD_ROOT/%{_lib}
154 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtirpc.so
155 ln -sf /%{_lib}/$(basename $RPM_BUILD_ROOT/%{_lib}/libtirpc.so.*.*.*) \
156         $RPM_BUILD_ROOT%{_libdir}/libtirpc.so
157
158 # obsoleted by pkgconfig
159 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtirpc.la
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %post   -p /sbin/ldconfig
165 %postun -p /sbin/ldconfig
166
167 %files
168 %defattr(644,root,root,755)
169 %doc AUTHORS COPYING ChangeLog NEWS README THANKS TODO
170 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bindresvport.blacklist
171 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/netconfig
172 %attr(755,root,root) /%{_lib}/libtirpc.so.*.*.*
173 %attr(755,root,root) %ghost /%{_lib}/libtirpc.so.3
174 %{_mandir}/man5/netconfig.5*
175
176 %files devel
177 %defattr(644,root,root,755)
178 %attr(755,root,root) %{_libdir}/libtirpc.so
179 %{_includedir}/tirpc
180 %{_pkgconfigdir}/libtirpc.pc
181 %{_mandir}/man3/bindresvport.3t*
182 %{_mandir}/man3/des_crypt.3t*
183 %{_mandir}/man3/getnet*.3t*
184 %{_mandir}/man3/getrpc*.3t*
185 %{_mandir}/man3/rpc*.3t*
186 %{_mandir}/man3/rtime.3t*
187
188 %files static
189 %defattr(644,root,root,755)
190 %{_libdir}/libtirpc.a
191
192 %if %{with musl}
193 %files musl-devel
194 %defattr(644,root,root,755)
195 %{_includedir}/musl/tirpc
196 %{_libdir}/musl/libtirpc.a
197 %endif
This page took 0.106026 seconds and 4 git commands to generate.