]> git.pld-linux.org Git - packages/libsoup.git/blob - libsoup.spec
3f35563c3f46a796c205daa63653809bb06b239d
[packages/libsoup.git] / libsoup.spec
1 # hack for distributor fault
2 %define         broken_ver 1.99.20
3
4 Summary:        SOAP (Simple Object Access Protocol) implementation in C
5 Summary(pl):    Implementacja w C SOAP (Simple Object Access Protocol)
6 Name:           libsoup
7 Version:        1.99.22
8 Release:        0.1
9 License:        LGPL
10 Group:          X11/Libraries
11 Source0:        ftp://ftp.gnome.org/pub/GNOME/sources/%{name}/1.99/%{name}-%{version}.tar.bz2
12 # Source0-md5: 78b2e1c656d361aa1c8252934ee7ddc1
13 URL:            http://www.gnome.org/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  glib2-devel
17 BuildRequires:  gtk-doc
18 BuildRequires:  libtool
19 BuildRequires:  openssl-devel >= 0.9.7
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 It provides an queued asynchronous callback-based mechanism for
24 sending and servicing SOAP requests, and a WSDL (Web Service
25 Definition Language) to C compiler which generates client stubs and
26 server skeletons for easily calling and implementing SOAP methods.
27
28 %description -l pl
29 Pakiet dostarcza interfejs kolejkowalnego, asynchronicznego mechanizmu
30 do wysy³ania i serwowania ¿±dañ SOAP oraz WSDL (Web Service Definition
31 Language) dla kompilatora C, który generuje klienckie stub i szkielety
32 serwerów dla ³atwego wywo³ywania i implementowania metod SOAP.
33
34 %package devel
35 Summary:        Include files etc to develop SOAP applications
36 Summary(pl):    Pliki nag³ówkowe, dokumentacja dla SOAP
37 Group:          X11/Development/Libraries
38 Requires:       %{name} = %{version}
39
40 %description devel
41 Header files, etc you can use to develop SOAP applications.
42
43 %description devel -l pl
44 Pliki nag³ówkowe itp. Jednym s³owem wszystko czego potrzebujesz aby
45 samemu tworzyæ sobie aplikacje korzystaj±ce z SOAP.
46
47 %package static
48 Summary:        SOAP static libraries
49 Summary(pl):    Biblioteki statyczne SOAP
50 Group:          X11/Development/Libraries
51 Requires:       %{name}-devel = %{version}
52
53 %description static
54 SOAP static libraries.
55
56 %description static -l pl
57 Biblioteki statyczne SOAP.
58
59 %prep
60 %setup  -q -n %{name}-%{broken_ver}
61
62 %build
63 rm -f missing
64 %{__libtoolize}
65 %{__aclocal}
66 %{__autoheader}
67 %{__autoconf}
68 %{__automake}
69
70 %configure \
71         --enable-ssl \
72         --enable-gtk-doc \
73         --with-html-dir=%{_gtkdocdir}
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         pkgconfigdir=%{_pkgconfigdir} \
82         m4datadir=%{_aclocaldir} \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %post   -p /sbin/ldconfig
89 %postun -p /sbin/ldconfig
90
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS ChangeLog README TODO
94 %attr(755,root,root) %{_libdir}/lib*.so.*.*
95 %attr(755,root,root) %{_libdir}/libsoup-ssl-proxy
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/lib*.so
100 %{_libdir}/lib*.la
101 %{_includedir}/*
102 %{_pkgconfigdir}/*
103
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/lib*.a
This page took 0.101449 seconds and 3 git commands to generate.