]> git.pld-linux.org Git - packages/libsndfile.git/blob - libsndfile.spec
- updated to 1.2.0 (security fixes in 1.0.29, MPEG support introduced)
[packages/libsndfile.git] / libsndfile.spec
1 # TODO:
2 #       - who needs sndfile-regtest?
3 #
4 # Conditional build:
5 %bcond_with     regtest         # build sndfile-regtest program
6 %bcond_without  octave          # don't build octave binding
7 %bcond_without  static_libs     # don't build static library
8 %bcond_without  tests           # don't build tests
9 #
10 Summary:        C library for reading and writing files containing sampled sound
11 Summary(pl.UTF-8):      Biblioteka obsługi plików dźwiękowych
12 Name:           libsndfile
13 Version:        1.2.0
14 Release:        1
15 License:        LGPL v2.1+
16 Group:          Libraries
17 #Source0Download: https://github.com/libsndfile/libsndfile/releases
18 Source0:        https://github.com/libsndfile/libsndfile/archive/%{version}/%{name}-%{version}.tar.gz
19 # Source0-md5:  015d2e3617241f293237bf1675f92486
20 Patch0:         octave32.patch
21 URL:            http://www.mega-nerd.com/libsndfile/
22 BuildRequires:  alsa-lib-devel
23 BuildRequires:  autoconf >= 2.69
24 BuildRequires:  automake >= 1:1.14
25 BuildRequires:  flac-devel >= 1.3.1
26 BuildRequires:  gcc-fortran
27 BuildRequires:  lame-libs-devel
28 BuildRequires:  libmpg123-devel >= 1.25.10
29 BuildRequires:  libogg-devel >= 2:1.3.0
30 %{?with_tests:BuildRequires:    libstdc++-devel}
31 BuildRequires:  libtool >= 2:2
32 BuildRequires:  libvorbis-devel >= 1:1.2.3
33 %{?with_octave:BuildRequires:   octave-devel >= 2:3}
34 BuildRequires:  opus-devel >= 1.1
35 BuildRequires:  pkgconfig
36 BuildRequires:  sed >= 4.0
37 %{?with_regtest:BuildRequires:  sqlite3-devel >= 3.2}
38 Requires:       flac >= 1.3.1
39 Requires:       libmpg123 >= 1.25.10
40 Requires:       libogg >= 2:1.3.0
41 Requires:       libvorbis >= 1:1.2.3
42 Requires:       opus >= 1.1
43 Obsoletes:      libsndfile1
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 Libsndfile is a C library for reading and writing files containing
48 sampled sound (such as MS Windows WAV and the Apple/SGI AIFF format)
49 through one standard library interface.
50
51 %description -l pl.UTF-8
52 Libsndfile to biblioteką napisaną w C, służąca do czytania i
53 zapisywania plików zawierających zsamplowany dźwięk (np. w formacie MS
54 Windows WAV czy Apple/SGI AIFF) poprzez jednolity, standardowy
55 interfejs.
56
57 %package devel
58 Summary:        libsndfile header files and development documentation
59 Summary(pl.UTF-8):      Pliki nagłówkowe oraz dokumentacja do libsndfile
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       flac-devel >= 1.3.1
63 Requires:       lame-libs-devel
64 Requires:       libmpg123-devel >= 1.25.10
65 Requires:       libogg-devel >= 2:1.3.0
66 Requires:       libvorbis-devel >= 1:1.2.3
67 Requires:       opus-devel >= 1.1
68 Obsoletes:      libsndfile1-devel
69
70 %description devel
71 Header files and development documentation for libsndfile.
72
73 %description devel -l pl.UTF-8
74 Pliki nagłówkowe oraz dokumentacja do biblioteki libsndfile.
75
76 %package static
77 Summary:        libsndfile static libraries
78 Summary(pl.UTF-8):      Biblioteki statyczne libsndfile
79 Group:          Development/Libraries
80 Requires:       %{name}-devel = %{version}-%{release}
81
82 %description static
83 libsndfile static libraries.
84
85 %description static -l pl.UTF-8
86 Biblioteki statyczne libsndfile.
87
88 %package progs
89 Summary:        libsndfile utility programs
90 Summary(pl.UTF-8):      Narzędzia korzystające z biblioteki libsndfile
91 Group:          Applications/Sound
92 Requires:       %{name} = %{version}-%{release}
93
94 %description progs
95 libsndfile utility programs:
96 - sndfile-convert - convert a sound files from one format to another
97 - sndfile-info - display information about a sound file
98 - sndfile-play - play a sound file
99
100 %description progs -l pl.UTF-8
101 Narzędzia z biblioteki libsndfile:
102 - sndfile-convert - kowertertuje pliki dźwiękowe
103 - sndfile-info - wyświetla informacje o pliku dźwiękowym
104 - sndfile-play - odtwarza pliki dźwiękowe
105
106 %package -n octave-sndfile
107 Summary:        sndfile module for Octave
108 Summary(pl.UTF-8):      Moduł sndfile dla Octave
109 Group:          Applications/Math
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       octave >= 2:3
112 Obsoletes:      libsndfile-octave
113
114 %description -n octave-sndfile
115 A couple of script files for loading, saving, and playing sound files
116 from within Octave.
117
118 %description -n octave-sndfile -l pl.UTF-8
119 Kilka skryptów Octave do ładowania, zapisywania i odtwarzania plików
120 dźwiękowych.
121
122 %prep
123 %setup -q
124 %patch0 -p1
125
126 %if %{without tests}
127 %{__sed} -i 's, tests$,,' Makefile.am
128 %endif
129
130 %build
131 %{__libtoolize}
132 %{__aclocal} -I m4
133 %{__autoconf}
134 %{__autoheader}
135 %{__automake}
136 %configure \
137         %{!?with_octave:--disable-octave} \
138         --disable-silent-rules \
139         %{!?with_regtest:--disable-sqlite} \
140         %{?with_static_libs:--enable-static}
141
142 %{__make}
143
144 %{?with_tests:%{__make} test}
145
146 %install
147 rm -rf $RPM_BUILD_ROOT
148
149 %{__make} install \
150         DESTDIR=$RPM_BUILD_ROOT
151
152 # packaged as %doc
153 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/libsndfile
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post   -p /sbin/ldconfig
159 %postun -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc AUTHORS CHANGELOG.md ChangeLog NEWS.OLD README SECURITY.md
164 %attr(755,root,root) %{_libdir}/libsndfile.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libsndfile.so.1
166
167 %files devel
168 %defattr(644,root,root,755)
169 %doc docs/*
170 %attr(755,root,root) %{_libdir}/libsndfile.so
171 %{_libdir}/libsndfile.la
172 %{_includedir}/sndfile.h*
173 %{_pkgconfigdir}/sndfile.pc
174
175 %if %{with static_libs}
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libsndfile.a
179 %endif
180
181 %files progs
182 %defattr(644,root,root,755)
183 %attr(755,root,root) %{_bindir}/sndfile-*
184 %{_mandir}/man1/sndfile-*.1*
185
186 %if %{with octave}
187 %files -n octave-sndfile
188 %defattr(644,root,root,755)
189 %{_datadir}/octave/site/m/sndfile_*.m
190 %dir %{_libdir}/octave/*/site/oct/*/sndfile
191 %{_libdir}/octave/*/site/oct/*/sndfile/PKG_ADD
192 %attr(755,root,root) %{_libdir}/octave/*/site/oct/*/sndfile/sndfile.oct
193 %endif
This page took 0.096261 seconds and 3 git commands to generate.