]> git.pld-linux.org Git - packages/libsigc++.git/blob - libsigc++.spec
- spec adapterized.
[packages/libsigc++.git] / libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++
2 Name:           libsigc++
3 Version:        1.0.0
4 Release:        1
5 License:        LGPL
6 Group:          Libraries
7 Group(fr):      Librairies
8 Group(pl):      Biblioteki
9 Vendor:         Karl E. Nelson <kenelson@ece.ucdavis.edu>
10 Source0:        ftp://download.sourceforge.net/pub/sourceforge/libsigc/%name-%version.tar.gz
11 Patch0:         %{name}-ac_thread.sh.patch
12 URL:            http://libsigc.sourceforge.net/
13 BuildRequires:  libstdc++-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 This library implements a full callback system for use in widget
18 libraries, abstract interfaces, and general programming. Originally
19 part of the Gtk-- widget set, %name is now a seperate library to
20 provide for more general use. It is the most complete library of its
21 kind with the ablity to connect an abstract callback to a class
22 method, function, or function object. It contains adaptor classes for
23 connection of dissimilar callbacks and has an ease of use unmatched by
24 other C++ callback libraries.
25
26 %package devel
27 Summary:        development tools for the Typesafe Signal Framework for C++ 
28 Group:          Development/Libraries
29 Group(fr):      Development/Librairies
30 Group(pl):      Programowanie/Biblioteki
31 Requires:       m4
32 Requires:       %{name} = %{version}
33
34 %description devel
35 Development tools for the Typesafe Signal Framework for C++.
36
37 %package static
38 Summary:        Static Typesafe Signal Framework for C++ libraries
39 Group:          Development/Libraries
40 Group(fr):      Development/Librairies
41 Group(pl):      Programowanie/Biblioteki
42 Requires:       %{name}-devel = %{version}
43
44 %description static
45 Static Typesafe Signal Framework for C++ libraries.
46
47 %prep
48 %setup -q
49 %patch0 -p1
50
51 %build
52 autoconf
53 LDFLAGS="-s"
54 CXXFLAGS="$RPM_OPT_FLAGS -fno-exceptions"
55 export LDFLAGS CXXFLAGS
56 %configure
57
58 make
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 make install \
63         DESTDIR=$RPM_BUILD_ROOT \
64         m4datadir=%{_aclocaldir}
65
66 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
67
68 gzip -9nf AUTHORS README IDEAS NEWS ChangeLog TODO doc/*
69
70 %post   -p /sbin/ldconfig
71 %postun -p /sbin/ldconfig
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %attr(755,root,root) %{_libdir}/lib*.so.*.*
79
80 %files devel
81 %defattr(644,root,root,755)
82 %doc *.gz doc/*
83 %attr(755,root,root) %{_bindir}/sigc-config
84 %attr(755,root,root) %{_libdir}/lib*.so
85 %attr(755,root,root) %{_libdir}/lib*.la
86 %{_includedir}/sigc++
87 %{_libdir}/sigc++
88 %{_aclocaldir}/*
89
90 %files static
91 %defattr(644,root,root,755)
92 %{_libdir}/lib*.a
This page took 0.042932 seconds and 4 git commands to generate.