]> git.pld-linux.org Git - packages/libsigc++.git/blob - libsigc++.spec
- added libsigc++-ac_thread.sh.patch
[packages/libsigc++.git] / libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++
2 Name:           libsigc++
3 Version:        1.0.0
4 Release:        1
5 License:        LGPL
6 Group:          Libraries
7 Group(fr):      Librairies
8 Group(pl):      Biblioteki
9 Vendor:         Karl E. Nelson <kenelson@ece.ucdavis.edu>
10 Source0:        ftp://download.sourceforge.net/pub/sourceforge/libsigc/%name-%version.tar.gz
11 Patch0: %{name}-ac_thread.sh.patch
12 URL:            http://libsigc.sourceforge.net/
13 BuildRequires:  libstdc++-devel
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 This library implements a full callback system for use in widget libraries,
18 abstract interfaces, and general programming. Originally part of the Gtk--
19 widget set, %name is now a seperate library to provide for more general use. It
20 is the most complete library of its kind with the ablity to connect an abstract
21 callback to a class method, function, or function object. It contains adaptor
22 classes for connection of dissimilar callbacks and has an ease of use unmatched
23 by other C++ callback libraries.
24
25 %package devel
26 Summary:        development tools for the Typesafe Signal Framework for C++ 
27 Group:          Development/Libraries
28 Group(fr):      Development/Librairies
29 Group(pl):      Programowanie/Biblioteki
30 Requires:       m4
31 Requires:       %{name} = %{version}
32
33 %description devel
34 Development tools for the Typesafe Signal Framework for C++.
35
36 %package static
37 Summary:        Static Typesafe Signal Framework for C++ libraries
38 Group:          Development/Libraries
39 Group(fr):      Development/Librairies
40 Group(pl):      Programowanie/Biblioteki
41 Requires:       %{name}-devel = %{version}
42
43 %description static
44 Static Typesafe Signal Framework for C++ libraries.
45
46 %prep
47 %setup -q
48 %patch0 -p1
49
50 %build
51 autoconf
52 LDFLAGS="-s"
53 CXXFLAGS="$RPM_OPT_FLAGS -fno-rtti -fno-exceptions"
54 export LDFLAGS CXXFLAGS
55 %configure
56
57 make
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 make install \
62         DESTDIR=$RPM_BUILD_ROOT \
63         m4datadir=%{_aclocaldir}
64
65 strip --strip-unneeded $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*
66
67 gzip -9nf AUTHORS README IDEAS NEWS ChangeLog TODO doc/*
68
69 %post   -p /sbin/ldconfig
70 %postun -p /sbin/ldconfig
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %attr(755,root,root) %{_libdir}/lib*.so.*.*
78
79 %files devel
80 %defattr(644,root,root,755)
81 %doc *.gz doc/*
82 %attr(755,root,root) %{_bindir}/sigc-config
83 %attr(755,root,root) %{_libdir}/lib*.so
84 %attr(755,root,root) %{_libdir}/lib*.la
85 %{_includedir}/sigc++
86 %{_libdir}/sigc++
87 %{_aclocaldir}/*
88
89 %files static
90 %attr(644,root,root) %{_libdir}/lib*.a
This page took 0.031651 seconds and 4 git commands to generate.