]> git.pld-linux.org Git - packages/libsigc++.git/blob - libsigc++.spec
- updated to 2.2.6
[packages/libsigc++.git] / libsigc++.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        The Typesafe Signal Framework for C++
6 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++
7 Name:           libsigc++
8 Version:        2.2.6
9 Release:        1
10 Epoch:          1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/%{name}-%{version}.tar.bz2
14 # Source0-md5:  d216ef85785e0d17eda9b0326cfdcf71
15 URL:            http://libsigc.sourceforge.net/
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  libstdc++-devel
19 BuildRequires:  libtool
20 BuildRequires:  m4
21 BuildRequires:  mm-common >= 0.7.2
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig
24 Obsoletes:      libsigc++-examples
25 Conflicts:      libsigc++ < 1.1.0
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This library implements a full callback system for use in widget
30 libraries, abstract interfaces, and general programming. Originally
31 part of the Gtk-- widget set, libsigc++ is now a seperate library to
32 provide for more general use. It is the most complete library of its
33 kind with the ablity to connect an abstract callback to a class
34 method, function, or function object. It contains adaptor classes for
35 connection of dissimilar callbacks and has an ease of use unmatched by
36 other C++ callback libraries.
37
38 %description -l pl.UTF-8
39 Ta biblioteka jest implementacją pełnego systemu callbacków do
40 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
41 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
42 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
43 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
44 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
45 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
46 callbacków.
47
48 %package devel
49 Summary:        Development tools for the Typesafe Signal Framework for C++
50 Summary(pl.UTF-8):      Narzędzia programistyczne do środowiska libsig++
51 Group:          Development/Libraries
52 Requires:       %{name} = %{epoch}:%{version}-%{release}
53 Requires:       libstdc++-devel
54 Requires:       m4
55
56 %description devel
57 Development tools for the Typesafe Signal Framework for C++.
58
59 %description devel -l pl.UTF-8
60 Narzędzia programistyczne do środowiska libsigc++ - sygnałów z
61 kontrolą typów.
62
63 %package doc
64 Summary:        Reference documentation for libsigc++
65 Summary(pl.UTF-8):      Szczegółowa dokumentacja dla libsigc++
66 Group:          Documentation
67
68 %description doc
69 Reference documentation for libsigc++.
70
71 %description doc -l pl.UTF-8
72 Szczegółowa dokumentacja dla libsigc++.
73
74 %package static
75 Summary:        Static Typesafe Signal Framework for C++ libraries
76 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
79
80 %description static
81 Static Typesafe Signal Framework for C++ libraries.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka libsigc++ - środowiska sygnałów z kontrolą typów.
85
86 %prep
87 %setup -q
88
89 %build
90 %{__libtoolize}
91 %{__aclocal} -I build
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         %{?with_static_libs:--enable-static}
96 %{__make} -j1 all check
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files
111 %defattr(644,root,root,755)
112 %doc AUTHORS ChangeLog NEWS README TODO
113 %attr(755,root,root) %{_libdir}/libsigc-2.0.so.*.*.*
114 %attr(755,root,root) %ghost %{_libdir}/libsigc-2.0.so.0
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/libsigc-2.0.so
119 %{_libdir}/libsigc-2.0.la
120 %{_includedir}/sigc++-2.0
121 %{_libdir}/sigc++-2.0
122 %{_pkgconfigdir}/sigc++-2.0.pc
123
124 %if %{with static_libs}
125 %files static
126 %defattr(644,root,root,755)
127 %{_libdir}/libsigc-2.0.a
128 %endif
129
130 %files doc
131 %defattr(644,root,root,755)
132 %{_datadir}/devhelp/books/libsigc++-2.0
133 %{_docdir}/libsigc++-2.0
This page took 0.061454 seconds and 4 git commands to generate.