]> git.pld-linux.org Git - packages/libsigc++.git/blob - libsigc++.spec
- perl -pi -e "s/^automake -a -c$/automake -a -c -f/"
[packages/libsigc++.git] / libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++
2 Summary(pl):    ¦rodowisko sygna³ów z kontrol± typów dla C++
3 Name:           libsigc++
4 Version:        1.1.8
5 Release:        1
6 Epoch:          1
7 License:        LGPL
8 Vendor:         Karl E. Nelson <kenelson@ece.ucdavis.edu>
9 Group:          Libraries
10 Source0:        http://prdownloads.sourceforge.net/libsigc/%{name}-%{version}.tar.gz
11 URL:            http://libsigc.sourceforge.net/
12 BuildRequires:  autoconf
13 BuildRequires:  automake
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool
16 BuildRequires:  m4
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18 Obsoletes:      libsigc++-examples
19 Conflicts:      %{name} < 1.1.0
20
21 %description
22 This library implements a full callback system for use in widget
23 libraries, abstract interfaces, and general programming. Originally
24 part of the Gtk-- widget set, %{name} is now a seperate library to
25 provide for more general use. It is the most complete library of its
26 kind with the ablity to connect an abstract callback to a class
27 method, function, or function object. It contains adaptor classes for
28 connection of dissimilar callbacks and has an ease of use unmatched by
29 other C++ callback libraries.
30
31 %description -l pl
32 Ta biblioteka jest implementacj± pe³nego systemu callbacków do
33 u¿ywania w bibliotekach widgetów, interfejsach abstrakcyjnych i
34 ogólnym programowaniu. Oryginalnie by³a to czê¶æ zestawu widgetów
35 Gtk--, ale jest teraz oddzieln± bibliotek± ogólniejszego
36 przeznaczenia. Jest to kompletna biblioteka tego typu z mo¿liwo¶ci±
37 ³±czenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
38 obiektami funkcji. Zawiera klasy adapterów do ³±czenia ró¿nych
39 callbacków.
40
41 %package devel
42 Summary:        Development tools for the Typesafe Signal Framework for C++
43 Summary(pl):    Narzêdzia programistyczne do ¶rodowiska libsig++
44 Group:          Development/Libraries
45 Requires:       m4
46 Requires:       %{name} = %{version}
47
48 %description devel
49 Development tools for the Typesafe Signal Framework for C++.
50
51 %description devel -l pl
52 Narzêdzia programistyczne do ¶rodowiska libsigc++ - sygna³ów z
53 kontrol± typów.
54
55 %package static
56 Summary:        Static Typesafe Signal Framework for C++ libraries
57 Summary(pl):    Statyczna biblioteka libsigc++
58 Group:          Development/Libraries
59 Requires:       %{name}-devel = %{version}
60
61 %description static
62 Static Typesafe Signal Framework for C++ libraries.
63
64 %description static -l pl
65 Statyczna biblioteka libsigc++ - ¶rodowiska sygna³ów z kontrol± typów.
66
67 %prep
68 %setup -q
69
70 %build
71 CXXFLAGS="%{rpmcflags} -fno-exceptions"
72 rm -f scripts/missing
73 libtoolize --copy --force
74 aclocal
75 autoconf
76 automake -a -c -f
77 %configure
78
79 %{__make}
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT \
86         m4datadir=%{_aclocaldir}
87
88 gzip -9nf AUTHORS README IDEAS FEATURES NEWS ChangeLog TODO doc/*
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post   -p /sbin/ldconfig
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %attr(755,root,root) %{_libdir}/lib*.so.*.*
99
100 %files devel
101 %defattr(644,root,root,755)
102 %doc *.gz doc/*
103 %attr(755,root,root) %{_bindir}/sigc-config*
104 %attr(755,root,root) %{_libdir}/lib*.so
105 %attr(755,root,root) %{_libdir}/lib*.la
106 %{_includedir}/sigc++-*
107 %{_libdir}/sigc++-*
108 %{_pkgconfigdir}/*
109 %{_aclocaldir}/*
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/lib*.a
This page took 0.041577 seconds and 4 git commands to generate.