]> git.pld-linux.org Git - packages/libsigc++.git/blob - libsigc++.spec
- updated to 1.0.4,
[packages/libsigc++.git] / libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++
2 Name:           libsigc++
3 Version:        1.0.4
4 Release:        1
5 Epoch:          1
6 License:        LGPL
7 Vendor:         Karl E. Nelson <kenelson@ece.ucdavis.edu>
8 Group:          Libraries
9 Group(de):      Libraries
10 Group(fr):      Librairies
11 Group(pl):      Biblioteki
12 Source0:        ftp://download.sourceforge.net/pub/sourceforge/libsigc/%{name}-%{version}.tar.gz
13 Patch0:         %{name}-remove_stupid_install-data-hook_targets.patch
14 URL:            http://libsigc.sourceforge.net/
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  libstdc++-devel
18 BuildRequires:  libtool
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20 Obsoletes:      libsigc++-examples
21
22 %description
23 This library implements a full callback system for use in widget
24 libraries, abstract interfaces, and general programming. Originally
25 part of the Gtk-- widget set, %name is now a seperate library to
26 provide for more general use. It is the most complete library of its
27 kind with the ablity to connect an abstract callback to a class
28 method, function, or function object. It contains adaptor classes for
29 connection of dissimilar callbacks and has an ease of use unmatched by
30 other C++ callback libraries.
31
32 %package devel
33 Summary:        development tools for the Typesafe Signal Framework for C++ 
34 Group:          Development/Libraries
35 Group(de):      Entwicklung/Libraries
36 Group(fr):      Development/Librairies
37 Group(pl):      Programowanie/Biblioteki
38 Requires:       m4
39 Requires:       %{name} = %{version}
40
41 %description devel
42 Development tools for the Typesafe Signal Framework for C++.
43
44 %package static
45 Summary:        Static Typesafe Signal Framework for C++ libraries
46 Group:          Development/Libraries
47 Group(de):      Entwicklung/Libraries
48 Group(fr):      Development/Librairies
49 Group(pl):      Programowanie/Biblioteki
50 Requires:       %{name}-devel = %{version}
51
52 %description static
53 Static Typesafe Signal Framework for C++ libraries.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58
59 %build
60 CXXFLAGS="%{rpmcflags} -fno-exceptions"
61 rm -f scripts/missing
62 libtoolize --copy --force
63 aclocal
64 autoconf
65 automake -a -c
66 %configure
67
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 %{__make} install \
73         DESTDIR=$RPM_BUILD_ROOT \
74         m4datadir=%{_aclocaldir}
75
76 gzip -9nf AUTHORS README IDEAS NEWS ChangeLog TODO doc/*
77
78 %post   -p /sbin/ldconfig
79 %postun -p /sbin/ldconfig
80
81 %clean
82 rm -rf $RPM_BUILD_ROOT
83
84 %files
85 %defattr(644,root,root,755)
86 %attr(755,root,root) %{_libdir}/lib*.so.*.*
87
88 %files devel
89 %defattr(644,root,root,755)
90 %doc *.gz doc/*
91 %attr(755,root,root) %{_bindir}/sigc-config
92 %attr(755,root,root) %{_libdir}/lib*.so
93 %attr(755,root,root) %{_libdir}/lib*.la
94 %{_includedir}/sigc++-1.0
95 %{_libdir}/sigc++-1.0
96 %{_aclocaldir}/*
97
98 %files static
99 %defattr(644,root,root,755)
100 %{_libdir}/lib*.a
This page took 0.041529 seconds and 4 git commands to generate.