]> git.pld-linux.org Git - packages/libsigc++.git/blob - libsigc++.spec
- updated to 2.6.1; C++11 now
[packages/libsigc++.git] / libsigc++.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        The Typesafe Signal Framework for C++
6 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++
7 Name:           libsigc++
8 Version:        2.6.1
9 Release:        1
10 Epoch:          1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.6/%{name}-%{version}.tar.xz
14 # Source0-md5:  136bbdc53c538b5824eddfd2a7fe10db
15 URL:            http://libsigc.sourceforge.net/
16 BuildRequires:  autoconf >= 2.59
17 BuildRequires:  automake >= 1:1.9
18 BuildRequires:  libstdc++-devel >= 6:4.6
19 BuildRequires:  libtool >= 2:2.0
20 BuildRequires:  m4
21 BuildRequires:  mm-common >= 0.9.8
22 BuildRequires:  perl-base
23 BuildRequires:  pkgconfig
24 BuildRequires:  tar >= 1:1.22
25 BuildRequires:  xz
26 Obsoletes:      libsigc++-examples
27 Conflicts:      libsigc++ < 1.1.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This library implements a full callback system for use in widget
32 libraries, abstract interfaces, and general programming. Originally
33 part of the Gtk-- widget set, libsigc++ is now a seperate library to
34 provide for more general use. It is the most complete library of its
35 kind with the ablity to connect an abstract callback to a class
36 method, function, or function object. It contains adaptor classes for
37 connection of dissimilar callbacks and has an ease of use unmatched by
38 other C++ callback libraries.
39
40 %description -l pl.UTF-8
41 Ta biblioteka jest implementacją pełnego systemu callbacków do
42 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
43 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
44 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
45 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
46 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
47 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
48 callbacków.
49
50 %package devel
51 Summary:        Development tools for the Typesafe Signal Framework for C++
52 Summary(pl.UTF-8):      Narzędzia programistyczne do środowiska libsig++
53 Group:          Development/Libraries
54 Requires:       %{name} = %{epoch}:%{version}-%{release}
55 Requires:       libstdc++-devel >= 6:4.6
56 Requires:       m4
57
58 %description devel
59 Development tools for the Typesafe Signal Framework for C++.
60
61 %description devel -l pl.UTF-8
62 Narzędzia programistyczne do środowiska libsigc++ - sygnałów z
63 kontrolą typów.
64
65 %package static
66 Summary:        Static Typesafe Signal Framework for C++ libraries
67 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++
68 Group:          Development/Libraries
69 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
70
71 %description static
72 Static Typesafe Signal Framework for C++ libraries.
73
74 %description static -l pl.UTF-8
75 Statyczna biblioteka libsigc++ - środowiska sygnałów z kontrolą typów.
76
77 %package doc
78 Summary:        Reference documentation for libsigc++
79 Summary(pl.UTF-8):      Szczegółowa dokumentacja dla libsigc++
80 Group:          Documentation
81
82 %description doc
83 Reference documentation for libsigc++.
84
85 %description doc -l pl.UTF-8
86 Szczegółowa dokumentacja dla libsigc++.
87
88 %prep
89 %setup -q
90
91 %build
92 %{__libtoolize}
93 %{__aclocal} -I build
94 %{__autoconf}
95 %{__automake}
96 %configure \
97         %{?with_static_libs:--enable-static}
98 %{__make} -j1 all check
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 %{__make} install \
104         DESTDIR=$RPM_BUILD_ROOT
105
106 %clean
107 rm -rf $RPM_BUILD_ROOT
108
109 %post   -p /sbin/ldconfig
110 %postun -p /sbin/ldconfig
111
112 %files
113 %defattr(644,root,root,755)
114 %doc AUTHORS ChangeLog NEWS README
115 %attr(755,root,root) %{_libdir}/libsigc-2.0.so.*.*.*
116 %attr(755,root,root) %ghost %{_libdir}/libsigc-2.0.so.0
117
118 %files devel
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_libdir}/libsigc-2.0.so
121 %{_libdir}/libsigc-2.0.la
122 %{_includedir}/sigc++-2.0
123 %{_libdir}/sigc++-2.0
124 %{_pkgconfigdir}/sigc++-2.0.pc
125
126 %if %{with static_libs}
127 %files static
128 %defattr(644,root,root,755)
129 %{_libdir}/libsigc-2.0.a
130 %endif
131
132 %files doc
133 %defattr(644,root,root,755)
134 %{_datadir}/devhelp/books/libsigc++-2.0
135 %{_docdir}/libsigc++-2.0
This page took 0.037954 seconds and 3 git commands to generate.