]> git.pld-linux.org Git - packages/libsigc++.git/blob - libsigc++.spec
767776609696c5a9bfa0d6a3c075e9dbfcbce8c9
[packages/libsigc++.git] / libsigc++.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4 #
5 Summary:        The Typesafe Signal Framework for C++
6 Summary(pl.UTF-8):      Środowisko sygnałów z kontrolą typów dla C++
7 Name:           libsigc++
8 Version:        2.0.17
9 Release:        2
10 Epoch:          1
11 License:        LGPL
12 Vendor:         Karl E. Nelson <kenelson@ece.ucdavis.edu>
13 Group:          Libraries
14 Source0:        http://ftp.gnome.org/pub/gnome/sources/libsigc++/2.0/%{name}-%{version}.tar.bz2
15 # Source0-md5:  fde0ee69e3125e982746d9fe005763e1
16 URL:            http://libsigc.sourceforge.net/
17 BuildRequires:  autoconf >= 2.59
18 BuildRequires:  automake >= 1.9
19 BuildRequires:  libstdc++-devel
20 BuildRequires:  libtool
21 BuildRequires:  m4
22 BuildRequires:  perl-base
23 Obsoletes:      libsigc++-examples
24 Conflicts:      libsigc++ < 1.1.0
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This library implements a full callback system for use in widget
29 libraries, abstract interfaces, and general programming. Originally
30 part of the Gtk-- widget set, libsigc++ is now a seperate library to
31 provide for more general use. It is the most complete library of its
32 kind with the ablity to connect an abstract callback to a class
33 method, function, or function object. It contains adaptor classes for
34 connection of dissimilar callbacks and has an ease of use unmatched by
35 other C++ callback libraries.
36
37 %description -l pl.UTF-8
38 Ta biblioteka jest implementacją pełnego systemu callbacków do
39 używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
40 ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
41 Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
42 przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
43 łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
44 obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
45 callbacków.
46
47 %package devel
48 Summary:        Development tools for the Typesafe Signal Framework for C++
49 Summary(pl.UTF-8):      Narzędzia programistyczne do środowiska libsig++
50 Group:          Development/Libraries
51 Requires:       %{name} = %{epoch}:%{version}-%{release}
52 Requires:       libstdc++-devel
53 Requires:       m4
54
55 %description devel
56 Development tools for the Typesafe Signal Framework for C++.
57
58 %description devel -l pl.UTF-8
59 Narzędzia programistyczne do środowiska libsigc++ - sygnałów z
60 kontrolą typów.
61
62 %package doc
63 Summary:        Reference documentation for libsigc++
64 Summary(pl.UTF-8):      Szczegółowa dokumentacja dla libsigc++
65 Group:          Documentation
66
67 %description doc
68 Reference documentation for libsigc++.
69
70 %description doc -l pl.UTF-8
71 Szczegółowa dokumentacja dla libsigc++.
72
73 %package static
74 Summary:        Static Typesafe Signal Framework for C++ libraries
75 Summary(pl.UTF-8):      Statyczna biblioteka libsigc++
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
78
79 %description static
80 Static Typesafe Signal Framework for C++ libraries.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka libsigc++ - środowiska sygnałów z kontrolą typów.
84
85 %prep
86 %setup -q
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I scripts
91 %{__autoconf}
92 %{__automake}
93 %configure \
94         %{!?with_static_libs:--disable-static}
95 %{__make} all check
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 mv $RPM_BUILD_ROOT%{_docdir}/libsigc-2.0/docs devel-docs
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post   -p /sbin/ldconfig
109 %postun -p /sbin/ldconfig
110
111 %files
112 %defattr(644,root,root,755)
113 %doc AUTHORS ChangeLog NEWS README TODO
114 %attr(755,root,root) %{_libdir}/lib*.so.*.*
115
116 %files devel
117 %defattr(644,root,root,755)
118 %attr(755,root,root) %{_libdir}/lib*.so
119 %{_libdir}/lib*.la
120 %{_includedir}/sigc++-*
121 %{_libdir}/sigc++*
122 %{_pkgconfigdir}/*
123
124 %files doc
125 %defattr(644,root,root,755)
126 %doc devel-docs/*
127
128 %if %{with static_libs}
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/lib*.a
132 %endif
This page took 0.028456 seconds and 2 git commands to generate.