]> git.pld-linux.org Git - packages/libsigc++.git/blob - libsigc++.spec
- massive attack: no need for 755 for *.la
[packages/libsigc++.git] / libsigc++.spec
1 Summary:        The Typesafe Signal Framework for C++
2 Summary(pl):    ¦rodowisko sygna³ów z kontrol± typów dla C++
3 Name:           libsigc++
4 Version:        1.2.1
5 Release:        1
6 Epoch:          1
7 License:        LGPL
8 Vendor:         Karl E. Nelson <kenelson@ece.ucdavis.edu>
9 Group:          Libraries
10 Source0:        http://prdownloads.sourceforge.net/libsigc/%{name}-%{version}.tar.gz
11 Patch0:         %{name}-m4.patch
12 URL:            http://libsigc.sourceforge.net/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool
17 BuildRequires:  m4
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19 Obsoletes:      libsigc++-examples
20 Conflicts:      %{name} < 1.1.0
21
22 %description
23 This library implements a full callback system for use in widget
24 libraries, abstract interfaces, and general programming. Originally
25 part of the Gtk-- widget set, %{name} is now a seperate library to
26 provide for more general use. It is the most complete library of its
27 kind with the ablity to connect an abstract callback to a class
28 method, function, or function object. It contains adaptor classes for
29 connection of dissimilar callbacks and has an ease of use unmatched by
30 other C++ callback libraries.
31
32 %description -l pl
33 Ta biblioteka jest implementacj± pe³nego systemu callbacków do
34 u¿ywania w bibliotekach widgetów, interfejsach abstrakcyjnych i
35 ogólnym programowaniu. Oryginalnie by³a to czê¶æ zestawu widgetów
36 Gtk--, ale jest teraz oddzieln± bibliotek± ogólniejszego
37 przeznaczenia. Jest to kompletna biblioteka tego typu z mo¿liwo¶ci±
38 ³±czenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
39 obiektami funkcji. Zawiera klasy adapterów do ³±czenia ró¿nych
40 callbacków.
41
42 %package devel
43 Summary:        Development tools for the Typesafe Signal Framework for C++
44 Summary(pl):    Narzêdzia programistyczne do ¶rodowiska libsig++
45 Group:          Development/Libraries
46 Requires:       m4
47 Requires:       %{name} = %{version}
48
49 %description devel
50 Development tools for the Typesafe Signal Framework for C++.
51
52 %description devel -l pl
53 Narzêdzia programistyczne do ¶rodowiska libsigc++ - sygna³ów z
54 kontrol± typów.
55
56 %package static
57 Summary:        Static Typesafe Signal Framework for C++ libraries
58 Summary(pl):    Statyczna biblioteka libsigc++
59 Group:          Development/Libraries
60 Requires:       %{name}-devel = %{version}
61
62 %description static
63 Static Typesafe Signal Framework for C++ libraries.
64
65 %description static -l pl
66 Statyczna biblioteka libsigc++ - ¶rodowiska sygna³ów z kontrol± typów.
67
68 %prep
69 %setup -q
70 %patch0 -p1
71
72 %build
73 CXXFLAGS="%{rpmcflags} -fno-exceptions"
74 rm -f scripts/missing
75 %{__libtoolize}
76 %{__aclocal}
77 %{__autoconf}
78 %{__automake}
79 %configure
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %post   -p /sbin/ldconfig
93 %postun -p /sbin/ldconfig
94
95 %files
96 %defattr(644,root,root,755)
97 %attr(755,root,root) %{_libdir}/lib*.so.*.*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %doc AUTHORS README IDEAS FEATURES NEWS ChangeLog TODO doc/*
102 %attr(755,root,root) %{_libdir}/lib*.so
103 %{_libdir}/lib*.la
104 %{_includedir}/sigc++-*
105 %{_libdir}/sigc++-*
106 %{_pkgconfigdir}/*
107
108 %files static
109 %defattr(644,root,root,755)
110 %{_libdir}/lib*.a
This page took 0.077433 seconds and 3 git commands to generate.