]> git.pld-linux.org Git - packages/libseccomp.git/blob - libseccomp.spec
cleanup (now unneccessary) bash dep
[packages/libseccomp.git] / libseccomp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests
4 %bcond_without  static_libs     # don't build static libraries
5 %bcond_with     python          # build Python bindings
6
7 Summary:        Enhanced Seccomp (mode 2) Helper library
8 Summary(pl.UTF-8):      Rozszerzona biblioteka pomocnicza Seccomp (trybu 2)
9 Name:           libseccomp
10 Version:        2.2.3
11 Release:        1
12 License:        LGPL v2.1
13 Group:          Libraries
14 Source0:        https://github.com/seccomp/libseccomp/releases/download/v%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  7db418d35d7a6168400bf6b05502f8bf
16 URL:            https://github.com/seccomp/libseccomp
17 BuildRequires:  pkgconfig
18 %if %{with python}
19 BuildRequires:  python-Cython >= 0.16
20 %endif
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The libseccomp library provides and easy to use, platform independent,
25 interface to the Linux Kernel's syscall filtering mechanism: seccomp.
26 The libseccomp API is designed to abstract away the underlying BPF
27 based syscall filter language and present a more conventional
28 function-call based filtering interface that should be familiar to,
29 and easily adopted by application developers.
30
31 %description -l pl.UTF-8
32 Biblioteka libseccomp udostępnia łatwy w użyciu, niezależny od
33 platformy interfejs do mechanizmu filtrowania wywołań systemowych
34 jądra Linuksa - seccomp. API libseccomp jest zaprojektowane tak, żeby
35 wyabstrahować język filtrowania wywołań BPF niższego poziomu i
36 zaprezentować bardziej konwencjonalny interfejs filtrowania w oparciu
37 o wywołania funkcji, który powinien być bardziej przyjazny i łatwiej
38 adaptowalny dla programistów aplikacji.
39
40 %package devel
41 Summary:        Header files for Seccomp library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Seccomp
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45
46 %description devel
47 Header files for Seccomp library.
48
49 %description devel -l pl.UTF-8
50 Pliki nagłówkowe biblioteki Seccomp.
51
52 %package static
53 Summary:        Static Seccomp library
54 Summary(pl.UTF-8):      Statyczna biblioteka Seccomp
55 Group:          Development/Libraries
56 Requires:       %{name}-devel = %{version}-%{release}
57
58 %description static
59 Static Seccomp library.
60
61 %description static -l pl.UTF-8
62 Statyczna biblioteka Seccomp.
63
64 %prep
65 %setup -q
66
67 %build
68 %configure \
69         --disable-silent-rules \
70         %{?with_python:--enable-python} \
71         %{!?with_static_libs:--disable-static}
72 %{__make}
73
74 %{?with_tests:%{__make} check}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 # obsoleted by pkg-config file
82 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libseccomp.la
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc CHANGELOG CREDITS README
93 %attr(755,root,root) %{_bindir}/scmp_sys_resolver
94 %attr(755,root,root) %{_libdir}/libseccomp.so.*.*.*
95 %attr(755,root,root) %ghost %{_libdir}/libseccomp.so.2
96 %{_mandir}/man1/scmp_sys_resolver.1*
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/libseccomp.so
101 %{_includedir}/seccomp.h
102 %{_pkgconfigdir}/libseccomp.pc
103 %{_mandir}/man3/seccomp_*.3*
104
105 %if %{with static_libs}
106 %files static
107 %defattr(644,root,root,755)
108 %{_libdir}/libseccomp.a
109 %endif
This page took 0.206887 seconds and 4 git commands to generate.