]> git.pld-linux.org Git - packages/libseccomp.git/blob - libseccomp.spec
- run testsuite
[packages/libseccomp.git] / libseccomp.spec
1 #
2 %bcond_without  tests
3 #
4 Summary:        Enhanced Seccomp (mode 2) Helper library
5 Summary(pl.UTF-8):      Rozszerzona biblioteka pomocnicza Seccomp (trybu 2)
6 Name:           libseccomp
7 Version:        2.1.1
8 Release:        1
9 License:        LGPL v2.1
10 Group:          Libraries
11 Source0:        http://downloads.sourceforge.net/libseccomp/%{name}-%{version}.tar.gz
12 # Source0-md5:  1f41207b29e66a7e5e375dd48a64de85
13 Patch0:         %{name}-pc.patch
14 URL:            http://libseccomp.sourceforge.net/
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 The libseccomp library provides and easy to use, platform independent,
19 interface to the Linux Kernel's syscall filtering mechanism: seccomp.
20 The libseccomp API is designed to abstract away the underlying BPF
21 based syscall filter language and present a more conventional
22 function-call based filtering interface that should be familiar to,
23 and easily adopted by application developers.
24
25 %description -l pl.UTF-8
26 Biblioteka libseccomp udostępnia łatwy w użyciu, niezależny od
27 platformy interfejs do mechanizmu filtrowania wywołań systemowych
28 jądra Linuksa - seccomp. API libseccomp jest zaprojektowane tak,
29 żeby wyabstrahować język filtrowania wywołań BPF niższego poziomu i
30 zaprezentować bardziej konwencjonalny interfejs filtrowania w oparciu
31 o wywołania funkcji, który powinien być bardziej przyjazny i łatwiej
32 adaptowalny dla programistów aplikacji.
33
34 %package devel
35 Summary:        Header files for Seccomp library
36 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Seccomp
37 Group:          Development/Libraries
38 Requires:       %{name} = %{version}-%{release}
39
40 %description devel
41 Header files for Seccomp library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki Seccomp.
45
46 %package static
47 Summary:        Static Seccomp library
48 Summary(pl.UTF-8):      Statyczna biblioteka Seccomp
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static Seccomp library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka Seccomp.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 %build
63 # not autoconf configure
64 ./configure \
65         --prefix=%{_prefix} \
66         --libdir=%{_libdir}
67
68 GCC="%{__cc}" \
69 CFLAGS="%{rpmcflags} -Wall" \
70 %{__make} \
71         V=1
72
73 %{?with_tests:%{__make} check V=1}
74
75 %install
76 rm -rf $RPM_BUILD_ROOT
77
78 %{__make} install \
79         DESTDIR=$RPM_BUILD_ROOT
80
81 install src/libseccomp.a $RPM_BUILD_ROOT%{_libdir}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc CHANGELOG CREDITS README
92 %attr(755,root,root) %{_bindir}/scmp_sys_resolver
93 %attr(755,root,root) %{_libdir}/libseccomp.so.*.*.*
94 %attr(755,root,root) %ghost %{_libdir}/libseccomp.so.2
95 %{_mandir}/man1/scmp_sys_resolver.1*
96
97 %files devel
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_libdir}/libseccomp.so
100 %{_includedir}/seccomp.h
101 %{_pkgconfigdir}/libseccomp.pc
102 %{_mandir}/man3/seccomp_*.3*
103
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/libseccomp.a
This page took 0.115994 seconds and 4 git commands to generate.