]> git.pld-linux.org Git - packages/libseccomp.git/blob - libseccomp.spec
up to 2.2.3
[packages/libseccomp.git] / libseccomp.spec
1 #
2 # Conditional build:
3 %bcond_without  tests
4 %bcond_without  static_libs     # don't build static libraries
5
6 Summary:        Enhanced Seccomp (mode 2) Helper library
7 Summary(pl.UTF-8):      Rozszerzona biblioteka pomocnicza Seccomp (trybu 2)
8 Name:           libseccomp
9 Version:        2.2.3
10 Release:        1
11 License:        LGPL v2.1
12 Group:          Libraries
13 Source0:        https://github.com/seccomp/libseccomp/releases/download/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  7db418d35d7a6168400bf6b05502f8bf
15 URL:            https://github.com/seccomp/libseccomp
16 BuildRequires:  bash
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The libseccomp library provides and easy to use, platform independent,
21 interface to the Linux Kernel's syscall filtering mechanism: seccomp.
22 The libseccomp API is designed to abstract away the underlying BPF
23 based syscall filter language and present a more conventional
24 function-call based filtering interface that should be familiar to,
25 and easily adopted by application developers.
26
27 %description -l pl.UTF-8
28 Biblioteka libseccomp udostępnia łatwy w użyciu, niezależny od
29 platformy interfejs do mechanizmu filtrowania wywołań systemowych
30 jądra Linuksa - seccomp. API libseccomp jest zaprojektowane tak, żeby
31 wyabstrahować język filtrowania wywołań BPF niższego poziomu i
32 zaprezentować bardziej konwencjonalny interfejs filtrowania w oparciu
33 o wywołania funkcji, który powinien być bardziej przyjazny i łatwiej
34 adaptowalny dla programistów aplikacji.
35
36 %package devel
37 Summary:        Header files for Seccomp library
38 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Seccomp
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Header files for Seccomp library.
44
45 %description devel -l pl.UTF-8
46 Pliki nagłówkowe biblioteki Seccomp.
47
48 %package static
49 Summary:        Static Seccomp library
50 Summary(pl.UTF-8):      Statyczna biblioteka Seccomp
51 Group:          Development/Libraries
52 Requires:       %{name}-devel = %{version}-%{release}
53
54 %description static
55 Static Seccomp library.
56
57 %description static -l pl.UTF-8
58 Statyczna biblioteka Seccomp.
59
60 %prep
61 %setup -q
62
63 %build
64 %configure \
65         --disable-silent-rules \
66         %{!?with_static_libs:--disable-static}
67 %{__make}
68
69 %{?with_tests:%{__make} check}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 # obsoleted by pkg-config file
77 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libseccomp.la
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files
86 %defattr(644,root,root,755)
87 %doc CHANGELOG CREDITS README
88 %attr(755,root,root) %{_bindir}/scmp_sys_resolver
89 %attr(755,root,root) %{_libdir}/libseccomp.so.*.*.*
90 %attr(755,root,root) %ghost %{_libdir}/libseccomp.so.2
91 %{_mandir}/man1/scmp_sys_resolver.1*
92
93 %files devel
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{_libdir}/libseccomp.so
96 %{_includedir}/seccomp.h
97 %{_pkgconfigdir}/libseccomp.pc
98 %{_mandir}/man3/seccomp_*.3*
99
100 %if %{with static_libs}
101 %files static
102 %defattr(644,root,root,755)
103 %{_libdir}/libseccomp.a
104 %endif
This page took 0.049881 seconds and 4 git commands to generate.