]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
- without gtk3 bcond
[packages/librsvg.git] / librsvg.spec
1 #
2 # TODO: - separate libs subpackage, current scheme conflicts on multilib
3 # shouldn't be a problem:
4 # - rsvg script doesn't differ
5 # - rsvg-{convert,view} are ELF binaries with proper colors in rpm, so should be handled properly
6 #
7 # Conditional build
8 %bcond_without  apidocs         # disable gtk-doc
9 %bcond_without  gtk3            # disable gtk+3
10 %bcond_without  libgsf          # build without libgsf (used for run-time decompression)
11 %bcond_without  libcroco        # build without CSS support through libcroco
12 %bcond_without  static_libs     # don't build static library
13 #
14 Summary:        A Raph's Library for Rendering SVG Data
15 Summary(pl.UTF-8):      Biblioteka Raph's SVG do renderowania danych SVG
16 Summary(pt_BR.UTF-8):   Biblioteca SVG
17 Summary(ru.UTF-8):      SVG библиотека
18 Summary(uk.UTF-8):      SVG бібліотека
19 Name:           librsvg
20 Version:        2.34.0
21 Release:        1
22 Epoch:          1
23 License:        LGPL v2+
24 Group:          X11/Libraries
25 Source0:        http://ftp.gnome.org/pub/GNOME/sources/librsvg/2.34/%{name}-%{version}.tar.bz2
26 # Source0-md5:  5eb2fcd0765aa5e47a4999985e3c27ab
27 URL:            http://librsvg.sourceforge.net/
28 BuildRequires:  autoconf
29 BuildRequires:  automake >= 1:1.9
30 BuildRequires:  docbook-dtd412-xml
31 BuildRequires:  gdk-pixbuf2-devel >= 2.0
32 BuildRequires:  glib2-devel >= 1:2.24.0
33 BuildRequires:  gtk+2-devel >= 2:2.16.0
34 %{?with_gtk3:BuildRequires:     gtk+3-devel >= 3.0.0}
35 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.13}
36 %{?with_apidocs:BuildRequires:  gtk-doc-automake}
37 %{?with_libcroco:BuildRequires: libcroco-devel >= 0.6.1}
38 %{?with_libgsf:BuildRequires:   libgsf-devel >= 1.14.4}
39 BuildRequires:  libtool
40 BuildRequires:  libxml2-devel >= 1:2.6.31
41 BuildRequires:  pkgconfig
42 BuildRequires:  rpm-pythonprov
43 BuildRequires:  sed >= 4.0
44 Requires(post,postun):  /sbin/ldconfig
45 Requires(post,postun):  gdk-pixbuf2
46 Requires:       gdk-pixbuf2 >= 2.0
47 Requires:       glib2 >= 1:2.24.0
48 Requires:       gtk+2 >= 2:2.16.0
49 %{?with_gtk3:Requires:  gtk+3 >= 3.0.0}
50 %{?with_libcroco:Requires:      libcroco >= 0.6.1}
51 %{?with_libgsf:Requires:        libgsf >= 1.14.4}
52 Requires:       libxml2 >= 1:2.6.31
53 Obsoletes:      browser-plugin-librsvg
54 Obsoletes:      librsvg0
55 Obsoletes:      mozilla-plugin-rsvg
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 # see gtk+2.spec for source of these ifdefs
59 %if "%{_lib}" != "lib"
60 %define         libext          %(lib="%{_lib}"; echo ${lib#lib})
61 %define         pqext           -%{libext}
62 %else
63 %define         pqext           %{nil}
64 %endif
65
66 %description
67 An library to render SVG (scalable vector graphics), databased upon
68 libart.
69
70 %description -l pl.UTF-8
71 Biblioteka do renderowania SVG (skalowalnej grafiki wektorowej) oparta
72 na kodzie libart.
73
74 %description -l ru.UTF-8
75 Библиотека SVG, базирующаяся на libart.
76
77 %description -l uk.UTF-8
78 Бібліотека SVG, базована на libart.
79
80 %package devel
81 Summary:        Include files for developing with librsvg
82 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia oprogramowania z użyciem librsvg
83 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
84 Summary(ru.UTF-8):      Библиотечные линки и файлы заголовков для разработки с librsvg
85 Summary(uk.UTF-8):      Бібліотечні лінки та файли заголовків для розробки з librsvg
86 Group:          X11/Development/Libraries
87 Requires:       %{name} = %{epoch}:%{version}-%{release}
88 Requires:       glib2-devel >= 1:2.24.0
89 Requires:       gdk-pixbuf2-devel >= 2.0
90 Requires:       gtk+2-devel >= 2:2.16.0
91 %{?with_libcroco:Requires:      libcroco-devel >= 0.6.1}
92 %{?with_libgsf:Requires:        libgsf-devel >= 1.14.4}
93 Requires:       libxml2-devel >= 1:2.6.31
94 Obsoletes:      librsvg0-devel
95
96 %description devel
97 This package provides the necessary development libraries and include
98 files to allow you to develop with librsvg.
99
100 %description devel -l pl.UTF-8
101 Pakiet zawiera pliki nagłówkowe potrzebne do tworzenia oprogramowania
102 z wykorzystaniem librsvg.
103
104 %description devel -l pt_BR.UTF-8
105 Este pacote contém os arquivos necessários para desenvolver com base
106 na biblioteca librsvg.
107
108 %description devel -l ru.UTF-8
109 Этот пакет содержит необходимые файлы для разработки программ с
110 использованием librsvg.
111
112 %description devel -l uk.UTF-8
113 Цей пакет містить необхідні файли для розробки програм з використанням
114 librsvg.
115
116 %package static
117 Summary:        Static libraries for developing with librsvg
118 Summary(es.UTF-8):      Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
119 Summary(pl.UTF-8):      Statyczne biblioteki librsvg
120 Summary(pt_BR.UTF-8):   Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
121 Group:          X11/Development/Libraries
122 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
123
124 %description static
125 This package contains static version of librsvg libraries.
126
127 %description static -l pl.UTF-8
128 Statyczna wersja bibliotek librsvg.
129
130 %description static -l pt_BR.UTF-8
131 Bibliotecas estáticas para o desenvolvimento de aplicações com
132 librsvg.
133
134 %package apidocs
135 Summary:        librsvg API documentation
136 Summary(pl.UTF-8):      Dokumentacja API biblioteki librsvg
137 Group:          Documentation
138 Requires:       gtk-doc-common
139
140 %description apidocs
141 librsvg API documentation.
142
143 %description apidocs -l pl.UTF-8
144 Dokumentacja API biblioteki librsvg.
145
146 %prep
147 %setup -q
148
149 %if !%{with apidocs}
150 echo 'CLEANFILES=' > gtk-doc.make
151 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
152 %endif
153
154 %{__sed} -e 's/gdk-pixbuf-query-loaders/gdk-pixbuf-query-loaders%{pqext}/' -i configure.in
155
156 %build
157 %{?with_apidocs:%{__gtkdocize}}
158 %{__libtoolize}
159 %{__aclocal}
160 %{__autoconf}
161 %{__autoheader}
162 %{__automake}
163 %configure \
164         --disable-silent-rules \
165         %{!?with_static_libs:--disable-static} \
166         %{?with_apidocs:--enable-gtk-doc} \
167         %{!?with_libcroco:--without-croco} \
168         %{!?with_libgsf:--without-svgz} \
169         --with-html-dir=%{_gtkdocdir}/%{name}
170 %{__make}
171
172 %install
173 rm -rf $RPM_BUILD_ROOT
174
175 %{__make} install \
176         DESTDIR=$RPM_BUILD_ROOT \
177         pkgconfigdir=%{_pkgconfigdir}
178
179 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/engines/*.{la,a}
180 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/*.{la,a}
181 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librsvg-2.la
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post
187 /sbin/ldconfig
188 umask 022
189 %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache || :
190
191 %postun
192 /sbin/ldconfig
193 umask 022
194 if [ -x %{_bindir}/gdk-pixbuf-query-loaders%{pqext} ]; then
195         %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache
196 fi
197
198 %files
199 %defattr(644,root,root,755)
200 %doc ChangeLog AUTHORS NEWS
201 %attr(755,root,root) %{_bindir}/rsvg
202 %attr(755,root,root) %{_bindir}/rsvg-convert
203 %{?with_gtk3:%attr(755,root,root) %{_bindir}/rsvg-view-3}
204 %attr(755,root,root) %{_bindir}/rsvg-view
205 %attr(755,root,root) %{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/libpixbufloader-svg.so
206 %attr(755,root,root) %{_libdir}/gtk-2.0/2.*/engines/libsvg.so
207 %attr(755,root,root) %{_libdir}/librsvg-2.so.*.*.*
208 %attr(755,root,root) %ghost %{_libdir}/librsvg-2.so.2
209 %{_datadir}/themes/bubble
210 %{_mandir}/man1/rsvg.1*
211 %{_pixmapsdir}/svg-viewer.svg
212
213 %files devel
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_libdir}/librsvg-2.so
216 %{_pkgconfigdir}/librsvg-2.0.pc
217 %{_includedir}/librsvg-2.0
218
219 %if %{with static_libs}
220 %files static
221 %defattr(644,root,root,755)
222 %{_libdir}/librsvg-2.a
223 %endif
224
225 %if %{with apidocs}
226 %files apidocs
227 %defattr(644,root,root,755)
228 %{_gtkdocdir}/%{name}
229 %endif
This page took 0.047691 seconds and 4 git commands to generate.