]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
- updated to 2.34.0
[packages/librsvg.git] / librsvg.spec
1 #
2 # TODO: - separate libs subpackage, current scheme conflicts on multilib
3 # shouldn't be a problem:
4 # - rsvg script doesn't differ
5 # - rsvg-{convert,view} are ELF binaries with proper colors in rpm, so should be handled properly
6 #
7 # Conditional build
8 %bcond_without  apidocs         # disable gtk-doc
9 %bcond_without  libgsf          # build without libgsf (used for run-time decompression)
10 %bcond_without  libcroco        # build without CSS support through libcroco
11 %bcond_without  static_libs     # don't build static library
12 #
13 Summary:        A Raph's Library for Rendering SVG Data
14 Summary(pl.UTF-8):      Biblioteka Raph's SVG do renderowania danych SVG
15 Summary(pt_BR.UTF-8):   Biblioteca SVG
16 Summary(ru.UTF-8):      SVG библиотека
17 Summary(uk.UTF-8):      SVG бібліотека
18 Name:           librsvg
19 Version:        2.34.0
20 Release:        1
21 Epoch:          1
22 License:        LGPL v2+
23 Group:          X11/Libraries
24 Source0:        http://ftp.gnome.org/pub/GNOME/sources/librsvg/2.34/%{name}-%{version}.tar.bz2
25 # Source0-md5:  5eb2fcd0765aa5e47a4999985e3c27ab
26 URL:            http://librsvg.sourceforge.net/
27 BuildRequires:  autoconf
28 BuildRequires:  automake >= 1:1.9
29 BuildRequires:  docbook-dtd412-xml
30 BuildRequires:  gdk-pixbuf2-devel >= 2.0
31 BuildRequires:  glib2-devel >= 1:2.24.0
32 BuildRequires:  gtk+2-devel >= 2:2.16.0
33 BuildRequires:  gtk+3-devel >= 3.0.0
34 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.13}
35 %{?with_apidocs:BuildRequires:  gtk-doc-automake}
36 %{?with_libcroco:BuildRequires: libcroco-devel >= 0.6.1}
37 %{?with_libgsf:BuildRequires:   libgsf-devel >= 1.14.4}
38 BuildRequires:  libtool
39 BuildRequires:  libxml2-devel >= 1:2.6.31
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  sed >= 4.0
43 Requires(post,postun):  /sbin/ldconfig
44 Requires(post,postun):  gdk-pixbuf2
45 Requires:       gdk-pixbuf2 >= 2.0
46 Requires:       glib2 >= 1:2.24.0
47 Requires:       gtk+2 >= 2:2.16.0
48 Requires:       gtk+3 >= 3.0.0
49 %{?with_libcroco:Requires:      libcroco >= 0.6.1}
50 %{?with_libgsf:Requires:        libgsf >= 1.14.4}
51 Requires:       libxml2 >= 1:2.6.31
52 Obsoletes:      browser-plugin-librsvg
53 Obsoletes:      librsvg0
54 Obsoletes:      mozilla-plugin-rsvg
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 # see gtk+2.spec for source of these ifdefs
58 %if "%{_lib}" != "lib"
59 %define         libext          %(lib="%{_lib}"; echo ${lib#lib})
60 %define         pqext           -%{libext}
61 %else
62 %define         pqext           %{nil}
63 %endif
64
65 %description
66 An library to render SVG (scalable vector graphics), databased upon
67 libart.
68
69 %description -l pl.UTF-8
70 Biblioteka do renderowania SVG (skalowalnej grafiki wektorowej) oparta
71 na kodzie libart.
72
73 %description -l ru.UTF-8
74 Библиотека SVG, базирующаяся на libart.
75
76 %description -l uk.UTF-8
77 Бібліотека SVG, базована на libart.
78
79 %package devel
80 Summary:        Include files for developing with librsvg
81 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia oprogramowania z użyciem librsvg
82 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
83 Summary(ru.UTF-8):      Библиотечные линки и файлы заголовков для разработки с librsvg
84 Summary(uk.UTF-8):      Бібліотечні лінки та файли заголовків для розробки з librsvg
85 Group:          X11/Development/Libraries
86 Requires:       %{name} = %{epoch}:%{version}-%{release}
87 Requires:       glib2-devel >= 1:2.24.0
88 Requires:       gdk-pixbuf2-devel >= 2.0
89 Requires:       gtk+2-devel >= 2:2.16.0
90 %{?with_libcroco:Requires:      libcroco-devel >= 0.6.1}
91 %{?with_libgsf:Requires:        libgsf-devel >= 1.14.4}
92 Requires:       libxml2-devel >= 1:2.6.31
93 Obsoletes:      librsvg0-devel
94
95 %description devel
96 This package provides the necessary development libraries and include
97 files to allow you to develop with librsvg.
98
99 %description devel -l pl.UTF-8
100 Pakiet zawiera pliki nagłówkowe potrzebne do tworzenia oprogramowania
101 z wykorzystaniem librsvg.
102
103 %description devel -l pt_BR.UTF-8
104 Este pacote contém os arquivos necessários para desenvolver com base
105 na biblioteca librsvg.
106
107 %description devel -l ru.UTF-8
108 Этот пакет содержит необходимые файлы для разработки программ с
109 использованием librsvg.
110
111 %description devel -l uk.UTF-8
112 Цей пакет містить необхідні файли для розробки програм з використанням
113 librsvg.
114
115 %package static
116 Summary:        Static libraries for developing with librsvg
117 Summary(es.UTF-8):      Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
118 Summary(pl.UTF-8):      Statyczne biblioteki librsvg
119 Summary(pt_BR.UTF-8):   Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
120 Group:          X11/Development/Libraries
121 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
122
123 %description static
124 This package contains static version of librsvg libraries.
125
126 %description static -l pl.UTF-8
127 Statyczna wersja bibliotek librsvg.
128
129 %description static -l pt_BR.UTF-8
130 Bibliotecas estáticas para o desenvolvimento de aplicações com
131 librsvg.
132
133 %package apidocs
134 Summary:        librsvg API documentation
135 Summary(pl.UTF-8):      Dokumentacja API biblioteki librsvg
136 Group:          Documentation
137 Requires:       gtk-doc-common
138
139 %description apidocs
140 librsvg API documentation.
141
142 %description apidocs -l pl.UTF-8
143 Dokumentacja API biblioteki librsvg.
144
145 %prep
146 %setup -q
147
148 %if !%{with apidocs}
149 echo 'CLEANFILES=' > gtk-doc.make
150 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
151 %endif
152
153 %{__sed} -e 's/gdk-pixbuf-query-loaders/gdk-pixbuf-query-loaders%{pqext}/' -i configure.in
154
155 %build
156 %{?with_apidocs:%{__gtkdocize}}
157 %{__libtoolize}
158 %{__aclocal}
159 %{__autoconf}
160 %{__autoheader}
161 %{__automake}
162 %configure \
163         --disable-silent-rules \
164         %{!?with_static_libs:--disable-static} \
165         %{?with_apidocs:--enable-gtk-doc} \
166         %{!?with_libcroco:--without-croco} \
167         %{!?with_libgsf:--without-svgz} \
168         --with-html-dir=%{_gtkdocdir}/%{name}
169 %{__make}
170
171 %install
172 rm -rf $RPM_BUILD_ROOT
173
174 %{__make} install \
175         DESTDIR=$RPM_BUILD_ROOT \
176         pkgconfigdir=%{_pkgconfigdir}
177
178 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/engines/*.{la,a}
179 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/*.{la,a}
180 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librsvg-2.la
181
182 %clean
183 rm -rf $RPM_BUILD_ROOT
184
185 %post
186 /sbin/ldconfig
187 umask 022
188 %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache || :
189
190 %postun
191 /sbin/ldconfig
192 umask 022
193 if [ -x %{_bindir}/gdk-pixbuf-query-loaders%{pqext} ]; then
194         %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache
195 fi
196
197 %files
198 %defattr(644,root,root,755)
199 %doc ChangeLog AUTHORS NEWS
200 %attr(755,root,root) %{_bindir}/rsvg
201 %attr(755,root,root) %{_bindir}/rsvg-convert
202 %attr(755,root,root) %{_bindir}/rsvg-view-3
203 %attr(755,root,root) %{_bindir}/rsvg-view
204 %attr(755,root,root) %{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/libpixbufloader-svg.so
205 %attr(755,root,root) %{_libdir}/gtk-2.0/2.*/engines/libsvg.so
206 %attr(755,root,root) %{_libdir}/librsvg-2.so.*.*.*
207 %attr(755,root,root) %ghost %{_libdir}/librsvg-2.so.2
208 %{_datadir}/themes/bubble
209 %{_mandir}/man1/rsvg.1*
210 %{_pixmapsdir}/svg-viewer.svg
211
212 %files devel
213 %defattr(644,root,root,755)
214 %attr(755,root,root) %{_libdir}/librsvg-2.so
215 %{_pkgconfigdir}/librsvg-2.0.pc
216 %{_includedir}/librsvg-2.0
217
218 %if %{with static_libs}
219 %files static
220 %defattr(644,root,root,755)
221 %{_libdir}/librsvg-2.a
222 %endif
223
224 %if %{with apidocs}
225 %files apidocs
226 %defattr(644,root,root,755)
227 %{_gtkdocdir}/%{name}
228 %endif
This page took 0.053814 seconds and 4 git commands to generate.