]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
- initial release based on spec from tar.gz package wich my changes
[packages/librsvg.git] / librsvg.spec
1 # Note that this is NOT a relocatable package
2 %define name            librsvg
3 %define ver             1.0.1
4 %define RELEASE         0_cvs_0
5 %define rel             %{?CUSTOM_RELEASE} %{!?CUSTOM_RELEASE:%RELEASE}
6 %define prefix          /usr
7 %define sysconfdir      /etc
8
9 Name:           %name
10 Vendor:         GNOME
11 Distribution:   CVS
12 Summary:        Raph's SVG library
13 Summary(pl):    biblioteka Raph's SVG
14
15 Version:        %ver
16 Release:        %rel
17 Copyright:      LGPL
18 Group:          System Environment/Libraries
19 Source:         %{name}-%{ver}.tar.gz
20 URL:            http://nautilus.eazel.com/
21 BuildRoot:      /var/tmp/%{name}-%{ver}-root
22 Docdir:         %{prefix}/doc
23 Requires:       glib >= 1.2.9
24 Requires:       gtk+ >= 1.2.9
25 Requires:       libxml >= 1.8.10
26 Requires:       gdk-pixbuf >= 0.10.0
27 Requires:       popt >= 1.5
28 Requires:       freetype >= 2.0.1
29 Requires:       libpng
30
31 %description
32 Eazel Extension Library
33
34 %description -l pl
35 Rozszezona bibioteka eazel
36
37 %package devel
38 Summary:        Libraries and include files for developing with librsvg.
39 Group:          Development/Libraries
40 Requires:       %name = %{PACKAGE_VERSION}
41
42 %description devel
43 This package provides the necessary development libraries and include
44 files to allow you to develop with librsvg.
45
46 %description devel -l pl
47 Bibliteki potrzebne do programowania.
48
49 %changelog
50 * Tue Oct 10 2000 Robin Slomkowski <rslomkow@eazel.com>
51 - removed obsoletes from sub packages and added mozilla and trilobite
52 subpackages
53
54 * Wed Apr 26 2000 Ramiro Estrugo <ramiro@eazel.com>
55 - created this thing
56
57 %prep
58 %setup
59
60 %build
61 %ifarch alpha
62         MYARCH_FLAGS="--host=alpha-redhat-linux"
63 %endif
64
65 LC_ALL=""
66 LINGUAS=""
67 LANG=""
68 export LC_ALL LINGUAS LANG
69
70 ## Warning!  Make sure there are no spaces or tabs after the \ 
71 ## continuation character, or else the rpm demons will eat you.
72 CFLAGS="$RPM_OPT_FLAGS" ./configure $MYARCH_FLAGS --prefix=%{prefix} \
73         --sysconfdir=%{sysconfdir}
74
75 make -k
76 make check
77
78 %install
79 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
80 make -k prefix=$RPM_BUILD_ROOT%{prefix} sysconfdir=$RPM_BUILD_ROOT%{sysconfdir} install
81 for FILE in "$RPM_BUILD_ROOT/bin/*"; do
82         file "$FILE" | grep -q not\ stripped && strip $FILE
83 done
84
85 %clean
86 [ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
87
88 %post
89 if ! grep %{prefix}/lib /etc/ld.so.conf > /dev/null ; then
90         echo "%{prefix}/lib" >> /etc/ld.so.conf
91 fi
92 /sbin/ldconfig
93
94 %postun -p /sbin/ldconfig
95
96 %files
97
98 %defattr(0555, bin, bin)
99 %doc AUTHORS COPYING COPYING.LIB ChangeLog NEWS README
100 %{prefix}/lib/*.so*
101
102 %files devel
103
104 %defattr(0555, bin, bin)
105 %{prefix}/lib/*.la
106 %{prefix}/lib/*.sh
107 %{prefix}/bin/librsvg-config
108
109 %defattr(0444, bin, bin)
110 %{prefix}/include/librsvg/*.h
This page took 0.042004 seconds and 4 git commands to generate.