]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
- comment on separation (no need to create lib-libs-reallyonlylibs subpackages everyw...
[packages/librsvg.git] / librsvg.spec
1 #
2 # TODO: - separate libs subpackage, current scheme conflicts on multilib
3 # shouldn't be a problem:
4 # - rsvg script doesn't differ
5 # - rsvg-{convert,view} are ELF binaries with proper colors in rpm, so should be handled properly
6 #
7 # Conditional build
8 %bcond_without  apidocs         # disable gtk-doc
9 %bcond_without  libgsf          # build without libgsf (used for run-time decompression)
10 %bcond_without  libcroco        # build without CSS support through libcroco
11 %bcond_without  static_libs     # don't build static library
12 #
13 Summary:        A Raph's Library for Rendering SVG Data
14 Summary(pl.UTF-8):      Biblioteka Raph's SVG do renderowania danych SVG
15 Summary(pt_BR.UTF-8):   Biblioteca SVG
16 Summary(ru.UTF-8):      SVG библиотека
17 Summary(uk.UTF-8):      SVG бібліотека
18 Name:           librsvg
19 Version:        2.32.1
20 Release:        1
21 Epoch:          1
22 License:        LGPL v2+
23 Group:          X11/Libraries
24 Source0:        http://ftp.gnome.org/pub/GNOME/sources/librsvg/2.32/%{name}-%{version}.tar.bz2
25 # Source0-md5:  4b00d0fee130c936644892c152f42db7
26 URL:            http://librsvg.sourceforge.net/
27 BuildRequires:  autoconf
28 BuildRequires:  automake >= 1:1.9
29 BuildRequires:  docbook-dtd412-xml
30 BuildRequires:  gdk-pixbuf2-devel >= 2.0
31 BuildRequires:  glib2-devel >= 1:2.24.0
32 BuildRequires:  gtk+2-devel >= 2:2.16.0
33 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.13}
34 %{?with_apidocs:BuildRequires:  gtk-doc-automake}
35 %{?with_libcroco:BuildRequires: libcroco-devel >= 0.6.1}
36 %{?with_libgsf:BuildRequires:   libgsf-devel >= 1.14.4}
37 BuildRequires:  libtool
38 BuildRequires:  libxml2-devel >= 1:2.6.31
39 BuildRequires:  pkgconfig
40 BuildRequires:  rpm-pythonprov
41 BuildRequires:  sed >= 4.0
42 Requires(post,postun):  /sbin/ldconfig
43 Requires(post,postun):  gdk-pixbuf2
44 Requires:       gdk-pixbuf2 >= 2.0
45 Requires:       glib2 >= 1:2.24.0
46 Requires:       gtk+2 >= 2:2.16.0
47 %{?with_libcroco:Requires:      libcroco >= 0.6.1}
48 %{?with_libgsf:Requires:        libgsf >= 1.14.4}
49 Requires:       libxml2 >= 1:2.6.31
50 Obsoletes:      browser-plugin-librsvg
51 Obsoletes:      librsvg0
52 Obsoletes:      mozilla-plugin-rsvg
53 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
54
55 # see gtk+2.spec for source of these ifdefs
56 %if "%{_lib}" != "lib"
57 %define         libext          %(lib="%{_lib}"; echo ${lib#lib})
58 %define         pqext           -%{libext}
59 %else
60 %define         pqext           %{nil}
61 %endif
62
63 %description
64 An library to render SVG (scalable vector graphics), databased upon
65 libart.
66
67 %description -l pl.UTF-8
68 Biblioteka do renderowania SVG (skalowalnej grafiki wektorowej) oparta
69 na kodzie libart.
70
71 %description -l ru.UTF-8
72 Библиотека SVG, базирующаяся на libart.
73
74 %description -l uk.UTF-8
75 Бібліотека SVG, базована на libart.
76
77 %package devel
78 Summary:        Include files for developing with librsvg
79 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia oprogramowania z użyciem librsvg
80 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
81 Summary(ru.UTF-8):      Библиотечные линки и файлы заголовков для разработки с librsvg
82 Summary(uk.UTF-8):      Бібліотечні лінки та файли заголовків для розробки з librsvg
83 Group:          X11/Development/Libraries
84 Requires:       %{name} = %{epoch}:%{version}-%{release}
85 Requires:       glib2-devel >= 1:2.24.0
86 Requires:       gdk-pixbuf2-devel >= 2.0
87 Requires:       gtk+2-devel >= 2:2.16.0
88 %{?with_libcroco:Requires:      libcroco-devel >= 0.6.1}
89 %{?with_libgsf:Requires:        libgsf-devel >= 1.14.4}
90 Requires:       libxml2-devel >= 1:2.6.31
91 Obsoletes:      librsvg0-devel
92
93 %description devel
94 This package provides the necessary development libraries and include
95 files to allow you to develop with librsvg.
96
97 %description devel -l pl.UTF-8
98 Pakiet zawiera pliki nagłówkowe potrzebne do tworzenia oprogramowania
99 z wykorzystaniem librsvg.
100
101 %description devel -l pt_BR.UTF-8
102 Este pacote contém os arquivos necessários para desenvolver com base
103 na biblioteca librsvg.
104
105 %description devel -l ru.UTF-8
106 Этот пакет содержит необходимые файлы для разработки программ с
107 использованием librsvg.
108
109 %description devel -l uk.UTF-8
110 Цей пакет містить необхідні файли для розробки програм з використанням
111 librsvg.
112
113 %package static
114 Summary:        Static libraries for developing with librsvg
115 Summary(es.UTF-8):      Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
116 Summary(pl.UTF-8):      Statyczne biblioteki librsvg
117 Summary(pt_BR.UTF-8):   Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
118 Group:          X11/Development/Libraries
119 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
120
121 %description static
122 This package contains static version of librsvg libraries.
123
124 %description static -l pl.UTF-8
125 Statyczna wersja bibliotek librsvg.
126
127 %description static -l pt_BR.UTF-8
128 Bibliotecas estáticas para o desenvolvimento de aplicações com
129 librsvg.
130
131 %package apidocs
132 Summary:        librsvg API documentation
133 Summary(pl.UTF-8):      Dokumentacja API biblioteki librsvg
134 Group:          Documentation
135 Requires:       gtk-doc-common
136
137 %description apidocs
138 librsvg API documentation.
139
140 %description apidocs -l pl.UTF-8
141 Dokumentacja API biblioteki librsvg.
142
143 %prep
144 %setup -q
145
146 %if !%{with apidocs}
147 echo 'CLEANFILES=' > gtk-doc.make
148 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
149 %endif
150
151 %{__sed} -e 's/gdk-pixbuf-query-loaders/gdk-pixbuf-query-loaders%{pqext}/' -i configure.in
152
153 %build
154 %{?with_apidocs:%{__gtkdocize}}
155 %{__libtoolize}
156 %{__aclocal}
157 %{__autoconf}
158 %{__autoheader}
159 %{__automake}
160 %configure \
161         --disable-silent-rules \
162         %{!?with_static_libs:--disable-static} \
163         %{?with_apidocs:--enable-gtk-doc} \
164         %{!?with_libcroco:--without-croco} \
165         %{!?with_libgsf:--without-svgz} \
166         --with-html-dir=%{_gtkdocdir}/%{name}
167 %{__make}
168
169 %install
170 rm -rf $RPM_BUILD_ROOT
171
172 %{__make} install \
173         DESTDIR=$RPM_BUILD_ROOT \
174         pkgconfigdir=%{_pkgconfigdir}
175
176 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/engines/*.{la,a}
177 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/*.{la,a}
178 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librsvg-2.la
179
180 %clean
181 rm -rf $RPM_BUILD_ROOT
182
183 %post
184 /sbin/ldconfig
185 umask 022
186 %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache || :
187
188 %postun
189 /sbin/ldconfig
190 umask 022
191 if [ -x %{_bindir}/gdk-pixbuf-query-loaders%{pqext} ]; then
192         %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache
193 fi
194
195 %files
196 %defattr(644,root,root,755)
197 %doc ChangeLog AUTHORS NEWS
198 %attr(755,root,root) %{_bindir}/rsvg
199 %attr(755,root,root) %{_bindir}/rsvg-convert
200 %attr(755,root,root) %{_bindir}/rsvg-view
201 %attr(755,root,root) %{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/libpixbufloader-svg.so
202 %attr(755,root,root) %{_libdir}/gtk-2.0/2.*/engines/libsvg.so
203 %attr(755,root,root) %{_libdir}/librsvg-2.so.*.*.*
204 %attr(755,root,root) %ghost %{_libdir}/librsvg-2.so.2
205 %{_datadir}/themes/bubble
206 %{_mandir}/man1/rsvg.1*
207 %{_pixmapsdir}/svg-viewer.svg
208
209 %files devel
210 %defattr(644,root,root,755)
211 %attr(755,root,root) %{_libdir}/librsvg-2.so
212 %{_pkgconfigdir}/librsvg-2.0.pc
213 %{_includedir}/librsvg-2.0
214
215 %if %{with static_libs}
216 %files static
217 %defattr(644,root,root,755)
218 %{_libdir}/librsvg-2.a
219 %endif
220
221 %if %{with apidocs}
222 %files apidocs
223 %defattr(644,root,root,755)
224 %{_gtkdocdir}/%{name}
225 %endif
This page took 0.078754 seconds and 4 git commands to generate.