]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
- fixed build on x86_64
[packages/librsvg.git] / librsvg.spec
1 #
2 # Conditional build
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  libgsf          # build without libgsf (used for run-time decompression)
5 %bcond_without  libcroco        # build without CSS support through libcroco
6 %bcond_without  static_libs     # don't build static library
7 #
8 Summary:        A Raph's Library for Rendering SVG Data
9 Summary(pl.UTF-8):      Biblioteka Raph's SVG do renderowania danych SVG
10 Summary(pt_BR.UTF-8):   Biblioteca SVG
11 Summary(ru.UTF-8):      SVG библиотека
12 Summary(uk.UTF-8):      SVG бібліотека
13 Name:           librsvg
14 Version:        2.32.0
15 Release:        2
16 Epoch:          1
17 License:        LGPL v2+
18 Group:          X11/Libraries
19 Source0:        http://ftp.gnome.org/pub/GNOME/sources/librsvg/2.32/%{name}-%{version}.tar.bz2
20 # Source0-md5:  b015a9bd80143ec876af489d882dc28b
21 URL:            http://librsvg.sourceforge.net/
22 BuildRequires:  autoconf
23 BuildRequires:  automake >= 1:1.9
24 BuildRequires:  docbook-dtd412-xml
25 BuildRequires:  glib2-devel >= 1:2.24.0
26 BuildRequires:  gtk+2-devel >= 2:2.16.0
27 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.13}
28 %{?with_apidocs:BuildRequires:  gtk-doc-automake}
29 %{?with_libcroco:BuildRequires: libcroco-devel >= 0.6.1}
30 %{?with_libgsf:BuildRequires:   libgsf-devel >= 1.14.4}
31 BuildRequires:  libtool
32 BuildRequires:  libxml2-devel >= 1:2.6.31
33 BuildRequires:  pkgconfig
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  sed >= 4.0
36 Requires(post,postun):  /sbin/ldconfig
37 Requires(post,postun):  gdk-pixbuf2
38 Requires:       glib2 >= 1:2.24.0
39 Requires:       gtk+2 >= 2:2.16.0
40 %{?with_libcroco:Requires:      libcroco >= 0.6.1}
41 %{?with_libgsf:Requires:        libgsf >= 1.14.4}
42 Requires:       libxml2 >= 1:2.6.31
43 Obsoletes:      browser-plugin-librsvg
44 Obsoletes:      librsvg0
45 Obsoletes:      mozilla-plugin-rsvg
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 # see gtk+2.spec for source of these ifdefs
49 %if "%{_lib}" != "lib"
50 %define         libext          %(lib="%{_lib}"; echo ${lib#lib})
51 %define         pqext           -%{libext}
52 %else
53 %define         pqext           %{nil}
54 %endif
55
56 %description
57 An library to render SVG (scalable vector graphics), databased upon
58 libart.
59
60 %description -l pl.UTF-8
61 Biblioteka do renderowania SVG (skalowalnej grafiki wektorowej) oparta
62 na kodzie libart.
63
64 %description -l ru.UTF-8
65 Библиотека SVG, базирующаяся на libart.
66
67 %description -l uk.UTF-8
68 Бібліотека SVG, базована на libart.
69
70 %package devel
71 Summary:        Include files for developing with librsvg
72 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia oprogramowania z użyciem librsvg
73 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
74 Summary(ru.UTF-8):      Библиотечные линки и файлы заголовков для разработки с librsvg
75 Summary(uk.UTF-8):      Бібліотечні лінки та файли заголовків для розробки з librsvg
76 Group:          X11/Development/Libraries
77 Requires:       %{name} = %{epoch}:%{version}-%{release}
78 Requires:       glib2-devel >= 1:2.24.0
79 Requires:       gtk+2-devel >= 2:2.16.0
80 %{?with_libcroco:Requires:      libcroco-devel >= 0.6.1}
81 %{?with_libgsf:Requires:        libgsf-devel >= 1.14.4}
82 Requires:       libxml2-devel >= 1:2.6.31
83 Obsoletes:      librsvg0-devel
84
85 %description devel
86 This package provides the necessary development libraries and include
87 files to allow you to develop with librsvg.
88
89 %description devel -l pl.UTF-8
90 Pakiet zawiera pliki nagłówkowe potrzebne do tworzenia oprogramowania
91 z wykorzystaniem librsvg.
92
93 %description devel -l pt_BR.UTF-8
94 Este pacote contém os arquivos necessários para desenvolver com base
95 na biblioteca librsvg.
96
97 %description devel -l ru.UTF-8
98 Этот пакет содержит необходимые файлы для разработки программ с
99 использованием librsvg.
100
101 %description devel -l uk.UTF-8
102 Цей пакет містить необхідні файли для розробки програм з використанням
103 librsvg.
104
105 %package static
106 Summary:        Static libraries for developing with librsvg
107 Summary(es.UTF-8):      Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
108 Summary(pl.UTF-8):      Statyczne biblioteki librsvg
109 Summary(pt_BR.UTF-8):   Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
110 Group:          X11/Development/Libraries
111 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
112
113 %description static
114 This package contains static version of librsvg libraries.
115
116 %description static -l pl.UTF-8
117 Statyczna wersja bibliotek librsvg.
118
119 %description static -l pt_BR.UTF-8
120 Bibliotecas estáticas para o desenvolvimento de aplicações com
121 librsvg.
122
123 %package apidocs
124 Summary:        librsvg API documentation
125 Summary(pl.UTF-8):      Dokumentacja API biblioteki librsvg
126 Group:          Documentation
127 Requires:       gtk-doc-common
128
129 %description apidocs
130 librsvg API documentation.
131
132 %description apidocs -l pl.UTF-8
133 Dokumentacja API biblioteki librsvg.
134
135 %prep
136 %setup -q
137
138 %if !%{with apidocs}
139 echo 'CLEANFILES=' > gtk-doc.make
140 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
141 %endif
142
143 %{__sed} -e 's/gdk-pixbuf-query-loaders/gdk-pixbuf-query-loaders%{pqext}/' -i configure.in
144
145 %build
146 %{?with_apidocs:%{__gtkdocize}}
147 %{__libtoolize}
148 %{__aclocal}
149 %{__autoconf}
150 %{__autoheader}
151 %{__automake}
152 %configure \
153         --disable-silent-rules \
154         %{!?with_static_libs:--disable-static} \
155         %{?with_apidocs:--enable-gtk-doc} \
156         %{!?with_libcroco:--without-croco} \
157         %{!?with_libgsf:--without-svgz} \
158         --with-html-dir=%{_gtkdocdir}/%{name}
159 %{__make}
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT \
166         pkgconfigdir=%{_pkgconfigdir}
167
168 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/engines/*.{la,a}
169 rm -f $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/*.{la,a}
170
171 %clean
172 rm -rf $RPM_BUILD_ROOT
173
174 %post
175 /sbin/ldconfig
176 umask 022
177 %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache
178 exit 0
179
180 %postun
181 /sbin/ldconfig
182 umask 022
183 if [ -x %{_bindir}/gdk-pixbuf-query-loaders%{pqext} ]; then
184         %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache
185 fi
186
187 %files
188 %defattr(644,root,root,755)
189 %doc ChangeLog AUTHORS NEWS
190 %attr(755,root,root) %{_bindir}/rsvg
191 %attr(755,root,root) %{_bindir}/rsvg-convert
192 %attr(755,root,root) %{_bindir}/rsvg-view
193 %attr(755,root,root) %{_libdir}/librsvg-2.so.*.*.*
194 %attr(755,root,root) %ghost %{_libdir}/librsvg-2.so.2
195 %attr(755,root,root) %{_libdir}/gtk-2.0/2.*/engines/libsvg.so
196 %attr(755,root,root) %{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/libpixbufloader-svg.so
197 %{_datadir}/themes/bubble
198 %{_mandir}/man1/rsvg.1*
199 %{_pixmapsdir}/svg-viewer.svg
200
201 %files devel
202 %defattr(644,root,root,755)
203 %attr(755,root,root) %{_libdir}/librsvg-2.so
204 %{_libdir}/librsvg-2.la
205 %{_pkgconfigdir}/librsvg-2.0.pc
206 %{_includedir}/librsvg-2.0
207
208 %if %{with static_libs}
209 %files static
210 %defattr(644,root,root,755)
211 %{_libdir}/librsvg-2.a
212 %endif
213
214 %if %{with apidocs}
215 %files apidocs
216 %defattr(644,root,root,755)
217 %{_gtkdocdir}/%{name}
218 %endif
This page took 0.102882 seconds and 4 git commands to generate.