]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
- fixed build on x86_64
[packages/librsvg.git] / librsvg.spec
1 #
2 # Conditional build
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_with     gtk2            # enable gtk+2
5 %bcond_without  libgsf          # build without libgsf (used for run-time decompression)
6 %bcond_without  libcroco        # build without CSS support through libcroco
7 %bcond_without  static_libs     # don't build static library
8 #
9
10 %define         ver     2.36
11 %define         pver    0
12
13 Summary:        A Raph's Library for Rendering SVG Data
14 Summary(pl.UTF-8):      Biblioteka Raph's SVG do renderowania danych SVG
15 Summary(pt_BR.UTF-8):   Biblioteca SVG
16 Summary(ru.UTF-8):      SVG библиотека
17 Summary(uk.UTF-8):      SVG бібліотека
18 Name:           librsvg
19 Version:        %{ver}.%{pver}
20 Release:        2
21 Epoch:          1
22 License:        LGPL v2+
23 Group:          X11/Libraries
24 Source0:        http://ftp.gnome.org/pub/GNOME/sources/librsvg/%{ver}/%{name}-%{version}.tar.xz
25 # Source0-md5:  1dbd07bbc870433ce6c5edcfba13a102
26 Source1:        rsvg
27 URL:            http://librsvg.sourceforge.net/
28 BuildRequires:  autoconf
29 BuildRequires:  automake >= 1:1.9
30 BuildRequires:  docbook-dtd412-xml
31 BuildRequires:  gdk-pixbuf2-devel >= 2.0
32 BuildRequires:  glib2-devel >= 1:2.24.0
33 BuildRequires:  gobject-introspection-devel >= 0.18.8
34 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.16.0}
35 BuildRequires:  gtk+3-devel >= 3.0.0
36 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.13}
37 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.13}
38 %{?with_libcroco:BuildRequires: libcroco-devel >= 0.6.1}
39 %{?with_libgsf:BuildRequires:   libgsf-devel >= 1.14.4}
40 BuildRequires:  libtool
41 BuildRequires:  libxml2-devel >= 1:2.6.31
42 BuildRequires:  pango-devel >= 1:1.10.0
43 BuildRequires:  pkgconfig
44 BuildRequires:  rpm-pythonprov
45 BuildRequires:  sed >= 4.0
46 BuildRequires:  tar >= 1:1.22
47 BuildRequires:  xz
48 Requires(post,postun):  /sbin/ldconfig
49 Requires(post,postun):  gdk-pixbuf2 >= 2.0
50 Requires:       gdk-pixbuf2 >= 2.0
51 Requires:       glib2 >= 1:2.24.0
52 %{?with_libcroco:Requires:      libcroco >= 0.6.1}
53 %{?with_libgsf:Requires:        libgsf >= 1.14.4}
54 Requires:       libxml2 >= 1:2.6.31
55 Requires:       pango >= 1:1.10.0
56 Obsoletes:      browser-plugin-librsvg
57 Obsoletes:      librsvg0
58 Obsoletes:      mozilla-plugin-rsvg
59 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
60
61 # see gdk-pixbuf2.spec for source of these ifdefs
62 %if "%{_lib}" != "lib"
63 %define         libext          %(lib="%{_lib}"; echo ${lib#lib})
64 %define         pqext           -%{libext}
65 %else
66 %define         pqext           %{nil}
67 %endif
68
69 %description
70 An library to render SVG (scalable vector graphics), databased upon
71 libart.
72
73 %description -l pl.UTF-8
74 Biblioteka do renderowania SVG (skalowalnej grafiki wektorowej) oparta
75 na kodzie libart.
76
77 %description -l ru.UTF-8
78 Библиотека SVG, базирующаяся на libart.
79
80 %description -l uk.UTF-8
81 Бібліотека SVG, базована на libart.
82
83 %package devel
84 Summary:        Include files for developing with librsvg
85 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia oprogramowania z użyciem librsvg
86 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
87 Summary(ru.UTF-8):      Библиотечные линки и файлы заголовков для разработки с librsvg
88 Summary(uk.UTF-8):      Бібліотечні лінки та файли заголовків для розробки з librsvg
89 Group:          X11/Development/Libraries
90 Requires:       %{name} = %{epoch}:%{version}-%{release}
91 Requires:       glib2-devel >= 1:2.24.0
92 Requires:       gdk-pixbuf2-devel >= 2.0
93 Requires:       gtk+3-devel >= 3.0.0
94 %{?with_libcroco:Requires:      libcroco-devel >= 0.6.1}
95 %{?with_libgsf:Requires:        libgsf-devel >= 1.14.4}
96 Requires:       libxml2-devel >= 1:2.6.31
97 Requires:       pango-devel >= 1:1.10.0
98 Obsoletes:      librsvg0-devel
99
100 %description devel
101 This package provides the necessary development libraries and include
102 files to allow you to develop with librsvg.
103
104 %description devel -l pl.UTF-8
105 Pakiet zawiera pliki nagłówkowe potrzebne do tworzenia oprogramowania
106 z wykorzystaniem librsvg.
107
108 %description devel -l pt_BR.UTF-8
109 Este pacote contém os arquivos necessários para desenvolver com base
110 na biblioteca librsvg.
111
112 %description devel -l ru.UTF-8
113 Этот пакет содержит необходимые файлы для разработки программ с
114 использованием librsvg.
115
116 %description devel -l uk.UTF-8
117 Цей пакет містить необхідні файли для розробки програм з використанням
118 librsvg.
119
120 %package static
121 Summary:        Static libraries for developing with librsvg
122 Summary(es.UTF-8):      Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
123 Summary(pl.UTF-8):      Statyczne biblioteki librsvg
124 Summary(pt_BR.UTF-8):   Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
125 Group:          X11/Development/Libraries
126 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
127
128 %description static
129 This package contains static version of librsvg libraries.
130
131 %description static -l pl.UTF-8
132 Statyczna wersja bibliotek librsvg.
133
134 %description static -l pt_BR.UTF-8
135 Bibliotecas estáticas para o desenvolvimento de aplicações com
136 librsvg.
137
138 %package apidocs
139 Summary:        librsvg API documentation
140 Summary(pl.UTF-8):      Dokumentacja API biblioteki librsvg
141 Group:          Documentation
142 Requires:       gtk-doc-common
143
144 %description apidocs
145 librsvg API documentation.
146
147 %description apidocs -l pl.UTF-8
148 Dokumentacja API biblioteki librsvg.
149
150 %package gtk+2
151 Summary:        librsvg/GTK+2 based SVG theme engine and viewer
152 Summary(pl.UTF-8):      Silnik motywów oraz przeglądarka plików SVG oparte na bibliotekach librsvg/GTK+2
153 Group:          X11/Libraries
154 Requires:       %{name} = %{epoch}:%{version}-%{release}
155 Requires:       gtk+2 >= 2:2.16.0
156
157 %description gtk+2
158 librsvg/GTK+2 based SVG theme engine and viewer.
159
160 %description gtk+2 -l pl.UTF-8
161 Silnik motywów oraz przeglądarka plików SVG oparte na bibliotekach
162 librsvg/GTK+2.
163
164 %package gtk+3
165 Summary:        librsvg/GTK+3 based SVG theme and viewer
166 Summary(pl.UTF-8):      Motyw i przeglądarka plików SVG oparte na bibliotekach librsvg/GTK+3
167 Group:          X11/Libraries
168 Requires:       %{name} = %{epoch}:%{version}-%{release}
169 Requires:       gtk+3 >= 3.0.0
170
171 %description gtk+3
172 librsvg/GTK+3 based SVG theme and viewer.
173
174 %description gtk+3 -l pl.UTF-8
175 Motyw i przeglądarka plików SVG oparte na bibliotekach librsvg/GTK+3.
176
177 %prep
178 %setup -q
179
180 %if !%{with apidocs}
181 echo 'CLEANFILES=' > gtk-doc.make
182 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
183 %endif
184
185 %build
186 %{?with_apidocs:%{__gtkdocize}}
187 %{__libtoolize}
188 %{__aclocal}
189 %{__autoconf}
190 %{__autoheader}
191 %{__automake}
192 %configure \
193         --disable-silent-rules \
194         %{!?with_static_libs:--disable-static} \
195         %{?with_apidocs:--enable-gtk-doc} \
196         --enable-introspection \
197         %{!?with_libcroco:--without-croco} \
198         %{!?with_libgsf:--without-svgz} \
199         --with-html-dir=%{_gtkdocdir}/%{name}
200 %{__make}
201
202 %install
203 rm -rf $RPM_BUILD_ROOT
204
205 %{__make} install \
206         DESTDIR=$RPM_BUILD_ROOT \
207         pkgconfigdir=%{_pkgconfigdir}
208
209 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/engines/*.{la,a}
210 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/*.{la,a}
211 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librsvg-2.la
212
213 %{__ln_s} rsvg-view-3 $RPM_BUILD_ROOT%{_bindir}/rsvg-view
214
215 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
216
217 %clean
218 rm -rf $RPM_BUILD_ROOT
219
220 %post
221 /sbin/ldconfig
222 umask 022
223 %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache || :
224
225 %postun
226 /sbin/ldconfig
227 umask 022
228 if [ -x %{_bindir}/gdk-pixbuf-query-loaders%{pqext} ]; then
229         %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache
230 fi
231
232 %files
233 %defattr(644,root,root,755)
234 %doc ChangeLog AUTHORS NEWS
235 %attr(755,root,root) %{_bindir}/rsvg
236 %attr(755,root,root) %{_bindir}/rsvg-convert
237 %attr(755,root,root) %{_libdir}/librsvg-2.so.*.*.*
238 %attr(755,root,root) %ghost %{_libdir}/librsvg-2.so.2
239 %{_libdir}/girepository-1.0/Rsvg-2.0.typelib
240 %attr(755,root,root) %{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/libpixbufloader-svg.so
241 %dir %{_datadir}/themes/bubble
242 %{_mandir}/man1/rsvg.1*
243 #%{_pixmapsdir}/svg-viewer.svg
244
245 %files devel
246 %defattr(644,root,root,755)
247 %attr(755,root,root) %{_libdir}/librsvg-2.so
248 %{_includedir}/librsvg-2.0
249 %{_datadir}/gir-1.0/Rsvg-2.0.gir
250 %{_pkgconfigdir}/librsvg-2.0.pc
251
252 %if %{with static_libs}
253 %files static
254 %defattr(644,root,root,755)
255 %{_libdir}/librsvg-2.a
256 %endif
257
258 %if %{with apidocs}
259 %files apidocs
260 %defattr(644,root,root,755)
261 %{_gtkdocdir}/%{name}
262 %endif
263
264 %if %{with gtk2}
265 %files gtk+2
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_libdir}/gtk-2.0/2.*/engines/libsvg.so
268 %{_datadir}/themes/bubble/gtk-2.0
269 %endif
270
271 %files gtk+3
272 %defattr(644,root,root,755)
273 %attr(755,root,root) %{_bindir}/rsvg-view-3
274 %attr(755,root,root) %{_bindir}/rsvg-view
This page took 0.087679 seconds and 4 git commands to generate.