]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
- release 3 (by relup.sh)
[packages/librsvg.git] / librsvg.spec
1 #
2 # Conditional build
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  gtk2            # legacy gtk+2 support
5 %bcond_without  libcroco        # build without CSS support through libcroco
6 %bcond_without  static_libs     # don't build static library
7
8 %define         mver    2.40
9 %define         pver    0
10 Summary:        A Raph's Library for Rendering SVG Data
11 Summary(pl.UTF-8):      Biblioteka Raph's SVG do renderowania danych SVG
12 Summary(pt_BR.UTF-8):   Biblioteca SVG
13 Summary(ru.UTF-8):      SVG библиотека
14 Summary(uk.UTF-8):      SVG бібліотека
15 Name:           librsvg
16 Version:        %{mver}.%{pver}
17 Release:        3
18 Epoch:          1
19 License:        LGPL v2+
20 Group:          X11/Libraries
21 Source0:        http://ftp.gnome.org/pub/GNOME/sources/librsvg/%{mver}/%{name}-%{version}.tar.xz
22 # Source0-md5:  e16a84e9a86a18e5ca6ba95c512db6c6
23 Source1:        rsvg
24 URL:            http://librsvg.sourceforge.net/
25 BuildRequires:  autoconf
26 BuildRequires:  automake >= 1:1.9
27 BuildRequires:  cairo-devel >= 1.2.0
28 BuildRequires:  docbook-dtd412-xml
29 BuildRequires:  gdk-pixbuf2-devel >= 2.20
30 BuildRequires:  glib2-devel >= 1:2.24.0
31 BuildRequires:  gobject-introspection-devel >= 0.10.8
32 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.16.0}
33 BuildRequires:  gtk+3-devel >= 3.2.0
34 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.13}
35 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.13}
36 %{?with_libcroco:BuildRequires: libcroco-devel >= 0.6.1}
37 BuildRequires:  libtool >= 2:2.0
38 BuildRequires:  libxml2-devel >= 1:2.7.0
39 BuildRequires:  pango-devel >= 1:1.32.6
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  xz
45 Requires(post,postun):  /sbin/ldconfig
46 Requires:       cairo >= 1.2.0
47 Requires:       gdk-pixbuf2 >= 2.20
48 Requires:       glib2 >= 1:2.24.0
49 %{?with_libcroco:Requires:      libcroco >= 0.6.1}
50 Requires:       libxml2 >= 1:2.7.0
51 Requires:       pango >= 1:1.16.0
52 Obsoletes:      browser-plugin-librsvg
53 Obsoletes:      librsvg0
54 Obsoletes:      librsvg-gtk+2
55 Obsoletes:      mozilla-plugin-rsvg
56 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
57
58 # see gdk-pixbuf2.spec for source of these ifdefs
59 %if "%{_lib}" != "lib"
60 %define         libext          %(lib="%{_lib}"; echo ${lib#lib})
61 %define         pqext           -%{libext}
62 %else
63 %define         pqext           %{nil}
64 %endif
65
66 %description
67 An library to render SVG (scalable vector graphics), databased upon
68 libart.
69
70 %description -l pl.UTF-8
71 Biblioteka do renderowania SVG (skalowalnej grafiki wektorowej) oparta
72 na kodzie libart.
73
74 %description -l ru.UTF-8
75 Библиотека SVG, базирующаяся на libart.
76
77 %description -l uk.UTF-8
78 Бібліотека SVG, базована на libart.
79
80 %package devel
81 Summary:        Include files for developing with librsvg
82 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia oprogramowania z użyciem librsvg
83 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
84 Summary(ru.UTF-8):      Библиотечные линки и файлы заголовков для разработки с librsvg
85 Summary(uk.UTF-8):      Бібліотечні лінки та файли заголовків для розробки з librsvg
86 Group:          X11/Development/Libraries
87 Requires:       %{name} = %{epoch}:%{version}-%{release}
88 Requires:       cairo-devel >= 1.2.0
89 Requires:       gdk-pixbuf2-devel >= 2.20
90 Requires:       glib2-devel >= 1:2.24.0
91 Requires:       gtk+3-devel >= 3.2.0
92 %{?with_libcroco:Requires:      libcroco-devel >= 0.6.1}
93 Requires:       libxml2-devel >= 1:2.7.0
94 Requires:       pango-devel >= 1:1.16.0
95 Obsoletes:      librsvg0-devel
96
97 %description devel
98 This package provides the necessary development libraries and include
99 files to allow you to develop with librsvg.
100
101 %description devel -l pl.UTF-8
102 Pakiet zawiera pliki nagłówkowe potrzebne do tworzenia oprogramowania
103 z wykorzystaniem librsvg.
104
105 %description devel -l pt_BR.UTF-8
106 Este pacote contém os arquivos necessários para desenvolver com base
107 na biblioteca librsvg.
108
109 %description devel -l ru.UTF-8
110 Этот пакет содержит необходимые файлы для разработки программ с
111 использованием librsvg.
112
113 %description devel -l uk.UTF-8
114 Цей пакет містить необхідні файли для розробки програм з використанням
115 librsvg.
116
117 %package static
118 Summary:        Static libraries for developing with librsvg
119 Summary(es.UTF-8):      Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
120 Summary(pl.UTF-8):      Statyczne biblioteki librsvg
121 Summary(pt_BR.UTF-8):   Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
122 Group:          X11/Development/Libraries
123 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
124
125 %description static
126 This package contains static version of librsvg libraries.
127
128 %description static -l pl.UTF-8
129 Statyczna wersja bibliotek librsvg.
130
131 %description static -l pt_BR.UTF-8
132 Bibliotecas estáticas para o desenvolvimento de aplicações com
133 librsvg.
134
135 %package apidocs
136 Summary:        librsvg API documentation
137 Summary(pl.UTF-8):      Dokumentacja API biblioteki librsvg
138 Group:          Documentation
139 Requires:       gtk-doc-common
140
141 %description apidocs
142 librsvg API documentation.
143
144 %description apidocs -l pl.UTF-8
145 Dokumentacja API biblioteki librsvg.
146
147 %package gtk+3
148 Summary:        librsvg/GTK+3 based SVG viewer
149 Summary(pl.UTF-8):      Przeglądarka plików SVG oparta na bibliotekach librsvg/GTK+3
150 Group:          X11/Applications/Graphics
151 Requires:       %{name} = %{epoch}:%{version}-%{release}
152 Requires:       gtk+3 >= 3.2.0
153
154 %description gtk+3
155 librsvg/GTK+3 based SVG viewer.
156
157 %description gtk+3 -l pl.UTF-8
158 Przeglądarka plików SVG oparta na bibliotekach librsvg/GTK+3.
159
160 %prep
161 %setup -q
162
163 %if %{without apidocs}
164 echo 'CLEANFILES=' > gtk-doc.make
165 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
166 %endif
167
168 # vala not ready yet here
169 #echo 'AC_DEFUN([VAPIGEN_CHECK],[AM_CONDITIONAL([ENABLE_VAPIGEN], [false])])' >> acinclude.m4
170
171 %build
172 mkdir m4
173 %{?with_apidocs:%{__gtkdocize}}
174 %{__libtoolize}
175 %{__aclocal}
176 %{__autoconf}
177 %{__autoheader}
178 %{__automake}
179 %configure \
180         --disable-silent-rules \
181         %{__enable_disable static_libs static} \
182         %{__enable_disable apidocs gtk-doc} \
183         --enable-introspection \
184         %{__with_without libcroco croco} \
185         --with-html-dir=%{_gtkdocdir}/%{name}
186 %{__make}
187
188 %install
189 rm -rf $RPM_BUILD_ROOT
190
191 %{__make} install \
192         DESTDIR=$RPM_BUILD_ROOT \
193         pkgconfigdir=%{_pkgconfigdir}
194
195 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/*.{la,a}
196 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librsvg-2.la
197
198 %{__ln_s} rsvg-view-3 $RPM_BUILD_ROOT%{_bindir}/rsvg-view
199
200 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
201
202 %clean
203 rm -rf $RPM_BUILD_ROOT
204
205 %post
206 /sbin/ldconfig
207 umask 022
208 %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache || :
209
210 %postun
211 /sbin/ldconfig
212 umask 022
213 if [ -x %{_bindir}/gdk-pixbuf-query-loaders%{pqext} ]; then
214         %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache
215 fi
216
217 %files
218 %defattr(644,root,root,755)
219 %doc ChangeLog AUTHORS NEWS
220 %attr(755,root,root) %{_bindir}/rsvg
221 %attr(755,root,root) %{_bindir}/rsvg-convert
222 %attr(755,root,root) %{_libdir}/librsvg-2.so.*.*.*
223 %attr(755,root,root) %ghost %{_libdir}/librsvg-2.so.2
224 %{_libdir}/girepository-1.0/Rsvg-2.0.typelib
225 %attr(755,root,root) %{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/libpixbufloader-svg.so
226 %{_mandir}/man1/rsvg-convert.1*
227
228 %files devel
229 %defattr(644,root,root,755)
230 %attr(755,root,root) %{_libdir}/librsvg-2.so
231 %{_includedir}/librsvg-2.0
232 %{_datadir}/gir-1.0/Rsvg-2.0.gir
233 %{_pkgconfigdir}/librsvg-2.0.pc
234
235 %if %{with static_libs}
236 %files static
237 %defattr(644,root,root,755)
238 %{_libdir}/librsvg-2.a
239 %endif
240
241 %if %{with apidocs}
242 %files apidocs
243 %defattr(644,root,root,755)
244 %{_gtkdocdir}/%{name}
245 %endif
246
247 %files gtk+3
248 %defattr(644,root,root,755)
249 %attr(755,root,root) %{_bindir}/rsvg-view
250 %attr(755,root,root) %{_bindir}/rsvg-view-3
This page took 0.059232 seconds and 4 git commands to generate.