]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
R: gdk-pixbuf2
[packages/librsvg.git] / librsvg.spec
1 #
2 # Conditional build
3 %bcond_without  apidocs         # disable gtk-doc
4 %bcond_without  gtk2            # legacy gtk+2 support
5 %bcond_without  libcroco        # build without CSS support through libcroco
6 %bcond_without  static_libs     # don't build static library
7
8 %define         ver     2.36
9 %define         pver    4
10 Summary:        A Raph's Library for Rendering SVG Data
11 Summary(pl.UTF-8):      Biblioteka Raph's SVG do renderowania danych SVG
12 Summary(pt_BR.UTF-8):   Biblioteca SVG
13 Summary(ru.UTF-8):      SVG библиотека
14 Summary(uk.UTF-8):      SVG бібліотека
15 Name:           librsvg
16 Version:        %{ver}.%{pver}
17 Release:        3
18 Epoch:          1
19 License:        LGPL v2+
20 Group:          X11/Libraries
21 Source0:        http://ftp.gnome.org/pub/GNOME/sources/librsvg/%{ver}/%{name}-%{version}.tar.xz
22 # Source0-md5:  3c94524c8ccf668e30b236f409239f54
23 Source1:        rsvg
24 URL:            http://librsvg.sourceforge.net/
25 BuildRequires:  autoconf
26 BuildRequires:  automake >= 1:1.9
27 BuildRequires:  cairo-devel >= 1.2.0
28 BuildRequires:  docbook-dtd412-xml
29 BuildRequires:  gdk-pixbuf2-devel >= 2.0
30 BuildRequires:  glib2-devel >= 1:2.24.0
31 BuildRequires:  gobject-introspection-devel >= 0.10.8
32 %{?with_gtk2:BuildRequires:     gtk+2-devel >= 2:2.16.0}
33 BuildRequires:  gtk+3-devel >= 3.0.0
34 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.13}
35 %{?with_apidocs:BuildRequires:  gtk-doc-automake >= 1.13}
36 %{?with_libcroco:BuildRequires: libcroco-devel >= 0.6.1}
37 BuildRequires:  libtool >= 2:2.0
38 BuildRequires:  libxml2-devel >= 1:2.7.0
39 BuildRequires:  pango-devel >= 1:1.16.0
40 BuildRequires:  pkgconfig
41 BuildRequires:  rpm-pythonprov
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  xz
45 Requires(post,postun):  /sbin/ldconfig
46 Requires:       cairo >= 1.2.0
47 Requires:       gdk-pixbuf2 >= 2.0
48 Requires:       glib2 >= 1:2.24.0
49 %{?with_libcroco:Requires:      libcroco >= 0.6.1}
50 Requires:       libxml2 >= 1:2.7.0
51 Requires:       pango >= 1:1.16.0
52 Obsoletes:      browser-plugin-librsvg
53 Obsoletes:      librsvg0
54 Obsoletes:      mozilla-plugin-rsvg
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 # see gdk-pixbuf2.spec for source of these ifdefs
58 %if "%{_lib}" != "lib"
59 %define         libext          %(lib="%{_lib}"; echo ${lib#lib})
60 %define         pqext           -%{libext}
61 %else
62 %define         pqext           %{nil}
63 %endif
64
65 %description
66 An library to render SVG (scalable vector graphics), databased upon
67 libart.
68
69 %description -l pl.UTF-8
70 Biblioteka do renderowania SVG (skalowalnej grafiki wektorowej) oparta
71 na kodzie libart.
72
73 %description -l ru.UTF-8
74 Библиотека SVG, базирующаяся на libart.
75
76 %description -l uk.UTF-8
77 Бібліотека SVG, базована на libart.
78
79 %package devel
80 Summary:        Include files for developing with librsvg
81 Summary(pl.UTF-8):      Pliki nagłówkowe do tworzenia oprogramowania z użyciem librsvg
82 Summary(pt_BR.UTF-8):   Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
83 Summary(ru.UTF-8):      Библиотечные линки и файлы заголовков для разработки с librsvg
84 Summary(uk.UTF-8):      Бібліотечні лінки та файли заголовків для розробки з librsvg
85 Group:          X11/Development/Libraries
86 Requires:       %{name} = %{epoch}:%{version}-%{release}
87 Requires:       cairo-devel >= 1.2.0
88 Requires:       gdk-pixbuf2-devel >= 2.0
89 Requires:       glib2-devel >= 1:2.24.0
90 Requires:       gtk+3-devel >= 3.0.0
91 %{?with_libcroco:Requires:      libcroco-devel >= 0.6.1}
92 Requires:       libxml2-devel >= 1:2.7.0
93 Requires:       pango-devel >= 1:1.16.0
94 Obsoletes:      librsvg0-devel
95
96 %description devel
97 This package provides the necessary development libraries and include
98 files to allow you to develop with librsvg.
99
100 %description devel -l pl.UTF-8
101 Pakiet zawiera pliki nagłówkowe potrzebne do tworzenia oprogramowania
102 z wykorzystaniem librsvg.
103
104 %description devel -l pt_BR.UTF-8
105 Este pacote contém os arquivos necessários para desenvolver com base
106 na biblioteca librsvg.
107
108 %description devel -l ru.UTF-8
109 Этот пакет содержит необходимые файлы для разработки программ с
110 использованием librsvg.
111
112 %description devel -l uk.UTF-8
113 Цей пакет містить необхідні файли для розробки програм з використанням
114 librsvg.
115
116 %package static
117 Summary:        Static libraries for developing with librsvg
118 Summary(es.UTF-8):      Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
119 Summary(pl.UTF-8):      Statyczne biblioteki librsvg
120 Summary(pt_BR.UTF-8):   Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
121 Group:          X11/Development/Libraries
122 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
123
124 %description static
125 This package contains static version of librsvg libraries.
126
127 %description static -l pl.UTF-8
128 Statyczna wersja bibliotek librsvg.
129
130 %description static -l pt_BR.UTF-8
131 Bibliotecas estáticas para o desenvolvimento de aplicações com
132 librsvg.
133
134 %package apidocs
135 Summary:        librsvg API documentation
136 Summary(pl.UTF-8):      Dokumentacja API biblioteki librsvg
137 Group:          Documentation
138 Requires:       gtk-doc-common
139
140 %description apidocs
141 librsvg API documentation.
142
143 %description apidocs -l pl.UTF-8
144 Dokumentacja API biblioteki librsvg.
145
146 %package gtk+2
147 Summary:        librsvg/GTK+2 based SVG theme engine and viewer
148 Summary(pl.UTF-8):      Silnik motywów oraz przeglądarka plików SVG oparte na bibliotekach librsvg/GTK+2
149 Group:          X11/Libraries
150 Requires:       %{name} = %{epoch}:%{version}-%{release}
151 Requires:       gtk+2 >= 2:2.16.0
152
153 %description gtk+2
154 librsvg/GTK+2 based SVG theme engine and viewer.
155
156 %description gtk+2 -l pl.UTF-8
157 Silnik motywów oraz przeglądarka plików SVG oparte na bibliotekach
158 librsvg/GTK+2.
159
160 %package gtk+3
161 Summary:        librsvg/GTK+3 based SVG theme and viewer
162 Summary(pl.UTF-8):      Motyw i przeglądarka plików SVG oparte na bibliotekach librsvg/GTK+3
163 Group:          X11/Libraries
164 Requires:       %{name} = %{epoch}:%{version}-%{release}
165 Requires:       gtk+3 >= 3.0.0
166
167 %description gtk+3
168 librsvg/GTK+3 based SVG theme and viewer.
169
170 %description gtk+3 -l pl.UTF-8
171 Motyw i przeglądarka plików SVG oparte na bibliotekach librsvg/GTK+3.
172
173 %prep
174 %setup -q
175
176 %if %{without apidocs}
177 echo 'CLEANFILES=' > gtk-doc.make
178 echo 'AC_DEFUN([GTK_DOC_CHECK],[])' >> acinclude.m4
179 %endif
180
181 # vala not ready yet here
182 echo 'AC_DEFUN([VAPIGEN_CHECK],[AM_CONDITIONAL([ENABLE_VAPIGEN], [false])])' >> acinclude.m4
183
184 %build
185 mkdir m4
186 %{?with_apidocs:%{__gtkdocize}}
187 %{__libtoolize}
188 %{__aclocal}
189 %{__autoconf}
190 %{__autoheader}
191 %{__automake}
192 %configure \
193         --disable-silent-rules \
194         %{__enable_disable static_libs static} \
195         %{__enable_disable apidocs gtk-doc} \
196         --enable-introspection \
197         %{__with_without libcroco croco} \
198         --with-html-dir=%{_gtkdocdir}/%{name}
199 %{__make}
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203
204 %{__make} install \
205         DESTDIR=$RPM_BUILD_ROOT \
206         pkgconfigdir=%{_pkgconfigdir}
207
208 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/engines/*.{la,a}
209 %{__rm} $RPM_BUILD_ROOT%{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/*.{la,a}
210 %{__rm} $RPM_BUILD_ROOT%{_libdir}/librsvg-2.la
211
212 %{__ln_s} rsvg-view-3 $RPM_BUILD_ROOT%{_bindir}/rsvg-view
213
214 install %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}
215
216 %clean
217 rm -rf $RPM_BUILD_ROOT
218
219 %post
220 /sbin/ldconfig
221 umask 022
222 %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache || :
223
224 %postun
225 /sbin/ldconfig
226 umask 022
227 if [ -x %{_bindir}/gdk-pixbuf-query-loaders%{pqext} ]; then
228         %{_bindir}/gdk-pixbuf-query-loaders%{pqext} --update-cache
229 fi
230
231 %files
232 %defattr(644,root,root,755)
233 %doc ChangeLog AUTHORS NEWS
234 %attr(755,root,root) %{_bindir}/rsvg
235 %attr(755,root,root) %{_bindir}/rsvg-convert
236 %attr(755,root,root) %{_libdir}/librsvg-2.so.*.*.*
237 %attr(755,root,root) %ghost %{_libdir}/librsvg-2.so.2
238 %{_libdir}/girepository-1.0/Rsvg-2.0.typelib
239 %attr(755,root,root) %{_libdir}/gdk-pixbuf-2.0/2.*.*/loaders/libpixbufloader-svg.so
240 %{_mandir}/man1/rsvg-convert.1*
241
242 %files devel
243 %defattr(644,root,root,755)
244 %attr(755,root,root) %{_libdir}/librsvg-2.so
245 %{_includedir}/librsvg-2.0
246 %{_datadir}/gir-1.0/Rsvg-2.0.gir
247 %{_pkgconfigdir}/librsvg-2.0.pc
248
249 %if %{with static_libs}
250 %files static
251 %defattr(644,root,root,755)
252 %{_libdir}/librsvg-2.a
253 %endif
254
255 %if %{with apidocs}
256 %files apidocs
257 %defattr(644,root,root,755)
258 %{_gtkdocdir}/%{name}
259 %endif
260
261 %if %{with gtk2}
262 %files gtk+2
263 %defattr(644,root,root,755)
264 %attr(755,root,root) %{_libdir}/gtk-2.0/2.*/engines/libsvg.so
265 %dir %{_datadir}/themes/bubble
266 %{_datadir}/themes/bubble/gtk-2.0
267 %endif
268
269 %files gtk+3
270 %defattr(644,root,root,755)
271 %attr(755,root,root) %{_bindir}/rsvg-view-3
272 %attr(755,root,root) %{_bindir}/rsvg-view
This page took 0.075318 seconds and 3 git commands to generate.