]> git.pld-linux.org Git - packages/librsvg.git/blob - librsvg.spec
- don't build gimp plugin by default (gimp.spec now includes improved version)
[packages/librsvg.git] / librsvg.spec
1 #
2 # Conditional build
3 %bcond_with     gimp            # build gimp svg plugin (but gimp.spec provides better plugin)
4 %bcond_without  libgsf          # build without libgsf (used for run-time decompression)
5 %bcond_with     libcroco        # build with CSS support through libcroco
6 #
7 %ifarch ppc
8 %define _without_gimp   1
9 %endif
10
11 Summary:        Raph's SVG library
12 Summary(pl):    Biblioteka Raph's SVG
13 Summary(pt_BR): Biblioteca SVG
14 Summary(ru):    SVG ÂÉÂÌÉÏÔÅËÁ
15 Summary(uk):    SVG Â¦Â̦ÏÔÅËÁ
16 Name:           librsvg
17 Version:        2.4.0
18 Release:        2
19 License:        LGPL
20 Vendor:         GNOME
21 Group:          Libraries
22 Source0:        http://ftp.gnome.org/pub/gnome/sources/%{name}/2.4/%{name}-%{version}.tar.bz2
23 # Source0-md5:  1a073864e5f6e9793cf23e38dc723803
24 Patch0:         %{name}-link.patch
25 URL:            http://nautilus.eazel.com/
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  freetype-devel >= 2.0.1
29 %{?with_gimp:BuildRequires:     gimp-devel >= 1.3.20}
30 BuildRequires:  gtk+2-devel >= 2.2.3
31 BuildRequires:  libart_lgpl-devel >= 2.3.15
32 %{?with_libcroco:BuildRequires: libcroco-devel >= 0.1.0}
33 %{?with_libgsf:BuildRequires:   libgsf-devel >= 1.6.0}
34 BuildRequires:  libpng-devel
35 BuildRequires:  libtool
36 BuildRequires:  libxml2-devel >= 2.5.10
37 BuildRequires:  popt-devel >= 1.5
38 Requires:       gtk+2 >= 2.2.3
39 Requires:       popt >= 1.5
40 Obsoletes:      librsvg0
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %if %{with gimp}
44 %define         gimpplugindir   %(gimptool --gimpplugindir)/plug-ins
45 %endif
46
47 %description
48 An SVG library based upon libart.
49
50 %description -l pl
51 Biblioteka do obs³ugi grafiki wektorowej.
52
53 %description -l pt_BR
54 Biblioteca de Extensão da Eazel.
55
56 %description -l ru
57 âÉÂÌÉÏÔÅËÁ SVG, ÂÁÚÉÒÕÀÝÁÑÓÑ ÎÁ libart.
58
59 %description -l uk
60 â¦Â̦ÏÔÅËÁ SVG, ÂÁÚÏ×ÁÎÁ ÎÁ libart.
61
62 %package devel
63 Summary:        Include files for developing with librsvg
64 Summary(pl):    Pliki nag³ówkowe do tworzenia oprogramowania z u¿yciem librsvg
65 Summary(pt_BR): Bibliotecas e arquivos de inclusão para desenvolvimento com a librsvg
66 Summary(ru):    âÉÂÌÉÏÔÅÞÎÙÅ ÌÉÎËÉ É ÆÁÊÌÙ ÚÁÇÏÌÏ×ËÏ× ÄÌÑ ÒÁÚÒÁÂÏÔËÉ Ó librsvg
67 Summary(uk):    â¦Â̦ÏÔÅÞΦ Ì¦ÎËÉ ÔÁ ÆÁÊÌÉ ÚÁÇÏÌÏ×˦נÄÌÑ ÒÏÚÒÏÂËÉ Ú librsvg
68 Group:          Development/Libraries
69 Requires:       %{name} = %{version}
70 Requires:       gtk+2-devel >= 2.2.3
71 Requires:       libart_lgpl-devel >= 2.3.15
72 %{?with_libcroco:Requires:      libcroco-devel >= 0.1.0}
73 %{?with_libgsf:Requires:        libgsf-devel >= 1.6.0}
74 Requires:       libxml2-devel >= 2.5.10
75 Obsoletes:      librsvg0-devel
76
77 %description devel
78 This package provides the necessary development libraries and include
79 files to allow you to develop with librsvg.
80
81 %description devel -l pl
82 Pakiet zawiera pliki nag³ówkowe potrzebne do tworzenia oprogramowania
83 z wykorzystaniem librsvg.
84
85 %description devel -l pt_BR
86 Este pacote contém os arquivos necessários para desenvolver com base
87 na biblioteca librsvg.
88
89 %description devel -l ru
90 üÔÏÔ ÐÁËÅÔ ÓÏÄÅÒÖÉÔ ÎÅÏÂÈÏÄÉÍÙÅ ÆÁÊÌÙ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ Ó
91 ÉÓÐÏÌØÚÏ×ÁÎÉÅÍ librsvg.
92
93 %description devel -l uk
94 ãÅÊ ÐÁËÅԠͦÓÔÉÔØ ÎÅÏÂȦÄΦ ÆÁÊÌÉ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ Ú ×ÉËÏÒÉÓÔÁÎÎÑÍ
95 librsvg.
96
97 %package static
98 Summary:        Static libraries for developing with librsvg
99 Summary(es):    Archivos estáticos necesarios para el desarrollo de aplicaciones con librsvg
100 Summary(pl):    Statyczne biblioteki librsvg
101 Summary(pt_BR): Arquivos estáticos necessários para o desenvolvimento de aplicações com librsvg
102 Group:          Development/Libraries
103 Requires:       %{name}-devel = %{version}
104
105 %description static
106 This package contains static version of librsvg libraries.
107
108 %description static -l pl
109 Statyczna wersja bibliotek librsvg.
110
111 %description static -l pt_BR
112 Bibliotecas estáticas para o desenvolvimento de aplicações com
113 librsvg.
114
115 %package -n gimp-svg
116 Summary:        SVG plugin for Gimp
117 Summary:        Wtyczka SVG dla Gimpa
118 Group:          X11/Applications/Graphics
119 Requires:       %{name} = %{version}
120 Requires:       gimp >= 1.3
121
122 %description -n gimp-svg
123 SVG plugin for Gimp.
124
125 %description -n gimp-svg -l pl
126 Wtyczka SVG dla Gimpa.
127
128 %prep
129 %setup -q
130 %patch -p1
131
132 %build
133 %{__libtoolize}
134 %{__aclocal}
135 %{__autoconf}
136 %{__automake}
137 %configure \
138         %{!?with_libcroco:--without-croco} \
139         %{!?with_gimp:--without-gimp} \
140         %{!?with_libgsf:--without-svgz}
141
142 %install
143 rm -rf $RPM_BUILD_ROOT
144
145 %{__make} install \
146         DESTDIR=$RPM_BUILD_ROOT \
147         pkgconfigdir=%{_pkgconfigdir} \
148         manonedir=%{_mandir}/man1
149
150 rm -f $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/2.*/{engines,loaders}/*.{la,a}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post   -p /sbin/ldconfig
156 %postun -p /sbin/ldconfig
157
158 %files
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/*
161 %attr(755,root,root) %{_libdir}/lib*.so.*.*
162 %attr(755,root,root) %{_libdir}/gtk-2.0/2.*/engines/*.so
163 %attr(755,root,root) %{_libdir}/gtk-2.0/2.*/loaders/*.so
164 %{_mandir}/man1/rsvg.1*
165
166 %files devel
167 %defattr(644,root,root,755)
168 %doc ChangeLog AUTHORS NEWS
169 %{_libdir}/lib*.la
170 %attr(755,root,root) %{_libdir}/lib*.so
171 %{_pkgconfigdir}/*.pc
172 %{_includedir}/librsvg-2
173 %{_docdir}/%{name}
174
175 %files static
176 %defattr(644,root,root,755)
177 %{_libdir}/lib*.a
178
179 %if %{with gimp}
180 %files -n gimp-svg
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{gimpplugindir}/svg
183 %endif
This page took 0.054119 seconds and 3 git commands to generate.