]> git.pld-linux.org Git - packages/libreport.git/blob - libreport.spec
- updated to 2.6.0
[packages/libreport.git] / libreport.spec
1 # TODO: teach build system to use python3.2+ __pycache__
2 #
3 # Conditional build:
4 %bcond_without  tests   # "make check"
5 #
6 Summary:        Generic library for reporting various problems
7 Summary(pl.UTF-8):      Ogólna biblioteka do zgłaszania różnych problemów
8 Name:           libreport
9 Version:        2.6.0
10 Release:        1
11 License:        GPL v2+
12 Group:          Libraries
13 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.gz
14 # Source0-md5:  764ef9745518391abe8349f979d6ce1d
15 Patch0:         format-security.patch
16 URL:            https://fedorahosted.org/abrt/
17 BuildRequires:  asciidoc
18 %{?with_tests:BuildRequires:    augeas}
19 BuildRequires:  augeas-devel
20 BuildRequires:  autoconf >= 2.50
21 BuildRequires:  automake
22 BuildRequires:  curl-devel
23 BuildRequires:  dbus-devel
24 BuildRequires:  desktop-file-utils
25 BuildRequires:  gettext-tools >= 0.17
26 BuildRequires:  glib2-devel >= 1:2.21
27 BuildRequires:  gtk+3-devel >= 3.0
28 BuildRequires:  intltool >= 0.35.0
29 BuildRequires:  json-c-devel
30 BuildRequires:  libproxy-devel
31 BuildRequires:  libtar-devel
32 BuildRequires:  libtool >= 1:1.4.2
33 BuildRequires:  libxml2-devel >= 2
34 BuildRequires:  newt-devel
35 BuildRequires:  nss-devel
36 BuildRequires:  pkgconfig
37 BuildRequires:  python-devel >= 2
38 BuildRequires:  python3-devel >= 3
39 BuildRequires:  rpmbuild(macros) >= 1.612
40 BuildRequires:  satyr-devel
41 # libsystemd-journal
42 BuildRequires:  systemd-devel
43 BuildRequires:  xmlrpc-c-client-devel
44 BuildRequires:  xmlrpc-c-devel
45 BuildRequires:  xmlto
46 BuildRequires:  xz-devel
47 Requires:       glib2 >= 1:2.21
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 Libraries providing API for reporting different problems in
52 applications to different bug targets like Bugzilla, ftp, trac, etc...
53
54 %description -l pl.UTF-8
55 Biblioteki udostępniające API do zgłaszania różnych programów w
56 aplikacjach do różnych docelowych systemów raportowania błędów, takich
57 jak Bugzilla, ftp, trac...
58
59 %package devel
60 Summary:        Header files for libreport libraries
61 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek libreport
62 Group:          Development/Libraries
63 Requires:       %{name} = %{version}-%{release}
64 Requires:       glib2-devel >= 1:2.21
65
66 %description devel
67 Header files for libreport libraries.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe bibliotek libreport.
71
72 %package web
73 Summary:        Library providing network API for libreport
74 Summary(pl.UTF-8):      Biblioteka zapewniająca API sieciowe dla libreport
75 Group:          Libraries
76 Requires:       %{name} = %{version}-%{release}
77
78 %description web
79 Library providing network API for libreport.
80
81 %description web -l pl.UTF-8
82 Biblioteka zapewniająca API sieciowe dla libreport.
83
84 %package web-devel
85 Summary:        Development headers for libreport-web
86 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-web
87 Group:          Development/Libraries
88 Requires:       %{name}-devel = %{version}-%{release}
89 Requires:       %{name}-web = %{version}-%{release}
90 Requires:       curl-devel
91 Requires:       json-c-devel
92 Requires:       libproxy-devel
93 Requires:       libxml2-devel >= 2
94 Requires:       satyr-devel
95 Requires:       xmlrpc-c-client-devel
96 Requires:       xmlrpc-c-devel
97
98 %description web-devel
99 Development headers for libreport-web.
100
101 %description web-devel -l pl.UTF-8
102 Pliki nagłówkowe biblioteki libreport-web.
103
104 %package -n python-%{name}
105 Summary:        Python 2 bindings for libreport libraries
106 Summary(pl.UTF-8):      Wiązania Pythona 2 do bibliotek libreport
107 Group:          Libraries/Python
108 Requires:       %{name} = %{version}-%{release}
109 Provides:       %{name}-python = %{version}-%{release}
110 Obsoletes:      libreport-python < 2.1.3-1
111
112 %description -n python-%{name}
113 Python 2 bindings for libreport libraries.
114
115 %description -n python-%{name} -l pl.UTF-8
116 Wiązania Pythona 2 do bibliotek libreport
117
118 %package -n python3-%{name}
119 Summary:        Python 3 bindings for libreport libraries
120 Summary(pl.UTF-8):      Wiązania Pythona 3 do bibliotek libreport
121 Group:          Libraries/Python
122 Requires:       %{name} = %{version}-%{release}
123
124 %description -n python3-%{name}
125 Python 3 bindings for libreport libraries.
126
127 %description -n python3-%{name} -l pl.UTF-8
128 Wiązania Pythona 3 do bibliotek libreport
129
130 %package cli
131 Summary:        libreport's command line interface
132 Summary(pl.UTF-8):      Interfejs linii poleceń libreport
133 Group:          Applications
134 Requires:       %{name} = %{version}-%{release}
135
136 %description cli
137 This package contains simple command line tool for working with
138 problem dump reports.
139
140 %description cli -l pl.UTF-8
141 Ten pakiet zawiera proste, działające z linii poleceń narzędzie do
142 pracy ze zgłoszeniami zawierającymi zrzuty problemów.
143
144 %package newt
145 Summary:        libreport's newt interface
146 Summary(pl.UTF-8):      Interfejs newt libreport
147 Group:          Applications
148 Requires:       %{name} = %{version}-%{release}
149
150 %description newt
151 This package contains a simple newt application for reporting bugs.
152
153 %description newt -l pl.UTF-8
154 Ten pakiet zawiera prostą aplikację newt do zgłaszania błędów.
155
156 %package gtk
157 Summary:        GTK+ front-end for libreport
158 Summary(pl.UTF-8):      Interfejs GTK+ libreport
159 Group:          X11/Applications
160 Requires:       %{name} = %{version}-%{release}
161
162 %description gtk
163 Application for reporting bugs using libreport backend.
164
165 %description gtk -l pl.UTF-8
166 Aplikacja do zgłaszania błędów przy użyciu libreport.
167
168 %package gtk-devel
169 Summary:        Development headers for libreport-gtk
170 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libreport-gtk
171 Group:          Development/Libraries
172 Requires:       %{name}-gtk = %{version}-%{release}
173
174 %description gtk-devel
175 Development headers for libreport-gtk.
176
177 %description gtk-devel -l pl.UTF-8
178 Pliki nagłówkowe biblioteki libreport-gtk.
179
180 %package plugin-bugzilla
181 Summary:        libreport's bugzilla plugin
182 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez Bugzillę
183 Group:          Libraries
184 Requires:       %{name}-web = %{version}-%{release}
185 Obsoletes:      abrt-plugin-bugzilla < 2.0.4
186
187 %description plugin-bugzilla
188 Plugin to report bugs into the bugzilla.
189
190 %description plugin-bugzilla -l pl.UTF-8
191 Wtyczka zgłaszająca problemy do systemu Bugzilla.
192
193 %package plugin-kerneloops
194 Summary:        libreport's kerneloops reporter plugin
195 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń awarii jądra (kerneloops)
196 Group:          Libraries
197 Requires:       %{name}-web = %{version}-%{release}
198 Requires:       curl
199
200 %description plugin-kerneloops
201 This package contains plugin which sends kernel crash information to
202 specified server, usually to kerneloops.org.
203
204 %description plugin-kerneloops -l pl.UTF-8
205 Ten pakiet zawiera wtyczkę wysyłającą informacje o awariach jądra na
206 określony serwer, zwykle kerneloops.org.
207
208 %package plugin-logger
209 Summary:        libreport's logger reporter plugin
210 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń w logu
211 Group:          Libraries
212 Requires:       %{name} = %{version}-%{release}
213 Obsoletes:      abrt-plugin-logger < 2.0.4
214
215 %description plugin-logger
216 The simple reporter plugin which writes a report to a specified file.
217
218 %description plugin-logger -l pl.UTF-8
219 Prosta wtyczka zgłaszająca problem, zapisująca raport w określonym
220 pliku.
221
222 %package plugin-mailx
223 Summary:        libreport's mailx reporter plugin
224 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez pocztę elektroniczną
225 Group:          Libraries
226 Requires:       %{name} = %{version}-%{release}
227 Requires:       mailx
228 Obsoletes:      abrt-plugin-mailx < 2.0.4
229
230 %description plugin-mailx
231 The simple reporter plugin which sends a report via mailx to a
232 specified email address.
233
234 %description plugin-mailx -l pl.UTF-8
235 Prosta wtyczka zgłaszająca problem, wysyłająca raport na określony
236 adres e-mail przy użyciu programu mailx.
237
238 %package plugin-mantisbt
239 Summary:        libreport's mantisbt plugin
240 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez mantisbt
241 Group:          Libraries
242 Requires:       %{name}-web = %{version}-%{release}
243
244 %description plugin-mantisbt
245 Plugin to report bugs into the mantisbt.
246
247 %description plugin-mantisbt -l pl.UTF-8
248 Wtyczka zgłaszająca problemy do systemu mantisbt.
249
250 %package plugin-reportuploader
251 Summary:        libreport's reportuploader plugin
252 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez FTP
253 Group:          Libraries
254 Requires:       %{name}-web = %{version}-%{release}
255 Obsoletes:      abrt-plugin-reportuploader < 2.0.4
256
257 %description plugin-reportuploader
258 Plugin to report bugs into anonymous FTP site associated with
259 ticketing system.
260
261 %description plugin-reportuploader -l pl.UTF-8
262 Wtyczka zgłaszająca błędy poprzez serwer anonimowego FTP powiązany z
263 systemem biletów.
264
265 %package plugin-rhtsupport
266 Summary:        libreport's RHTSupport plugin
267 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń przez RHTSupport
268 Group:          Libraries
269 Requires:       %{name}-web = %{version}-%{release}
270 Obsoletes:      abrt-plugin-rhtsupport < 2.0.4
271
272 %description plugin-rhtsupport
273 Plugin to report bugs into RH support system.
274
275 %description plugin-rhtsupport -l pl.UTF-8
276 Wtyczka zgłaszająca problemy do systemu obsługi RH.
277
278 %package plugin-ureport
279 Summary:        libreport's micro report plugin
280 Summary(pl.UTF-8):      Wtyczka libreport do zgłoszeń typu micro-report
281 Group:          Libraries
282 Requires:       %{name}-web = %{version}-%{release}
283
284 %description plugin-ureport
285 Uploads micro-report to abrt server.
286
287 %description plugin-ureport -l pl.UTF-8
288 Wtyczka przesyłająca raporty typu micro-report na serwer abrt.
289
290 %package anaconda
291 Summary:        Default configuration for reporting Anaconda bugs
292 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów w Anacondzie
293 Group:          Applications/File
294 Requires:       %{name}-plugin-bugzilla = %{version}-%{release}
295 Requires:       %{name}-plugin-reportuploader = %{version}-%{release}
296
297 %description anaconda
298 Default configuration for reporting Anaconda problems using Fedora
299 infrastructure or uploading the gathered data over ftp/scp...
300
301 %description anaconda -l pl.UTF-8
302 Domyślna konfiguracja do zgłaszania problemów z Anacondą przy użyciu
303 infrastruktury Fedory lub przesyłając zebrane dane po ftp/scp.
304
305 %package centos
306 Summary:        Default configuration for reporting bugs via CentOS infrastructure
307 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę CentOS
308 Group:          Applications/File
309 Requires:       %{name}-web = %{version}-%{release}
310 Requires:       %{name}-plugin-mantisbt = %{version}-%{release}
311
312 %description centos
313 Default configuration for reporting bugs via CentOS infrastructure
314 used primarily to easy configure the reporting process for CentOS
315 systems.
316
317 %description centos -l pl.UTF-8
318 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
319 CentOS, służąca przede wszystkim do łatwej konfiguracji procesu
320 zgłaszania błędów w systemach CentOS.
321
322 %package fedora
323 Summary:        Default configuration for reporting bugs via Fedora infrastructure
324 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę Fedory
325 Group:          Applications/File
326 Requires:       %{name} = %{version}-%{release}
327
328 %description fedora
329 Default configuration for reporting bugs via Fedora infrastructure
330 used primarily to easy configure the reporting process for Fedora
331 systems.
332
333 %description fedora -l pl.UTF-8
334 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
335 Fedory, służąca przede wszystkim do łatwej konfiguracji procesu
336 zgłaszania błędów w systemach Fedora.
337
338 %package rhel
339 Summary:        Default configuration for reporting bugs via RHEL infrastructure
340 Summary(pl.UTF-8):      Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę RHEL
341 Group:          Applications/File
342 Requires:       %{name} = %{version}-%{release}
343
344 %description rhel
345 Default configuration for reporting bugs via RHEL infrastructure used
346 primarily to easy configure the reporting process for RHEL systems.
347
348 %description rhel -l pl.UTF-8
349 Domyślna konfiguracja do zgłaszania błędów poprzez infrastrukturę
350 RHEL, służąca przede wszystkim do łatwej konfiguracji procesu
351 zgłaszania błędów w systemach RHEL.
352
353 %prep
354 %setup -q
355 %patch0 -p1
356
357 %build
358 %{__libtoolize}
359 %{__aclocal} -I m4
360 %{__autoconf}
361 %{__autoheader}
362 %{__automake}
363 %configure \
364         AUGPARSE=/usr/bin/augparse \
365         --disable-silent-rules
366
367 %{__make}
368
369 %if %{with tests}
370 %{__make} check
371 %endif
372
373 %install
374 rm -rf $RPM_BUILD_ROOT
375
376 %{__make} install \
377         DESTDIR=$RPM_BUILD_ROOT
378
379 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
380 # compat layer for compatibility tool
381 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/report,%{_mandir}/man1/report.1}
382
383 %py_postclean
384 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/report*/*.la
385 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/report*/*.la
386
387 # empty version ru
388 %{__rm} -r $RPM_BUILD_ROOT%{_localedir}/ru_RU
389
390 %find_lang %{name}
391
392 %clean
393 rm -rf $RPM_BUILD_ROOT
394
395 %post   -p /sbin/ldconfig
396 %postun -p /sbin/ldconfig
397
398 %post   web -p /sbin/ldconfig
399 %postun web -p /sbin/ldconfig
400
401 %post   gtk -p /sbin/ldconfig
402 %postun gtk -p /sbin/ldconfig
403
404 %files -f %{name}.lang
405 %defattr(644,root,root,755)
406 %doc README
407 %dir %{_sysconfdir}/%{name}
408 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/report_event.conf
409 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/forbidden_words.conf
410 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/ignored_words.conf
411 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/libreport.conf
412 %dir %{_sysconfdir}/%{name}/events
413 %dir %{_sysconfdir}/%{name}/events.d
414 %dir %{_sysconfdir}/%{name}/plugins
415 %dir %{_sysconfdir}/%{name}/workflows.d
416 %attr(755,root,root) %{_libdir}/libreport.so.*.*.*
417 %attr(755,root,root) %ghost %{_libdir}/libreport.so.0
418 %attr(755,root,root) %{_libdir}/libabrt_dbus.so.*.*.*
419 %attr(755,root,root) %ghost %{_libdir}/libabrt_dbus.so.0
420 %{_datadir}/augeas/lenses/libreport.aug
421 %dir %{_datadir}/libreport
422 %dir %{_datadir}/libreport/conf.d
423 %{_datadir}/libreport/conf.d/libreport.conf
424 %dir %{_datadir}/libreport/conf.d/plugins
425 %dir %{_datadir}/libreport/events
426 %dir %{_datadir}/libreport/workflows
427 %{_mandir}/man5/forbidden_words.conf.5*
428 %{_mandir}/man5/ignored_words.conf.5*
429 %{_mandir}/man5/libreport.conf.5*
430 %{_mandir}/man5/report_event.conf.5*
431
432 %files devel
433 %defattr(644,root,root,755)
434 %attr(755,root,root) %{_libdir}/libreport.so
435 %attr(755,root,root) %{_libdir}/libabrt_dbus.so
436 %dir %{_includedir}/libreport
437 %{_includedir}/libreport/client.h
438 %{_includedir}/libreport/config_item_info.h
439 %{_includedir}/libreport/dump_dir.h
440 %{_includedir}/libreport/event_config.h
441 %{_includedir}/libreport/file_obj.h
442 %{_includedir}/libreport/global_configuration.h
443 %{_includedir}/libreport/libreport_types.h
444 %{_includedir}/libreport/problem_data.h
445 %{_includedir}/libreport/report.h
446 %{_includedir}/libreport/run_event.h
447 %{_includedir}/libreport/internal_abrt_dbus.h
448 %{_includedir}/libreport/internal_libreport.h
449 %{_includedir}/libreport/problem_report.h
450 %{_includedir}/libreport/problem_utils.h
451 %{_includedir}/libreport/reporters.h
452 %{_includedir}/libreport/ureport.h
453 %{_includedir}/libreport/workflow.h
454 %{_includedir}/libreport/xml_parser.h
455 %{_pkgconfigdir}/libreport.pc
456
457 %files web
458 %defattr(644,root,root,755)
459 %attr(755,root,root) %{_libdir}/libreport-web.so.*.*
460 %attr(755,root,root) %ghost %{_libdir}/libreport-web.so.0
461
462 %files web-devel
463 %defattr(644,root,root,755)
464 %attr(755,root,root) %{_libdir}/libreport-web.so
465 %{_includedir}/libreport/libreport_curl.h
466 %{_pkgconfigdir}/libreport-web.pc
467
468 %files -n python-%{name}
469 %defattr(644,root,root,755)
470 %dir %{py_sitedir}/report
471 %attr(755,root,root) %{py_sitedir}/report/_pyreport.so
472 %{py_sitedir}/report/*.py[co]
473 %dir %{py_sitedir}/report/io
474 %{py_sitedir}/report/io/*.py[co]
475 %dir %{py_sitedir}/reportclient
476 %attr(755,root,root) %{py_sitedir}/reportclient/_reportclient.so
477 %{py_sitedir}/reportclient/*.py[co]
478
479 %files -n python3-%{name}
480 %defattr(644,root,root,755)
481 %dir %{py3_sitedir}/report
482 %attr(755,root,root) %{py3_sitedir}/report/_py3report.so
483 %{py3_sitedir}/report/*.py*
484 %dir %{py3_sitedir}/report/io
485 %{py3_sitedir}/report/io/*.py*
486 %dir %{py3_sitedir}/reportclient
487 %attr(755,root,root) %{py3_sitedir}/reportclient/_reportclient3.so
488 %{py3_sitedir}/reportclient/*.py*
489
490 %files cli
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/report-cli
493 %{_mandir}/man1/report-cli.1*
494
495 %files newt
496 %defattr(644,root,root,755)
497 %attr(755,root,root) %{_bindir}/report-newt
498 %{_mandir}/man1/report-newt.1*
499
500 %files gtk
501 %defattr(644,root,root,755)
502 %attr(755,root,root) %{_bindir}/report-gtk
503 %attr(755,root,root) %{_libdir}/libreport-gtk.so.*.*
504 %attr(755,root,root) %ghost %{_libdir}/libreport-gtk.so.0
505 %{_mandir}/man1/report-gtk.1*
506
507 %files gtk-devel
508 %defattr(644,root,root,755)
509 %attr(755,root,root) %{_libdir}/libreport-gtk.so
510 %{_includedir}/libreport/internal_libreport_gtk.h
511 %{_includedir}/libreport/problem_details_dialog.h
512 %{_includedir}/libreport/problem_details_widget.h
513 %{_pkgconfigdir}/libreport-gtk.pc
514
515 %files plugin-bugzilla
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_bindir}/reporter-bugzilla
518 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla.conf
519 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format.conf
520 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_analyzer_libreport.conf
521 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_kernel.conf
522 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup.conf
523 %config(noreplace) %{_sysconfdir}/libreport/events/report_Bugzilla.conf
524 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_event.conf
525 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.bugzilla.xml
526 %{_datadir}/libreport/conf.d/plugins/bugzilla.conf
527 %{_datadir}/libreport/events/report_Bugzilla.xml
528 %{_datadir}/libreport/events/watch_Bugzilla.xml
529 %{_mandir}/man1/reporter-bugzilla.1*
530 %{_mandir}/man5/bugzilla.conf.5*
531 %{_mandir}/man5/bugzilla_event.conf.5*
532 %{_mandir}/man5/bugzilla_format.conf.5*
533 %{_mandir}/man5/bugzilla_format_analyzer_libreport.conf.5*
534 %{_mandir}/man5/bugzilla_format_kernel.conf.5*
535 %{_mandir}/man5/bugzilla_formatdup.conf.5*
536 %{_mandir}/man5/report_Bugzilla.conf.5*
537
538 %files plugin-kerneloops
539 %defattr(644,root,root,755)
540 %attr(755,root,root) %{_bindir}/reporter-kerneloops
541 %{_datadir}/libreport/events/report_Kerneloops.xml
542 %{_mandir}/man1/reporter-kerneloops.1*
543
544 %files plugin-logger
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_bindir}/reporter-print
547 %config(noreplace) %{_sysconfdir}/libreport/events/report_Logger.conf
548 %config(noreplace) %{_sysconfdir}/libreport/events.d/print_event.conf
549 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_logger.conf
550 %{_datadir}/libreport/events/report_Logger.xml
551 %{_datadir}/libreport/workflows/workflow_Logger.xml
552 %{_datadir}/libreport/workflows/workflow_LoggerCCpp.xml
553 %{_mandir}/man1/reporter-print.1*
554 %{_mandir}/man5/print_event.conf.5*
555 %{_mandir}/man5/report_Logger.conf.5*
556 %{_mandir}/man5/report_logger.conf.5*
557
558 %files plugin-mailx
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/reporter-mailx
561 %config(noreplace) %{_sysconfdir}/libreport/plugins/mailx.conf
562 %config(noreplace) %{_sysconfdir}/libreport/events.d/mailx_event.conf
563 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_mailx.conf
564 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.mailx.xml
565 %{_datadir}/libreport/conf.d/plugins/mailx.conf
566 %{_datadir}/libreport/events/report_Mailx.xml
567 %{_datadir}/libreport/workflows/workflow_Mailx.xml
568 %{_datadir}/libreport/workflows/workflow_MailxCCpp.xml
569 %{_mandir}/man1/reporter-mailx.1*
570 %{_mandir}/man5/mailx.conf.5*
571 %{_mandir}/man5/mailx_event.conf.5*
572 %{_mandir}/man5/report_mailx.conf.5*
573
574 %files plugin-mantisbt
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_bindir}/reporter-mantisbt
577 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt.conf
578 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format.conf
579 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_format_analyzer_libreport.conf
580 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup.conf
581 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/plugins/mantisbt_formatdup_analyzer_libreport.conf
582 %{_datadir}/libreport/conf.d/plugins/mantisbt.conf
583 %{_mandir}/man1/reporter-mantisbt.1*
584 %{_mandir}/man5/mantisbt.conf.5*
585 %{_mandir}/man5/mantisbt_format.conf.5*
586 %{_mandir}/man5/mantisbt_format_analyzer_libreport.conf.5*
587 %{_mandir}/man5/mantisbt_formatdup.conf.5*
588 %{_mandir}/man5/mantisbt_formatdup_analyzer_libreport.conf.5*
589
590 %files plugin-reportuploader
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_bindir}/reporter-upload
593 %config(noreplace) %{_sysconfdir}/libreport/plugins/upload.conf
594 %config(noreplace) %{_sysconfdir}/libreport/events.d/uploader_event.conf
595 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_uploader.conf
596 %{_datadir}/libreport/conf.d/plugins/upload.conf
597 %{_datadir}/libreport/events/report_Uploader.xml
598 %{_datadir}/libreport/workflows/workflow_Upload.xml
599 %{_datadir}/libreport/workflows/workflow_UploadCCpp.xml
600 %{_mandir}/man1/reporter-upload.1*
601 %{_mandir}/man5/report_uploader.conf.5*
602 %{_mandir}/man5/uploader_event.conf.5*
603
604 %files plugin-rhtsupport
605 %defattr(644,root,root,755)
606 %attr(755,root,root) %{_bindir}/reporter-rhtsupport
607 %config(noreplace) %{_sysconfdir}/libreport/plugins/rhtsupport.conf
608 %config(noreplace) %{_sysconfdir}/libreport/events.d/rhtsupport_event.conf
609 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.rhtsupport.xml
610 %{_datadir}/libreport/conf.d/plugins/rhtsupport.conf
611 %{_datadir}/libreport/events/report_RHTSupport.xml
612 %{_mandir}/man1/reporter-rhtsupport.1*
613 %{_mandir}/man5/rhtsupport.conf.5*
614 %{_mandir}/man5/rhtsupport_event.conf.5*
615
616 %files plugin-ureport
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_bindir}/reporter-ureport
619 %config(noreplace) %{_sysconfdir}/libreport/events.d/emergencyanalysis_event.conf
620 %config(noreplace) %{_sysconfdir}/libreport/plugins/ureport.conf
621 %{_datadir}/dbus-1/interfaces/com.redhat.problems.configuration.ureport.xml
622 %{_datadir}/libreport/conf.d/plugins/ureport.conf
623 %{_datadir}/libreport/events/report_uReport.xml
624 %{_datadir}/libreport/events/report_EmergencyAnalysis.xml
625 %{_mandir}/man1/reporter-ureport.1*
626 %{_mandir}/man5/emergencyanalysis_event.conf.5*
627 %{_mandir}/man5/ureport.conf.5*
628
629 %files anaconda
630 %defattr(644,root,root,755)
631 %config(noreplace) %{_sysconfdir}/libreport/events.d/bugzilla_anaconda_event.conf
632 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_format_anaconda.conf
633 %config(noreplace) %{_sysconfdir}/libreport/plugins/bugzilla_formatdup_anaconda.conf
634 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/anaconda_event.conf
635 %{_datadir}/libreport/workflows/workflow_AnacondaFedora.xml
636 %{_datadir}/libreport/workflows/workflow_AnacondaRHEL.xml
637 %{_datadir}/libreport/workflows/workflow_AnacondaRHELBugzilla.xml
638 %{_datadir}/libreport/workflows/workflow_AnacondaUpload.xml
639 %{_mandir}/man5/anaconda_event.conf.5*
640 %{_mandir}/man5/bugzilla_anaconda_event.conf.5*
641 %{_mandir}/man5/bugzilla_format_anaconda.conf.5*
642 %{_mandir}/man5/bugzilla_formatdup_anaconda.conf.5*
643
644 %files centos
645 %defattr(644,root,root,755)
646 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events/report_CentOSBugTracker.conf
647 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/events.d/centos_report_event.conf
648 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libreport/workflows.d/report_centos.conf
649 %{_datadir}/libreport/events/report_CentOSBugTracker.xml
650 %{_datadir}/libreport/workflows/workflow_CentOSCCpp.xml
651 %{_datadir}/libreport/workflows/workflow_CentOSJava.xml
652 %{_datadir}/libreport/workflows/workflow_CentOSKerneloops.xml
653 %{_datadir}/libreport/workflows/workflow_CentOSLibreport.xml
654 %{_datadir}/libreport/workflows/workflow_CentOSPython.xml
655 %{_datadir}/libreport/workflows/workflow_CentOSPython3.xml
656 %{_datadir}/libreport/workflows/workflow_CentOSVmcore.xml
657 %{_datadir}/libreport/workflows/workflow_CentOSXorg.xml
658 %{_mandir}/man5/centos_report_event.conf.5*
659 %{_mandir}/man5/report_CentOSBugTracker.conf.5*
660 %{_mandir}/man5/report_centos.conf.5*
661
662 %files fedora
663 %defattr(644,root,root,755)
664 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_fedora.conf
665 %{_datadir}/libreport/workflows/workflow_Fedora*.xml
666 %{_mandir}/man5/report_fedora.conf.5*
667
668 %files rhel
669 %defattr(644,root,root,755)
670 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel.conf
671 %config(noreplace) %{_sysconfdir}/libreport/workflows.d/report_rhel_bugzilla.conf
672 %{_datadir}/libreport/workflows/workflow_RHEL*.xml
673 %{_mandir}/man5/report_rhel.conf.5*
674 %{_mandir}/man5/report_rhel_bugzilla.conf.5*
This page took 0.114317 seconds and 4 git commands to generate.