]> git.pld-linux.org Git - packages/libreoffice.git/blob - libreoffice.spec
b13376e8a1796d5e55fbb388488b3c96e587fb9f
[packages/libreoffice.git] / libreoffice.spec
1
2 # Conditional build:
3 # _with_ibm_java        - uses IBM java instead SUN java
4 # _with_nest            - build for nest envinronment
5
6 # _with_us              - 01 US translation
7 # _with_pl              - 48 PL translation
8 # _with_de              - 49 DE translation
9
10 #%define                oo_ver  1.0
11 Summary:        OpenOffice - powerful office suite
12 Summary(pl):    OpenOffice - potê¿ny pakiet biurowy
13 Name:           openoffice
14 Version:        1.0.0
15 Release:        0.5
16 Epoch:          1
17 License:        GPL/LGPL
18 Group:          X11/Applications
19 #Source0:       http://sf1.mirror.openoffice.org/%{version}/oo_%{version}_source.tar.bz2
20 Source0:        http://sf1.mirror.openoffice.org/%{version}/OOo_%{version}_source.tar.bz2
21 Source1:        ftp://ftp.cs.man.ac.uk/pub/toby/gpc/gpc231.tar.Z
22 Source2:        %{name}-db3.jar
23 Source3:        %{name}-rsfile.txt
24 Source4:        %{name}-xmlparse.sh
25 Patch0:         %{name}-gcc.patch
26 Patch1:         %{name}-db3.patch
27 Patch2:         %{name}-mozilla.patch
28 Patch3:         %{name}-nest.patch
29 Patch4:         %{name}-perl.patch
30 # Start using some system libraries:
31 Patch5:         %{name}-system-freetype.patch
32 Patch6:         %{name}-system-getopt.patch
33 Patch7:         %{name}-freetype-2.1.patch
34 # Fix broken makefiles
35 Patch8:         %{name}-braindamage.patch
36 # Add jj patch for CLK_TCK -> CLOCKS_PER_SEC
37 Patch9:         %{name}-clockspersec.patch
38 # Fix psprint /euro to /Euro
39 Patch10:        %{name}-psprint-euro.patch
40 # Fix config_office/configure
41 Patch11:        %{name}-ac.patch
42 # Hackery around zipdep
43 Patch12:        %{name}-openoffice-zipdep.patch
44 # Remove GPC from linking to GPL/LGPL OO.o code!
45 Patch13:        %{name}-remove-gpc.patch
46 Patch14:        %{name}-fontcache-1.5.patch
47 URL:            http://www.openoffice.org/
48 BuildRequires:  STLport-static
49 BuildRequires:  XFree86-devel
50 BuildRequires:  XFree86-fonts-PEX
51 BuildRequires:  XFree86-Xvfb
52 BuildRequires:  db3-devel
53 BuildRequires:  autoconf
54 BuildRequires:  automake
55 BuildRequires:  bison
56 BuildRequires:  flex
57 BuildRequires:  freetype-devel >= 2.1
58 BuildRequires:  freetype-static
59 %{?!_with_nest:BuildRequires:   gcc <= 3.0.0}
60 %{?_with_nest:BuildRequires:    gcc2}
61 %{?!_with_nest:BuildRequires:   gcc-c++ <= 3.0.0}
62 %{?_with_nest:BuildRequires:    gcc2-c++}
63 %{?_with_ibm_java:BuildRequires:        ibm-java-sdk}
64 %{?!_with_ibm_java:BuildRequires:       jdk = 1.3.1_03}
65 %{?!_with_nest:BuildRequires:   libstdc++-devel <= 3.0.0}
66 %{?_with_nest:BuildRequires:    libstdc++2-devel}
67 BuildRequires:  pam-devel
68 BuildRequires:  perl
69 BuildRequires:  tcsh
70 BuildRequires:  unzip
71 BuildRequires:  zip
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %define         _prefix         /usr/X11R6
75
76 %description
77 OpenOffice.org is an open-source project sponsored by Sun Microsystems
78 and hosted by CollabNet. In October of 2000, Sun released the source
79 code of its popular StarOfficeTM productivity suite under open-source
80 licenses. The aim of the OpenOffice.org project is to create, using
81 open-source methods, the next generation of open-network productivity
82 services, including the establishment of open, XML-based standards for
83 office productivity file formats and language-independent bindings to
84 component APIs.
85
86 Features of OpenOffice.org include:
87  - Downloadable source code,
88  - CVS control, and
89  - Infrastructure for community involvement, including guidelines and
90    discussion groups.
91
92 %description -l pl
93 OpenOffice.org jest projektem open-source sponsorowanym przez Sun
94 Microsystems i przechowywanym przez CollabNet. W pa¼dzierniku 2000
95 roku Sun udostêpni³ kod ¼ród³owy popularnego pakietu biurowego
96 StarOfficeTM na zasadach licencji open-source. G³ównym celem
97 OpenOffice.org jest stworzenie sieciowego pakietu biurowego nastêpnej
98 generacji, wykorzystuj±c open-source'owe metody pracy.
99
100 Do zalet OpenOffice.org mo¿na zaliczyæ:
101  - dostêpny ca³y czas kod ¼ród³owy,
102  - kontrola CVS,
103  - infrastruktura s³u¿±ca do komunikowania siê w ramach projektu.
104
105 %prep
106 %setup -q -n oo_1.0_src
107 %patch0 -p1
108 %patch1 -p1
109 %patch2 -p1
110 %if%{?_with_nest:1}%{!?_with_nest:0}
111 %patch3 -p1
112 %endif
113 %patch4 -p1
114 %patch5 -p1
115 %patch6 -p1
116 %patch7 -p1
117 %patch8 -p1
118 %patch9 -p1
119 %patch10 -p1
120 %patch11 -p1
121 %patch12 -p1
122 %patch13 -p1
123 %patch14 -p1
124
125 install %{SOURCE1} external
126 cd external; tar fxz %{SOURCE1}; cp -fr gpc231/* gpc
127
128 %build
129 cd config_office
130 autoconf
131
132 %{?!_with_ibm_java:JAVA_HOME="/usr/lib/jdk1.3.1_03"}
133 %{?_with_ibm_java:JAVA_HOME="/usr/lib/IBMJava2-13"}
134 %configure2_13 \
135         --with-jdk-home=$JAVA_HOME \
136         --with-stlport4-home=/usr \
137         --with-lang=ALL \
138         --with-x
139
140 cd ..
141
142 cat <<EOF > prep
143 #!/bin/tcsh
144 ./bootstrap
145 EOF
146 chmod u+rx prep
147 ./prep
148
149 install -d solver/641/unxlngi3.pro/bin
150 install %{SOURCE2} solver/641/unxlngi3.pro/bin/db.jar
151
152 cat <<EOF > compile
153 #!/bin/tcsh
154 source LinuxIntelEnv.Set
155 dmake -p -v
156 EOF
157 chmod u+rx compile
158 ./compile
159
160 %install
161 rm -rf $RPM_BUILD_ROOT
162
163 cat <<EOF > install
164 #!/bin/tcsh
165 source LinuxIntelEnv.Set
166 dmake install
167 EOF
168
169 chmod u+rx install
170 ./install
171
172 # starting Xvfb
173 i=0
174 while [ -f /tmp/.X$i-lock ]; do
175         i=$(($i+1))
176 done
177
178 /usr/X11R6/bin/Xvfb :$i & 
179 PID=$!
180 sleep 5
181
182 # preparing to start installator
183 cp -f %{SOURCE3} $RPM_BUILD_DIR/oo_%{oo_ver}_src/install.rs.in
184 sed -e "s,@DESTDIR@,$RPM_BUILD_ROOT/usr/X11R6/lib/openoffice," \
185         -e "s,@LOGFILE@,$RPM_BUILD_DIR/oo_%{oo_ver}_src/install.log," \
186         install.rs.in > install.rs
187
188 # starting installator
189 %{?_with_us:DISPLAY=":$i" instsetoo/unxlngi3.pro/01/normal/setup -R:$RPM_BUILD_DIR/oo_%{oo_ver}_src/install.rs}
190 %{?_with_pl:DISPLAY=":$i" instsetoo/unxlngi3.pro/48/normal/setup -R:$RPM_BUILD_DIR/oo_%{oo_ver}_src/install.rs}
191 %{?_with_de:DISPLAY=":$i" instsetoo/unxlngi3.pro/49/normal/setup -R:$RPM_BUILD_DIR/oo_%{oo_ver}_src/install.rs}
192
193 # stopping Xvfb
194 #kill $PID
195
196 %clean
197 rm -rf $RPM_BUILD_ROOT
198
199 %files
200 %defattr(644,root,root,755)
This page took 0.046266 seconds and 2 git commands to generate.