]> git.pld-linux.org Git - packages/libpsl.git/blob - libpsl.spec
ae51b485cb29727cf003960e5d959079da07302c
[packages/libpsl.git] / libpsl.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # static library
4 #
5 Summary:        C library for the Publix Suffix List
6 Summary(pl.UTF-8):      Biblioteka C do obsługi listy przyrostków publicznych (Public Suffix List)
7 Name:           libpsl
8 Version:        0.8.1
9 Release:        1
10 License:        MIT
11 Group:          Networking
12 Source0:        https://github.com/rockdaboot/libpsl/archive/%{name}-%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  515060957760ed78d5bd5a87f424b5d5
14 %define psl_ref 1fc1ed365818a6a77d6f31d425ff03ca54cdc7f3
15 %define psldate 20150827
16 Source1:        https://github.com/publicsuffix/list/archive/%{psl_ref}/publicsuffix_list-%{psldate}.tar.gz
17 # Source1-md5:  ee9a591d4545d9f6ca350bd9df2c2e51
18 Patch0:         %{name}-am.patch
19 URL:            https://rockdaboot.github.io/libpsl
20 BuildRequires:  autoconf >= 2.59
21 BuildRequires:  automake >= 1:1.10
22 BuildRequires:  gettext-tools >= 0.18.1
23 BuildRequires:  glib2-devel
24 BuildRequires:  gtk-doc >= 1.15
25 BuildRequires:  libicu-devel
26 BuildRequires:  libtool >= 2:2
27 BuildRequires:  libxslt-progs
28 BuildRequires:  pkgconfig
29 BuildRequires:  sed >= 4.0
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 libpsl is a C library to handle the Public Suffix List. A "public
34 suffix" is a domain name under which Internet users can directly
35 register own names.
36
37 Browsers and other web clients can use it to
38 - Avoid privacy-leaking "supercookies";
39 - Avoid privacy-leaking "super domain" certificates;
40 - Domain highlighting parts of the domain in a user interface;
41 - Sorting domain lists by site;
42
43 Libpsl...
44 - has built-in PSL data for fast access;
45 - allows to load PSL data from files;
46 - checks if a given domain is a "public suffix";
47 - provides immediate cookie domain verification;
48 - finds the longest public part of a given domain;
49 - finds the shortest private part of a given domain;
50 - works with international domains (UTF-8 and IDNA2008 Punycode);
51 - is thread-safe;
52 - handles IDNA2008 UTS#46;
53
54 %description -l pl.UTF-8
55 libpsl to biblioteka C do obsługi listy przyrostków publicznych
56 (Public Suffix List). "Przyrostek publiczny" to nazwa domeny, poniżej
57 której bezpośrednio użytkownicy Internetu mogą rejestrować własne
58 nazwy.
59
60 Przeglądarki i inni klienci WWW mogą jej używać w celu:
61 - zapobieganiu "superciasteczek" naruszającym prywatność
62 - zapobieganiu certyfikatom "superdomenowym" naruszającym prywatność
63 - podświetlania części domen w interfejsie użytkownika
64 - sortowania listy domen według serwisu.
65
66 Libpsl:
67 - ma wbudowane dane PSL dla szybkiego dostępu
68 - pozwala na wczytywanie danych PSL z plików
69 - sprawdza, czy dana domena jest "przyrostkiem publicznym"
70 - zapewnia natychmiastową weryfikację domeny ciasteczka
71 - znajduje najdłuższą publiczną część podanej domeny
72 - znajduje najkrótszą prywatną część podanej domeny
73 - działa z domenami międzynarodowymi (UTF-8 i IDNA2008 Punycode)
74 - jest bezpieczna względem wątków
75 - obsługuje IDNA2008 UTS#46.
76
77 %package devel
78 Summary:        Development files for libpsl
79 Summary(pl.UTF-8):      Pliki programistyczne biblioteki libpsl
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82
83 %description devel
84 This package contains the header file for developing applications that
85 use libpsl.
86
87 %description devel -l pl.UTF-8
88 Ten pakiet zawiera plik nagłówkowy do tworzenia aplikacji
89 wykorzystujących bibliotekę libpsl.
90
91 %package static
92 Summary:        Static libpsl library
93 Summary(pl.UTF-8):      Statyczna biblioteka libpsl
94 Group:          Development/Libraries
95 Requires:       %{name}-devel = %{version}-%{release}
96
97 %description static
98 Static libpsl library.
99
100 %description static -l pl.UTF-8
101 Statyczna biblioteka libpsl.
102
103 %package apidocs
104 Summary:        API documentation for libpsl library
105 Summary(pl.UTF-8):      Dokumentacja API biblioteki libpsl
106 Group:          Documentation
107
108 %description apidocs
109 API documentation for libpsl library.
110
111 %description apidocs -l pl.UTF-8
112 Dokumentacja API biblioteki libpsl.
113
114 %package utils
115 Summary:        Commandline utility to explore the Public Suffix List
116 Summary(pl.UTF-8):      Narzędzie linii poleceń do eksplorowania listy przyrostków publicznych
117 Group:          Applications/Networking
118 Requires:       %{name} = %{version}-%{release}
119
120 %description utils
121 This package contains a commandline utility to explore the Public
122 Suffix List, for example it checks if domains are public suffixes,
123 checks if cookie-domain is acceptable for domains and so on.
124
125 %description utils -l pl.UTF-8
126 Ten pakiet zawiera narzędzie linii poleceń do eksplorowania listy
127 przyrostków publicznych (Public Suffix List); sprawdza ono na
128 przykład, czy domeny są przyrostkami publicznymi, czy domena
129 ciasteczka jest akceptowalna dla domen itp.
130
131 %prep
132 %setup -q -n %{name}-%{name}-%{version}
133 %patch0 -p1
134
135 rmdir list
136 %{__tar} xf %{SOURCE1}
137 %{__mv} list-%{psl_ref} list
138
139 # gettextize workaround
140 %{__sed} -i -e 's,po/Makefile\.in,,' configure.ac
141
142 %build
143 %{__gettextize}
144 %{__gtkdocize}
145 %{__libtoolize}
146 %{__aclocal} -I m4
147 %{__autoconf}
148 %{__autoheader}
149 %{__automake}
150
151 %configure \
152         --disable-silent-rules \
153         %{!?with_static_libs:--disable-static} \
154         --enable-gtk-doc \
155         --enable-man \
156         --with-html-dir=%{_gtkdocdir}
157
158 %{__make}
159
160 %{?with_tests:%{__make} check}
161
162 %install
163 rm -rf $RPM_BUILD_ROOT
164 %{__make} install \
165         DESTDIR=$RPM_BUILD_ROOT
166
167 # obsoleted by pkg-config
168 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libpsl.la
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post   -p /sbin/ldconfig
174 %postun -p /sbin/ldconfig
175
176 %files
177 %defattr(644,root,root,755)
178 %doc AUTHORS COPYING NEWS README.md
179 %attr(755,root,root) %{_libdir}/libpsl.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libpsl.so.0
181
182 %files devel
183 %defattr(644,root,root,755)
184 %attr(755,root,root) %{_libdir}/libpsl.so
185 %{_includedir}/libpsl.h
186 %{_pkgconfigdir}/libpsl.pc
187 %{_mandir}/man3/libpsl.3*
188
189 %files static
190 %defattr(644,root,root,755)
191 %{_libdir}/libpsl.a
192
193 %files apidocs
194 %defattr(644,root,root,755)
195 %{_gtkdocdir}/libpsl
196
197 %files utils
198 %defattr(644,root,root,755)
199 %attr(755,root,root) %{_bindir}/psl
This page took 0.068708 seconds and 3 git commands to generate.