]> git.pld-linux.org Git - packages/libprelude.git/blob - libprelude.spec
- tabs in preamble
[packages/libprelude.git] / libprelude.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # don't build perl bindings
4 %bcond_without  python  # don't build python bindings (required by prewikka)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        The Prelude library
8 Summary(pl.UTF-8):      Biblioteka Prelude
9 Name:           libprelude
10 Version:        0.9.12.2
11 Release:        1
12 License:        GPL
13 Group:          Libraries
14 Source0:        http://www.prelude-ids.org/download/releases/%{name}-%{version}.tar.gz
15 # Source0-md5:  4636cf21c3e96adbd9463138fb49f401
16 URL:            http://www.prelude-ids.org/
17 BuildRequires:  bison
18 BuildRequires:  flex
19 BuildRequires:  gnutls-devel >= 1.0.17
20 BuildRequires:  gtk-doc
21 %{?with_perl:BuildRequires:     perl-devel}
22 %{?with_python:BuildRequires:   python-devel}
23 BuildRequires:  rpm-perlprov
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The Prelude library is a collection of generic functions providing
28 communication between the Prelude Hybrid IDS suite components. It
29 provides a convenient interface for sending alerts to Prelude Manager
30 with transparent SSL, failover and replication support, asynchronous
31 events and timer interfaces, an abstracted configuration API (hooking
32 at the commandline, the configuration line, or wide configuration,
33 available from the Manager), and a generic plugin API. It allows you
34 to easily turn your favorite security program into a Prelude sensor.
35
36 %description -l pl.UTF-8
37 Biblioteka Prelude to zbiór ogólnych funkcji zapewniających
38 komunikację pomiędzy komponentami zestawu Prelude Hybrid IDS.
39 Dostarcza wygodny interfejs do wysyłania alarmów do zarządcy Prelude z
40 przezroczystą obsługę SSL, failover i replikacji, interfejsy do
41 zdarzeń asynchronicznych i zegarów, abstrakcyjne API konfiguracyjne
42 (obsługujące linię poleceń, linię konfiguracji i konfigurację
43 dostępną z zarządcy) oraz ogólne API wtyczek. Pozwala łatwo zamienić
44 ulubiony program związany z bezpieczeństwem na czujnik Prelude.
45
46 %package libs
47 Summary:        The Prelude library
48 Summary(pl.UTF-8):      Biblioteka Prelude
49 Group:          Libraries
50
51 %description libs
52 The Prelude library.
53
54 %description libs -l pl.UTF-8
55 Biblioteka Prelude.
56
57 %package devel
58 Summary:        Header files and development documentation for libprelude
59 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programistyczna dla libprelude
60 Group:          Development/Libraries
61 Requires:       %{name}-libs = %{version}-%{release}
62 Requires:       gnutls-devel
63
64 %description devel
65 Header files and development documentation for libprelude.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe i dokumentacja programistyczna dla libprelude.
69
70 %package static
71 Summary:        Static libprelude library
72 Summary(pl.UTF-8):      Statyczna biblioteka libprelude
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Static libprelude library.
78
79 %description static -l pl.UTF-8
80 Statyczna biblioteka libprelude.
81
82 %package -n perl-libprelude
83 Summary:        libprelude Perl bindings
84 Summary(pl.UTF-8):      Dowiązania Perla do libprelude
85 Group:          Development/Languages/Perl
86
87 %description -n perl-libprelude
88 libprelude Perl bindings.
89
90 %description -n perl-libprelude -l pl.UTF-8
91 Dowiązania Perla dla libprelude.
92
93 %package -n python-libprelude
94 Summary:        libprelude Python bindings
95 Summary(pl.UTF-8):      Dowiązania Pythona dla libprelude
96 Group:          Development/Languages/Python
97
98 %description -n python-libprelude
99 libprelude Python bindings.
100
101 %description -n python-libprelude -l pl.UTF-8
102 Dowiązania Pythona dla libprelude.
103
104 %prep
105 %setup -q
106
107 %build
108 %configure \
109         --enable-shared \
110         --enable-static \
111         --enable-gtk-doc \
112         --with%{!?with_perl:out}-perl \
113         --with%{!?with_python:out}-python \
114         --with-html-dir=%{_gtkdocdir}/libprelude
115
116 # first make the perl makefile otherwise with jobserver strange things happen:
117 # Makefile out-of-date with respect to Makefile.PL
118 %if %{with perl}
119 %{__make} -C bindings perl/Makefile.PL
120 %endif
121
122 %{__make}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129
130 %if %{with perl}
131 cd bindings/perl && %{__perl} Makefile.PL \
132         INSTALLDIRS=vendor
133 cd ../..
134 %{__make} -C bindings/perl install \
135         DESTDIR=$RPM_BUILD_ROOT
136 %endif
137
138 %if %{with python}
139 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
140 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
141 %endif
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   libs -p /sbin/ldconfig
147 %postun libs -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc AUTHORS ChangeLog NEWS README
152 %dir %{_sysconfdir}/prelude
153 %dir %{_sysconfdir}/prelude/default
154 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/prelude/default/*.conf
155 %dir %{_sysconfdir}/prelude/profile
156
157 %files libs
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/prelude-adduser
160 %attr(755,root,root) %{_libdir}/lib*.so.*.*
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/libprelude-config
165 %attr(755,root,root) %{_libdir}/lib*.so
166 %{_libdir}/lib*.la
167 %{_includedir}/libprelude
168 %{_aclocaldir}/*.m4
169 %{_gtkdocdir}/libprelude
170
171 %files static
172 %defattr(644,root,root,755)
173 %{_libdir}/lib*.a
174
175 %if %{with perl}
176 %files -n perl-libprelude
177 %defattr(644,root,root,755)
178 %dir %{perl_vendorarch}/auto/Prelude
179 %attr(755,root,root) %{perl_vendorarch}/auto/Prelude/*.so
180 %{perl_vendorarch}/auto/Prelude/*.bs
181 %{perl_vendorarch}/Prelude.pm
182 %endif
183
184 %if %{with python}
185 %files -n python-libprelude
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{py_sitedir}/*.so
188 %{py_sitedir}/*.py[co]
189 %endif
This page took 0.044833 seconds and 4 git commands to generate.