]> git.pld-linux.org Git - packages/libprelude.git/blob - libprelude.spec
- updated to 1.0.0
[packages/libprelude.git] / libprelude.spec
1 #
2 # Conditional build:
3 %bcond_without  perl    # don't build perl bindings
4 %bcond_without  python  # don't build python bindings (required by prewikka)
5 #
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        The Prelude library
8 Summary(pl.UTF-8):      Biblioteka Prelude
9 Name:           libprelude
10 Version:        1.0.0
11 Release:        1
12 License:        GPL v2 or commercial
13 Group:          Libraries
14 #Source0Download: http://www.prelude-ids.com/developpement/telechargement/index.html
15 Source0:        http://www.prelude-ids.com/download/releases/libprelude/%{name}-%{version}.tar.gz
16 # Source0-md5:  a5bb76538d240e5fac5f6ab0b7fabfe5
17 Patch0:         %{name}-libtool.patch
18 URL:            http://www.prelude-ids.com/
19 BuildRequires:  autoconf >= 2.59
20 BuildRequires:  automake
21 BuildRequires:  bison
22 BuildRequires:  flex
23 BuildRequires:  gnutls-devel >= 1.0.17
24 BuildRequires:  gtk-doc >= 1.0
25 BuildRequires:  libgcrypt-devel >= 1.1.94
26 BuildRequires:  libltdl-devel
27 BuildRequires:  libtool
28 %{?with_perl:BuildRequires:     perl-devel}
29 %{?with_python:BuildRequires:   python-devel >= 1:2.5}
30 BuildRequires:  rpm-perlprov
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.219
33 %{?with_perl:BuildRequires: swig-perl}
34 Requires:       %{name}-libs = %{version}-%{release}
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %description
38 The Prelude library is a collection of generic functions providing
39 communication between the Prelude Hybrid IDS suite components. It
40 provides a convenient interface for sending alerts to Prelude Manager
41 with transparent SSL, failover and replication support, asynchronous
42 events and timer interfaces, an abstracted configuration API (hooking
43 at the commandline, the configuration line, or wide configuration,
44 available from the Manager), and a generic plugin API. It allows you
45 to easily turn your favorite security program into a Prelude sensor.
46
47 %description -l pl.UTF-8
48 Biblioteka Prelude to zbiór ogólnych funkcji zapewniających
49 komunikację pomiędzy komponentami zestawu Prelude Hybrid IDS.
50 Dostarcza wygodny interfejs do wysyłania alarmów do zarządcy Prelude z
51 przezroczystą obsługę SSL, failover i replikacji, interfejsy do
52 zdarzeń asynchronicznych i zegarów, abstrakcyjne API konfiguracyjne
53 (obsługujące linię poleceń, linię konfiguracji i konfigurację dostępną
54 z zarządcy) oraz ogólne API wtyczek. Pozwala łatwo zamienić ulubiony
55 program związany z bezpieczeństwem na czujnik Prelude.
56
57 %package libs
58 Summary:        The Prelude library
59 Summary(pl.UTF-8):      Biblioteka Prelude
60 Group:          Libraries
61 Requires:       gnutls >= 1.0.17
62 Requires:       libgcrypt >= 1.1.94
63
64 %description libs
65 The Prelude library.
66
67 %description libs -l pl.UTF-8
68 Biblioteka Prelude.
69
70 %package devel
71 Summary:        Header files and development documentation for libprelude
72 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja programistyczna dla libprelude
73 Group:          Development/Libraries
74 Requires:       %{name}-libs = %{version}-%{release}
75 Requires:       gnutls-devel >= 1.0.17
76 Requires:       libgcrypt-devel >= 1.1.94
77 Requires:       libltdl-devel
78
79 %description devel
80 Header files and development documentation for libprelude.
81
82 %description devel -l pl.UTF-8
83 Pliki nagłówkowe i dokumentacja programistyczna dla libprelude.
84
85 %package static
86 Summary:        Static libprelude library
87 Summary(pl.UTF-8):      Statyczna biblioteka libprelude
88 Group:          Development/Libraries
89 Requires:       %{name}-devel = %{version}-%{release}
90
91 %description static
92 Static libprelude library.
93
94 %description static -l pl.UTF-8
95 Statyczna biblioteka libprelude.
96
97 %package -n perl-libprelude
98 Summary:        libprelude Perl bindings
99 Summary(pl.UTF-8):      Dowiązania Perla do libprelude
100 Group:          Development/Languages/Perl
101 Requires:       %{name}-libs = %{version}-%{release}
102
103 %description -n perl-libprelude
104 libprelude Perl bindings.
105
106 %description -n perl-libprelude -l pl.UTF-8
107 Dowiązania Perla dla libprelude.
108
109 %package -n python-libprelude
110 Summary:        libprelude Python bindings
111 Summary(pl.UTF-8):      Dowiązania Pythona dla libprelude
112 Group:          Development/Languages/Python
113 Requires:       %{name}-libs = %{version}-%{release}
114
115 %description -n python-libprelude
116 libprelude Python bindings.
117
118 %description -n python-libprelude -l pl.UTF-8
119 Dowiązania Pythona dla libprelude.
120
121 %prep
122 %setup -q
123 %patch0 -p1
124
125 %build
126 %{__libtoolize}
127 %{__aclocal} -I m4 -I libmissing/m4
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 %configure \
132         --enable-static \
133         --enable-gtk-doc \
134         --with%{!?with_perl:out}-perl \
135         --with%{!?with_python:out}-python \
136         --with-html-dir=%{_gtkdocdir}/libprelude \
137         --with-perl-installdirs=vendor
138
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT
146
147 %if %{with python}
148 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
149 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
150 %py_postclean
151 %endif
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post   libs -p /sbin/ldconfig
157 %postun libs -p /sbin/ldconfig
158
159 %files
160 %defattr(644,root,root,755)
161 %doc AUTHORS ChangeLog LICENSE.README NEWS README
162 %attr(755,root,root) %{_bindir}/prelude-adduser
163 %attr(755,root,root) %{_bindir}/prelude-admin
164 %dir %{_sysconfdir}/prelude
165 %dir %{_sysconfdir}/prelude/default
166 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/prelude/default/*.conf
167 %dir %{_sysconfdir}/prelude/profile
168 %{_mandir}/man1/prelude-admin.1*
169
170 %files libs
171 %defattr(644,root,root,755)
172 %attr(755,root,root) %{_libdir}/libprelude.so.*.*.*
173 %attr(755,root,root) %{_libdir}/libpreludecpp.so.*.*.*
174 %attr(755,root,root) %ghost %{_libdir}/libprelude.so.2
175 %attr(755,root,root) %ghost %{_libdir}/libpreludecpp.so.0
176
177 %files devel
178 %defattr(644,root,root,755)
179 %attr(755,root,root) %{_bindir}/libprelude-config
180 %attr(755,root,root) %{_libdir}/libprelude.so
181 %attr(755,root,root) %{_libdir}/libpreludecpp.so
182 %{_libdir}/libprelude.la
183 %{_libdir}/libpreludecpp.la
184 %{_includedir}/libprelude
185 %{_aclocaldir}/libprelude.m4
186 %{_gtkdocdir}/libprelude
187 %{_pkgconfigdir}/libprelude.pc
188
189 %files static
190 %defattr(644,root,root,755)
191 %{_libdir}/libprelude.a
192 %{_libdir}/libpreludecpp.a
193
194 %if %{with perl}
195 %files -n perl-libprelude
196 %defattr(644,root,root,755)
197 %{perl_vendorarch}/Prelude.pm
198 %dir %{perl_vendorarch}/auto/Prelude
199 %{perl_vendorarch}/auto/Prelude/Prelude.bs
200 %attr(755,root,root) %{perl_vendorarch}/auto/Prelude/Prelude.so
201 %endif
202
203 %if %{with python}
204 %files -n python-libprelude
205 %defattr(644,root,root,755)
206 %attr(755,root,root) %{py_sitedir}/_prelude.so
207 %attr(755,root,root) %{py_sitedir}/_PreludeEasy.so
208 %{py_sitedir}/prelude.py[co]
209 %{py_sitedir}/PreludeEasy.py[co]
210 %{py_sitedir}/prelude-*.egg-info
211 %{py_sitedir}/PreludeEasy-*.egg-info
212 %endif
This page took 0.08102 seconds and 4 git commands to generate.