]> git.pld-linux.org Git - packages/libnsfb.git/blob - libnsfb.spec
- updated to 0.1.3
[packages/libnsfb.git] / libnsfb.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static library
4
5 Summary:        Framebuffer abstraction library
6 Summary(pl.UTF-8):      Biblioteka abstrakcji bufora ramki
7 Name:           libnsfb
8 Version:        0.1.3
9 Release:        1
10 License:        MIT
11 Group:          Libraries
12 Source0:        http://download.netsurf-browser.org/libs/releases/%{name}-%{version}-src.tar.gz
13 # Source0-md5:  0bca85a89e0be26a57d826979c56b89a
14 Patch0:         %{name}-link.patch
15 URL:            http://www.netsurf-browser.org/projects/libnsfb/
16 BuildRequires:  SDL-devel
17 BuildRequires:  libvncserver-devel
18 BuildRequires:  libxcb-devel >= 1.3
19 BuildRequires:  netsurf-buildsystem >= 1.3
20 BuildRequires:  pkgconfig
21 BuildRequires:  wayland-devel
22 BuildRequires:  xcb-util-devel
23 BuildRequires:  xcb-util-image-devel
24 BuildRequires:  xcb-util-keysyms-devel
25 BuildRequires:  xcb-util-wm-devel >= 0.3.0
26 Requires:       libxcb-devel >= 1.3
27 Requires:       xcb-util-wm-devel >= 0.3.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 LibNSFB is a framebuffer abstraction library, written in C. It is
32 currently in development for use with NetSurf and is intended to be
33 suitable for use in other projects too.
34
35 The overall idea of the library is to provide a generic abstraction to
36 a linear section of memory which corresponds to a visible array of
37 pixel elements on a display device. Different colour depths are
38 supported and the library provides routines for tasks such as drawing
39 onto the framebuffer and rectangle copy operations.
40
41 LibNSFB currently supports the following as framebuffer providers:
42 - Linux framebuffer
43 - X
44 - SDL
45 - VNC
46 - ABLE framebuffer
47
48 %description
49 LibNSFB to napisana w C biblioteka abstrakcji bufora ramki. Obecnie
50 jest rozwijana pod kątem użycia w przeglądarce NetSurf, ale może być
51 także używana w innych projektach.
52
53 Ogólną ideą biblioteki jest zapewnienie ogólnej abstrakcji liniowego
54 obszaru pamięci, który odpowiada widocznej tablicy pikseli na
55 urządzeniu wyświetlającym. Obsługiwane są różne głębie koloru, a
56 biblioteka udostępnia takie operacje, jak rysowanie w buforze ramki
57 czy kopiowanie prostokątów.
58
59 LibNSFB obecnie obsługuje następujące bufory ramki:
60 - linuksowy framebuffer
61 - X
62 - SDL
63 - VNC
64 - framebuffer ABLE
65
66 %package devel
67 Summary:        libnsfb library headers
68 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libnsfb
69 Group:          Development/Libraries
70 Requires:       %{name} = %{version}-%{release}
71 Requires:       SDL-devel
72 Requires:       libvncserver-devel
73 Requires:       libxcb-devel >= 1.3
74 Requires:       wayland-devel
75 Requires:       xcb-util-devel
76 Requires:       xcb-util-image-devel
77 Requires:       xcb-util-keysyms-devel
78 Requires:       xcb-util-wm-devel >= 0.3.0
79
80 %description devel
81 This package contains the include files and other resources you can
82 use to incorporate libnsfb into applications.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe pozwalające na używanie biblioteki libnsfb w swoich
86 programach.
87
88 %package static
89 Summary:        libnsfb static library
90 Summary(pl.UTF-8):      Statyczna biblioteka libnsfb
91 Group:          Development/Libraries
92 Requires:       %{name}-devel = %{version}-%{release}
93
94 %description static
95 This is package with static libnsfb library.
96
97 %description static -l pl.UTF-8
98 Statyczna biblioteka libnsfb.
99
100 %prep
101 %setup -q
102 %patch0 -p1
103
104 %build
105 export CC="%{__cc}"
106 export CFLAGS="%{rpmcflags}"
107 export LDFLAGS="%{rpmldflags}"
108
109 %{__make} \
110         Q= \
111         PREFIX=%{_prefix} \
112         COMPONENT_TYPE=lib-shared
113 %if %{with static_libs}
114 %{__make} \
115         Q= \
116         PREFIX=%{_prefix} \
117         COMPONENT_TYPE=lib-static
118 %endif
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 %{__make} install \
123         Q= \
124         PREFIX=%{_prefix} \
125         LIBDIR=%{_lib} \
126         COMPONENT_TYPE=lib-shared \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 %if %{with static_libs}
130 %{__make} install \
131         Q= \
132         PREFIX=%{_prefix} \
133         LIBDIR=%{_lib} \
134         COMPONENT_TYPE=lib-static \
135         DESTDIR=$RPM_BUILD_ROOT
136 %endif
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %post   -p /sbin/ldconfig
142 %postun -p /sbin/ldconfig
143
144 %files
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_libdir}/libnsfb.so.*.*.*
147 %attr(755,root,root) %ghost %{_libdir}/libnsfb.so.0
148
149 %files devel
150 %defattr(644,root,root,755)
151 %doc usage
152 %attr(755,root,root) %{_libdir}/libnsfb.so
153 %{_includedir}/libnsfb*.h
154 %{_pkgconfigdir}/libnsfb.pc
155
156 %if %{with static_libs}
157 %files static
158 %defattr(644,root,root,755)
159 %{_libdir}/libnsfb.a
160 %endif
This page took 0.089781 seconds and 3 git commands to generate.