]> git.pld-linux.org Git - packages/libmysofa.git/blob - libmysofa.spec
- updated to 1.3.2
[packages/libmysofa.git] / libmysofa.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build tests
4
5 Summary:        Library to read AES SOFA files
6 Summary(pl.UTF-8):      Biblioteka do odczytu plików AES SOFA
7 Name:           libmysofa
8 Version:        1.3.2
9 Release:        1
10 License:        BSD
11 Group:          Libraries
12 #Source0Download: https://github.com/hoene/libmysofa/releases
13 Source0:        https://github.com/hoene/libmysofa/archive/v%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  483878b0ed4dc177a64bdec3c3fe6f1e
15 URL:            https://github.com/hoene/libmysofa
16 %{?with_tests:BuildRequires:    CUnit}
17 BuildRequires:  cmake >= 2.8.12
18 %{?with_tests:BuildRequires:    pkgconfig}
19 BuildRequires:  rpmbuild(macros) >= 1.742
20 BuildRequires:  zlib-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This is a simple set of C functions to read AES SOFA files, if they
25 contain HRTFs stored according to the AES69-2015 standard
26 <http://www.aes.org/publications/standards/search.cfm?docID=99>.
27
28 %description -l pl.UTF-8
29 Prosty zbiór funkcji C do odczytu plików AES SOFA, zawierających dane
30 HRTF zapisane zgodnie ze standardem AES69-2015
31 <http://www.aes.org/publications/standards/search.cfm?docID=99>.
32
33 %package devel
34 Summary:        Header files for libmysofa library
35 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki libmysofa
36 Group:          Development/Libraries
37 Requires:       %{name} = %{version}-%{release}
38 Requires:       zlib-devel
39
40 %description devel
41 Header files for libmysofa library.
42
43 %description devel -l pl.UTF-8
44 Pliki nagłówkowe biblioteki libmysofa.
45
46 %package static
47 Summary:        Static libmysofa library
48 Summary(pl.UTF-8):      Statyczna biblioteka libmysofa
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}-%{release}
51
52 %description static
53 Static libmysofa library.
54
55 %description static -l pl.UTF-8
56 Statyczna biblioteka libmysofa.
57
58 %prep
59 %setup -q
60
61 %build
62 install -d build
63 cd build
64 %cmake .. \
65         %{cmake_on_off tests BUILD_TESTS} \
66         -DCODE_COVERAGE:BOOL=OFF
67
68 %{__make}
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} -C build install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %post   -p /sbin/ldconfig
80 %postun -p /sbin/ldconfig
81
82 %files
83 %defattr(644,root,root,755)
84 %doc LICENSE README.md
85 %{?with_tests:%attr(755,root,root) %{_bindir}/mysofa2json}
86 %attr(755,root,root) %{_libdir}/libmysofa.so.*.*.*
87 %attr(755,root,root) %ghost %{_libdir}/libmysofa.so.1
88 %{_datadir}/libmysofa
89
90 %files devel
91 %defattr(644,root,root,755)
92 %attr(755,root,root) %{_libdir}/libmysofa.so
93 %{_includedir}/mysofa.h
94 %{_pkgconfigdir}/libmysofa.pc
95 %{_libdir}/cmake/mysofa
96
97 %files static
98 %defattr(644,root,root,755)
99 %{_libdir}/libmysofa.a
This page took 0.043639 seconds and 3 git commands to generate.