]> git.pld-linux.org Git - packages/libkolab.git/blob - libkolab.spec
- 0.3.1
[packages/libkolab.git] / libkolab.spec
1 Summary:        Kolab Object Handling Library
2 Name:           libkolab
3 Version:        0.3.1
4 Release:        0.1
5 Group:          Libraries
6 License:        LGPLv3+
7 URL:            http://git.kolab.org/libkolab
8 Source0:        http://mirror.kolabsys.com/pub/releases/%{name}-%{version}.tar.gz
9 # Source0-md5:  99f2b2c519c3ebaa57f8f520e8880e9a
10 BuildRequires:  curl-devel
11 BuildRequires:  kde4-kdepimlibs-devel
12 BuildRequires:  libcalendaring-devel
13 BuildRequires:  libkolabxml-devel >= 0.7
14 BuildRequires:  php-devel
15 BuildRequires:  python-devel
16 BuildRequires:  qt-devel
17
18 %description
19 The libkolab library is an advanced library to handle Kolab objects.
20
21 %package devel
22 Summary:        Kolab library development headers
23 BuildRequires:  kde4-kdepimlibs-devel >= 4.8
24 BuildRequires:  libcalendaring-devel
25 Group:          Development/Libraries
26 Requires:       %{name} = %{version}-%{release}
27 Requires:       libkolabxml-devel >= 0.7
28 Requires:       php-devel
29 Requires:       pkgconfig
30 Requires:       python-devel
31
32 %description devel
33 Development headers for the Kolab object libraries.
34
35 %package -n php-kolab
36 Summary:        PHP Bindings for libkolab
37 Group:          Libraries
38 Requires:       %{name} = %{version}-%{release}
39 Requires:       php(api) = %{php_core_api}
40 Requires:       php(zend-abi) = %{php_zend_api}
41
42 %description -n php-kolab
43 PHP Bindings for libkolab
44
45 %package -n python-kolab
46 Summary:        Python bindings for libkolab
47 Group:          Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description -n python-kolab
51 Python bindings for libkolab
52
53 %prep
54 %setup -q
55
56 %build
57 rm -rf build
58 mkdir -p build
59 pushd build
60 %{cmake} -Wno-fatal-errors -Wno-errors \
61         -DINCLUDE_INSTALL_DIR=%{_includedir} \
62 %if 0%{?rhel} < 7 && 0%{?fedora} < 17
63         -DUSE_LIBCALENDARING=ON \
64 %endif
65         -DPHP_BINDINGS=ON \
66         -DPHP_INSTALL_DIR=%{php_extdir} \
67         -DPYTHON_BINDINGS=ON \
68         -DPYTHON_INSTALL_DIR=%{py_sitedir} \
69         ..
70 %{__make}
71 popd
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 pushd build
76 %{__make} install DESTDIR=$RPM_BUILD_ROOT
77 popd
78
79 %check
80 pushd build/tests
81 ./benchmarktest || :
82 ./calendaringtest || :
83 ./formattest || :
84 ./freebusytest || :
85 ./icalendartest || :
86 ./kcalconversiontest || :
87 ./upgradetest || :
88 popd
89
90 %clean
91 rm -rf $RPM_BUILD_ROOT
92
93 %post -p /sbin/ldconfig
94
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %{_libdir}/%{name}.so.0
100 %{_libdir}/%{name}.so.0.3
101
102 %files devel
103 %defattr(644,root,root,755)
104 %{_libdir}/%{name}.so
105 %{_libdir}/cmake/Libkolab
106 %{_includedir}/kolab
107
108 %files -n php-kolab
109 %defattr(644,root,root,755)
110 %{php_extdir}/calendaring.php
111 %{php_extdir}/calendaring.so
112 %{php_extdir}/icalendar.php
113 %{php_extdir}/icalendar.so
114
115 %files -n python-kolab
116 %defattr(644,root,root,755)
117 %{py_sitedir}/_calendaring.so
118 %{py_sitedir}/calendaring.py*
119 %{py_sitedir}/_icalendar.so
120 %{py_sitedir}/icalendar.py*
121
122
This page took 0.055742 seconds and 4 git commands to generate.