]> git.pld-linux.org Git - packages/libkolab.git/blob - libkolab.spec
- almost raw
[packages/libkolab.git] / libkolab.spec
1 Summary:        Kolab Object Handling Library
2 Name:           libkolab
3 Version:        0.3
4 Release:        0.1
5 License:        LGPLv3+
6 URL:            http://git.kolab.org/libkolab
7 Source0:        http://git.kolab.org/libkolab/snapshot/%{name}-%{version}.tar.gz
8 BuildRequires:  curl-devel
9 BuildRequires:  kde4-kdepimlibs-devel
10 BuildRequires:  libcalendaring-devel
11 BuildRequires:  libkolabxml-devel >= 0.7
12 BuildRequires:  php-devel
13 BuildRequires:  python-devel
14 BuildRequires:  qt-devel
15
16 %description
17 The libkolab library is an advanced library to handle Kolab objects.
18
19 %package devel
20 Summary:        Kolab library development headers
21 BuildRequires:  kde4-kdepimlibs-devel >= 4.8
22 BuildRequires:  libcalendaring-devel
23 Requires:       %{name} = %{version}-%{release}
24 Requires:       libkolabxml-devel >= 0.7
25 Requires:       php-devel
26 Requires:       pkgconfig
27 Requires:       python-devel
28
29 %description devel
30 Development headers for the Kolab object libraries.
31
32 %package -n php-kolab
33 Summary:        PHP Bindings for libkolab
34 Group:          Libraries
35 Requires:       %{name} = %{version}-%{release}
36 Requires:       php(api) = %{php_core_api}
37 Requires:       php(zend-abi) = %{php_zend_api}
38
39 %description -n php-kolab
40 PHP Bindings for libkolab
41
42 %package -n python-kolab
43 Summary:        Python bindings for libkolab
44 Group:          Libraries
45 Requires:       %{name} = %{version}-%{release}
46
47 %description -n python-kolab
48 Python bindings for libkolab
49
50 %prep
51 %setup -q
52
53 %build
54 rm -rf build
55 mkdir -p build
56 pushd build
57 %{cmake} -Wno-fatal-errors -Wno-errors \
58         -DINCLUDE_INSTALL_DIR=%{_includedir} \
59 %if 0%{?rhel} < 7 && 0%{?fedora} < 17
60         -DUSE_LIBCALENDARING=ON \
61 %endif
62         -DPHP_BINDINGS=ON \
63         -DPHP_INSTALL_DIR=%{php_extdir} \
64         -DPYTHON_BINDINGS=ON \
65         -DPYTHON_INSTALL_DIR=%{py_sitedir} \
66         ..
67 %{__make}
68 popd
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 pushd build
73 %{__make} install DESTDIR=$RPM_BUILD_ROOT
74 popd
75
76 %check
77 pushd build/tests
78 ./benchmarktest || :
79 ./calendaringtest || :
80 ./formattest || :
81 ./freebusytest || :
82 ./icalendartest || :
83 ./kcalconversiontest || :
84 ./upgradetest || :
85 popd
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post -p /sbin/ldconfig
91
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %{_libdir}/%{name}.so.0
97 %{_libdir}/%{name}.so.0.3
98
99 %files devel
100 %defattr(644,root,root,755)
101 %{_libdir}/%{name}.so
102 %{_libdir}/cmake/Libkolab
103 %{_includedir}/kolab
104
105 %files -n php-kolab
106 %defattr(644,root,root,755)
107 %{php_extdir}/calendaring.php
108 %{php_extdir}/calendaring.so
109 %{php_extdir}/icalendar.php
110 %{php_extdir}/icalendar.so
111
112 %files -n python-kolab
113 %defattr(644,root,root,755)
114 %{py_sitedir}/_calendaring.so
115 %{py_sitedir}/calendaring.py*
116 %{py_sitedir}/_icalendar.so
117 %{py_sitedir}/icalendar.py*
118
119
This page took 0.060339 seconds and 4 git commands to generate.