]> git.pld-linux.org Git - packages/libkolab.git/blob - libkolab.spec
- partial pldization
[packages/libkolab.git] / libkolab.spec
1 # TODO
2 # - pldize this package!
3 #  - php deps
4 #  - file attrs
5 #  - macros
6 Summary:        Kolab Object Handling Library
7 Name:           libkolab
8 Version:        0.3.1
9 Release:        0.1
10 License:        LGPL v3+
11 Group:          Libraries
12 URL:            http://git.kolab.org/libkolab
13 Source0:        http://mirror.kolabsys.com/pub/releases/%{name}-%{version}.tar.gz
14 # Source0-md5:  99f2b2c519c3ebaa57f8f520e8880e9a
15 BuildRequires:  curl-devel
16 BuildRequires:  kde4-kdepimlibs-devel >= 4.8
17 BuildRequires:  libcalendaring-devel
18 BuildRequires:  libcalendaring-devel
19 BuildRequires:  libkolabxml-devel >= 0.7
20 BuildRequires:  php-devel
21 BuildRequires:  python-devel
22 BuildRequires:  qt-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The libkolab library is an advanced library to handle Kolab objects.
27
28 %package devel
29 Summary:        Kolab library development headers
30 Group:          Development/Libraries
31 Requires:       %{name} = %{version}-%{release}
32 Requires:       libkolabxml-devel >= 0.7
33 Requires:       php-devel
34 Requires:       pkgconfig
35 Requires:       python-devel
36
37 %description devel
38 Development headers for the Kolab object libraries.
39
40 %package -n php-kolab
41 Summary:        PHP Bindings for libkolab
42 Group:          Libraries
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       php(api) = %{php_core_api}
45 Requires:       php(zend-abi) = %{php_zend_api}
46
47 %description -n php-kolab
48 PHP Bindings for libkolab
49
50 %package -n python-kolab
51 Summary:        Python bindings for libkolab
52 Group:          Libraries
53 Requires:       %{name} = %{version}-%{release}
54
55 %description -n python-kolab
56 Python bindings for libkolab
57
58 %prep
59 %setup -q
60
61 %build
62 rm -rf build
63 install -d build
64 cd build
65 %cmake \
66         -Wno-fatal-errors -Wno-errors \
67         -DINCLUDE_INSTALL_DIR=%{_includedir} \
68 %if 0%{?rhel} < 7 && 0%{?fedora} < 17
69         -DUSE_LIBCALENDARING=ON \
70 %endif
71         -DPHP_BINDINGS=ON \
72         -DPHP_INSTALL_DIR=%{php_extdir} \
73         -DPYTHON_BINDINGS=ON \
74         -DPYTHON_INSTALL_DIR=%{py_sitedir} \
75         ..
76 %{__make}
77 cd -
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 %{__make} -C build install \
82         DESTDIR=$RPM_BUILD_ROOT
83
84 %check
85 pushd build/tests
86 ./benchmarktest || :
87 ./calendaringtest || :
88 ./formattest || :
89 ./freebusytest || :
90 ./icalendartest || :
91 ./kcalconversiontest || :
92 ./upgradetest || :
93 popd
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %{_libdir}/%{name}.so.0
104 %{_libdir}/%{name}.so.0.3
105
106 %files devel
107 %defattr(644,root,root,755)
108 %{_libdir}/%{name}.so
109 %{_libdir}/cmake/Libkolab
110 %{_includedir}/kolab
111
112 %files -n php-kolab
113 %defattr(644,root,root,755)
114 %{php_extdir}/calendaring.php
115 %{php_extdir}/calendaring.so
116 %{php_extdir}/icalendar.php
117 %{php_extdir}/icalendar.so
118
119 %files -n python-kolab
120 %defattr(644,root,root,755)
121 %{py_sitedir}/_calendaring.so
122 %{py_sitedir}/calendaring.py[co]
123 %{py_sitedir}/_icalendar.so
124 %{py_sitedir}/icalendar.py[co]
This page took 0.071164 seconds and 4 git commands to generate.